Voz y Comunicaciones unificadas : Cisco ATA Analog Telephone Adaptors de la serie 180

Configuración y resolución de problemas de un ATA 186 con el IOS de Cisco Gatekeepers

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Noviembre 2015) | Comentarios


Contenido


Introducción

El adaptador telefónico analógico Cisco (ATA) 186 es un adaptador de microteléfono a Ethernet que permite conectar teléfonos analógicos estándar a redes de telefonía IP. El ATA 186 tiene dos puertos de voz que solo pueden soportar teléfonos analógicos antiguos de marcación por tonos. A diferencia de los puertos normales de la Estación de Intercambio Remoto (FXS), estos no se pueden interconectar con una central telefónica privada (PBX) porque el ATA 186 no puede enviar dígitos en estos puertos. Con esta configuración, puede utilizar ambos puertos de voz con diferentes direcciones E.164 en cada uno.

prerrequisitos

Requisitos

Este documento asume que el lector es familiar con el contenido en el documento de la configuración básica del Cisco ATA 186.

Esta configuración requiere el ATA186 estar en la versión 2.0 o posterior, usando el conjunto de características de H.323.

Asegúrese de que haya conectividad del IP entre el ATA186, el gateway, y los dispositivos de gatekeeper. También, asegúrese de que el ATA186 sea accesible con el método del servidor Web para la configuración adicional.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • ATA186 con la versión 2.12

  • Cisco 3640 con el Software Release 12.1 del � del Cisco IOS como gateway

  • Cisco 2600 con el Cisco IOS Software Release 12.2 como portero

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/19084/ata_gatekeeper_1.gif

Registro de ATA 186 con el gatekeeper

Siga estas instrucciones de registrar el ATA186 con el portero.

  1. En un campo del direccionamiento o de la ubicación del buscador Web, teclee el ip_address_of_ata/revelador URL http:// para acceder a la pantalla de configuración ATA186, donde está la dirección IP el ip_address_of_ata del ATA186 que usted se está registrando.

    En este ejemplo, el URL es http://172.16.104.117/dev. La ventana de configuración del Cisco ATA 186 aparece.

    Nota: Los campos subrayados son los parámetros configurados pertinentes para este escenario.

    /image/gif/paws/19084/ata_gatekeeper_2.gif

    El IP Addressing se puede hacer estáticamente o dinámicamente, como se explica en el documento de la configuración básica del Cisco ATA 186. En la pantalla anterior, se utiliza el IP Address estático.

  2. En la ventana de configuración del Cisco ATA 186, configure estos campos:

    • UID0 y UID1 — Configure los direccionamientos E.164 de los puertos de voz 0 y 1.

      Ambos puertos de voz no pueden tener el mismo direccionamiento E.164, pues el ATA186 no puede cazar si uno de los puertos está ocupado. Si ambos puertos de voz se asignan el mismo direccionamiento E.164, la llamada será enviada siempre al primer puerto de voz. Si este puerto está ocupado, la señal de ocupado se envía al llamador.

    • RxCodec y TxCodec — Configure el id del códec.

      • G.723.1 — id del códec 0.

      • G.711a — id del códec 1.

      • G.711u — id del códec 2.

      • G.729a — id del códec 3.

      En la configuración mostrada abajo, el codificador-decodificador del G.729r8 se utiliza en el ATA186 y en el gateway.

    • LBRCodec — Configuración como 0 o 3, sobre la base del codificador-decodificador elegido.

      • El LBRC es 0 — El codificador-decodificador G.723.1 está disponible para ambos puertos FXS en cualquier momento. Cada línea puede mantener dos llamadas G.723.1 en un estado de no conferencia. Por lo tanto, hasta cuatro llamadas G.723.1 se pueden mantener en el Cisco ATA 186. Un ejemplo es llamada en espera.

      • El LBRC es 3 — El G.729a está disponible para uno de los dos puertos FXS sobre una base primero-venir-primero-servida. Si el Cisco IOS Gateway se configura con el codificador-decodificador predeterminado de G.729, sólo un puerto ATA186 puede ser utilizado. Para evitar que la segunda llamada falle, configure una CODEC-clase de la Voz en el gateway para negociar la segunda llamada usando un codificador-decodificador de G.711. Para la información detallada, refiera a la sección de la negociación de códec comprensión del codecs: Complejidad, soporte del hardware, MOS, y documento de la negociación.

    • GKOrProxy — Configure la dirección IP del portero.

      Una vez que se hace esto, cualquier cosa que se marca de los puertos de voz ATA186 se envía al portero.

  3. Haga clic el botón Apply Button y después recargue la página.

    El ATA186 tarda 10 segundos para configurarse de nuevo.

Estos ejemplos son configuraciones pertinentes para el Cisco IOS Gatekeeper y el gateway:

2610-Gatekeeper
interface Ethernet0/0
 ip addreinterface Ethernet0/0
 ip address 172.16.13.12 255.255.255.224
 half-duplex
 h323 interface
 h323 h323-id pro
 h323 gatekeeper ipaddr 172.16.13.12
 h323 t120 bypass
!
dial-peer cor custom
!
!
!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
no shutdown
!

3640-Gateway
interface Ethernet0/0
 ip address 172.16.13.40 255.255.255.224
 half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.13.33
ip http server
!
!
!
voice-port 3/0/0
!
voice-port 3/0/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 34
 port 3/0/0
!
dial-peer voice 2 pots
 destination-pattern 45
 port 3/0/1
!
dial-peer voice 100 pots
 destination-pattern 1234
 port 3/0/0
!
dial-peer voice 3000 voip
 destination-pattern 300.
 session target ras

!--- Dial-peer to send the calls to ATA.

!

Adición de seguridad

A partir de la versión de software ATA 2.12, las opciones en esta sección están disponibles agregar la Seguridad.

Autenticación del punto final en el control de acceso con una ID de H.323.

Siga los siguientes pasos para configurar el ATA186 para registrarse con H.323 ID:

  1. Fije el campo de AutMethod a 0 (el valor por defecto es 1).

    El valor hexadecimal que debe ser configurado para este campo es 0x0.

  2. Fije el campo UseLoginID a 1.

  3. Configure el LoginID0 y el LoginID1, con H.323 ID para el ATA186.

    El ATA186 se registra como dos diversos Terminales H.323, uno para cada puerto.

Esto es una configuración en funcionamiento de la muestra para el portero al usar el ATA con el método de autenticación de ID de H.323:

/image/gif/paws/19084/ata_gatekeeper_3.gif

2610-Gatekeeper
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1

!--- Same as the LoginID0 and LoginID1 fields.

username atagw2
username 3640

!--- Same as the H.323 ID configured on the gateway.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security any

!--- Register after the H.323 ID or E.164 address is authenticated.

no shutdown
!

Autentique el punto final en el portero con un direccionamiento E.164

Siga los siguientes pasos para configurar el ATA186 para registrarse con el direccionamiento E.164:

  1. Fije el campo de AutMethod a 0 (el valor por defecto es 1).

    El valor hexadecimal que debe ser configurado para este campo es 0x0.

  2. Fije el campo UseLoginID a 0.

    El ATA utiliza los campos UID0 y UID1 para conseguir autenticado por el portero.

Esto es una configuración en funcionamiento de la muestra para el gatekeeper y gateway al usar el ATA con el método de autenticación de ID E.164:

2610-Gatekeeper
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username 3001

!--- Same as the UID0.

username 3000

!--- Same as the UID1.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security any

!--- Register after the H.323 ID or E.164 address is authenticated.

no shutdown
!

Autentique el punto final en el portero con H.323 ID y contraseña

Siga los siguientes pasos para configurar el ATA186 para registrarse con H.323 ID y contraseña:

  1. Fije el campo de AutMethod a 1 (el valor por defecto es 1).

    El valor hexadecimal que debe ser configurado para este campo es 0x1. Este campo se fija para indicar que el ATA ahora busca la contraseña.

  2. Fije el campo UseLoginID a 1.

  3. Configure el LoginID0 y el LoginID1, con H.323 ID para el ATA186.

    El ATA186 se registra como dos diversos Terminales H.323, uno para cada puerto.

  4. Configure el PWD0 y el PWD1 con la contraseña para cada puerto.

    Nota: El ATA utiliza la contraseña para generar el token. Este token se envía al gatekeeper para autenticar.

  5. Configuración NTPIP con la dirección IP del servidor del Network Time Protocol (NTP).

    El portero y el ATA deben tener relojes sincronizados al mismo servidor NTP.

Nota: El grupo fecha/hora se utiliza para la generación de token. Para más información, refiera al gateway al portero (H.235) y al portero al guía de Troubleshooting de la Seguridad del portero (IZCT).

Esto es una configuración en funcionamiento de la muestra para el gatekeeper y gateway al usar el ATA con H.323 ID y el método de autenticación de contraseña:

2610-Gatekeeper
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1 password cisco

!--- Same as the LoginID0 and PWD0 fields.

username atagw2 password cisco

!--- Same as the LoginID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security token required-for registration

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

Nota: Para más información sobre la seguridad del gatekeeper, refiera al gateway al portero (H.235) y al portero al guía de Troubleshooting de la Seguridad del portero (IZCT).

Autentique el punto final en el portero con un direccionamiento E.164 y una contraseña

Siga los siguientes pasos para configurar el ATA186 para registrarse con el E.164 ID y contraseña:

  1. Fije el campo de AutMethod a 1 (el valor por defecto es 1).

    El valor hexadecimal que debe ser configurado para este campo es 0x0. Este campo se fija para indicar que el ATA ahora buscará la contraseña.

  2. Fije el campo UseLoginID a 0.

  3. Configure el UID0 y el UID1 con el E.164 ID para el ATA186.

    El ATA186 se registra como dos diversos Terminales H.323, uno para cada puerto.

  4. Configure el PWD0 y el PWD1 con la contraseña para el cada puerto.

    Nota: El ATA utiliza la contraseña para generar el token. Este token se envía al gatekeeper para autenticar.

  5. Configuración NTPIP con la dirección IP del servidor NTP.

    El portero y el ATA deben tener relojes sincronizados al mismo servidor NTP.

Nota: El grupo fecha/hora se utiliza para la generación de token. Para más información, refiera al gateway al portero (H.235) y al portero al guía de Troubleshooting de la Seguridad del portero (IZCT).

Esto es una configuración en funcionamiento de la muestra para el gatekeeper y gateway al usar el ATA con el E.164 ID y el método de autenticación de contraseña:

2610-Gatekeeper
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username 3001 password cisco

!--- Same as the UID0 and PWD0 fields.

username 3000 password cisco


!--- Same as the UID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security token required-for registration

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

Nota: Para más información sobre la seguridad del gatekeeper, refiera al gateway al portero (H.235) y al portero al guía de Troubleshooting de la Seguridad del portero (IZCT).

Autentique el punto final en el portero con H.323 ID y contraseña usando el separador

Siga los siguientes pasos para configurar el ATA186 para registrarse con H.323 ID y contraseña:

  1. Fije el campo de AutMethod a 1 (el valor por defecto es 1).

    El valor hexadecimal configurado para este campo es 0x1. Este campo se fija para indicar que el ATA ahora busca la contraseña.

  2. Fije el campo UseLoginID a 1.

  3. Configure el LoginID0 y el LoginID1 con H.323 ID, seguido por el separador y la contraseña para el ATA186.

    Por ejemplo, el LoginID0 es atagw1=cisco.

    El ATA186 se registra como dos diversos Terminales H.323, uno para cada puerto.

    Nota: El ATA utiliza la contraseña para generar el token. Este token se envía al gatekeeper para autenticar.

  4. Configuración NTPIP con la dirección IP del servidor NTP.

    El portero y el ATA deben tener relojes sincronizados al mismo servidor NTP.

Nota: El grupo fecha/hora se utiliza para la generación de token. Para más información, refiera al gateway al portero (H.235) y al portero al guía de Troubleshooting de la Seguridad del portero (IZCT).

Esto es una configuración en funcionamiento de la muestra para el gatekeeper y gateway al usar el ATA con H.323 ID y el método de autenticación de contraseña usando un separador:

2610-Gatekeeper
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1 password cisco

!--- Same as the LoginID0 and PWD0 fields.

username atagw2 password cisco

!--- Same as the LoginID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security h323-id
security password separator =

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

Nota: Para más información sobre la seguridad del gatekeeper, refiera al gateway al portero (H.235) y al portero al guía de Troubleshooting de la Seguridad del portero (IZCT).

Verificación

El ejemplo en esta sección muestra el registro del punto de final del gatekeeper.

Para verificar la configuración, publique el comando show gatekeeper endpoint.

                            GATEKEEPER ENDPOINT
REGISTRATION

CallSignalAddr  Port  RASSignalAddr  Port  Zone Name  Type     Flags
--------------  ----  -------------  ----  ---------  ----     -----
172.16.13.40    1720  172.16.13.40   50923    gk2     VOIP-GW  E164-ID: 1234
                                                               H323-ID: 3640
172.16.13.43    1720  172.16.13.43   58400    gk2     VOIP-GW  H323-ID: 3660-2
172.16.104.117  1720  172.69.85.90   1719     gk2     TERM     E164-ID: 3000
172.16.104.117  1721  172.69.85.90   1739     gk2     TERM     E164-ID: 3001
Total number of active registrations=3

Nota: El ATA186 se registra como terminal de H.323 (TÉRMINO) y no como gateway de H.323. Esto se hace deliberadamente para solamente enviarle las llamadas previstas para el ATA186.

Nota: Usted no puede tener ningún direccionamiento en el campo del gateway ATA. Usted no puede configurar el ATA186 para trabajar con el portero así como el gateway.

Troubleshooting

Esta sección proporciona la información para resolver problemas en su configuración.

El ATA186 no proporciona el tono de discado si no se registra con éxito con el portero. Si el ATA186 no se está registrando con el portero, verifique estos elementos:

  • La conectividad del IP existe entre el ATA186 y el portero.

  • Los campos UID0 y UID1 ATA186 se configuran correctamente.

    • Si los campos del UID se fijan a 0, el ATA186 no intenta registrarse con el portero.

    • Por lo menos, el campo UID0 debe ser un valor sin cero, para que el ATA186 comience el proceso de inscripción.

    • Si ambos puertos ATA186 (UID0 y UID1) tienen direccionamientos no-cero E.164, el ATA186 intenta registrarse con ambos puertos. El ATA186 no proporciona el tono de discado, incluso si uno de los puertos no puede registrarse.

  • Configuran al portero correctamente.

    • Si configuran al portero con un prefijo de la zona local, el direccionamiento E.164 del ATA186 debe ser incluido.

    • Si la Seguridad se configura en el portero, el ATA186 se debe configurar por consiguiente.

Además, verifique que el campo de UseSIP esté fijado a 0. Esto es necesario configurar el ATA186 en el modo de H.323. Si el campo de UseSIP se fija a 1, el ATA186 no envía el pedido de inscripción al portero.

Resuelva problemas al portero

Cuando se configura la Seguridad, publique el comando debug aaa authentication.

Si no se configura ninguna Seguridad, publique el comando debug ras.

Nota: El ATA186 se registra para los dos puertos de voz por separado. El ATA186, por lo tanto, consigue dos veces autenticados Terminales H.323 tan diversos, tal y como se muestra en de este debug:

4w4d: AAA/AUTHEN/CONT (3800768902): continue_login (user='atagw1')
4w4d: AAA/AUTHEN (3800768902): status = GETPASS
4w4d: AAA/AUTHEN/CONT (3800768902): Method=LOCAL
4w4d: AAA/AUTHEN (3800768902): status = PASS
4w4d: AAA: parse name=<no string> idb type=-1    tty=-1
4w4d: AAA/MEMORY: create_user (0x83149EFC) user='atagw2'ruser='NULL' port='NULL'
      rem_addr='NULL' authen_type=ASCII service=LOGIN priv=0 initial_task_id='0'
4w4d: AAA/AUTHEN/START (294225678): port='' list='h323' action=LOGIN service=LOGIN
4w4d: AAA/AUTHEN/START (294225678): found list h323
4w4d: AAA/AUTHEN/START (294225678): Method=LOCAL
4w4d: AAA/AUTHEN (294225678): status = GETPASS
4w4d: AAA/H323: Password:
4w4d: AAA/AUTHEN/CONT (294225678): continue_login (user='atagw2')
4w4d: AAA/AUTHEN (294225678): status = GETPASS
4w4d: AAA/AUTHEN/CONT (294225678): Method=LOCAL
4w4d: AAA/AUTHEN (294225678): status = PASS
4w4d: AAA: parse name=<no string> idb type=-1    tty=-1
4w4d: AAA/MEMORY: create_user (0x831910C0) user='3660'  ruser='NULL' port='NULL'
      rem_addr='NULL' authen_type=ASCII service=LOGIN priv=0 initial_task_id='0

Para más ejemplos de Troubleshooting, refiera a los Problemas de registro de gatekeeper del troubleshooting.

Resuelva problemas el ATA186

Cuando usted está trabajando con los gatekeeperes de terceros y los gatewayes, la herramienta de Troubleshooting en el ATA186 es muy útil. Para habilitar la herramienta de Troubleshooting ATA186, siga los siguientes pasos:

  1. En el campo ATA Nprintf, configure la dirección IP del PC que está en la misma subred como el ATA186.

  2. El puerto especificado después de la dirección debe ser 9001.

  3. En el prompt DOS en el PC, publique el programa del preserv.exe.

Usted puede descargar el programa del preserv.exe del centro de CiscoSoftware (registeredcustomers solamente).

El programa del preserv.exe se incluye en la última versión de software ATA186 archivo zip.

Depuraciones de muestra para llamadas realizadas desde ATA 186

D:\Documents and Settings\sshafiqu\My Documents\voice\ata>prserv.exe
GK<-1: KPA-RRQ:300 sec
GK->1: RCF:TTL 300

!--- ATA was reset after the gatekeeper configuration was added.

WStop:0
Wed Feb 06 19:06:54 2002 Hello from 171.69.85.90(0)
Build 1109a: v2.12 ata186
Successfully Registered with the Gatekeeper
GK zone<gk2>172.16.13.12: 3000
GK zone:gk2
0x13e138 delayed RRQ: 48 ticks: 300
GK zone<gk2>172.16.13.12: 3001
GK zone:gk2
0x141e58 delayed RRQ: 56 ticks: 300
BMK : gk2
GK<-1: KPA-RRQ:300 sec
BMK : gk2
GK<-0: KPA-RRQ:300 sec
GK->1: RCF:TTL 300
GK->0: RCF:TTL 300
SCC->(0 0) <cmd 0>
3000 active @0xab45555a (GK @0xac100d0c)

!--- Call made from voice port 0.

[0]DTMF 1
[0]DTMF 2
[0]DTMF 3
[0]DTMF 4
[0]DTMF #
Calling 1234
SCC->(0 0) <cmd 16>
CLIP\
\SCC->(0 0) <cmd 2>
\<0 0> dial<1234>
GK<-0: ARQ: 0
GK->0: ACF:0:direct call
IRR in 240 sec
CallRasCallBack: 1 33e15eb 33e206b 33e39b0
Connect to <0xac100d28 1720>>..
>>>>>>>> TX CALLER ID : 0x1          0x80 6
Q931<-0:Setup:CRV 25006
Q931->0:Proceeding
Connect H245...
H245 TCP conn ac100d28 11006
CESE/MSDSE start:<0 0 0 0>
capSize = 3
H245->0:Cese
RemoteInputCap <15 5>
RemoteInputCap <15 4>
RemoteInputCap <15 1>
RemoteInputCap <4 11>
MODE FRAME : 11 2
RemoteAudioCap <4 10>
Capability set accepted
H245->0:MSD: <rn tt> = <0x269c 60>
H245->0:CeseAck
H245->0:MsdAck
h323.c 1837: cstate : 3
->H245<0> OLC
H245<-0:LcseOpen
set TX audio to G729/G729A 2 fpp
SetG723Mode: 2 0
H245->0:LcseOpen
H245->0:OLC mode 10
remote OpenLogicalReq G711/G729(10) : 2 fpp
OpenRtpRxPort(0,0x0,4000):14
RTP Rx Init: 0, 0
RTP->0:<0xab45555a 4000>
H245->0:LcseOpenAck
RTP<-0:<0xac100d28 17304>
[0]Enable encoder 18
RTP TX[0]:SSRC_ID = 4af964c0
RTP Tx Init: 0, 0
[0]DPKT 1st: 861812319 861812079, pt 18
Enable LEC adapt [0]=1
H323Dispatcher : 3 3
[0]Received pi=8 in q931
Q931->0:Progress
Q931->0:Connect
SCC:ev=12[0:0] 3 0
Q931->0:ReleaseComplete: reason 16, tone = 13
H245<-0:EndSessionCmd 1
0: Close RTPRX
write TCP err : 13 -33
[0:0]Rel LBRC Res
Q931<-*:ReleaseComplete

!--- ATA side hangs up the call.

write TCP err : 12 -33
GK<-0: DRQ:0

!--- Disconnect request sent by ATA.

SCC:ev=13[0:0] 4 0
[0:0]SCC: Disconnected
GK->0: DCF

!--- Disconnect confirm received.

SCC->(0 0) <cmd 1>
[0]MPT mode 0

No hay tono de marcado ejemplo del debug ATA

Ambos puertos de voz necesitan un direccionamiento único E.164, si no el ATA recibe un rechazo del portero. Durante este tiempo, usted verá el ATA186 el ser con una sola voz puerto registrado como terminal de H.323, pero habrá no hay tono de marcado.

K<-0: GRQ
BMK : gk2
GK->0: GCF:GK@0xac100d0c-1719
BMK : gk2
Secured RRQ
GK<-0: RRQ
GK->0:RRJ: reason 4

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 19084