IP : Protocolo mejorado de routing de gateway interior (EIGRP)

Cómo evitar ID duplicados de router EIGRP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El router duplicado ID del Enhanced Interior Gateway Routing Protocol (EIGRP) puede causar los problemas con la redistribución de las rutas EIGRP externas. Este documento explica el problema y proporciona la configuración adecuada para prevenirla.

La ID del router EIGRP generalmente se selecciona de la misma manera que con el método de abrir primero el trayecto más corto (OSPF). La dirección IP más alta asignada a una interfaz de loopback se elije como la ID del router. Si no hay ninguna Loopback Address configurada, la dirección IP más alta asignada a cualquier otra interfaz se elige como el Router ID.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Esta configuración fue desarrollada y probada usando el Software Release 12.2(10b) del½ del¿Â del Cisco IOSïÂ.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Problema

El problema que se encuentra con las rutas redistribuido debido a la presencia de Routers con el router EIGRP duplicado ID se puede entender con la ayuda de esta configuración de la red.

Diagrama de la red

eigrp-dup-id.jpg

Configuraciones

Router 4
interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 10.10.10.10 255.255.255.0

!

interface Ethernet0

 ip address 172.16.3.4 255.255.255.0

!

router rip

 version 2

 network 10.0.0.0

 network 172.16.0.0

Router 3
interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface Ethernet0

 ip address 172.16.3.3 255.255.255.0

 ip pim sparse-dense-mode

!

interface Serial1

 ip address 172.16.13.3 255.255.255.0

 clockrate 4000000

!

router eigrp 7

 redistribute rip metric 1 1 1 1 1

 network 172.16.0.0

!

router rip

 version 2

 network 172.16.0.0

Router 1
interface Loopback0

 ip address 2.2.2.2 255.255.255.0

!

interface Serial1

 ip address 172.16.13.1 255.255.255.0

 no ip mroute-cache

!

router eigrp 7

 network 172.16.0.0

 auto-summary

 no eigrp log-neighbor-changes

Comandos show

Según lo mostrado previamente, el router3 redistribuye las rutas del Routing Information Protocol (RIP) en el EIGRP. Éste es los 3 tabla de ruteo y tabla de topología EIGRP.

Router-3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
R    10.0.0.0/8 [120/1] via 172.16.3.4, 00:00:25, Ethernet0 
!--- Router 3 sees network 10.0.0.0.

     172.16.0.0/24 is subnetted, 3 2 subnets
C       172.16.13.0 is directly connected, Serial1
C       172.16.3.0 is directly connected, Ethernet0
router-3#


router-3#show ip eigrp topology 10.0.0.0 255.0.0.0
IP-EIGRP (AS 7): topology entry for 10.0.0.0/8
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
  Routing Descriptor Blocks:
  0.0.0.0, from Redistributed, Send flag is 0x0
      Composite metric is (2560000256/0), Route is External
      Vector metric:
        Minimum bandwidth is 1 Kbit
        Total delay is 10 microseconds
        Reliability is 1/255
        Load is 1/255
        Minimum MTU is 1
        Hop count is 0
      External data:
        Originating router is 2.2.2.2 (this system)
!--- Shows that Router 3 is the originating router of the external route.

        AS number of route is 0
        External protocol is RIP, external metric is 1
        Administrator tag is 0 (0x00000000)
router-3#

De la salida anterior, usted puede ver que el router3 ha aprendido sobre la red 10.0.0.0 vía el RIP. Con la redistribución, la ruta se ha ingresado en la tabla de topología EIGRP como ruta externo. El router3 también muestra que es el router de origen de la ruta externo; su router EIGRP ID es 2.2.2.2.

Puesto que el router3 parece redistribuir la ruta externo, se espera que la vea en la tabla de ruteo del router1. Ésta es la visualización de la tabla de ruteo y de la tabla de topología EIGRP para el router1.

router-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 3 2 subnets
C       172.16.13.0 is directly connected, Serial1
D       172.16.3.0 [90/2195456] via 172.16.13.3, 00:31:59, Serial1
router-1#


router-1# show ip eigrp topology
IP-EIGRP Topology Table for AS(7)/ID(2.2.2.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.13.0/24, 1 successors, FD is 2169856
         via Connected, Serial1
P 172.16.3.0/24, 1 successors, FD is 2195456
         via 172.16.13.3 (2195456/281600), Serial1
router-1#

De la salida anterior usted puede ver que la ruta prevista de 10.0.0.0/8 no está en la tabla de ruteo o la tabla de topología EIGRP de router1. La posible razón de esto es que los Routers 1 y 3 tienen la misma ID de router EIGRP. En el Cisco IOS Software Release 12.0(2) y Posterior, Cisco registra los ID de routeres duplicados en el registro de eventos del EIGRP, que usted puede ver con el comando show ip eigrp events. Ésta es la salida de esto para el router1:

router-1 #show ip eigrp events 
Event information for AS 7:
1    18:06:15.863 Change queue emptied, entries: 1
2    18:06:15.863 Ignored route, metric: 10.0.0.0 2560512256
3    18:06:15.863 Ignored route, neighbor info: 172.16.13.3 Serial2
4    18:06:15.863 Ignored route, dup router: 2.2.2.2


!--- Output suppressed.

De la salida anterior usted puede ver que el ID de router duplicado es la razón que el router1 no valida la ruta del router3.

Solución

La solución es cambiar el Router ID en uno del Routers cambiando la dirección IP más alta en el Loopback Interface. Si usted Cisco IOS Software Release 12.1(6) o Posterior del ause, usted puede también utilizar el subcomando de router del <router-id> router-identificación del eigrp para cambiar el Router ID. En este ejemplo, cambiamos la ID del router en el Router 1.

router-1(config)#router eigrp 7 
router-1(config-router)#eigrp router-id 3.3.3.3

Nota: Eigrp del IP del problema < comando claros del sistema autónomo después de que usted cambie el Router ID del eigrp.

La ruta externo ahora aparece en la tabla de ruteo como se muestra aquí.

router-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, IA - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.13.0 is directly connected, Serial1
D       172.16.3.0 [90/2195456] via 172.16.13.3, 00:00:00, Serial1
D EX 10.0.0.0/8 [170/2560512256] via 172.16.13.3, 00:00:00, Serial1
router-1# 

Información Relacionada


Document ID: 18685