Calidad de servicio (QoS) : Supervisión de QoS

‘Configuración del paquete de marcación en PVC de Frame Relay’

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documentos revisa los comandos admitidos de configurar el paquete que marca sobre las interfaces de Frame Relay.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no se limita a una versión específica de software o de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Marca del paquete en base a la clase

La marca del paquete en base a la clase utiliza los comandos set y otros comandos del comando line interface(cli) de la calidad de servicio modular (QoS) de cambiar el valor de un campo en un encabezado de paquete.

Las versiones de software actuales del ½ del ¿Â de Cisco IOSï permiten que usted haga estas acciones:

  • Fije los bits de precedencia IP o el Differentiated Services Code Point IP (DSCP) en el byte del tipo de servicio IP (TOS).

  • Fije el valor del Clase de Servicio (CoS) de la capa 2.

  • Asocie un valor de grupo local de QoS a un paquete.

  • Cambie la configuración del bit del Prioridad de pérdida de celda (CLP) en el encabezado ATM de un paquete a partir de la 0 a 1.

Se soportan ambas directivas entradas y salidas. Cuando usted está configurando el Marcado basado en clases, observe estas restricciones:

  • Las políticas de resultado requieren el Control de tráfico de Frame Relay (FRTS).

  • Solamente se soportan los paquetes conmutados por Cisco Express Forwarding.

  • Una correspondencia de políticas que contiene el comando set atm-clp se puede asociar como política de resultado solamente.

Éste es un ejemplo de cómo se fija el valor DSCP:

Ejemplo de configuración - Marcado basado en clases
class-map user1
  match access-group 101
!
class-map user2
  match access-group 102
!
policy-map dscp
  class user1
    set ip dscp AF11
  class user2
    set ip dscp AF12
!
map-class frame set-dscp
  service-policy input dscp
!
int s0/0/0:0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
int s0/0/0:0.125
 frame-relay interface-dlci 125
  class set-dscp

Configuración de bit calificado para descarte

El Modular QoS CLI soporta dos comandos de cambiar el valor del calificado para descarte (DE) mordido en una trama de Frame Relay. Esos comandos son FR-de determinado con la modelación basada en la clase, y set-frde-transmit con el class-based policing.

Nota: El comando set-frde-transmit no se aplica al tráfico de Frame Relay transportado vía ningún transporte sobre MPLS (átomo).

Soportes de Frame Relay un esquema de dos niveles de la prioridad de paquetes usando el DE bit. Originalmente, solamente los dispositivos de red, tales como switches de Frame Relay, fijaron al DE bit para indicar la importancia relativa de un bastidor. En las versiones de Cisco IOS Software recientes, el Routers ahora puede fijar al DE bit.

El diagrama siguiente ilustra el formato de una trama de Frame Relay. El DE bit es uno de tres bits que controlen los mecanismos de la notificación de congestión de Frame Relay.

/image/gif/paws/18662/config_fr_pvc.gif

Publique estos comandos de monitorear el Marcado basado en clases:

  • pvc del show frame-relay — Visualiza las estadísticas para todos los componentes de circuito virtual permanente (PVC). Esto incluye estas estadísticas:

    • FRTS e información de la política de servicio

    • fragmentación

    • el número de paquetes adentro y hacia fuera

    • el número de bastidores con el Notificación explícita de la congestión hacia atrás (BECN), el Notificación explícita de la congestión del reenvío (FECN), y el conjunto de DE bits

Ejemplo de configuración - El corresponder con en el DE Bit
class-map match-fr-de
  match fr-de

!--- Define a class-map named “match-fr-de” to match packets with the FR DE bit set.

!
policy-map set-de
  class match-fr-de
   set ip precedence 1

!--- All packets that match the class have IP precedence set to 1.

!
map-class frame-relay pvc150
   service-policy input set-DE

!--- Apply the policy map to the map class.

!
interface Serial0.1 point-to-point
   frame-relay class pvc150
   frame-relay interface-dlci 150

!--- Associate a map class to the Frame Relay data-link connection identifier (DLCI).

Router# show policy-map interface s0.1

Serial0.1

 Service-policy input: set-prec

   Class-map: match-fr-de (match-all)
     358 packets, 103820 bytes
     30 second offered rate 18000 bps, drop rate 0 BPS  Match: fr-de
     QoS Set
       ip precedence  1
         Packets marked 359

   Class-map: class-default (match-any)
     643 packets, 186470 bytes
     30 second offered rate 32000 BPS, drop rate 0 BPS
     Match: any  (1201)

Soporte introducido Cisco IOS Software Release 12.2(2)T para fijar al DE bit con la opción del set-frde-transmit como parte del comando police. (Para más información, refiera a la Vigilancia de tráfico.) Puede también ser útil fijar al DE bit cuando está utilizado con los mecanismos de limitación de velocidad, como el class-based policing. El objetivo de tal a política de calidad de servicio (QoS) es transmitir los paquetes sin conformidad a normas con el Frame Relay y el conjunto de bits DE, de modo que el Switches rio abajo pueda potencialmente caer todo el tráfico sin conformidad a normas durante las condiciones de la congestión.

Nota: Aunque el class-based policing soporte la marca del paquete, se recomienda que usted utiliza esta característica solamente si usted necesita marcar los paquetes para evitar ejecutarlos a través del mecanismo del token bucket de los policer.

El ejemplo de configuración siguiente utiliza el comando police de limitar el tráfico total a 800 kbps. Todo el tráfico que conforma se transmite con una Prioridad IP de 7, y todo el tráfico sin conformidad a normas tiene el conjunto de bits DE.

Ejemplo de configuración - Determinación del DE Bit
policy-map set-DE
  class class-default
   police 800000 1000 1000 conform-action
   set-prec-transmit 7 exceed-action set-frde-transmit
   violate-action set-frde-transmit
!
map-class frame-relay pvc100
  frame-relay traffic-rate 1000000
  frame-relay mincir 1000000
  service-policy input set-DE
!
interface S0/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial0/0.1 point-to-point
  ip address 10.1.1.1 255.255.255.252
  no ip directed-broadcast
  frame-relay class pvc100
  frame-relay interface-dlci 100

router# show policy-map set-DE

 Policy Map set-DE
    Class class-default
      police 800000 1000 1000 conform-action
      set-prec-transmit 7 exceed-action
      set-frde-transmit violate-action
      set-frde-transmit

router# show frame-relay PVC 100

PVC Statistics for interface Serial0 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0.1

input pkts 0       output pkts 13000    in bytes 0
out bytes 3770000  dropped pkts 0       in FECN pkts 0
in BECN pkts 0     out FECN pkts 0      out BECN pkts 0
in DE pkts 0       out DE pkts 4447
out bcast pkts 0   out bcast bytes 0
PVC create time 00:51:50, last time PVC status changed 00:51:50

service policy set-DE

  Service-policy output: set-DE (1069)

   Class-map: class-default (match-any) (1071/2)
     11519 packets, 3340510 bytes
     30 second offered rate 1140000 BPS, drop rate 0bps
      Match: ip precedence 1  (1075)
      police:
        800000 BPS, 1000 limit, 1000 extended limit
        conformed 4448 packets, 1289920 bytes; action:
        set-prec-transmit 7
        exceeded 11 packets, 3190 bytes; action:
        set-frde-transmit
        violated 8475 packets, 2457750 bytes; action:
        set-frde-transmit
        conformed 394000 BPS, exceed 1000 BPS violate
        749000 BPS
   Output queue size 20/max total 600/drops 1451

Cuando usted está probando su configuración, observe esta información:

  • El Marcado basado en clases requiere el Cisco Express Forwarding. Publique el comando ip cef en el modo de configuración global, de habilitar el Cisco Express Forwarding, si no se habilita ya.

  • Originalmente, el Marcado basado en clases se aplicó solamente a los paquetes que eran expresos de Cisco Expedición-conmutados. Así, usted no vería incrementar a los contadores de paquetes coincidentes si usted utilizaba el ping para generar el tráfico en el mismo router, porque tales paquetes son process-switched.

  • El soporte para el Marcado basado en clases de los paquetes generados por el router se introduce en el Cisco IOS Software Release 12.2(6.8)T.

Elección de Dónde Aplicar una Política de Servicio

En las Cisco 7200 Series, el Cisco Series 2600/3600, y otras Plataformas de la NON-ruta/del Procesador del switch (RSP), una política de servicio debe ser aplicados dentro de un map-class; no puede ser aplicada directamente al PVC de Frame Relay. Las políticas de resultado requieren el FRTS, que usted habilita con el comando frame-relay traffic-shaping. Este comando configura las colas de administración del tráfico PVC. Así, una política de servicio se debe configurar generalmente en el modo de configuración de DLCI o en el PVC.

En las versiones de Cisco IOS Software actuales, las interfaces de Frame Relay soportan la aplicación de una correspondencia de políticas (con el comando service-policy) a las interfaces, a las subinterfaces, y a VCs. Esta tabla enumera las combinaciones soportadas de directivas:

Política de entrada Política de salida
Soportado en una interfaz lógica. Soportado en las interfaces lógicas múltiples que deben ser pares, tales como PVC múltiples.

Nota: Una interfaz principal y una subinterfaz no son interfaces de peer y no pueden soportar una política de servicio al mismo tiempo.

Soportado en uno o dos interfaces lógicas simultáneamente. Combinaciones válidas:
  • PVC y interfaz principal
  • Subinterfaz y interfaz principal
Combinaciones no válidas:
  • PVC y subinterfaz
  • PVC, subinterfaz, y interfaz principal

Originalmente, la configuración de una política de servicio con el comando set directamente en una interfaz principal no marcó el tráfico de la subinterfaz. Esto ilustra los síntomas de este problema:

Interface Serial5/1:1
no ip address
 encapsulation frame-relay
 no keepalive
 service-policy output set

!--- Avoid the placement of a service policy on a main interface.

 no fair-queue
 frame-relay class data-map
 frame-relay traffic-shaping
!
interface Serial5/1:1.1 point-to-point
 ip address 23.0.0.2 255.0.0.0
 frame-relay interface-dlci 300

giulia# show policy-map interface

 Serial5/1:1

  Service-policy output: set

    Class-map: prec-0 (match-all)
      100 packets, 10400 bytes

!--- Packets are classified correctly.

      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip precedence 0
      QoS Set
        ip precedence 1
          Packets marked 0

!--- No packets are marked.


    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any

Como solución alternativa, aplique la política de servicio a la subinterfaz.

Sintaxis heredada – Listas DE

En las versiones de Cisco IOS Software que no soportan el nuevo sintaxis del Modular QoS CLI de Cisco, usted puede utilizar el sintaxis de DE marking del legado de Cisco para fijar al DE bit. La sintaxis heredada utiliza a DE lists que identifica las características de los paquetes para ser elegible para el descarte, y usted puede también especificar a DE groups para identificar el DLCI que es afectado.

Router(config)# frame-relay de-list list-number 
              {protocol protocol | interface typenumber} characteristic


!--- Issue this command on one line.

Usted puede crear a DE lists basada en el protocolo o en la interfaz, y basada en las diversas características tales como fragmentación del paquete, de un puerto específico del protocolo Protocolo de control de transmisión (TCP) (TPC) o del User Datagram Protocol (UDP), un número de lista de acceso, o un tamaño de paquetes. Refiera al comando frame-relay de-list en la referencia del comando wide-area networking del Cisco IOS para más información.

Para definir a un DE group que especifique al DE list y el DLCI afectado, publique el comando frame-relay de-group group-number dlci en el modo de configuración de la interfaz.


Información Relacionada


Document ID: 18662