Calidad de servicio (QoS) : Supervisión de QoS

Configuración de CBWFQ en PVC de Frame Relay

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento brinda ejemplos de configuración para el Almacenamiento en cola basado en clases con ponderación equilibrada (CBWFQ) en una interfaz de Frame Relay. CBWFQ se habilita con el comando bandwidth, tal como está configurado en un mapa de políticas con los comandos de la Interfaz de línea de comandos de calidad de servicio (CLI QoS) modular.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

El CBWFQ se soporta a partir de las versiones de software siguientes del ½ del ¿Â de Cisco IOSï dependiendo de la plataforma:

  • Serie Cisco 7500 con Procesadores de interfaces versátiles (VIP) (CBWFQ distribuida) - 12.1(5)T

  • Series Cisco 7200, 2600/3600 y otras plataformas que no son de la serie 7500 - 12.1(2)T

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Modelado y almacenamiento en cola

La espera se utiliza generalmente en el contexto del shaping, que reduce la velocidad de salida e induce así la congestión. Utilice el CBWFQ con los mecanismos de modelado y los comandos siguientes dependiendo de su plataforma.

  Serie 7500 de Cisco Cisco 7200, 3600, 2600 y otras plataformas no VIP
Mecanismos de modelado compatibles Control de tráfico distribuido (dTS) Modelado del tráfico de Frame Relay (Frame Relay TS)
Comando de configuración configure el comando según la política de mapa frame-relay traffic-shaping en una interfaz principal, comandos de configuración de la clase de asociador para especificar parámetros de modelado
Requiere Distributed Cisco Express Forwarding (dCEF). Sí (Verificar con el comando show cef linecard) No

Series Cisco 7200, 3600, 2600

El Cisco IOS 12.1(2)T introduce el soporte para el CBWFQ en los 7200, 2600/3600, y otras Plataformas del Non-Route Switch Processor (RSP). (Para más información, refiera al low latency queueing (el LLQ) sobre el Frame Relay.) En estas Plataformas, el CBWFQ en las interfaces de Frame Relay está siempre en el contexto de TS de Frame Relay. Utilice el comando frame-relay traffic-shaping para habilitar el TS de Frame Relay. En estas plataformas, no puede utilizar CBWFQ con el Modelado de tráfico genérico (GTS) o el comando shape. Abajo se brinda un ejemplo de configuración.

Ejemplo de configuración de CBWFQ en las series 7200, 3600 y 2600 de Cisco.
 policy-map mypolicy 
  class voice 
   priority 16 
  class priority-data 
   bandwidth 16 

!--- Create a policy-map and apply the bandwidth 
!--- command to a class. 

! 
 int s0/0 
  encapsulation frame-relay IETF 
  load-interval 30 
  frame-relay traffic-shaping 

!--- Enable Frame Relay TS. 

! 
 interface Serial0/0.1 point-to-point 
  frame-relay interface-dlci 100 
    class frclass 

!--- Apply the map-class to the Frame Relay PVC. 

! 
 map-class frame-relay frclass 
  service-policy output mypolicy 
  frame-relay cir 64000 
  frame-relay bc 640 

!--- Apply the service policy inside the map-class.

Nota: Si usted habilita una política de servicio directamente en una interfaz principal y no dentro de un comando map-class, usted también no puede aplicar el TS de Frame Relay directamente a la interfaz. Es importante observar que los Mecanismos para formar la cola después se aplican a una sola cola de la interfaz grande bastante que a las colas de administración del tráfico del Per-Virtual Circuit (VC)

En las Cisco 7200 Series, de la versión del Cisco IOS Software 12.0(26)S y posterior, no es posible configurar una política de servicio de resultados en un comando frame-relay map-class más. En lugar la configuración del Cisco 7500 debe ser aplicada como se explica en la sección siguiente. Un directiva-mapa jerárquico se debe configurar con el shaping en una política controlante y los Datos en espera en una política hija. La política controlante se debe entonces asociar a la tubería o a la subinterfaz. Si usted intenta configurar un resultado de la política de servicio en el comando map-class frame-relay, el mensaje de error siguiente aparecerá:

c7200(config)#map-class frame-relay
	 stef
c7200(config-map-class)#frame-relay cir
	 64000
c7200(config-map-class)#service-policy output
	 aan
Frame relay output service policy is not
	 supported

Serie 7500 de Cisco

A partir del Cisco IOS 12.1(5)T, las directivas de QoS deben ejecutarse en el modo distribuido en el VIP; porque el QoS RSP basado se soporta no más. Así, usted debe utilizar el comando shape y otros comandos del Modular QoS CLI de implementar el DTS para las interfaces de Frame Relay en los VIP en las Cisco 7500 Series. DTS combina TS de retransmisión de tramas y GTS. En el documento Configuración del modelado de tráfico distribuido y a continuación se ofrece un ejemplo de configuración.

Configuración de muestra de DTS con una política jerárquica
ip cef distributed 
 !  
 class-map 1  
   match < >  

!--- Define match-on criteria.

 class-map 2  
   match < >

!--- Define match-on criteria.

 !  
 policy-map CBWFQ  
   class 1  
     bandwidth < >  
     !-- Define value in kbps or percent.  
   class 2  
     priority < > 
 
!--- Define value in kbps or percent.

 !  
 Policy-map SHAPE  
    class class-default  
     shape average    
     service-policy CBWFQ  
 !  
 int s0/0/0  
   encapsulation frame-relay  
   ip route-cache distributed  
 !  
 int s0/0/0.1 point-to-point  
   ip address a.b.c.d  
   frame-relay interface-dlci xxx  
    class cisco  
 !  
 map-class frame-relay cisco  
   service-policy output SHAPE

Elección de Dónde Aplicar una Política de Servicio

Al configurar CBWFQ, utiliza los comandos del modular QoS CLI para crear un mapa de política de tráfico con varias clases de tráfico y una o más características de QoS. En las versiones actuales del Cisco IOS Software, las interfaces de Frame Relay soportan la aplicación de un directiva-mapa con el comando service-policy a las interfaces, a las subinterfaces, y a VCs. Ahora sólo se admiten combinaciones de políticas correctas. La siguiente tabla describe dónde se puede aplicar la política QoS con el modelado de tráfico.

  Serie 7500 de Cisco Cisco 7200, 2600/3600 Series, y otras Plataformas
Interfaz principal Configure una política de servicio en la interfaz principal Soportado solamente si el TS de Frame Relay no se habilita y los Mecanismos para formar la cola se aplican a un tubo de la sola interfaz.
Subinterfaz Configure una política de servicio en la subinterfaz. Configure una política de servicio dentro de una clase de mapa de Frame Relay y habilite el almacenamiento en cola por VC con comando frame-relay traffic-shaping. Se puede aplicar la clase de mapa a la subinterfaz.
Nivel de VC   Configure una servicio-directiva dentro de una clase de correspondencia de Frame Relay y habilite la espera por VC con el comando frame-relay traffic-shaping. Usted puede aplicar el map-class al VC.

Problemas conocidos

Al configurar el CBWFQ en las interfaces de Frame Relay, observe las advertencias siguientes:

  • Luego de que un router vuelve a cargarse, es posible que los contadores de coincidencias entre paquetes de una política de servicio no aumenten cuando la política se aplica a la interfaz principal. Este problema se resuelve asegurando que los indicadores de la clasificación WFQ (Colocación en cola equilibrada ponderada) se copien desde la interfaz principal a las subinterfaces.

  • No se admite la configuración simultánea de LLQ y TS Frame Relay en el nivel físico de la interfaz El router quita la política de servicio de la configuración corriente después de una recarga de router. La política de servicio se debe asociar al map-class cuando el TS de Frame Relay se habilita en la interfaz. El intentar configurar esta combinación da lugar al mensaje de error CBWFQ: No soportado en esta interfaz.

  • Cuando una política de servicio con el CBWFQ se aplica directamente a una interfaz principal de Frame Relay (tal como, no envío a la cola por VC), la directiva se puede quitar después de una recarga de router si las sentencias de ancho de banda se configuran en una subinterfaz y una interfaz principal. El router puede informar mensajes de registro similares a los siguientes:

    CBWFQ: Not enough available bandwidth for all classes Available 44 (kbps) 
        Needed 1 00 (kbps)
        CBWFQ: Removing service policy on Serial1/0

    Este problema es resuelto cambiando el comportamiento del CBWFQ para ignorar las notificaciones cuando el ancho de banda en la subinterfaz se cambia, puesto que el CBWFQ se puede configurar fuera de una clase de correspondencia de Frame Relay solamente en el nivel de interfaz principal. Como solución alternativa, quite el comando bandwidth de la subinterfaz. Si utiliza ancho de banda en la subinterfaz para influenciar la métrica de ruteo, utilice un método alternativo como el de costo, como en el caso de abrir el trayecto más corto en primer lugar (OSPF) o retraso, como en el protocolo de ruteo de puerto de enlace interior mejorado (EIGRP).

Notas de configuración

  • Cuando los comandos bandwidth y priority calculan la cantidad total de ancho de banda disponible en una entidad, se invocan las siguientes directivas en caso de que la entidad sea un circuito virtual permanente (PVC) Frame Relay modelado:

    • Si no se configura una Velocidad de la información comprometida (minCIR) mínima aceptable, la CIR se divide en dos.

    • Si hay un minCIR configurado, la configuración de minCIR se usará en el cálculo.

    • Todo el ancho de banda del índice anterior puede ser asignado a clases de ancho de banda y de prioridad. De este modo, el comando max-reserved-bandwidth no cuenta con soporte en PVC de Frame Relay, a pesar de que debería tener el cuidado de asegurarse que la cantidad de ancho de banda configurada sea suficiente como para además acomodar la sobrecarga de Capa 2 (L2). Para más información, refiérase a qué bytes son contados haciendo cola del IP to ATM CoS?.

  • Evite fijar el CIR o el mincir a la velocidad de acceso. De lo contrario, podría observar colas de salida formándose y causando grandes demoras en las clases CBWFQ. La razón es que la velocidad de modelado no tiene en cuenta los bytes de tara del indicador ni los campos de Verificación por redundancia cíclica (CRC), por lo que la velocidad del modelado en línea excede actualmente el número de suscriptores y esto provocará una congestión en la interfaz. Realmente no existe ninguna razón para modelar a la velocidad de acceso. Usted debe traficar siempre la dimensión de una variable en el 95 por ciento de la velocidad de acceso o, más generalmente, la tarifa formada global debe siempre ser el 95 por ciento debajo de la velocidad de acceso.

  • Al configurar FRF 12, el tamaño de la cola de salida aumenta para ubicar el mismo número de bytes que ahora se fragmentan. Es decir usted va de una cola de paquete a una cola del fragmento.

  • El WFQ por VC está incluido en la versión 12.0(7)T del software del IOS de Cisco.

  • El CBWFQ con el GTS se incluye en la versión del Cisco IOS Software 12.1(2)T.


Información Relacionada


Document ID: 18661