Calidad de servicio (QoS) : Supervisión de QoS

Control de tráfico de Frame Relay con el calidad del servicio (QoS) distribuida en las Cisco 7500 Series

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (23 Abril 2008) | Inglés (23 Abril 2015) | Comentarios


Contenido


Introducción

Este documento aclara las diferencias entre la aplicación del modelado de tráfico a las interfaces de Frame Relay en los Cisco 7500 Series Router con el Versatile Interface Processors (VIP) y en otras Plataformas. Las otras Plataformas incluyen a los routeres de la serie del 7200, 3600 y 2600 de Cisco.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

A partir del Software Release 12.1(5)T del ½ del ¿Â de Cisco IOSïÂ, las directivas del Calidad de Servicio (QoS) deben ejecutarse en el modo distribuido en el VIP; El Route Switch Processor (RSP) - QoS basado se soporta no más. Así, usted debe utilizar el comando shape y otros comandos de la interfaz de la línea de comandos de la Calidad del servicio (QoS) modular (MQC) para implementar el Control de tráfico distribuido (dTS) para las interfaces de Frame Relay en los VIP en las Cisco 7500 Series. Control de tráfico genérico (GTS) y Control de tráfico de Frame Relay (TS de Frame Relay) de las cosechadoras del DTS. Refiera a configurar el Distributed Traffic Shaping para una configuración de muestra.

Esta tabla aclara cómo configurar el TS de Frame Relay, que depende de la plataforma:

Serie 7500 7200, 3600, 2600 y otras plataformas no VIP
Mecanismos de modelado compatibles DTS TS de Frame Relay
Comando de configuración comando shape en una correspondencia de políticas formar EL tráfico del Frame Relay en una interfaz principal; comandos de configuración de la clase correspondiente de especificar los parámetros de modelado
Requiere el dCEF1 Sí (verifique con el comando show cef linecard.) No

1 dCEF = Distributed Cisco Express Forwarding

Nota: En las Cisco 7500 Series, la capacidad de configurar el TS de Frame Relay vía el comando frame-relay traffic-shaping ahora se bloquea porque el TS de Frame Relay ejecuta solamente el RSP en un modo no distribuido. Con el dCEF y el TS de Frame Relay, una adyacencia de la “batea” CEF hace el RSP ayunar el Switch todos los paquetes, que es subóptimo para el rendimiento de reenvío máximo.

Pasos de configuración

Utilice estos pasos para configurar el DTS en las interfaces de Frame Relay VIP basadas:

  1. Habilite el dCEF con este comando:

    router(config)# ip cef distributed
    
  2. Asegúrese de que la interfaz de Frame Relay esté habilitada para el Distributed Switching.

    router(config-if)# interface serial 8/0/0 
    router(config-if)# ip route-cache distributed
    
    router# show ip interface serial 8/0/0 
    Serial8/0/0 is up, line protocol is up 
      Internet address is 24.0.0.2/24 
      Broadcast address is 255.255.255.255 
     
    !--- Output suppressed.
     
      ICMP redirects are always sent 
      ICMP unreachables are always sent 
      ICMP mask replies are never sent 
      IP fast switching is enabled 
      IP fast switching on the same interface is disabled 
      IP Flow switching is disabled 
      IP CEF switching is enabled 
      IP Distributed switching is enabled 
      IP Fast switching turbo vector 
      IP CEF switching with tag imposition turbo vector 
      IP multicast fast switching is enabled 
      IP multicast distributed fast switching is disabled 
      IP route-cache flags are Fast, Distributed, CEF 
      Router Discovery is disabled 
      IP output packet accounting is disabled
  3. Cree una política de servicio y apliqúela al map class.

    Usted puede implementar una de estas directivas:

    Nota: Mientras que el Cisco IOS Software Release 12.1(2)T introdujo el soporte para el low latency queueing (LLQ) en las Plataformas con excepción de las Cisco 7500 Series, el LLQ distribuido (dLLQ) fue introducido en el Cisco IOS Software Release 12.1(5)T en el VIP. La versión distribuida aumenta el funcionamiento de esta característica. Usted puede configurar una directiva de servicio único por el identificador de conexión de link de datos (DLCI). Usted no necesita utilizar un map class. Usted puede aplicar el comando service-policy directamente a la subinterfaz o al DLCI. Sin embargo, dLLQ de la configuración dentro de un map class.

  4. Verifique la operación correcta de su política de servicio con estos comandos:

    • show policy-map interface

    • show interface shape

    • show vip full-qos

    Configuración de muestra del DTS con una política de jerarquía
    ip cef distributed 
    ! 
    class-map 1 
      match <> 
      
    !--- Define match-on criteria.
     
    class-map 2 
      match <> 
      
    !--- Define match-on criteria.
     
    ! 
    policy-map CBWFQ 
      class 1 
        bandwidth <>  
        
    !--- Define the value in kbps or percent.
     
      class 2 
        priority <>  
        
    !--- Define the value in kbps or percent.
     
    ! 
    policy-map SHAPE 
       class class-default 
        shape average   
        service-policy CBWFQ 
    ! 
    int s0/0 
      encapsulation frame-relay 
      ip route-cache distributed 
    
    !--- Do not configure frame-relay traffic-shaping.
    
    ! 
    int s0/0.1 point-to-point 
      ip address a.b.c.d 
      frame-relay interface-dlci xxx 
       class cisco 
    ! 
    map-class frame-relay cisco 
      service-policy output SHAPE

FRF.12 y DTS

La Versión 12.1(5)T del software del IOS de Cisco introdujo una versión distribuida de fragmentación de Frame Relay, FRF.12. Cuando usted aplica el FRF.12 distribuido a una interfaz de Frame Relay, usted debe definir un map class y aplicar la política de servicio bajo el map class. Si usted intenta configurar un map class con la política de servicio aplicada directamente a la interfaz, sus informes del router este mensaje de error con la consola de registro habilitada:

Frame Relay fragmentation works with dTS only. 
Please remove traffic-shaping from the interface serial 1/0/0

Probaron la configuración en esta sección y a los comandos configuration verification en un Cisco 7500 Series Router que funciona con el Cisco IOS Software Release 12.2(5)T en un RSP8.

Nota: Refiera al VoIP over Frame Relay con la calidad de servicio (fragmentación, modelado de tráfico, prioridad de RTP LLQ/IP) para más información sobre la selección de valores de fragmentación.

Ejemplo de configuración de DTS y FRF.12
interface Ethernet4/1/3 
 ip address 10.122.3.206 255.255.255.0 
! 
interface Serial5/0/0:0 
 no ip address 
 encapsulation frame-relay 
 load-interval 30 
 no fair-queue 

!--- Do not configure frame-relay traffic-shaping.

! 
interface Serial5/0/0:0.1 point-to-point 
 ip address 10.1.1.2 255.255.255.0 
 frame-relay interface-dlci 16  
 class test 
 frame-relay ip rtp header-compression 
! 
map-class frame-relay test 
 no frame-relay adaptive-shaping 
 service-policy output llq-shape 
 frame-relay fragment 120 

!--- Apply the frame-relay fragment command to the  
!--- Frame Relay map class.

 access-list 101 permit udp any range 16384 32767 any  range 16384 32767

MS-7507-8A# show ip rtp head 
RTP/UDP/IP header compression statistics: 
DLCI 16 Link/Destination info: point-to-point dlci 
Interface Serial5/0/0:0: 
Distributed fast switched: 
4 seconds since line card sent last stats update 
Rcvd: 105475 total, 105472 compressed, 0 errors 
0 dropped, 0 buffer copies, 0 buffer failures 
Sent: 99451 total, 99447 compressed,  
3776208 bytes saved, 2187963 bytes sent 
2.72 efficiency improvement factor 
Connect: 256 rx slots, 256 tx slots,  
0 long searches, 3 misses 0 collisions, 0 negative cache hits 
99% hit ratio, five minute miss rate 0 misses/sec, 0 max 

MS-7507-8A# show policy-map  
Policy Map llq-shape 
 Class class-default 
  shape peak 256000 1024 1024 
  service-policy llq 
Policy Map llq 
 Class voip 
  priority percent 50 

MS-7507-8A# show policy-map interface s 5/0/0:0.1 
Serial5/0/0:0.1: DLCI 16 - 
Service-policy output: llq-shape 
  queue stats for all priority classes: 
  queue size 0, queue limit 32 
  packets output 147008, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 
 Class-map: class-default (match-any) 
  148237 packets, 10393582 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: any  
   queue size 0, queue limit 64 
   packets output 149563, packet drops 0 
   tail/random drops 0, no buffer drops 0, other drops 0 
  Shape: cir 256000, Bc 1024, Be 1024 
   lower bound cir 0, adapt to fecn 0 
   output bytes 6972057, shape rate 10000 bps 
Service-policy : llq 
  Class-map: voip (match-all) 
  146701 packets, 10325334 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: access-group 101 
  Priority: 50% (128 kbps), burst bytes 3200, b/w  
  exceed drops: 0 
  Class-map: class-default (match-any) 
  1536 packets, 68248 bytes 
  30 second offered rate 0 bps, drop rate 0 bps 
  Match: any  
  queue size 0, queue limit 32 
  packets output 2555, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 

MS-7507-8A# show frame pvc 16 
PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE) 
DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1 
input pkts 3036327   output pkts 199453 
in bytes 198958363  
out bytes 17271661   dropped pkts 0   in FECN pkts 0  
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0  
in DE pkts 0         out DE pkts 0  
out bcast pkts 1071  out bcast bytes 371448  
5 minute input rate 0 bits/sec, 0 packets/sec 
5 minute output rate 35000 bits/sec, 50 packets/sec 
pvc create time 17:51:42, last time pvc status changed 17:50:53 
fragment type end-to-end fragment size 120  

MS-7507-8A# show interface shape 
Serial5/0/0:0 nobuffer drop 0 
Serial5/0/0:0.1(class 0): 
cir 256000, Bc 1024, Be 1024 
lower bound cir 0, adapt to fecn 0 
packets output 152104, bytes output 6985505 
queue limit 64, queue size 0, drops 0 
last clear = 16:58:59 ago, shape rate = 10000 bps

MS-7507-8A# show ip rtp head 
RTP/UDP/IP header compression statistics: 
DLCI 16 Link/Destination info: point-to-point dlci 
Interface Serial5/0/0:0: 
Distributed fast switched: 
4 seconds since line card sent last stats update 
Rcvd: 105475 total, 105472 compressed, 0 errors 
0 dropped, 0 buffer copies, 0 buffer failures 
Sent: 99451 total, 99447 compressed,  
3776208 bytes saved, 2187963 bytes sent 
2.72 efficiency improvement factor 
Connect: 256 rx slots, 256 tx slots,  
0 long searches, 3 misses 0 collisions, 0 negative cache hits 
99% hit ratio, five minute miss rate 0 misses/sec, 0 max 

MS-7507-8A# show policy-map  
Policy Map llq-shape 
 Class class-default 
  shape peak 256000 1024 1024 
  service-policy llq 
Policy Map llq 
 Class voip 
  priority percent 50 

MS-7507-8A# show policy-map interface s 5/0/0:0.1 
Serial5/0/0:0.1: DLCI 16 - 
Service-policy output: llq-shape 
  queue stats for all priority classes: 
  queue size 0, queue limit 32 
  packets output 147008, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 
 Class-map: class-default (match-any) 
  148237 packets, 10393582 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: any  
   queue size 0, queue limit 64 
   packets output 149563, packet drops 0 
   tail/random drops 0, no buffer drops 0, other drops 0 
  Shape: cir 256000, Bc 1024, Be 1024 
   lower bound cir 0, adapt to fecn 0 
   output bytes 6972057, shape rate 10000 bps 
Service-policy : llq 
  Class-map: voip (match-all) 
  146701 packets, 10325334 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: access-group 101 
  Priority: 50% (128 kbps), burst bytes 3200, b/w  
  exceed drops: 0 
  Class-map: class-default (match-any) 
  1536 packets, 68248 bytes 
  30 second offered rate 0 bps, drop rate 0 bps 
  Match: any  
  queue size 0, queue limit 32 
  packets output 2555, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 

MS-7507-8A# show frame pvc 16 
PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE) 
DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1 
input pkts 3036327   output pkts 199453 
in bytes 198958363  
out bytes 17271661   dropped pkts 0   in FECN pkts 0  
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0  
in DE pkts 0         out DE pkts 0  
out bcast pkts 1071  out bcast bytes 371448  
5 minute input rate 0 bits/sec, 0 packets/sec 
5 minute output rate 35000 bits/sec, 50 packets/sec 
pvc create time 17:51:42, last time pvc status changed 17:50:53 
fragment type end-to-end fragment size 120 

MS-7507-8A# show interface shape 
Serial5/0/0:0 nobuffer drop 0 
Serial5/0/0:0.1(class 0): 
cir 256000, Bc 1024, Be 1024 
lower bound cir 0, adapt to fecn 0 
packets output 152104, bytes output 6985505 
queue limit 64, queue size 0, drops 0 
last clear = 16:58:59 ago, shape rate = 10000 bps

Problema conocido

Si usted todavía utiliza el Cisco IOS Software Release 12.1E, la interfaz VIP que se configura con la Encapsulación de Frame Relay puede causar un crash con a error de bus. Esta caída ocurre si usted aplica una política de servicio mientras que la interfaz pasa el tráfico. La solución alternativa es parar todo el tráfico de fondo antes de que usted ponga al día la política de servicio. O usted puede actualizar al Cisco IOS Software Release 12.2 o Posterior.

Para más información, refiera a la página de las herramientas y de los recursos de Cisco.


Información Relacionada


Document ID: 18660