IP : Cisco Express Forwarding (CEF)

Resolución de problemas de equilibrio de carga sobre enlaces paralelos por medio de Cisco Express Forwarding

18 Junio 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (19 Mayo 2008) | Inglés (19 Diciembre 2015) | Comentarios


Contenido


Introducción

Este documento aclara cómo el software del½ del¿Â del Cisco IOSï implementa el Equilibrio de carga de la capa 3 a través de los links paralelo múltiple al usar el Cisco Express Forwarding.

prerrequisitos

Requisitos

Este documento asume una comprensión de las dos estructuras de datos del Cisco Express Forwarding.

  • Base de información de reenvío (FIB)

  • Tabla de adyacencia

Vea la sección de la “información relacionada” de este documento para una descripción general del funcionamiento del Cisco Express Forwarding.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Antecedentes

El switching IP es el mecanismo interno utilizado por Cisco IOS para reenviar paquetes a través del router. Los mecanismos disponibles incluyen process switching, fast switching y Cisco Express Forwarding. Según cuál de los tres mecanismos se use para conmutar la mayoría de los paquetes, el rendimiento general del sistema y el equilibrio de carga son afectados.

Los mecanismos de conmutación de IP admiten dos modos generales, por paquete y por destino. La tabla siguiente describe las ventajas y desventajas de ambos modos.

Por destino Por paquete
Mecanismo del Switching IP Fast Switching y Cisco Express Forwarding por destino. Conmutación de procesos y Cisco Express Forwarding por paquete.
Ventajas Con el fast switching, se garantiza que los paquetes con un destino determinado tomarán el mismo trayecto, incluso si hay varios trayectos disponibles. Con el Cisco Express Forwarding Switching, los paquetes para un par del host dado del origen de destino se garantizan para tomar la misma trayectoria, incluso si los trayectos múltiples están disponibles. El tráfico destinado para diversos pares tiende a tomar diversas trayectorias. La utilización del trayecto con equilibro de carga por paquete es buena ya que permite que el router envíe paquetes sucesivos de datos sobre los trayectos independientemente de los host individuales o sesiones de usuario. Utiliza el método de ordenamiento cíclico para determinar que la trayectoria cada paquete lleva el destino
Desventajas Con la transferencia rápida, por la transferencia del destino puede dar lugar a la carga a compartir desigual porque los paquetes a un destino siguen siempre la misma trayectoria. El Cisco Express Forwarding Switching puede dar lugar a la distribución desigual con una pequeña cantidad de pares de destino fuente. El equilibrio de la carga por destino depende de la distribución estadística de tráfico; la carga a compartir se hace más eficaz mientras que el número de pares de destino fuente aumenta. Los paquetes de un host con un par origen/destino determinado pueden tomar trayectos diferentes, lo que podría resultar en un reordenamiento de paquetes. Esto no se recomienda para la voz sobre IP (VoIP) y otros flujos que requieren la entrega secuencial.

¿Qué es el balance de carga?

El equilibro de cargas describe la capacidad de un router de transmitir paquetes a una dirección IP de destino (también conocida como prefijo IP) a través de más de un trayecto.

Al tratar el tema del equilibrio de carga, primero necesitamos definir los siguientes términos.

Término Definición
Prefijo Describe una red del IP de destino, tal como 192.16.10.0/24. El IOS de Cisco agrega un prefijo IP de destino a la tabla de ruteo utilizando información obtenida del intercambio de mensajes mediante un protocolo de ruteo dinámico o la configuración manual de rutas estáticas.
Trayecto: Describe una ruta válida para alcanzar un prefijo de destino. El Cisco IOS asigna un coste a cada trayectoria. Un conjunto de los trayectos activos a un prefijo de destino puede tener el igual o costos desiguales.
Sesión Describe un flujo de comunicación unidireccional entre dos nodos de IP. Todos los paquetes en una sesión usan la misma dirección IP de origen y de destino.

Para obtener más información, vea ¿Cómo funciona el balance de carga?

Antes de Cisco Express Forwarding – Recopilación de múltiples trayectos o rutas

Cisco Express Forwarding usa la información del trayecto en la tabla de IP Routing para equilibrar el tráfico por links múltiples. Por esta razón, la confirmación del balance de carga adecuado de Cisco Express Forwarding comienza con la confirmación de los contenidos de la tabla de IP Routing.

En la siguiente topología, dos routers, el Router A y el Router B, se conectan directamente en tres interfaces seriales con encapsulación de High-Level Data Link Control (HDLC).

router A router B
interface Ethernet 0 
 ip address  192.168.20.1 255.255.255.0 
! 
interface Serial1 
 ip address 10.10.10.1 255.255.255.0  
! 
interface Serial2 
 ip address 20.20.20.1 255.255.255.0 
! 
interface Serial3 
 ip address 30.30.30.1 255.255.255.0 
 ip ospf cost 100 
! 
router ospf 1 
 network 10.10.10.0 0.0.0.255 area 0 
 network 20.20.20.0 0.0.0.255 area 0 
 network 30.30.30.0 0.0.0.255 area 0 
network 192.168.20.0 0.0.0.255 area 0
interface Serial1 
 ip address 10.10.10.2 255.255.255.0 
 clockrate 2000000 
! 
interface Serial2 
 ip address 20.20.20.2 255.255.255.0 
 clockrate 148000 
! 
interface Serial3 
 ip address 30.30.30.2 255.255.255.0 
 ip ospf cost 100 
 clockrate 148000 
router ospf 1 
 network 10.10.10.0 0.0.0.255 area 0 
 network 20.20.20.0 0.0.0.255 area 0 
 network 30.30.30.0 0.0.0.255 area 0
maximum-paths 1

Miremos cómo el router B selecciona una o más trayectorias para alcanzar la red del IP 192.168.20.0 de la interfaz de Ethernet del router a.

  • De manera predeterminada, Abrir el trayecto más corto primero (OSPF) soporta cuatro trayectos de igual costo a un destino. En este escenario, el Router B se configura con las máximo-trayectorias iguales a una. Por lo tanto el router B elegirá solamente una trayectoria entre los trayectos equivalentes posibles basados en cuál recibió primero. El router B comienza seleccionando el Serial2 como el trayecto único a la red de 192.168.20.0. Utilice el cef y los comandos show ip route del IP de la demostración de ver el conjunto del trayecto actual.

    RouterB#show ip cef  192.168.20.0
    	
     192.168.20.0/24, version 59, cached adjacency to Serial2 
    0 packets, 0 bytes 
      via 20.20.20.1, Serial2, 0 dependencies 
        next hop 20.20.20.1, Serial2 
        valid cached adjacency
    	 
    RouterB#show ip route  192.168.20.0
     
    Routing entry for  192.168.20.0/24 
      Known via "ospf 1", distance 110, metric 74, type intra area 
      Redistributing via ospf 1 
      Last update from 20.20.20.1 on Serial2, 00:03:58 ago 
      Routing Descriptor Blocks: 
      * 20.20.20.1, from 204.204.204.1, 00:03:58 ago, via Serial2 
          Route metric is 74, traffic share count is 1
    
  • Utilice el comando maximum-paths bajo OSPF para permitir más de un trayecto a la tabla de ruteo. El OSPF permite sólo el equilibrio de cargas de igual costo. Para configurar el uso compartido de la carga de costo desigual, configure el Protocolo de ruteo de puerta de enlace interior mejorado/Protocolo de ruteo de puerta de enlace interior (EIGRP/IGRP) como su Protocolo de puerta de enlace interior (IGP). ¿Vea cómo hace el trabajo del equilibrio de cargas de trayectos de costo desigual (variación) en el IGRP y el EIGRP? para más información.

    RouterB(config)#router ospf 1
    	
    RouterB(config-router)#maximum-paths ? 
      <1-6>  Number of paths 
      
    RouterB(config-router)#maximum-paths 3 
    
    
  • Utilice el comando show ip route de confirmar que la tabla de ruteo contiene dos trayectorias a 192.168.20.0.

    RouterB#show ip route  192.168.20.0
    	
    Routing entry for  192.168.20.0/24 
      Known via "ospf 1", distance 110, metric 74, type intra area 
      Redistributing via ospf 1 
      Last update from 10.10.10.1 on Serial1, 00:00:11 ago 
      Routing Descriptor Blocks: 
      * 20.20.20.1, from 204.204.204.1, 00:00:11 ago, via Serial2 
          Route metric is 74, traffic share count is 1 
             10.10.10.1, from 204.204.204.1, 00:00:11 ago, via Serial1 
          Route metric is 74, traffic share count is 1 
          
    !--- The route metric is 74 for both paths.
    
    
  • A pesar que configuramos OSPF para soportar los tres trayectos de igual costo, solo dos trayectos activos se muestran en la salida de show ip route. Para determinar el motivo, se puede utilizar el comando show ip ospf interface. El serial 3 tiene un coste más alto que el Serial1 y el Serial2, y es por lo tanto desigual.

    RouterB#show ip ospf interface s1
    	
    Serial1 is up, line protocol is up 
      Internet Address 10.10.10.4/24, Area 0 
      Process ID 1, Router ID 100.100.100.1, Network Type POINT_TO_POINT, Cost: 64 
      
    RouterB#show ip ospf interface s2
    
    Serial2 is up, line protocol is up 
      Internet Address 20.20.20.2/24, Area 0 
      Process ID 1, Router ID 100.100.100.1, Network Type POINT_TO_POINT, Cost: 64 
      
    RouterB#show ip ospf interface s3
    
    Serial3 is up, line protocol is up 
      Internet Address 30.30.30.2/24, Area 0 
      Process ID 1, Router ID 100.100.100.1, Network Type POINT_TO_POINT, Cost: 100
    
  • Utilice el comando show run de confirmar si el serial 3 está configurado con el comando ip ospf cost 100. Utilice el comando no ip ospf cost 100 sub-interface de quitarlo de la configuración y de hacer los costes en los tres links seriales iguales.

    RouterB#show run interface s3
     
    Building configuration...
     
    Current configuration: 
    ! 
    interface Serial3 
     ip address 30.30.30.2 255.255.255.0 
     no ip directed-broadcast 
     ip ospf cost 100 
     ip ospf interface-retry 0
    
  • El comando show ip route ahora visualiza tres trayectos de igual costo a la red de 192.168.20.0.

    RouterB#show ip route  192.168.20.0
     
    Routing entry for  192.168.20.0/24 
      Known via "ospf 1", distance 110, metric 74, type intra area 
      Redistributing via ospf 1 
      Last update from 10.10.10.1 on Serial1, 00:00:01 ago 
      Routing Descriptor Blocks: 
      * 20.20.20.1, from 204.204.204.1, 00:00:01 ago, via Serial2 
          Route metric is 74, traffic share count is 1 
        30.30.30.1, from 204.204.204.1, 00:00:01 ago, via Serial3 
          Route metric is 74, traffic share count is 1 
        10.10.10.1, from 204.204.204.1, 00:00:01 ago, via Serial1 
          Route metric is 74, traffic share count is

Ahora miremos cómo el Equilibrio de carga del Cisco Express Forwarding utiliza la información en la tabla de ruteo para remitir los paquetes.

Configuración de distribución de carga Cisco Express Forwarding

Cisco Express Forwarding logra un equilibrio de reenvío con el uso de la tabla de compartición de carga. Al igual que con todas las otras soluciones de equilibrio de carga en los routers Cisco, la decisión de equilibrio de carga se toma en las interfaces salientes. A diferencia de otros métodos de conmutación, el reenvío express de Cisco realiza un seguimiento de los trayectos en función de las direcciones de origen y de destino del trayecto. Para simplificar esto, usted podría decir que la trayectoria es una sesión IP y cada sesión está identificada lógicamente como par de direcciones de origen y destino único.

Para comprender cómo se realiza el equilibrio de carga, primero tiene que entender cómo se relacionan las tablas. La tabla de Cisco Express Forwarding señala 16 cubetas de troceo (tabla load share), que señalan la tabla de adyacencia para los trayectos paralelos. Vea la sección de los mecanismos internos del Equilibrio de carga del Cisco Express Forwarding para más detalles. Cada paquete que se conmutará está quebrado para arriba en el par de direcciones de origen y destino y se marca contra la tabla loadshare.

Nota: Hay dos tipos principales de Cisco Express Forwarding Switching, de por destino y de por paquete. Si ambos tipos se usan en un router, cada tipo tiene su propia tabla de cargas compartidas.

El equilibrio de carga por destino permite que el router utilice varios trayectos para lograr compartir la carga. El equilibrio de carga por destino se activa de manera predeterminada cuando el usuario activa la auditoria de seguridad activa de Cisco, y es el método de equilibrio de carga de preferencia en la mayoría de las situaciones. Dado que el balance de carga por destino depende de la distribución estadística del tráfico, la distribución de carga es más eficaz a medida que aumenta la cantidad de pares de origen-destino.

El Equilibrio de carga por paquete permite que el router envíe los paquetes de datos sucesivos sobre las trayectorias sin consideración alguna hacia los host individuales o las sesiones del usuario. Utiliza el método de ordenamiento cíclico para determinar qué trayecto hace cada paquete hacia el destino. El equilibrio de carga por paquete asegura el equilibrio sobre los links múltiples. La utilización de trayecto con equilibrio de carga por paquete es buena, pero los paquetes para un par de host de origen-destino determinado pueden tomar diferentes trayectos, lo que puede provocar que los paquetes se reordenen. Por este motivo, el Equilibrio de carga por paquete es con certeza los tipos de tráfico de datos inadecuados, tales como VoIP, que dependen de los paquetes que llegan el destino en orden. Equilibrio de carga por paquete del uso a ayudar a asegurarse de que una trayectoria para un solo par de destino fuente no se sobrecarga.

Utilice el comando ip load-sharing de cambiar entre los métodos por paquete y del por destino.

7200-1.3(config)#interface fast 0/0
   
7200-1.3(config-if)#ip load-sharing ? 
  per-destination  Deterministic distribution 
  per-packet       Random distribution 
  
7200-1.3(config-if)#ip load-sharing per-packet

Utilice el comando show cef interface para confirmar sus modificaciones.

7200-1.3#show cef interface fast 0/0 
FastEthernet0/0 is up (if_number 3) 
  Corresponding hwidb fast_if_number 3 
  Corresponding hwidb firstsw->if_number 3 
  Internet address is 172.16.81.13/24 
  ICMP redirects are always sent 
  Per packet load-sharing is enabled 
  IP unicast RPF check is disabled 
  Inbound access list is not set 
  Outbound access list is not set 
  IP policy routing is disabled 
  Hardware idb is FastEthernet0/0 
  Fast switching type 1, interface type 18 
  IP CEF switching enabled 
  IP Feature Fast switching turbo vector 
  IP Feature CEF switching turbo vector 
  Input fast flags 0x0, Output fast flags 0x0 
  ifindex 1(1) 
  Slot 0 Slot unit 0 VC -1 
  Transmit limit accumulator 0x0 (0x0) 
  IP MTU 1500

Mecanismos internos de equilibrio de carga de Cisco Express Forwarding

Comencemos analizando el mecanismo interno detrás del Equilibrio de carga del Cisco Express Forwarding.

  • Cada sesión (véase la tabla antedicha) se asigna a un trayecto activo.

  • La asignación de sesión a trayecto se realiza mediante una función de troceo que toma las direcciones IP de origen y destino y, en las versiones recientes de IOS de Cisco, una ID de troceo única que randomiza la asignación en el trayecto de extremo a extremo.

  • Los trayectos activos se asignan internamente a varios de 16 compartimientos del hash. La asignación de trayecto a cubeta varía con el tipo de equilibrio de cargas y la cantidad de trayectos activos.

  • El resultado de la función de troceo se usa para elegir una de las cubetas habilitadas y, por lo tanto, elegir qué trayecto usar para la sesión.

  • Para todas las sesiones que son remitidas por el router, cada trayecto activo lleva el mismo número de sesiones.

Miremos un ejemplo de estos internals del Cisco Express Forwarding.

  1. Uso del comando maximum-paths para reducir a dos el número de trayectos activos para el prefijo de destino.

    RouterB(config)#router ospf 1
    RouterB(config-router)#maximum-paths 2
    
  2. Utilice el comando show ip cef {prefix} internal de ver la asignación del trayectoria-a-compartimiento.

    RouterB#show ip cef  192.168.20.0 internal 
     192.168.20.0/24, version 66, per-destination sharing 
    0 packets, 0 bytes 
      via 20.20.20.1, Serial2, 0 dependencies 
        traffic share 1 
        next hop 20.20.20.1, Serial2 
        valid adjacency 
      via 30.30.30.1, Serial3, 0 dependencies 
        traffic share 1 
        next hop 30.30.30.1, Serial3 
        valid adjacency 
      0 packets, 0 bytes switched through the prefix 
      Load distribution: 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 (refcount 1) 
      
    !--- The load distribution line summarizes how each path is 
    !--- assigned to the hash buckets.
    
      
    
      Hash  OK  Interface                 Address         Packets 
      1     Y   Serial2                   point2point           0 
      2     Y   Serial3                   point2point           0 
      3     Y   Serial2                   point2point           0 
      4     Y   Serial3                   point2point           0 
      5     Y   Serial2                   point2point           0 
      6     Y   Serial3                   point2point           0 
      7     Y   Serial2                   point2point           0 
      8     Y   Serial3                   point2point           0 
      9     Y   Serial2                   point2point           0 
      10    Y   Serial3                   point2point           0 
      11    Y   Serial2                   point2point           0 
      12    Y   Serial3                   point2point           0 
      13    Y   Serial2                   point2point           0 
      14    Y   Serial3                   point2point           0 
      15    Y   Serial2                   point2point           0 
      16    Y   Serial3                   point2point 

    Las 16 cubetas de troceo se establecen de acuerdo al tipo de balance de carga y la cantidad de trayectos activos. El caso simple es el de un número de rutas par. Los 16 compartimientos se llenan uniformemente de los trayectos activos. Si 16 no es divisible por el número de trayectos activos, las últimas cubetas que representan el resto están desactivadas. La tabla siguiente muestra cómo los compartimientos del hash buscan dos y tres trayectos activos.

    Compartimiento/trayectorias 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
    2 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1
    3 0 1 2 0 1 2 0 1 2 0 1 2 0 1 2 x

    En el siguiente ejemplo, tenemos tres rutas para el destino. Aviso cómo el Cisco Express Forwarding ha quitado el compartimiento 16 del hash y cómo los tres links seriales se asignan uniformemente para desmenuzar los compartimientos 1 a 15.

    RouterB#show ip cef  192.168.20.0 interface 
     192.168.20.0/24, version 64, per-destination sharing 
    0 packets, 0 bytes 
      via 20.20.20.1, Serial2, 0 dependencies 
        traffic share 1 
        next hop 20.20.20.1, Serial2 
        valid adjacency 
      via 30.30.30.1, Serial3, 0 dependencies 
        traffic share 1 
        next hop 30.30.30.1, Serial3 
        valid adjacency 
      via 10.10.10.1, Serial1, 0 dependencies 
        traffic share 1 
        next hop 10.10.10.1, Serial1 
        valid adjacency 
    
      0 packets, 0 bytes switched through the prefix 
      Load distribution: 0 1 2 0 1 2 0 1 2 0 1 2 0 1 2 (refcount 1) 
      
    !--- The active paths are assigned to hash buckets in a 
    !--- round-robin pattern.
    
       
    
      Hash  OK  Interface                 Address         Packets 
      1     Y   Serial2                   point2point           0 
      2     Y   Serial3                   point2point           0 
      3     Y   Serial1                   point2point           0 
      4     Y   Serial2                   point2point           0 
      5     Y   Serial3                   point2point           0 
      6     Y   Serial1                   point2point           0 
      7     Y   Serial2                   point2point           0 
      8     Y   Serial3                   point2point           0 
      9     Y   Serial1                   point2point           0 
      10    Y   Serial2                   point2point           0 
      11    Y   Serial3                   point2point           0 
      12    Y   Serial1                   point2point           0 
      13    Y   Serial2                   point2point           0 
      14    Y   Serial3                   point2point           0 
      15    Y   Serial1                   point2point           0 
      
    !--- Hash bucket 16 has been removed.
     
    
    

    Nota: Aunque seleccionen un trayecto único para un destino, el por destino del Cisco Express Forwarding y los mecanismos de Switching rápidos diferencian en cómo seleccionan esa trayectoria. El Cisco Express Forwarding considera ambos los IP Address de origen y de destino, mientras que la transferencia rápida considera solamente el IP Address de destino.

Verificación del balance de carga del reenvío express de Cisco

Utilice los pasos siguientes para verificar el Equilibrio de carga del Cisco Express Forwarding en su router.

  1. Confirme que Cisco Express Forwarding se encuentra habilitado globalmente en el router.

    S3-4K-2#show ip cef 
    %CEF not running 
    Prefix                      Next Hop                     Interface 
    
    !--- This output shows Cisco Express Forwarding is not enabled. 
    !--- Use ip cef command in global configuration to enable it.
    
    
    
  2. Confirme por paquete o el Switching por destino se habilita en las interfaces de salida particular. El valor por defecto es por destino.

    RouterA#show cef interface s1
     
    Serial1 is up (if_number 3)
      Internet address is 10.10.10.1/24 
      ICMP redirects are always sent 
      Per packet loadbalancing is disabled 
      IP unicast RPF check is disabled 
      Inbound access list is not set 
      Outbound access list is not set 
      Interface is marked as point to point interface 
      Hardware idb is Serial1 
      Fast switching type 4, interface type 40 
      IP CEF switching enabled 
     
     !--- Cisco Express Forwarding is enabled on the interface. 
    
      IP CEF Fast switching turbo vector 
      Input fast flags 0x0, Output fast flags 0x0 
      ifindex 5(5)
      
    Slot 0 Slot unit 1 VC -1 
      
      Transmit limit accumulator 0x0 (0x0) 
      IP MTU 1500 
  3. Confirme que la tabla de ruteo y la tabla de reenvío rápido de Cisco contengan todos los trayectos paralelos utilizando el comando show ip route.

    RouterB#show ip route 192.168.20.0 
    Routing entry for 192.168.20.0/32, 1 known subnets 
     
    O       192.168.20.1 [110/65] via 20.20.20.1, 00:06:54, Serial1 
                         [110/65] via 10.10.10.1, 00:06:54, Serial2 
                         [110/65] via 30.30.30.1, 00:06:54, Serial3 
    
  4. Verifique Cisco Express Forwarding FIB utilizando el comando show ip cef.

    RouterB#show ip cef 192.168.20.0
    192.168.20.0/24, version 18, per-destination sharing
    0 packets, 0 bytes
      via 30.30.30.1, Serial3,   0 dependencies
        traffic share 1
        next hop 30.30.30.1, Serial3
        valid adjacency
      via 20.20.20.1, Serial2, 0 dependencies
        traffic share 1
        next hop 20.20.20.1, Serial2
        valid adjacency
      via 10.10.10.1, Serial1, 0 dependencies
        traffic share 1
        next hop 10.10.10.1, Serial1
        valid adjacency
      0 packets, 0 bytes switched through the prefix
      tmstats: external 0 packets, 0 bytes
               internal 0 packets, 0 bytes
    
    
    RouterB#show ip cef 192.168.20.0 internal
    192.168.20.0/24, version 18, per-destination sharing
    0 packets, 0 bytes
      via 30.30.30.1, Serial3, 0 dependencies
        traffic share 1
        next hop 30.30.30.1, Serial3
        valid adjacency
      via 20.20.20.1, Serial2, 0 dependencies
        traffic share 1
        next hop 20.20.20.1, Serial2
        valid adjacency
      via 10.10.10.1, Serial1, 0 dependencies
        traffic share 1
        next hop 10.10.10.1, Serial1
        valid adjacency
    
      0 packets, 0 bytes switched through the prefix
      tmstats: external 0 packets, 0 bytes
               internal 0 packets, 0 bytes
      Load distribution: 0 1 2 0 1 2 0 1 2 0 1 2 0 1 2 (refcount 1)
    
      Hash  OK  Interface                 Address         Packets
      1     Y   Serial3                   point2point           0
      2     Y   Serial2                   point2point           0
      3     Y   Serial1                   point2point           0
      4     Y   Serial3                   point2point           0
      5     Y   Serial2                   point2point           0
      6     Y   Serial1                   point2point           0
      7     Y   Serial3                   point2point           0
      8     Y   Serial2                   point2point           0
      9     Y   Serial1                   point2point           0
      10    Y   Serial3                   point2point           0
      11    Y   Serial2                   point2point           0
      12    Y   Serial1                   point2point           0
      13    Y   Serial3                   point2point           0
      14    Y   Serial2                   point2point           0
      15    Y   Serial1                   point2point           0
    

    Nota: La tabla loadshare antedicha muestra a distribución de carga 0 1 2 0 1 2. , y la parte del tráfico es 1 para cada ruta. Esto significa una distribución de carga por destino del igual costo entre tres rutas de costo equivalente.

  5. Adyacencias del Cisco Express Forwarding del control.

    RouterB#show adjacency detail
    Protocol Interface                 Address
    IP       Serial1                   point2point(11)
                                       0 packets, 0 bytes
                                       0F000800
                                       CEF   expires: 00:02:31
                                             refresh: 00:00:31
    IP       Serial2                   point2point(11)
                                       0 packets, 0 bytes
                                       0F000800
                                       CEF   expires: 00:02:31
                                             refresh: 00:00:31
    IP       Serial3                   point2point(11)
                                       0 packets, 0 bytes
                                       0F000800
                                       CEF   expires: 00:02:31
                                             refresh: 00:00:31
  6. Confirme el mecanismo previsto del balanceo de carga del Cisco Express Forwarding se configura en todas las interfaces de salida.

    RouterB#show ip cef  192.168.20.0
    
     192.168.20.0/24, version 89, per-destination sharing 
    0 packets, 0 bytes 
      via 10.10.10.1, Serial1, 0 dependencies 
        traffic share 1 
        next hop 10.10.10.1, Serial1 
        valid adjacency 
      [output omitted]
  7. Contabilidad de la cubeta del troceo del permiso para recoger las estadísticas para entender mejor los modelos del Cisco Express Forwarding en su red. Por ejemplo, usted puede ser que quiera recoger la información tal como el número de paquetes y de bytes conmutados a un destino o el número de paquetes conmutados a través de un destino. Use el siguiente comando:

    router(config)# ip cef accounting load-balance-hash
    

    Verifique el flujo de paquetes observando los valores bajo campo del paquete.

    RouterB#show ip cef 192.168.20.0 internal
    [...]
    
      Load distribution: 0 1 2 0 1 2 0 1 2 0 1 2 0 1 2 (refcount 1)
    
      Hash  OK  Interface                 Address         Packets
      1     Y   Serial                    point2point           0
      2     Y   Serial2                   point2point           0
      3     Y   Serial1                   point2point           0
      4     Y   Serial3                   point2point           0
      5     Y   Serial2                   point2point          35
      6     Y   Serial1                   point2point           0
      7     Y   Serial3                   point2point           0
      8     Y   Serial2                   point2point          60
      9     Y   Serial1                   point2point           0
      10    Y   Serial3                   point2point           0
      11    Y   Serial2                   point2point           0
      12    Y   Serial1                   point2point           0
      13    Y   Serial3                   point2point           0
      14    Y   Serial2                   point2point          30
      15    Y   Serial1                   point2point           0

    125 paquetes atravesaron el Serial2. Si usted utiliza el ping para generar el tráfico, asegúrese de que los paquetes ping deban transitar al router Expedición-conmutado expreso de Cisco. En otras palabras, los paquetes de ping deben entrar desde una interfaz conmutada mediante Cisco Express Forwarding, deben ser conmutados mediante Cisco Express Forwarding y deben partir desde otra interfaz conmutada mediante Cisco Express Forwarding.

    Nota: La carga a compartir por destino se torna más eficiente a medida que se incrementa la cantidad de pares de destino fuente.

  8. Mientras envía tráfico al prefijo, capture varios resultados del comando show interface. Analice los valores del “txload” y del “rxload”. (Algunas interfaces visualizan un solo valor “carga”, que considera transmite y recibe). Aunque el Equilibrio de carga por paquete proporcione una distribución uniforme en el número de paquetes, los links paralelos pueden exhibir una tarifa levemente desigual dependiendo del tamaño de paquetes.

    Serial1/0:0 is up, line protocol is up
    reliability 255/255, txload 10/255, rxload 3/255
     
    Serial1/1:0 is up, line protocol is up
    reliability 255/255, txload 18/255, rxload 3/255
    
    
  9. Con la carga por destino del Cisco Express Forwarding equilibrando, usted puede determinar a qué trayectoria se asigna una sesión con el siguiente comando. Agregue la palabra clave interna para visualizar que el compartimiento del hash se utiliza.

    show ip cef exact-route {source-ip-address} {dest-ip-address} [internal]
     
    RouterB# show ip cef exact-route 50.50.50.2 192.168.20.1  internal
    50.50.50.2      -> 192.168.20.1   : Serial9/0 (next hop 20.20.20.1)
                                        Bucket 4 from 15, total 3 paths
    RouterB# show ip cef exact-route 5.5.5.1 192.168.20.1  internal   
    5.5.5.1         ->192.168.20.1   : Serial9/0 (next hop 20.20.20.1)
                                        Bucket 7 from 15, total 3 paths
    RouterB# show ip cef exact-route 6.6.6.1 192.168.20.1  internal
    6.6.6.1         -> 192.168.20.1   : Serial9/0 (next hop 20.20.20.1)
                                        Bucket 7 from 15, total 3 paths
    RouterB# show ip cef exact-route 8.8.8.1 192.168.20.1  internal
    8.8.8.1         -> 192.168.20.1   : Serial9/0 (next hop 20.20.20.1)
                                        Bucket 13 from 15, total 3 paths
    
  10. Si la salida es irregular, considere lo siguiente:

    • El número de pares de direcciones de origen y destinos o de sesiones únicos que atraviesan los links paralelos.

    • El número y el tamaño de los paquetes en cada sesión. ¿Una sesión tiene gran cantidad de paquetes? El equilibrio de la carga por destino depende de la distribución estadística de tráfico y se hace más eficaz mientras que el número de pares de destino fuente aumenta.

Carga a compartir después de un cambio de link

Cuando un cambio de la tabla de ruteo ajusta la cantidad de trayectoriass activas a un destino, el Cisco Express Forwarding pone al día las estructuras de balanza de la carga consideradas en la salida del comando show ip cef {prefix} internal. Luego, Cisco Express Forwarding hace coincidir los paquetes nuevos entrantes con una adyacencia y la cubeta de troceo correspondiente. La cubeta seleccionada puede o no ser la misma utilizada anteriormente.

Los siguientes pasos describen cómo se actualiza la información del equilibrio de carga de Cisco Express Forwarding luego de un cambio en la cantidad de trayectos activos a un prefijo de destino.

  1. Asuma que un prefijo de destino es accesible a través de dos trayectorias. La trayectoria 1 está inactiva, y la trayectoria 2 es activa y que lleva todo el tráfico.

  2. Cuando está disponible nuevamente el trayecto 1, éste inicia los procesos de reconvergencia de IP Routing.

  3. Cisco Express Forwarding equilibra la carga en ambos trayectos y no conserva los flujos existentes en el trayecto 2. Si hiciera esto, dejaría al trayecto 1 sin utilizar. En otras palabras, Cisco Express Forwarding no considera que puede reenviar paquetes para una sesión en un trayecto válido y puede seleccionar un trayecto nuevo para un flujo según qué cubeta del troceo selecciona.

Información de carga a compartir programada para eliminación

Luego de que se produce un cambio en la tabla de ruteo, Cisco Express Forwarding elimina y luego reconstruye las estructuras de equilibrio de carga que asignan trayectos activos a los bloques de memoria de troceo. Durante el proceso de reconstrucción, algunos paquetes pueden ser perdidos, y el comando show ip cef {prefix} internal indica la información destinada a ser eliminada de la carga a compartir.

router#show ip cef 10.10.128.0 int 
 10.10.128.0/28, version 63, per-destination sharing 
 0 packets, 0 bytes 
   via 10.8.0.31, 0 dependencies, recursive 
     next hop 10.8.2.49, POS0/0/0 
     valid adjacency 
   Load sharing information due for deletion 

Los cambios implementados con el Id. de bug Cisco CSCdm87127 minimizan la pérdida del paquete durante un cambio en la cantidad de trayectoriass activas para la ruta predeterminada de 0.0.0.0. Específicamente, Cisco Express Forwarding asigna ahora una entrada FIB con espacio para la mayor cantidad posible de trayectos activos para esta ruta.

Problemas conocidos

El equilibrio de carga del Cisco Express Forwarding no es igual en los cuatro trayectos. Para otros detalles, refiera a CSCdm87756 (clientes registrados solamente).

En las versiones deL Cisco IOS anterior que 12.0(16)S, ingresar el comando show ip cef exact-route puede hacer el (RP) del Route Processor en un Cisco 12000 Series Internet Router o un Cisco 7500/RSP Series Router recargar. Esta situación ocurre cuando el prefijo de destino es recurrente y el router comparte la carga con el salto siguiente. Para obtener más información, consulte CSCdt80914 (sólo clientes registrados), donde se resuelve el problema.

En el equilibrio de carga por paquete de la plataforma CEF de las 6500 Series no se soporta. Esto es debido a la limitación del hardware y es solamente posible tener carga por destino que equilibra actualmente. Por lo tanto la única opción es utilizar carga compartida del flujo distribuido del protocolo multilink point-to-point (dMLPPP) o de la capa 4.

Soporte del hardware para equilibrio de carga en Cisco Express Forwarding

Originalmente, el balance de carga por paquete de Cisco Express Forwarding era soportado por plataformas que usan reenvío por software. Estas plataformas incluyen las series 2600, 3600 y 7200. El equilibrio de carga por paquete ahora está soportado en hardware mediante Parallel Express Forwarding (PXF) en la serie 7200 con un NSE-1, y las serie 10000. En las Catalyst 6000 Series, los comandos ip load-sharing per-packet, ip cef accounting per-prefix, y ip cef accounting non-recursive del Cisco Express Forwarding del Cisco IOS en el MSFC2 se aplican solamente al tráfico que es expreso de Cisco Expedición-conmutado en el software en el MSFC2. Los comandos no afectan el tráfico de hardware conmutado por Capa 3 en módulos de conmutación equipados con DFC o PFC2. Vea configurar el Layer 3 Switching de la unidifusión IP en el Supervisor Engine 2 para más información.

Nota: Un Cisco 7300 Router con una placa del procesador del NSE-100 no soporta el Equilibrio de carga por paquete CEF en el PXF. Los soportes PXF solamente por el equilibrio de la carga de destino. Sin embargo, aparecía que tienen soporte porque los comandos configuration estaban disponibles en el CLI del router. Esto se corrige y se registra en el Id. de bug Cisco CSCdx63389.

En las 12000 Series, el Equilibrio de carga por paquete está disponible en todos los Motores de reenvío de la capa 3 excepto los motores 3 y 4. Cada linecard toma las decisiones de reenvío independientes. Para ver la ruta exacta para cada flujo IP, utilice el comando exec slot X show ip hardware-cef exact-route src dst en las tarjetas de línea que utilizan tablas de Cisco Express Forwarding basadas en hardware.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 18285