WAN : Frame Relay

Configurar el Class Based Weighted Fair Queueing con el FRTS

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento aporta una configuración de muestra para Class-Based Weighted Fair Queueing (CBWFQ) con Frame Relay Traffic Shaping (FRTS).

El CBWFQ amplía las funciones de espera de la equilibrada ponderada estándar (WFQ) para proporcionar el soporte para las clases de tráfico definidas por el usario. El FRTS usa colas en una red Frame Relay para limitar las oleadas que pueden causar congestión. Los datos están mitigados y después enviados en la red en las cantidades reguladas para asegurarse de que los ajustes del tráfico dentro del sobre prometido del tráfico para la conexión determinada.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

El CBWFQ se soporta a partir de las versiones de software siguientes del½ del¿Â del Cisco IOSï dependiendo de la plataforma:

  • Cisco 7500 Series con el Procesadores de interfaz versátil (VIP) (CBWFQ distribuido) - Cisco IOS Software Release 12.1(5)T

  • Cisco 7200 Series, 2600/3600 Series, y otras Plataformas no 7500 de la serie - Cisco IOS Software Release 12.1(2)T

Sin embargo ambo el Routers usado para este documento sobre configuración funcionaba con el Cisco IOS Software Release 12.2(2).

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

¿Por qué utilice el CBWFQ con el FRTS?

Si usted tiene datos específicos a proteger, el CBWFQ proporciona una manera de especificar más lejos estos datos usando las clases específicas. Al utilizar CBWFQ, el peso indicado para una clase se convierte en el peso de cada paquete que coincide con el criterio de clases. Para obtener más información consulte la sección de Marcado entrante El WFQ entonces se aplica a estas clases, en vez de la aplicación a los flujos ellos mismos, y las clases pueden incluir varios flujos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

La tabla abajo proporciona una guía de referencia rápida a las entradas que usted puede ser que vea en configuraciones:

Campo Descripción
Interfaz FR Interfaz de salida.
subinterfaz Interfaz lógica.
dlci Identificador de conexión de link de datos. El valor que especifica el (SVC) de un circuito virtual permanente (PVC) o del circuito virtual conmutado en una red Frame Relay.
XXX de la clase Aplica el XXX del Frame Relay del map-class.
XXX del Frame Relay del map-class Parámetros FRTS.
servicio-directiva ZZZ CBWFQ.
directiva-mapa ZZZ Política mencionada.
clase YYY Nombra la clase.
ancho de banda, policing, prioridad Específicos para esto flujo.
class class-default Materias del sintaxis y del deletreo al crear sus clases predeterminadas.
clase-mapa YYY corresponda con todos Establece los criterios de concordancia contra los cuales se marca el paquete.
acceso-grupo 101 de la coincidencia Ata el clase-mapa a una lista de acceso.
access-list 101 permit ip any any Lista de acceso normal.

Nota:  Cisco serie 7500 A partir del Cisco IOS Software Release 12.1(5)T, las directivas del Calidad de Servicio (QoS) deben ejecutarse en el modo distribuido en el procesador de interfaz versátil (VIP) porque ruta/el Procesador del switch (RSP) - QoS basado se soportan no más. Por lo tanto, utilice el comando shape y otros comandos para la interfaz de línea del comando modular qos (CLI) de implementar el Control de tráfico distribuido (dTS) para las interfaces de Frame Relay en los VIP en las Cisco 7500 Series. Control de tráfico genérico (GTS) de las cosechadoras del DTS y FRTS.

Procedimiento obligatorio

Configurar el CBWFQ con el FRTS incluye los tres pasos obligatorios siguientes:

  1. Defina las correspondencias de la clase (clase-mapa).

    Establezca los criterios de concordancia contra los cuales un paquete se marca para determinar si pertenece a una clase.

  2. Configure la correspondencia de políticas (directiva-mapa) y la definición de las clases (clase).

    Especifica el nombre de la correspondencia de políticas. Asocia las especificaciones para las garantías de ancho de banda, el policing, y la prioridad a cada clase de tráfico. Este proceso exige la configuración de ancho de banda, y así sucesivamente, para ser aplicado a los paquetes que pertenecen a uno del class-maps previamente definida. Para este proceso, configure una correspondencia de políticas que especifique la directiva para cada clase de tráfico.

  3. Asocie la política de servicio al map-class FRTS (servicio-directiva).

    Asocie las directivas prescritas identificadas con la servicio-directiva específica al map-class (y así al DLCI o a la subinterfaz donde está aplicado el Frame Relay del map-class).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/17920/traffic_shaping.gif

El diagrama de la red antedicho utiliza los valores siguientes:

  • CONCENTRADOR - tarifa física = 192 kbps, tarifa garantizada = 32 kbps

  • TELECONTROL - tarifa física = 64 kbps, tarifa garantizada = 32 kbps

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

Concentrador con el CBWFQ configurado
<snip> 
!
class-map match-all YYY
  match access-group 101
!
!
policy-map ZZZ
  class YYY
   bandwidth percent 50
<snip>
interface Serial0/0 
  no ip address 
  encapsulation frame-relay 
  no fair-queue 
  frame-relay traffic-shaping 

 interface Serial0/0.1 point-to-point 
  ip address 10.1.1.1 255.255.255.0 
  frame-relay interface-dlci 16  
  frame-relay class XXX 
 ! 
 map-class frame-relay XXX 
  frame-relay cir 64000  
  frame-relay mincir 32000 
  frame-relay adaptive-shaping becn 
  frame-relay bc 8000
  service-policy output ZZZ
<snip>
!
access-list 101 permit ip host 10.0.0.1 host 11.0.0.1

Remoto
interface Serial0/0 
no ip address 
encapsulation frame-relay 
no fair-queue 
frame-relay traffic-shaping 
! 
interface Serial0/0.1 point-to-point 
ip address 10.1.1.2 255.255.255.0 
frame-relay interface-dlci 16  
frame-relay class XXX 
! 
map-class frame-relay XXX 
frame-relay cir 64000 
frame-relay mincir 32000 
frame-relay adaptive-shaping becn 
frame-relay bc 8000 
!

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • pvc del show frame-relay - Visualiza las estadísticas sobre los PVC para las interfaces de Frame Relay.

  • directiva-mapa de la demostración - Visualiza la configuración de todas las clases que comprenden la correlación de políticas de servicio especificada o todas las clases para toda la política existente asocian.

  • show policy-map [interface] - Visualiza la configuración de todas las clases configuradas para todas las políticas de servicio en la interfaz especificada o visualizar las clases para la política de servicio para un PVC específico en la interfaz.

Lo que sigue es salida de muestra del comando show frame-relay pvc:

Hubrouter#show frame-relay pvc [interface interface ][dlci]
PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            1            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0       out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  pvc create time 00:01:12, last time pvc status changed 00:01:12
Hubrouter#

Usted puede utilizar el sintaxis siguiente con este comando:

  • interfaz - (opcional) indica una interfaz específica para la cual se visualice la información de PVC.

  • interfaz - Número de interfaz (opcional) que contiene los DLCI para los cuales usted desea visualizar la información de PVC.

  • dlci - número DLCI específico (opcional) A usado en la interfaz. Las estadísticas para el PVC especificado se visualizan cuando un DLCI también se especifica.

Lo que sigue es salida de muestra del comando show policy-map:

Hubrouter#show policy-map 
   Policy Map ZZZ 
    Class YYY 
      Weighted Fair Queueing 
            Bandwidth 50 (%) Max Threshold 64 (packets) 
    Class WWW 
      Weighted Fair Queueing 
            Bandwidth 25 (%) Max Threshold 64 (packets)

Lo que sigue es salida de muestra del show policy-map [interface].

 Hubrouter#show policy-map interface s0/0.1 
  Serial 0/0.1: DLCI 16 
  Service-policy output: ZZZ (1057) 
    Class-map: YYY (match-all) (1059/2) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 101 (1063) 
      Weighted Fair Queueing 
        Output Queue: Conversation 73 
        Bandwidth 50 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: WWW (match-all) (1067/3) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 102 (1071) 
      Weighted Fair Queueing 
        Output Queue: Conversation 74 
        Bandwidth 25 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: class-default (match-any) (1075/0) 
         2 packets, 706 bytes 
         30 second offered rate 0 bps, drop rate 0 bps    
         Match: any  (1079)

Otros términos que usted puede también ver en las configuraciones similares se explican abajo:

  • CIR - Committed information rate. Tarifa en la cual una red Frame Relay acuerda transferir la información en condiciones normales, hecha un promedio sobre un incremento mínimo del tiempo.

  • Espera (Primero en Entrar, Primero en Salir FIFO) - Primero en entrar, espera del primero en salir. FIFO implica el almacenamiento en buffer y el reenvío de paquetes en el orden de llegada. FIFO no expresa ningún concepto de prioridad o clases de tráfico. Hay solamente una cola, y todos los paquetes se tratan igual. Los paquetes se envían una interfaz en el orden en que llegan.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 17920