Switching de LAN : Integrated Routing and Bridging (IRB)

Introducción y configuración del ruteo de VLAN y de la conexión en puente en un router por medio de la función IRB

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (31 Diciembre 2015) | Comentarios


Contenido


Introducción

Este documento describe la progresión de las VLAN mientras se implementan con un router que esté realizando un routing de IP, bridging de IP y bridging de IP con Integrated Routing and Bridging (IRB). A su vez, este documento proporciona una configuración de ejemplo sobre cómo configurar la función IRB en un router.

Nota: El IRB se ha inhabilitado deliberadamente en los Catalyst 6500 Series Switch y los Cisco 7600 Series Router. Para más información, refiera por favor a la sección general de los Límites y restricción bajo los Release Note para el Cisco IOS Release 12.1 E en el Catalyst 6000 y Supervisor Engine del Cisco 7600 y MSFC.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Antecedentes

Para que un VLA N atraviese a un router, el router debe ser capaz de los bastidores de la expedición a partir de una interfaz a otra, mientras que mantiene el encabezado VLAN. Si configuran al router para rutear un protocolo de la capa 3 (capa de red), terminará el VLA N y las capas MAC en la interfaz una trama llegan encendido. La encabezado de la capa MAC puede ser mantenida si el router está interligando el protocolo de capa de red. Sin embargo, el Bridging común todavía termina el encabezado VLAN. Usando la característica IRB en la versión 11.2 del � del Cisco IOS o mayor, un router puede ser configurado para rutear y interligar el mismo protocolo de capa de red en la misma interfaz. Esto permite que el encabezado VLAN sea mantenido en una trama mientras que transita a un router a partir de una interfaz a otra. El IRB proporciona la capacidad de rutear entre un dominio Bridged y un dominio ruteado con el (BVI) del Interfaz Virtual de Bridge Group. El BVI es una interfaz virtual dentro del router que actúa como una interfaz ruteada normal que no soporte el bridging, pero representa al Grupo de Bridge comparable a las interfaces ruteadas dentro del router. El Número de interfaz del BVI es el número del Grupo de Bridge que la interfaz virtual representa. El número es el link entre el BVI y el Grupo de Bridge.

Cuando usted configura y habilita la encaminamiento en el BVI, los paquetes que vienen adentro en una interfaz ruteada, que son destinados para un host en un segmento en un Grupo de Bridge, se rutean al BVI. Del BVI, el paquete se remite al motor del bridging, que adelante él a través de una interfaz Bridged. Esto se remite sobre la base de la dirección MAC del destino. Semejantemente, los paquetes que vienen adentro en una interfaz Bridged, pero son destinados para un host en una red ruteada, primero van al BVI. Después, el BVI adelante los paquetes al motor de ruteo antes de que les envíe la interfaz ruteada de los. En una sola interfaz física, el IRB se puede crear con dos subinterfaces del VLA N (802.1Q que marca con etiqueta); una sub-interfaz del VLA N tiene una dirección IP que se utilice para rutear, y la otra sub-interfaz del VLA N interliga entre la sub-interfaz usada para rutear y la otra interfaz física en el router.

Puesto que el BVI representa a un Grupo de Bridge como interfaz ruteada, debe ser configurado solamente con las características de la capa 3 (L3), tales como direcciones de capa de red. Semejantemente, las interfaces configuraron para interligar un protocolo no se deben configurar con cualquier característica L3.

Concepto de VLAN Routing y Bridging con IRB

En la Figura I, las PC A y B están conectadas a las VLAN que a su vez están separadas por un router. Esto ilustra el concepto erróneo común de que una red VLAN simple puede tener una conexión basada en router en el medio.

/image/gif/paws/17054/router_vlan1.gif

Esta figura también muestra el flujo de las tres capas de encabezados para una trama que atraviesa los links desde PC A a PC B.

Mientras la trama fluye por el switch, se aplica el encabezado de la VLAN porque la conexión es un link troncal. Pueden existir varias VLAN comunicadas a través del tronco.

El router termina la capa del VLA N y la capa MAC. Examina el IP Address de destino y adelante la trama apropiadamente. En este caso, la trama IP debe ser remitida el puerto de los hacia el PC B. También es un troncal VLAN y entonces se aplica un encabezado VLAN.

Aunque la VLAN que conecta el switch 2 con el router puede ser denominada con el mismo número que la VLAN que conecta el switch 1 con el router, en realidad, no es la misma VLAN. El encabezado VLAN original se elimina cuando la trama entra al router. Una nueva encabezado se puede aplicar como la trama sale al router. Esta nueva encabezado puede incluir el mismo número VLAN que fue utilizado en el encabezado VLAN que fue eliminado cuando llegó la trama. Esto es demostrada por el hecho que la trama IP movida a través del router sin un encabezado VLAN asociado, y fue remitida sobre la base del contenido del campo de IP Destination Address, y no en un campo VLAN ID.

Dado que los dos troncales VLAN se encuentran en sitios opuestos del router, deben ser subredes IP diferentes.

Para que los dos PC tengan la misma dirección de subred, el router tendría que interligar el IP en sus interfaces. Sin embargo, teniendo los dispositivos en los VLA N comparta una subred común no significa que están en el mismo VLA N.

La figura II muestra el aspecto de la topología VLAN.

/image/gif/paws/17054/router_vlan2.gif

La necesidad de cambiar la dirección las estaciones terminales IP durante los movimientos puede ser evitada interligando el IP en alguno o todas las interfaces en el router que conecta los VLA N. Sin embargo, esto elimina todas las ventajas de las redes basadas en router del edificio para controlar los broadcasts en la capa de red. La figura III muestra ocurren qué cambios cuando configuran al router para interligar el IP. La figura IV muestra qué sucede cuando configuran al router para interligar el IP con el IRB.

La Figura III muestra que el router está conectando IP en puente. Ambas PC se encuentran ahora en la misma subred.

Nota: El router (Bridge) ahora adelante la encabezado de la capa MAC a través a la interfaz del exterior-límite. El router todavía termina el encabezado VLAN y aplica una nueva encabezado antes de mandar la trama al PC B.

/image/gif/paws/17054/router_vlan3.gif

La figura IV muestra qué sucede cuando se configura el IRB. El VLA N ahora atraviesa al router, y se mantiene el encabezado VLAN mientras que la trama transita al router.

/image/gif/paws/17054/router_vlan4.gif

Ejemplo de configuración IRB

Esta configuración es un ejemplo del IRB. La configuración permite el interligar del IP entre dos interfaces de Ethernet, y el rutear del IP de las interfaces Bridged usando un (BVI) de la Interfaz Virtual Interconectada. En el siguiente diagram de red, cuando PC_A las tentativas de entrar en contacto el PC_B, el r1 del router detectan que la dirección IP del destino (PC_B) está en la misma subred, así que los paquetes son interligados por el r1 del router entre la interfaz E0 y el e1. Cuando PC_A o PC_B intentan comunicarse con PC_C, el router R1 detecta que la dirección IP (PC_C) de destino se encuentra en una subred diferente y el paquete se enruta mediante la BVI. Esta manera, protocolo IP se interliga así como ruteado en el mismo router.

Diagrama de la red

router_vlan5.gif

Configuración

Configuración de muestra:
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
no ip domain-lookup
bridge irb

!-- This command enables the IRB feature on this router.

!
!
!
interface Ethernet0
no ip address
no ip directed-broadcast
bridge-group 1

!-- The interface E0 is in bridge-group 1.

!
Interface Ethernet1
no ip address
no ip directed-broadcast
bridge-group 1

!-- The interface E1 is in bridge-group 1.

!
Interface Serial0
ip address 10.10.20.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BVI1
ip address 10.10.10.1 255.255.255.0

!-- An ip address is assigned to the logical BVI for routing


!-- IP between bridged interfaces and routed interfaces.

no ip directed-broadcast
!
ip classless
ip route 10.10.30.0 255.255.255.0 10.10.20.2
!
bridge 1 protocol ieee

!-- This command enables the bridging on this router.

bridge 1 route ip

!-- This command enable bridging as well routing for IP protocol.

!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

Resultados del comando show

show interfaces [interface] irb

Este comando muestra los protocolos que pueden rutearse o enviarse a una conexión en puente para la interfaz específica de la siguiente manera:

R1#show interface e0 irb

Ethernet0

Routed protocols on Ethernet0:
ip
    
Bridged protocols on Ethernet0:
ip         ipx

!-- IP protocol is routed as well as bridged.


Software MAC address filter on Ethernet0
 Hash Len    Address      Matches  Act      Type
 0x00:  0 ffff.ffff.ffff     0     RCV  Physical broadcast
 0x2A:  0 0900.2b01.0001     0     RCV  DEC spanning tree
 0x9E:  0 0000.0c3a.5092     0     RCV  Interface MAC address
 0x9E:  1 0000.0c3a.5092     0     RCV  Bridge-group Virtual Interface
 0xC0:  0 0100.0ccc.cccc    157    RCV  CDP
 0xC2:  0 0180.c200.0000     0     RCV  IEEE spanning tree
 0xC2:  1 0180.c200.0000     0     RCV  IBM spanning tree
R1#

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 17054