Switching de LAN : Inter-Switch Link (ISL)

Configurar los troncales ISL en los routeres Cisco

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Noviembre 2015) | Comentarios


Contenido


Introducción

Este documento explica la configuración de los links troncales de Inter-Switch Link Protocol (ISL) en routers Cisco externos como los de las series 7500/7000, 3600, 4500 o 2500. Este documento no explica la configuración de links troncales ISL en switches de Capa 2 (L2)/Capa 3 (L3) como el Cisco Catalyst 6500 o 4500.

Para la información sobre configurar el ISL y los trunks del 802.1Q entre el Switches L2 y L3 del Catalyst que funciona con el Catalyst OS (CatOS) o el software de Cisco IOS�, refiera a cualquiera de éstos:

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

  • Soporte ISL en los switches de Catalyst

    El soporte ISL es dependiente del hardware para los switches de Catalyst. Cuando usted conecta a un router externo con un Catalyst 6500/6000, 5500/5000 o 4500/4000 Switch, utiliza uno de estos comandos de determinar el soporte de encapsulación por módulo:

    • CatOS — muestre las capacidades de puerto

    • Cisco IOS Software — muestre las capacidades de las interfaces

  • Soporte ISL en los routeres Cisco

    En el Cisco IOS Software Release 11.2 y Posterior, solamente a más el conjunto de características es necesaria. El conjunto de características más es IP Plus o escritorio más. Cualquier fast ethernet o interfaz de Ethernet Gigabite en el Routers soporta el enlace del ISL VLAN.

    En el Cisco IOS Software Release 11.3 y Anterior, solamente el IP y el Intercambio de paquetes entre redes (IPX) con una encapsulación de IEEE 802.3 (novell-ether) tienen soporte sobre el ISL. Encapsulaciones y protocolos adicionales agregados Cisco IOS Software Release 11.3.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

UN VLA N es un dominio de broadcast lógico. Para permitir que los datos atraviesen entre dos VLA N, o los dominios de broadcast, usted debe utilizar un dispositivo L3 para rutear entre los VLA N. El modelo del interconexión de sistema abierto (OSI) de la siete-capa define esta regla. Ninguno de estos dispositivos pueden lograr esta encaminamiento:

  • Un router externo, tal como los 2500, los 4000, o los 7000

  • Un router interno, tal como un (MSFC) de la Multilayer Switch Feature Card

  • Un dispositivo externo con el Routing Software, como un host UNIX que ejecuta ruteado o bloqueado

El método original era conectar un diverso puerto físico en el router con cada VLAN individual. Este método llega a ser muy costoso mientras que el número de VLA N aumenta. Pero hay un mejor método. Los administradores de la red pueden decidir utilizar el VLAN Trunking para asignar los VLAN múltiples a una sola interfaz ruteada en lugar de otro. Solamente el Routers con el 100 MB o accesos de Ethernet más rápidos puede hacer el VLAN Trunking.

El VLAN Trunking permite que los fast ethernet del 100 MB o las interfaces de Ethernet Gigabite del 1000 MB pongan una etiqueta en el paquete que identifica el VLA N al cual el paquete pertenece. Cuando el otro extremo del troncal ISL recibe este paquete con Tag, el troncal ISL coloca el paquete en el VLA N correcto. La etiqueta ISL es una encabezado 30-byte que se agrega alrededor de la trama de los fast ethernet. Por lo tanto, el ISL es una tecnología Point-to-Point y trabaja solamente entre dos switches Cisco o Routers que soporten el ISL en los fast ethernet del 100 MB o las interfaces de Ethernet Gigabite del 1000 MB.

Esta figura proporciona una descripción visual de los troncales ISL:

/image/gif/paws/17051/24a.gif

Configuraciones

Complete estos pasos:

  1. Conecte al router con el Switch con los puertos ISL-capaces con el uso de los cables adecuados.

    Utilice la categoría continua 5 o los cables de fibra óptica.

  2. Aseegurese que usted ha creado los VLA N en el lado del switch de Catalyst y que usted ha configurado el puerto del switch para ser un puerto de troncal ISL.

    Nota: Recuerde que los routeres Cisco no pueden negociar el Dynamic Trunking Protocol (DTP) o las tramas del protocolo del Dynamic InterSwitch Link (DISL). Por lo tanto, usted debe configurar al modo tronco para ser nonegocia en el lado del Switch. Refiera al documento del �the que configura el enlace ISL y 802.1q entre un switch CatOS y un router externo (InterVLAN Routing) o la sección de información relacionada de este documento.

  3. Comience a definir los VLA N en el router.

    Aseegurese que usted sabe qué información L2 y L3 a configurar para cada VLA N. Esto incluye la dirección IP, el número de red IPX, y la otra información.

version 11.3
no service password-encryption
!
hostname lt-4500-static
!
enable secret 5 $1$XqiP$3ADCgrFMC21pwyVQIkith.
!
no ip domain-lookup
appletalk routing
ipx routing 0000.0c0b.f2f5
!
!
interface FastEthernet0              

!--- Only Layer 1 is configured here.

 no ip address
 full-duplex             
!
interface FastEthernet0.1            

!--- All L2 and L3 are on subinterfaces.

 encapsulation isl 1                 

!--- This defines ISL encapsulation and the VLAN number.

 ip address 10.6.1.220 255.255.255.0
 no ip redirects           
 appletalk cable-range 100-100 100.149
 appletalk zone cisco
 ipx network ABC encapsulation SAP
!
interface FastEthernet0.2
 encapsulation isl 2
 ip address 10.7.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 200-200 200.135
 appletalk zone cisco1
 ipx network DEADBEEF encapsulation ARPA
!
interface FastEthernet0.3
 encapsulation isl 3
 ip address 10.8.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 300-300 300.69
 appletalk zone cisco2
 ipx network 1234 encapsulation SNAP
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Usted necesita configurar el comando encapsulation isl vlan- antes de que usted configure cualquier otra información L2 o L3. La subinterfaz no tiene que hacer juego el número VLAN ID. Sin embargo, una coincidencia hace la administración y el Troubleshooting de los problemas del VLA N más fáciles.

Usted debe utilizar las subinterfaces para evitar una infracción de la regla de división del horizonte. La regla de división del horizonte prohíbe el anuncio de una ruta de un router a través de una interfaz que el router sí mismo está utilizando para alcanzar el destino. Este acercamiento es muy similar utilizar de las subinterfaces punto a punto con el Frame Relay en un entorno WAN.

Debug y Troubleshooting

Una vez que usted ha verificado que su configuración, Cisco IOS Software, y plataforma de hardware están correctos, usted necesita verificar que las cosas trabajen correctamente. Utilice los comandos en esta sección de verificar la operación y de resolver problemas los problemas.

Nota: La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

  • demostración vlan — Este comando le dice qué información L2 o L3 se configura para cada VLA N.

    lt-4500-static# show vlan
    Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.1       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.6.1.220                   0                   0
           IPX (SAP)        ABC.0000.0c0b.f2f5              0                   8
             AppleTalk           100.149                    0                  22
    Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.2       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.7.1.220                   0                   0
        IPX (ARPA)     DEADBEEF.0000.0c0b.f2f5              0                   8
             AppleTalk           200.135                    0                  22
    Virtual LAN ID:  3 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.3       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.8.1.220                   0                   0
           IPX (SNAP)      1234.0000.0c0b.f2f5              0                   9
             AppleTalk           300.69                     0                  23
    
  • interfaz de la demostración — Este comando dice le el estado de la interfaz y subinterfaz, así como a color de VLAN de las subinterfaces. El color de VLAN es lo mismo que el número VLAN.

    lt-4500-static# show interface
    FastEthernet0 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:00, output 00:00:03, output hang never
      Last clearing of "show interface" counters 00:04:25
      Queueing strategy: fifo
      Output queue 0/40, 0 drops; input queue 0/75, 0 drops
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         415 packets input, 25392 bytes, 0 no buffer
         Received 415 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 watchdog, 0 multicast
         0 input packets with dribble condition detected
         137 packets output, 12378 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    FastEthernet0.1 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.6.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.2 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.7.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.3 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.8.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 3.
      ARP type: ARPA, ARP Timeout 04:00:00
    
  • muestre {IP | ipx | ruta del APPLETALK} — este comando le dice que la subinterfaz ISL correcta es de aprendizaje o de envío de la información de ruteo.

    lt-4500-static# show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
           U - per-user static route, o - ODR
    Gateway of last resort is not set
          10.0.0.0/24 is subnetted, 3 subnets
    C       10.8.1.0 is directly connected, FastEthernet0.3
    C       10.7.1.0 is directly connected, FastEthernet0.2
    C       10.6.1.0 is directly connected, FastEthernet0.1
    
    lt-4500-static# show appletalk route
    Codes: R - RTMP derived, E - EIGRP derived, C - connected, A - AURP
           S - static  P - proxy 
    3 routes in internet
    The first zone listed for each entry is its default (primary) zone.
    C Net 100-100 directly connected, Fa0.1, zone cisco
    C Net 200-200 directly connected, Fa0.2, zone cisco1
    C Net 300-300 directly connected, Fa0.3, zone cisco2
    
    lt-4500-static# show ipx route
    Codes: C - Connected primary network,    c - Connected secondary network
           S - Static, F - Floating static, L - Local (internal), W - IPXWAN
           R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
           s - seconds, u - uses, U - Per-user static
    3 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
    No default route known.
    C        ABC (ISL vLAN),      Fa0.1
    C       1234 (ISL vLAN),      Fa0.3
    C   DEADBEEF (ISL vLAN),      Fa0.2
    
  • debug vlan packet — Este comando le dice si hay un misconfiguration de los paquetes en el troncal ISL o si la subinterfaz ISL incorrecta es de envío o de recepción de los paquetes.

    precaución Precaución: Tenga siempre cuidado cuando usted utiliza cualquier comando debug. Los comandos debug pueden causar los problemas graves de rendimiento en el router. Para inhabilitar el debugging, publique el comando undebug all.

    lt-4500-static# debug vlan packet
    Virtual LAN packet information debugging is on
    lt-4500-static#
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 3
          on interface FastEthernet0.3 which is not configured to
          route or bridge this packet type.
    vLAN: ISL packet received bearing colour ID 4 on FastEthernet0
          which has no subinterface configured to route or bridge ID 4.
    vLAN: ISL packet received bearing colour ID 5 on FastEthernet0
          which has no subinterface configured to route or bridge ID 5.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 17051