IP : Protocolo mejorado de routing de gateway interior (EIGRP)

Protocolo de ruteo de gateway interior mejorado

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (23 Marzo 2008) | Inglés (27 Abril 2015) | Comentarios


Interactivo: Este documento ofrece un análisis personalizado de su dispositivo Cisco.


Contenido


Introducción

Enhanced Interior Gateway Routing Protocol (EIGRP) es un protocolo de gateway interior apropiado para muchos tipos diferente de topologías y de medios. En una red bien diseñada, EIGRP escala bien y ofrece tiempos de convergencia extremadamente rápidos con un mínimo tráfico de red.

Teoría de Funcionamiento de EIGRP

Algunas de las varias ventajas de EIGRP son:

  • Uso muy bajo de recursos de red durante el funcionamiento normal. Solamente los paquetes hello se transmiten en una red estable.

  • Cuando ocurre un cambio, solo se propagan los cambios de la tabla de ruteo, no la tabla de ruteo completa. Esto reduce la carga que el mismo protocolo de ruteo coloca en la red.

  • Tiempos de convergencia rápidos para los cambios en la topología de red (en algunas situaciones, la convergencia puede ser casi instantánea).

EIGRP es un protocolo de vector de distancias optimizado, que se basa en el Algoritmo de Actualización Difusa (DUAL) para calcular la trayectoria más corta hacia un destino dentro de una red.

Revisiones Principales del Protocolo

Hay dos revisiones principales de EIGRP, las versiones 0 y 1. Las versiones del Cisco IOS anteriores a 10.3(11), 11.0(8) y 11.1(3) ejecutan la versión anterior de EIGRP; algunas explicaciones de este documento pueden no aplicarse a esa versión anterior. Recomendamos especialmente utilizar la última versión de EIGRP, ya que esta incluye varias mejoras de funcionamiento y estabilidad.

Teoría Básica

Un protocolo de vector de distancia típico guarda la siguiente información al computar la mejor trayectoria hacia un destino: la distancia (distancia o métrica total, como conteo de saltos) y el vector (el salto siguiente). Por ejemplo, todos los routers en la red de la Figura 1 ejecutan Routing Information Protocol (RIP). El Router Dos elige la trayectoria hacia la Red A al examinar el conteo de saltos a través de cada trayectoria disponible.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp1.gif

Dado que la trayectoria a través del Router Tres tiene tres saltos y la trayectoria a través del Router Uno tiene dos saltos, el Router Dos elige la trayectoria a través del Uno y desecha la información que detectó a través del Tres. Si la trayectoria entre el Router Uno y la Red A se interrumpe, el Router Dos pierde toda conectividad con este destino hasta que se agote el tiempo de la ruta de su tabla de ruteo (tres períodos de actualización o 90 segundos) y el Router Tres vuelve a anunciar la ruta (lo cual ocurre cada 30 segundos en RIP). Sin tener en cuenta el tiempo de espera, el Router Dos tardará entre 90 y 120 segundos para conmutar la trayectoria del Router Uno al Router Tres.

EIGRP, en lugar de depender de actualizaciones periódicas completas para reconverger, crea una tabla de topologías a partir de cada uno de los anuncios de sus vecinos (en lugar de desechar los datos) y converge ya sea buscando una ruta probablemente libre de loops en la tabla de topologías o, si no conoce ninguna otra ruta, consultando a sus vecinos. El Router Dos guarda la información que recibió de los Routers Uno y Tres. Elige la trayectoria a través de Uno como su mejor trayectoria (el sucesor) y la trayectoria a través de Tres como una trayectoria libre de loops (un sucesor factible). Cuando la trayectoria a través del Router Uno no esté disponible, el Router Dos examinará su tabla de topologías y, al encontrar un sucesor factible, comenzará inmediatamente a usar la trayectoria a través del Tres.

Con esta breve explicación, es evidente que EIGRP debe proporcionar:

  • Un sistema donde envía solo las actualizaciones necesarias en un momento dado. Esto se realiza a través del mantenimiento y de la detección de vecinos.

  • una manera de determinar qué trayectos ha aprendido un router como libres de loops

  • un proceso para eliminar rutas defectuosas de las tablas de topología de todos los routers en la red

  • un proceso de consulta a vecinos para encontrar rutas hacia destinos perdidos

Analizaremos cada uno de estos requisitos oportunamente.

Mantenimiento y Detección de Vecinos

Para distribuir información de ruteo a través de una red, EIGRP utiliza actualizaciones de ruteo graduales no periódicas. Es decir, EIGRP enviará solamente actualizaciones de ruteo sobre las trayectorias que hayan cambiado cuando esas trayectorias cambien.

El problema básico con el envío de solo las actualizaciones de ruteo es que usted no puede saber cuándo una trayectoria a través de un router de vencidad ya no está disponible. No puede agotar el tiempo de las rutas con el objetivo de recibir una nueva tabla de ruteo de sus vecinos. EIGRP confía en las relaciones de vecinos para propagar de forma confiable los cambios de la tabla de ruteo en toda la red. Dos routers se convierten en vecinos cuando ven los paquetes hello de cada uno en una red común.

EIGRP envía paquetes hello cada 5 segundos en links de ancho de banda alto y cada 60 segundos en links multipunto de ancho de banda bajo.

  • saludo de 5 segundos:

    • medios de broadcast, como Ethernet, Token Ring y FDDI

    • links seriales punto a punto, como circuitos dedicados HDLC o PPP, subinterfaces punto a punto Frame Relay y la subinterfaz punto a punto ATM

    • circuitos multipunto de ancho de banda alto (mayor que T1), como ISDN PRI y Frame Relay

  • Hello de 60 segundos:

    • circuitos multipunto de ancho de banda de T1 o inferior, como interfaces multipunto Frame Relay, interfaces multipunto ATM, circuitos virtuales conmutados ATM e ISDN BRI

La velocidad con que EIGRP envía los paquetes hello se llama intervalo hello y usted puede ajustarlo por interfaz con el comando ip hello-interval eigrp. El tiempo de espera es la cantidad de tiempo que un router considerará a un vecino activo sin recibir un paquete hello. El tiempo de espera es generalmente el triple del intervalo hello; de forma predeterminada, 15 segundos y 180 segundos. Puede ajustar el tiempo de espera con el comando ip hold-time eigrp.

Recuerde que si cambia el intervalo de saludo, el período de inactividad no se ajustará en forma automática, debe ajustar en forma manual el período de inactividad para que refleje el intervalo de saludo configurado.

Es posible que dos routers se conviertan en vecinos de EIGRP aunque los temporizadores de espera y hello no coincidan. El tiempo de retención se incluye en los paquetes de saludo, de modo que cada vecino se mantenga activo aunque los temporizadores de retención y el intervalo de saludo no coincidan.

Mientras que no hay forma directa de determinar cuáles está el intervalo de saludo en un router, usted puede deducirlo de la salida de los vecinos del eigrp del IP de la demostración en el router de la vencidad.

Si usted tiene la salida de un comando show ip eigrp neighbors de su dispositivo de Cisco, usted puede utilizar el Output Interpreter (clientes registrados solamente) para visualizar los problemas potenciales y los arreglos. Para poder utilizar la herramienta Output Interpreter Tool, debe tener JavaScript habilitado.

router# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address       Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2      Et1           13 12:00:53   12   300  0  620
0   10.1.2.2      S0           174 12:00:56   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           12 12:00:55   12   300  0  620
0   10.1.2.2       S0           173 12:00:57   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           11 12:00:56   12   300  0  620
0   10.1.2.2       S0           172 12:00:58   17   200  0  645

El valor de la columna Hold del resultado del comando nunca debe exceder el tiempo de espera y nunca debe ser menor que el tiempo de espera menos el intervalo hello (a menos que, por supuesto, esté perdiendo paquetes hello). Si la columna Hold varía generalmente entre 10 y 15 segundos, el intervalo hello es de 5 segundos y el tiempo de espera es de 15 segundos. Si la columna Hold tiene generalmente un rango más amplio (entre 120 y 180 segundos), el intervalo hello es de 60 segundos y el tiempo de espera es de 180 segundos. Si los números no parecen estar dentro de las configuraciones de temporizador predeterminadas, verifique la interfaz en cuestión en el router de vencidad; es posible que los temporizadores de espera y hello se hayan configurado de forma manual.

Nota: 

  • EIGRP no crea relaciones de peers sobre direcciones secundarias. Todo el tráfico EIGRP se origina en la dirección primaria de la interfaz.

  • Al configurar EIGRP en una red multiacceso Frame Relay (punto a multipunto, etc.), configure la palabra clave broadcast en las declaracionessframe-relay map. Sin la palabra clave broadcast, no se establecerían las adyacencias entre los dos routers de EIGRP. Consulte Configuración y Troubleshooting de Frame Relay para obtener más información.

  • No existen limitaciones en el número de vecinos que EIGRP puede soportar. El número real de vecinos soportados depende de la capacidad del dispositivo, por ejemplo:

    • capacidad de memoria

    • potencia de procesamiento

    • cantidad de información intercambiada, como el número de rutas enviadas

    • complejidad de la topología

    • estabilidad de la red

Creación de la Tabla de Topologías

Ahora que estos routers se comunican entre sí, ¿de qué hablan? De sus tablas de topologías, por supuesto. EIGRP, a diferencia de RIP e IGRP, no se basa en la tabla de ruteo (o reenvío) del router para mantener toda la información necesaria para funcionar. En cambio, crea una segunda tabla, la tabla de topología, desde la cual instala rutas en la tabla de ruteo.

Nota: A partir de las versiones 12.0T y 12.1 de IOS de Cisco, RIP mantiene su propia base de datos desde el cual instala las rutas en la tabla de ruteo.

Para ver el formato básico de la tabla de topologías en un router que ejecuta EIGRP, ejecute el comando show ip eigrp topology. La tabla de topología contiene la información necesaria para crear un conjunto de distancias y vectores para cada red alcanzable, que incluye:

  • el ancho de banda más bajo en la trayectoria hacia ese destino según lo informado por el vecino de flujo ascendente

  • demora total

  • confiabilidad de la trayectoria

  • carga de la trayectoria

  • unidad máxima de transmisión (MTU) de trayectoria mínima

  • distancia factible

  • distancia informada

  • origen de la ruta (las rutas externas están marcadas)

Las distancias factible e informada se discuten más adelante en esta sección.

Si tiene el resultado de un comando show ip eigrp topology de su dispositivo Cisco, puede utilizar la herramienta Output Interpreter Tool (solo para clientes registrados) para ver los posibles problemas y sus soluciones. Para poder utilizar la herramienta Output Interpreter Tool, debe tener JavaScript habilitado.

Métricas de EIGRP

EIGRP utiliza el ancho de banda mínimo en la trayectoria hacia una red de destino y la demora total para computar las métricas de ruteo. Aunque usted puede configurar otras métricas, no recomendamos hacerlo, ya que puede causar loops de ruteo en su red. Las métricas de demora y ancho de banda se determinan a partir de los valores configurados en las interfaces de los routers en la trayectoria hacia la red de destino.

Por ejemplo, en la Figura 3, a continuación, el Router Uno está calculando la mejor trayectoria hacia la Red A.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp2.gif

Comienza con los dos anuncios para esta red: uno a través del Router Cuatro, con un ancho de banda mínimo de 56 y una demora total de 2200; y el otro a través del Router Tres, con un ancho de banda mínimo de 128 y una demora de 1200. El Router Uno elige la trayectoria con la métrica más baja.

Computemos las métricas. EIGRP calcula la métrica total escalando las métricas de demora y ancho de banda. EIGRP utiliza la siguiente fórmula para escalar el ancho de banda:

  • ancho de banda = (10.000.000/ancho de banda(i)) * 256

    donde ancho de banda(i) es el ancho de banda menor de todas las interfaces de salida en la ruta hacia la red de destino representado en kilobits.

EIGRP utiliza la siguiente fórmula para escalar la demora:

  • demora = demora(i) * 256

    donde demora(i) es la suma de las demoras configuradas en las interfaces, en la ruta hacia la red de destino, en decenas de microsegundos. La demora que se muestra en los comandos show ip eigrp topology o show interface se expresa en microsegundos, de manera que debe dividir ese valor por 10 antes de utilizarlo en esta fórmula. En todo este documento, utilizamos la demora como está configurada y como se muestra en la interfaz.

EIGRP utiliza estos valores escalados para determinar la métrica total hacia la red:

  • métrico = ([K1 * bandwidth + (K2 * bandwidth)/(256 - load) + K3 * delay] * [K5/(reliability + K4)]) * 256

Nota: Estos valores K deben utilizarse después de una planificación minuciosa. Los valores K no coincidentes impiden que se cree una relación de vecinos, lo que puede hacer que su red no pueda converger.

Nota: Si el K5 = 0, la fórmula reduce a métrico = ([k1 * ancho de banda + (k2 * bandwidth)/(256 - carga) + k3 * retardo]) * 256.

Los valores predeterminados para K son:

  • K1 = 1

  • K2 = 0

  • K3 = 1

  • K4 = 0

  • K5 = 0

Para un comportamiento predeterminado, puede simplificar la fórmula de la siguiente manera:

metric = bandwidth + delay 

Los routers de Cisco no realizan aritmética de punto flotante; por lo tanto, en cada etapa del cálculo, es necesario redondear al entero más cercano para calcular las métricas adecuadamente. En este ejemplo, el costo total a través del Router Cuatro es:

En este ejemplo, el costo total a través del Router Cuatro es:

minimum bandwidth = 56k 

total delay = 100 + 100 + 2000 = 2200 

[(10000000/56) + 2200] x 256 = (178571 + 2200) x 256 = 180771 x 256 = 46277376  

Y el costo total a través del Router Tres es:

minimum bandwidth = 128k 

total delay = 100 + 100 + 1000 = 1200 

[(10000000/128) + 1200] x 256 = (78125 + 1200) x 256 = 79325 x 256 = 20307200  

Por lo tanto, para llegar a la Red A, el Router Uno selecciona la ruta a través del Router Tres.

Observe que los valores de retraso y de ancho de banda utilizados son aquellos que están configurados en la interfaz a través de la cual el router alcanza su salto siguiente hacia la red de destino. Por ejemplo, el Router Dos anunció la Red A con la demora configurada en su interfaz de Ethernet. El Router Cuatro agregó la demora configurada en su Ethernet y el Router Uno agregó la demora configurada en su serial.

Distancia Factible, Distancia Informada y Sucesor Factible

La distancia factible es la mejor métrica a lo largo de una trayectoria hacia una red de destino, que incluye la métrica hacia el vecino que anuncia esa trayectoria. La distancia informada es la métrica total a lo largo de una trayectoria hacia una red de destino según lo anunciado por un vecino de flujo ascendente. Un sucesor factible es una trayectoria cuya distancia informada es menor que la distancia factible (la mejor trayectoria actual). En la Figura 3, se ilustra este proceso:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp3.gif

El Router Uno ve que tiene dos rutas hacia la Red A: una a través del Router Tres y otra a través del Router Cuatro.

  • La ruta a través del Router Cuatro tiene un costo de 46.277.376 y una distancia informada de 307.200.

  • La ruta a través del Router Tres tiene un costo de 20.307.200 y una distancia informada de 307.200.

Observe que, en cada caso, EIGRP calcula la distancia informada del router que anuncia de la ruta hacia la red. En otras palabras, la distancia informada del Router Cuatro es la métrica para llegar a la Red A desde el Router Cuatro y la distancia informada del Router Tres es la métrica para llegar a la Red A desde el Router Tres. EIGRP elige la ruta a través del Router Tres como la mejor trayectoria y utiliza la métrica a través del Router Tres como la distancia factible. Dado que la distancia informada hacia esta red a través del Router Cuatro es menor que la distancia factible, el Router Uno considera la trayectoria a través del Router Cuatro como un sucesor factible.

Cuando el link entre los Routers Uno y Tres se interrumpe, el Router Uno examina cada trayectoria que conoce hacia la Red A y encuentra que tiene un sucesor factible a través del Router Cuatro. El Router Uno utiliza esta ruta, usando la métrica a través del Router Cuatro como la nueva distancia factible. La red converge inmediatamente y las actualizaciones a los vecinos de flujo descendente representan el único tráfico del protocolo de ruteo.

Observemos una situación más compleja, que se muestra en la Figura 4.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp4.gif

Hay dos rutas hacia la Red A desde el Router Uno: una a través del Router Dos con una métrica de 46.789.376 y otra a través del Router Cuatro con una métrica de 20.307.200. El Router Uno elige la métrica más baja de las dos como su ruta hacia la Red A y esta métrica se convierte en la distancia factible. Luego, observemos la trayectoria a través del Router Dos para ver si califica como un sucesor factible. La distancia informada desde el Router Dos es de 46.277.376, que es mayor que la distancia factible; por lo tanto, esta trayectoria no es un sucesor factible. Si buscara en la tabla de topologías del Router Uno en este punto (utilizando show ip eigrp topology), solo vería una entrada para la Red A, a través del Router Cuatro. (En realidad, hay dos entradas en la tabla de topologías en el Router Uno, pero solamente una será un sucesor factible; por lo tanto, la otra no se mostrará en show ip eigrp topology; puede ver las rutas que no son sucesores factibles usando show ip eigrp topology all-links).

Supongamos que el link entre el Router Uno y el Router Cuatro se interrumpe. El Router Uno ve que ha perdido su única ruta hacia la Red A y consulta a cada uno de sus vecinos (en este caso, solo el Router Dos) para saber si cuentan con una ruta hacia la Red A. Dado que el Router Dos tiene una ruta hacia la Red A, responde a la consulta. Dado que el Router Uno ya no es la mejor ruta a través del Router Cuatro, acepta esta ruta a través del Router Dos hacia la Red A.

Cómo Decidir si una Trayectoria está Libre de Loops

¿Cómo EIGRP utiliza los conceptos de distancia factible, distancia informada y sucesor factible para determinar si una trayectoria es válida, y no un loop? En la Figura 4a, el Router Tres examina las rutas hacia la Red A. Dado que el split horizon está inhabilitado (por ejemplo, si estas son interfaces multipunto Frame Relay), el Router Tres muestra tres rutas hacia la Red A: a través del Router Cuatro, del Router Dos (la trayectoria es dos, uno, tres, cuatro) y del Router Uno (la trayectoria es uno, dos, tres, cuatro).

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp21.gif

Si el Router Tres acepta todas estas rutas, se originará un loop de ruteo como resultado. El Router Tres piensa que puede llegar a la Red A a través del Router Dos, pero la trayectoria a través del Router Dos pasa a través del Router Tres para llegar a la Red A. Si la conexión entre el Router Cuatro y Router Tres se interrumpe, el Router Tres cree que puede llegar a la Red A con una de las otras trayectorias, pero debido a las reglas para determinar los sucesores factibles, nunca utilizará estas trayectorias como alternativas. Observemos las métricas para ver por qué:

  • Métrica total hacia la Red A a través del Router Cuatro: 20281600

  • Métrica total hacia la Red A a través del Router Dos: 47019776

  • Métrica total hacia la Red A a través del Router Uno: 47019776

Dado que la trayectoria a través del Router Cuatro tiene la mejor métrica, el Router Tres instala esta ruta en la tabla de reenvío y utiliza 20.281.600 como su distancia factible hacia la Red A. Luego, el Router Tres computa la distancia informada hacia la Red A a través de los Routers Dos y Uno: 47019776 para el trayecto a través del Router Dos y 47019776 para el trayecto a través del Router Uno. Debido a que ambas métricas son mayores que la distancia factible, el Router Tres no instala ninguna ruta como un sucesor factible para la Red A.

Suponga que el link entre los Routers Tres y Cuatro se interrumpe. El Router Tres le consulta a cada uno de sus vecinos para obtener una ruta alternativa hacia la Red A. El Router Dos recibe la consulta y, debido a que proviene de su sucesor, busca cada una de las otras entradas en su tabla de topologías para ver si existe un sucesor factible. La única otra entrada en la tabla de topologías es del Router Uno, con una distancia informada igual que la última mejor métrica conocida a través del Router Tres. Debido a que la distancia informada a través del Router Uno no es menor que la última distancia factible conocida, el Router Dos marca la ruta como inalcanzable y consulta a cada uno de sus vecinos (en este caso, solamente el Router Uno) para obtener una trayectoria hacia a la Red A.

El Router Tres también envía una consulta para la Red A al Router Uno. El Router Uno examina su tabla de topologías y descubre que la única trayectoria hacia la Red A es a través del Router Dos con una distancia informada igual que la última distancia factible conocida a través del Router Tres. Una vez más, debido a que la distancia informada a través del Router Dos no es menor que la última distancia factible conocida, esta ruta no es un sucesor factible. El Router Uno marca la ruta como inalcanzable y le consulta a su único vecino, el Router Dos, para obtener una trayectoria hacia la Red A.

Este es el primer nivel de consultas. El Router Tres ha consultado a cada uno de sus vecinos en un intento de encontrar una ruta a la Red A. A su vez, los Routers Uno y Dos han marcado la ruta como inalcanzable y consultaron a cada uno de sus vecinos restantes en un intento de encontrar una trayectoria a la Red A. Cuando el Router Dos recibe la consulta del Router Uno, examina su tabla de topología y observa que el destino está marcado como inalcanzable. El Router Dos le responde al Router Uno que la Red A es inalcanzable. Cuando el Router Uno recibe la consulta del Router Dos, también responde que la Red A es inalcanzable. Los Routers Uno y Dos han concluido que la Red A es inalcanzable y responden la consulta original del Router Tres. La red convergió y todas las rutas regresan al estado pasivo.

Mecanismos Split Horizon y Poison Reverse

En el ejemplo anterior, supusimos que el método split horizon no estaba activado para mostrar cómo el EIGRP usa la distancia factible y la distancia informada a fin de determinar si es probable que una ruta sea un loop. En algunas circunstancias, sin embargo, el EIGRP utiliza el método split horizon para evitar loops de ruteo. Antes de abordar en profundidad la manera en que el EIGRP utiliza split horizon, repasemos qué es este método y cómo funciona. La regla de división del horizonte afirma:

  • Un router nunca publica una ruta por la misma interfaz a través de la cual se aprendió de ella.

Por ejemplo, en la Figura 4a, si el Router Uno está conectado con los Routers Dos y Tres por medio de una sola interfaz multipunto (tal como Frame Relay) y si aprendió sobre la Red A a través del Router Dos, no le publicará la ruta a la Red A al Router Tres a través de la misma interfaz. El Router Uno supone que el Router Tres tomará conocimiento de la Red A directamente a través del Router Dos.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp21.gif

El envenenamiento de ruta es otra forma de evitar loops de ruteo. Su regla afirma:

  • Una vez que detecte una ruta a través de una interfaz, anúnciela como inalcanzable mediante la misma interfaz.

Supongamos que los routers en la Figura 4a tiene habilitado el método poison reverse. Cuando el Router Uno aprende acerca de la Red A desde el Router Dos, anuncia a la Red A como inalcanzable a través de su link hacia los Routers Dos y Tres. El Router Tres, si muestra alguna trayectoria a la Red A a través del Router Uno, quita esa trayectoria debido a la publicación de inalcanzable. EIGRP combina estas dos reglas para evitar loops de ruteo.

EIGRP utilizan la división del horizonte o anuncia que una ruta es inalcanzable cuando:

  • hay dos routers en modo de inicio (están intercambiando tablas de topología por primera vez)

  • anuncio de un cambio en la tabla de topología

  • envío de una consulta

Analicemos cada una de estas situaciones.

Modo de inicio

Cuando dos routers se vuelven vecinos, intercambian las tablas de topología durante el modo de inicio. Por cada entrada de tabla que un router recibe durante el modo de inicio, vuelve a publicar la misma entrada a su vecino nuevo con una métrica máxima (ruta envenenada).

Cambio en la Tabla de Topología

En la Figura 5, el Router Uno utiliza varianza para equilibrar el tráfico destinado a la Red A entre los dos links seriales: el link de 56k entre los Routers Dos y Cuatro, y el link de 128k entre los Routers Tres y Cuatro (consulte la sección Balanceo de carga para obtener información sobre la varianza).

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp5.gif

El Router Dos considera que la trayectoria a través del Router Tres es un sucesor factible. Si el link entre los Routers Dos y Cuatro deja de funcionar, el Router Dos simplemente vuelve a hacer convergencia en la trayectoria a través del Router Tres. Debido a que las reglas de división del horizonte establecen que nunca debe anunciarse una ruta fuera de la interfaz a través de la cual se conoció ésta, el router dos normalmente no enviará una actualización. Sin embargo, esto deja al Router Uno con una entrada en la tabla de topología no válida. Cuando un router cambia su tabla de topología de manera que se modifica la interfaz a través de la cual el router alcanza una red, el método split horizon se desactiva y se aplica poison reverse a la ruta anterior y se publica a través de todas las interfaces. En este caso, el Router Dos desactiva split horizon para esta ruta y publica que la Red A como inalcanzable. El Router Uno escucha esta advertencia y revela su ruta a la Red A mediante el Router Dos desde su tabla de ruteo.

Consultas

Las consultas traen como consecuencia un horizonte dividido sólo cuando un router recibe una consulta o una actualización de parte del sucesor que está usando para el destino en la consulta. Observemos la red en la Figura 6.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp6.gif

El Router Tres recibe una consulta sobre 10.1.2.0/24 (que alcanza a través del Router Uno) del Router Cuatro. Si el Router Tres no tiene un sucesor para este destino por inestabilidad del link o por otra condición temporal de la red, envía una consulta a cada uno de sus vecinos que, en este caso, son los Routers Uno, Dos y Cuatro. Si, sin embargo, el Router Tres recibe una consulta o una actualización (tal como un cambio en la métrica) de parte del Router Uno para el destino 10.1.2.0/24, no vuelve a enviar una consulta al Router Uno porque este es su sucesor en esta red. En cambio, envía las consultas a los Routers Dos y Cuatro solamente.

Rutas en Estado Stuck In Active

En algunas circunstancias, se demora mucho tiempo en contestar una consulta. que el router que envió la consulta abandona y quita su conexión al router que no responde, y de esta manera reinicia eficazmente la relación de vecindad con el vecino que falló al responder la consulta. Esto se conoce como ruta en estado “stuck in active” (SIA). Las rutas SIA más básicas surgen cuando una consulta tarda mucho en alcanzar el otro extremo de la red y una respuesta tarda en regresar. Por ejemplo, en la Figura 7, el Router Uno está registrando una gran cantidad de rutas SIA desde el Router Dos.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp7.gif

Luego de hacer algunas investigaciones, el problema se reduce a la demora del link satelital entre los Routers Dos y Tres. Existen dos posibles soluciones para este tipo de problema. La primera consiste en aumentar el tiempo de espera del router entre el envío de una consulta y la declaración de la ruta SIA. Esta configuración puede cambiarse utilizando el comando timers active-time.

Sin embargo, la mejor solución es rediseñar la red para reducir el rango de consultas (por lo que muy pocas consultas pasan al link satelital). El rango de consulta se trata en la sección Rango de Consulta. El rango de consulta en sí mismo no es, sin embargo, un motivo común para las rutas SIA notificadas. Con más frecuencia sucede que un router en la red no puede responder una consulta por uno de los siguientes motivos:

  • el router está demasiado ocupado como para contestar la consulta (por lo general debido a un alto nivel de uso de la CPU)

  • el router presenta problemas de memoria y no puede asignar la memoria para procesar la consulta o construir el paquete de respuesta

  • el circuito entre los dos routers no es bueno - se están transmitiendo suficientes paquetes como para mantener la relación de vecinos pero algunas consultas o respuestas se están perdiendo entre los routers

  • Links unidireccionales (un link a través del cual el tráfico puede fluir en una dirección solamente debido a una falla).

Troubleshooting de Rutas SIA

Troubleshooting rutas SIA es generalmente un proceso de tres pasos:

  1. Encontrar las rutas que se informan constantemente como SIA.

  2. Encontrar el router que sistemáticamente no logra responder las consultas por estas rutas.

  3. Busque la razón por la que el router no está recibiendo o respondiendo consultas.

El primer paso debería ser bastante fácil. Si usted está registrando mensajes de la consola, mediante una lectura rápida del registro podrá conocer las rutas que son marcadas como SIA con más frecuencia. El segundo paso es más difícil. El comando para recopilar esta información es show ip eigrp topology active:

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

A 10.2.4.0/24, 0 successors, FD is 512640000, Q 
    1 replies, active 00:00:01, query-origin: Local origin 
         via 10.1.2.2 (Infinity/Infinity), Serial1 
    1 replies, active 00:00:01, query-origin: Local origin 
         via 10.1.3.2 (Infinity/Infinity), r, Serial3 
    Remaining replies: 
         via 10.1.1.2, r, Serial0

Cualquier vecino que muestre una R aún tiene que responder (el temporizador activo muestra durante cuánto tiempo la ruta ha estado activa). Tenga en cuenta que estos vecinos pueden no aparecer en la sección Respuestas pendientes; pueden aparecer entre las otras RDB. Preste especial atención a las rutas con respuestas pendientes que han estado activas durante cierto tiempo, generalmente de dos a tres minutos. Ejecute este comando varias veces y comenzará a ver qué vecinos no responden las consultas (o qué interfaces parecen tener muchas consultas sin responder). Examine a este vecino para ver si espera constantemente las respuestas de alguno de sus vecinos. Repita este proceso hasta que encuentre el router que sistemáticamente no responde las consultas. Puede detectar problemas relativos al link con el vecino, la memoria o la utilización de CPU u otros problemas asociados al vecino.

Si se encuentra en una situación en la que, aparentemente, el rango de consulta es el problema, siempre es mejor reducir dicho rango en lugar de aumentar el temporizador SIA.

Redistribución

En esta sección se analizan diferentes escenarios relacionados con la redistribución. Tenga en cuenta que los siguientes ejemplos muestran el mínimo requerido para configurar la redistribución. La redistribución puede ocasionar problemas, tales como ruteo por debajo del nivel óptimo, loops de ruteo y convergencia lenta. Para evitar estos problemas, consulte "Cómo Evitar Problemas Ocasionados por la Redistribución" en Redistribución de Protocolos de Ruteo.

Redistribución Entre Dos Sistemas Autónomos EIGRP

En la Figura 8, los routers se configuran como se muestra a continuación:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp8.gif

Router Uno

router eigrp 2000 

!--- The "2000" is the autonomous system 

 network 172.16.1.0 0.0.0.255 

Router Dos

router eigrp 2000 
 redistribute eigrp 1000 route-map to-eigrp2000
 network 172.16.1.0 0.0.0.255 
! 
router eigrp 1000 
 redistribute eigrp 2000 route-map to-eigrp1000
 network 10.1.0.0 0.0.255.255

route-map to-eigrp1000 deny 10
match tag 1000
!
route-map to-eigrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

Router Tres

router eigrp 1000 
 network 10.1.0.0 0.0.255.255

El Router Tres publica, a través del sistema autónomo 1000, la red 10.1.2.0/24 al Router Dos. El Router Dos redistribuye esta ruta en el sistema autónomo 2000 y la publica al Router Uno.

Nota: Las rutas del EIGRP 1000 se marcan con la etiqueta 1000 antes de su redistribución en EIGRP 2000. Cuando las rutas del EIGRP 2000 se vuelven a redistribuir en EIGRP 1000, las rutas con etiquetas 1000 se niegan para asegurar una topología sin loops. Para obtener más información sobre la redistribución entre protocolos de ruteo, consulte Redistribución de Protocolos de Ruteo.

En el Router Uno, observamos lo siguiente:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 2 
      External data: 
        Originating router is 10.1.2.1 
        AS number of route is 1000 
        External protocol is EIGRP, external metric is 46251776 
        Administrator tag is 1000 (0x000003E8)

Observe que, a pesar de que el link entre los Routers Uno y Dos tiene un ancho de banda de 1.544Mb, el ancho de banda mínimo que aparece en esta entrada de la tabla de topología es 56k. Esto significa que EIGRP preserva todas las métricas durante la redistribución entre dos sistemas autónomos EIGRP.

Redistribución Entre EIGRP e IGRP en Dos Sistemas Autónomos Diferentes

En la Figura 9, hemos cambiado las configuraciones de la siguiente manera:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp9.gif

Router Uno

router eigrp 2000 
 network 172.16.1.0

Router Dos

router eigrp 2000 
 redistribute igrp 1000 route-map to-eigrp2000
 network 172.16.1.0
! 
router igrp 1000 
 redistribute eigrp 2000 route-map to-igrp1000
 network 10.0.0.0 
!

route-map to-igrp1000 deny 10
match tag 1000
!
route-map to-igrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

Router Tres

router igrp 1000 
 network 10.0.0.0

A continuación, se muestra la configuración del Router Uno:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 1000 
        External protocol is IGRP, external metric is 180671 
        Administrator tag is 1000 (0x000003E8)

Las métricas de IGRP se mantienen cuando las rutas se redistribuyen en EIGRP con un sistema autónomo diferente, pero se amplían multiplicando la métrica de IGRP por la constante 256. Es importante considerar una advertencia con respecto a la redistribución entre IGRP y EIGRP. Si la red está conectada directamente con el router que hace la redistribución, la ruta se publica con una métrica de 1.

Por ejemplo, la red 10.1.1.0/24 está conectada directamente con el Router Dos e IGRP es el protocolo de ruteo para esta red (hay una declaración de red conforme al IGRP del router que trata sobre esta interfaz). EIGRP no es el protocolo de ruteo para esta red, pero conoce acerca de esta interfaz conectada directamente a través de una redistribución desde IGRP. En el Router Uno, la entrada de la tabla de topología para 10.1.1.0/24 indica lo siguiente:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (2169856/1), Route is External 
                                    
      Vector metric: 
        Minimum bandwidth is 1544 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 0/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 1000 
        External protocol is IGRP, external metric is 0 
        Administrator tag is 1000 (0x000003E8)

Observe que la distancia informada del Router Dos, que está en negrita, es 1".

Redistribución Entre EIGRP e IGRP en el Mismo Sistema Autónomo

Los siguientes cambios se realizan en las configuraciones del router en la Figura 10:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp10.gif

Router Uno

router eigrp 2000 
 network 172.16.1.0 

Router Dos

router eigrp 2000 
 network 172.16.1.0
! 
router igrp 2000 
 network 10.0.0.0

Router Tres

router igrp 2000 
 network 10.0.0.0

El Router Uno se configura de la siguiente manera:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 2000 
        External protocol is IGRP, external metric is 180671 
        Administrator tag is 0 (0x00000000)

La configuración luce increíblemente parecida al resultado anterior obtenido durante la redistribución entre dos sistemas autónomos diferentes que ejecutaban IGRP y EIGRP. La red directamente conectada 10.1.1.0/24 recibe el mismo tratamiento en los dos casos:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (2169856/1), Route is External 
      Vector metric: 
        Minimum bandwidth is 1544 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 2000 
        External protocol is IGRP, external metric is 0 
        Administrator tag is 0 (0x00000000)

Por lo tanto, esta red, que está conectada directamente al Router Uno, se redistribuye de IGRP a EIGRP con una métrica de 1 (la misma métrica que vemos durante la redistribución entre dos sistemas autónomos diferentes).

Hay dos advertencias con respecto a la redistribución EIGRP/IGRP dentro del mismo sistema autónomo:

  • Las rutas EIGRP internas siempre son preferidas en lugar de las rutas EIGRP o IGRP externas.

  • Las métricas de las rutas EIGRP externas se comparan con las métricas de IGRP ampliadas (se ignora la distancia administrativa).

Analicemos estas advertencias en la Figura 11:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp11.gif

El Router Uno publica 10.1.4.0/24 en el sistema autónomo 100 IGRP. El Router Cuatro publica 10.1.4.0/24 como externa en el sistema autónomo 100 EIGRP. El Router Dos ejecuta tanto EIGRP como IGRP en el sistema autónomo 100.

Si ignoramos la ruta EIGRP publicada por el Router Cuatro (apagando el link entre los Routers Dos y Cuatro, por ejemplo), el Router Dos muestra lo siguiente:

two# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "igrp 100", distance 100, metric 12001 
  Redistributing via igrp 100, eigrp 100 
  Advertised by igrp 100 (self originated) 
                eigrp 100 
  Last update from 10.1.1.2 on Serial1, 00:00:42 ago 
  Routing Descriptor Blocks: 
  * 10.1.1.2, from 10.1.1.2, 00:00:42 ago, via Serial1 
      Route metric is 12001, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 0

Tenga en cuenta que la distancia administrativa es 100. Cuando agregamos la ruta EIGRP, el Router Dos muestra lo siguiente:

two# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "eigrp 100", distance 170, metric 3072256, type external 
  Redistributing via igrp 100, eigrp 100 
  Last update from 10.1.2.2 on Serial0, 00:53:59 ago 
  Routing Descriptor Blocks: 
  * 10.1.2.2, from 10.1.2.2, 00:53:59 ago, via Serial0 
      Route metric is 3072256, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 1

Tenga en cuenta que las métricas para estas dos rutas son las mismas después de ser ampliadas de IGRP a EIGRP (consulte la sección Métricas):

  • 12001 x 256 = 3072256

En este caso, 12001, una métrica de IGRP, pertenece al Router Uno; y 3072256, una métrica de EIGRP, pertenece al Router Cuatro.

El Router Dos prefiere la ruta EIGRP externa con la misma métrica (luego de la ampliación) y una distancia administrativa mayor. Esto es verdadero cada vez que ocurre la distribución automática entre EIGRP e IGRP dentro del mismo sistema autónomo. El router siempre prefiere la trayectoria con la métrica de menor costo e ignora la distancia administrativa.

Redistribución Desde y Hacia Otros Protocolos

La redistribución entre EIGRP y otros protocolos (RIP y OSPF, por ejemplo) funciona de la misma manera que cualquier redistribución. Siempre es preferible usar la métrica predeterminada durante una redistribución entre protocolos. Al redistribuir entre EIGRP y otros protocolos, debe ser consciente de las dos siguientes cuestiones:

  • Las rutas distribuidas en EIGRP no siempre están resumidas. Consulte la sección Resumen para obtener una explicación.

  • Las rutas EIGRP externas tienen una distancia administrativa de 170.

Redistribución de Rutas Estáticas en las Interfaces

Cuando instala una ruta estática en una interfaz y configura una declaración de red por medio de un router eigrp, que incluye la ruta estática, EIGRP redistribuye esta ruta como si fuera una interfaz directamente conectada. Miremos la red en la Figura 12.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp12.gif

El Router Uno tiene una ruta estática para la red 172.16.1.0/24 configurada mediante la interfaz Serial 0:

ip route 172.16.1.0 255.255.255.0 Serial0

Además, el Router Uno también tiene una declaración de red para el destino de esta ruta estática:

router eigrp 2000 
 network 10.0.0.0 
 network 172.16.0.0 
 no auto-summary 

El Router Uno redistribuye esta ruta, aunque no redistribuya rutas estáticas, porque EIGRP la considera una red directamente conectada. En el Router Dos, esto se ve de la siguiente manera:

two# show ip route 
    .... 
        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
    C       10.1.1.0/24 is directly connected, Serial0
    D       10.1.2.0/24 [90/2169856] via 10.1.1.1, 00:00:47, Serial0
         172.16.0.0/24 is subnetted, 1 subnets 
    D       172.16.1.0 [90/2169856] via 10.1.1.1, 00:00:47, Serial0

Observe que la ruta a 172.16.1.0/24 aparece como ruta EIGRP interna en el Router Dos.

Resumen

Hay dos formas de resúmenes en EIGRP: resúmenes automáticos y resúmenes manuales.

Resumen automático

El EIGRP realiza una resumen automático cada vez que cruza una frontera entre dos redes principales diferentes. Por ejemplo, en la Figura 13, el Router Dos publica solo la red 10.0.0.0/8 al Router Uno debido a que la interfaz que usa el Router Dos para alcanzar el Router Uno se encuentra en una red principal diferente.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp13.gif

En el Router Uno, esto es similar a lo siguiente:

one# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 11023872 
  Routing Descriptor Blocks: 
  172.16.1.1 (Serial0), from 172.16.1.2, Send flag is 0x0 
      Composite metric is (11023872/10511872), Route is Internal 
      Vector metric: 
        Minimum bandwidth is 256 Kbit 
        Total delay is 40000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1

Esta ruta no está marcada como ruta de resumen de ninguna manera; se ve como una ruta interna. La métrica es la mejor métrica de las rutas resumidas. Tenga en cuenta que el ancho de banda mínimo en esta ruta es de 256k, aunque haya links en la red 10.0.0.0 con un ancho de banda de 56K.

En el router que realiza el resumen, se genera una ruta null0 para la dirección resumida:

two# show ip route 10.0.0.0 
Routing entry for 10.0.0.0/8, 4 known subnets 
  Attached (2 connections) 
  Variably subnetted with 2 masks 
  Redistributing via eigrp 2000 

C       10.1.3.0/24 is directly connected, Serial2 
D       10.1.2.0/24 [90/10537472] via 10.1.1.2, 00:23:24, Serial1 
D       10.0.0.0/8 is a summary, 00:23:20, Null0 
C       10.1.1.0/24 is directly connected, Serial1

La ruta a 10.0.0.0/8 se marca como un resumen a través de Null0. La entrada de la tabla de topología para esta ruta de resumen se ve de la siguiente manera:

two# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 10511872 
  Routing Descriptor Blocks: 
  0.0.0.0 (Null0), from 0.0.0.0, Send flag is 0x0 
          (note: the 0.0.0.0 here means this route is originated by this router) 
      Composite metric is (10511872/0), Route is Internal 
      Vector metric: 
        Minimum bandwidth is 256 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 0

Para que el Router Dos publique los componentes de la red 10.0.0.0 en lugar de un resumen, configure la función no auto-summary en el proceso EIGRP del Router Dos:

En el Router Dos

router eigrp 2000 
 network 172.16.0.0 
 network 10.0.0.0 
 no auto-summary

Si la función de resumen automático se desactiva, el Router Uno puede ver todos los componentes de la red 10.0.0.0:

one# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 10.1.3.0/24, 1 successors, FD is 46354176 
         via 20.1.1.1 (46354176/45842176), Serial0 
P 10.1.2.0/24, 1 successors, FD is 11049472 
         via 20.1.1.1 (11049472/10537472), Serial0 
P 10.1.1.0/24, 1 successors, FD is 11023872 
         via 20.1.1.1 (11023872/10511872), Serial0 
P 172.16.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0

Deben tenerse en cuenta algunas advertencias cuando se está trabajando con el resumen de rutas externas. Estas advertencias se discuten más adelante en la sección Resumen Automático de Rutas Externas.

Resumen Manual

El EIGRP le permite resumir las rutas internas y externas en casi cualquier límite de bit mediante la utilización del resumen manual. Por ejemplo, en la Figura 14, el Router Dos resume las rutas 192.1.1.0/24, 192.1.2.0/24 y 192.1.3.0/24 en el bloque CIDR 192.1.0.0/22.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp14.gif

Esta es la configuración en el Router Dos:

two# show run 
.... 
! 
interface Serial0 
 ip address 10.1.50.1 255.255.255.0 
 ip summary-address eigrp 2000 192.1.0.0 255.255.252.0 
 no ip mroute-cache 
! 
.... 

two# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status

P 10.1.10.0/24, 1 successors, FD is 45842176 
         via Connected, Loopback0 
P 10.1.50.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 192.1.1.0/24, 1 successors, FD is 10511872 
         via Connected, Serial1 
P 192.1.0.0/22, 1 successors, FD is 10511872 
         via Summary (10511872/0), Null0 
P 192.1.3.0/24, 1 successors, FD is 10639872 
         via 192.1.1.1 (10639872/128256), Serial1 
P 192.1.2.0/24, 1 successors, FD is 10537472 
         via 192.1.1.1 (10537472/281600), Serial1

Observe el comando ip summary-address eigrp bajo el serial0 de la interfaz, y la ruta de resumen vía el null0. En el Router Uno, esto se ve como una ruta interna:

  one# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 10.1.10.0/24, 1 successors, FD is 46354176 
         via 10.1.50.1 (46354176/45842176), Serial0 
P 10.1.50.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 192.1.0.0/22, 1 successors, FD is 11023872 
         via 10.1.50.1 (11023872/10511872), Serial0

Resumen Automático de Rutas Externas

EIGRP no realizará resúmenes automáticos de las rutas externas, a menos que haya un componente de la misma red principal que sea una red interna. Para obtener una ilustración, consulte la figura 15.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp15.gif

El Router Tres está ingresando rutas externas a 192.1.2.0/26 y a 192.1.2.64/26 en EIGRP usando el comando redistribute connected, tal como se muestra en las configuraciones de abajo.

Router Tres

interface Ethernet0 
 ip address 192.1.2.1 255.255.255.192 
! 
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Ethernet2
 ip address 10.1.2.1 255.255.255.0
!router eigrp 2000 
 redistribute connected 
 network 10.0.0.0 
 default-metric 10000 1 255 1 1500

Si el Router Tres tiene esta configuración, la tabla de ruteo en el Router Uno muestra lo siguiente:

  one# show ip route
.... 
     10.0.0.0/8 is subnetted, 2 subnets 
D       10.1.2.0 [90/11023872] via 10.1.50.2, 00:02:03, Serial0 
C       10.1.50.0 is directly connected, Serial0 
     192.1.2.0/26 is subnetted, 1 subnets 
D EX    192.1.2.0 [170/11049472] via 10.1.50.2, 00:00:53, Serial0 
D EX    192.1.2.64 [170/11049472] via 10.1.50.2, 00:00:53, Serial0

Aunque el resumen automático normalmente hace que el Router Tres resuma las rutas 192.1.2.0/26 y 192.1.2.64/26 en un destino de la red principal (192.1.2.0/24), no lo realiza porque ambas rutas son externas. Sin embargo, si vuelve a configurar el link entre los Routers 2 y 3 en 192.1.2.128/26 y agrega declaraciones de la red para esta red en los Routers 2 y 3, el resumen automático 192.1.2.0/24 luego se genera en el Router 2.

Router Tres

 interface Ethernet0 
 ip address 192.1.2.1 255.255.255.192 
! 
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Serial0 
 ip address 192.1.2.130 255.255.255.192 
! 
router eigrp 2000 
 network 192.1.2.0

Ahora, el Router Dos genera el resumen para 192.1.2.0/24:

two# show ip route 
.... 
D       192.1.2.0/24 is a summary, 00:06:48, Null0
....

Y el Router Uno muestra solo la ruta de resumen:

 one# show ip route 
.... 
     10.0.0.0/8 is subnetted, 1 subnets 
C       10.1.1.0 is directly connected, Serial0 
D    192.1.2.0/24 [90/11023872] via 10.1.50.2, 00:00:36, Serial0

Procesamiento y Rango de Consultas

Cuando un router procesa una consulta de un vecino, se aplican las siguientes reglas:

Origen de la consulta Estado de la ruta Acción
vecino (no el sucesor actual) pasivo Se responde con la información del sucesor actual
sucesor pasivo Se intenta encontrar el nuevo sucesor. Si la búsqueda resulta exitosa, se responde con la nueva información; si la búsqueda no resulta exitosa, el destino se marca como inalcanzable y se consulta a todos los vecinos, excepto al sucesor anterior.
cualquier vecino sin trayectoria a través de este vecino antes de la consulta Se responde con la mejor trayectoria conocida actualmente
cualquier vecino no conocido antes de la consulta Se responde que el destino es inalcanzable
vecino (no el sucesor actual) activo si no hay un sucesor actual de estos destinos (normalmente esto sería así), responda con un inalcanzable
Si existe un buen sucesor, se responde con la información de la trayectoria actual.
sucesor activo Se intenta encontrar el nuevo sucesor. Si la búsqueda resulta exitosa, se responde con la nueva información; si la búsqueda no resulta exitosa, el destino se marca como inalcanzable y se consulta a todos los vecinos, excepto al sucesor anterior.

Las acciones mencionadas en la tabla de arriba afectan el rango de la consulta en la red al determinar la cantidad de routers que reciben y responden la consulta antes de que la red haga convergencia en la nueva topología. Para ver cómo estas reglas afectan la manera en que se administran las consultas, observemos la red en la Figura 16, que funciona en condiciones normales.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16.gif

Podemos esperar que suceda lo siguiente respecto a la red 192.168.3.0/24 (lado derecho más alejado):

  • El Router Uno tiene dos trayectorias hacia 192.168.3.0/24:

    • una a través del Router Dos con una distancia de 46533485 y una distancia informada de 20307200;

    • mediante el Router 3 con una distancia de 20563200 y una distancia informada de 20307200

  • El Router Uno elige la trayectoria a través del Router Tres y mantiene la trayectoria a través del Router Dos como un posible sucesor.

  • Los Routers Dos y Tres muestran una trayectoria a 192.168.3.0/24 a través del Router Cuatro.

Suponga que 192.168.3.0/24 falla. ¿Qué actividad podemos esperar en esta red? Las figuras de la 16a hasta la 16h ilustran el proceso.

El Router Cinco marca 192.168.3.0/24 como inalcanzable y envía una consulta al Router Cuatro:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16a.gif

El Router Cuatro, al recibir una consulta de su sucesor, intenta encontrar un nuevo sucesor factible para esta red. No encuentra ninguno, así que marca 192.168.3.0/24 como inalcanzable y envía una consulta a los Routers Dos y Tres:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16b.gif

Los Routers Dos y Tres, a su vez, ven que han perdido la única ruta factible a 192.168.3.0/24 y la marcan como inalcanzable; ambos envían consultas al Router Uno:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16c.gif

Para simplificar, supongamos que el Router Uno recibe la consulta del Router Tres primero y marca la ruta como inalcanzable. El Router Uno luego recibe la consulta del Router Dos. Si bien es posible otro orden, todos tendrán el mismo resultado final.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16d.gif

El Router Uno responde ambas consultas indicando que el destino es inalcanzable; El router Uno se encuentra pasivo en este momento para 192.168.3.0/24:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16e.gif

Los Routers Dos y Tres responden la consulta del Router Cuatro; Los Routers Dos y Tres ahora se encuentran en estado pasivo para 192.168.3.0/24:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16f.gif

El Router Cinco, tras recibir la respuesta del Router Cuatro, quita la red 192.168.3.0/24 de su tabla de ruteo; el Router Cinco ahora se encuentra en estado pasivo para la red 192.168.3.0/24. El Router Cinco envía actualizaciones al Router Cuatro para que la ruta se quite de las tablas de topología y de ruteo de los routers restantes.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16g.gif

Es importante entender que aunque pueda haber otros órdenes de procesamiento u otras trayectorias de consultas, todos los routers en la red procesan una consulta para la red 192.168.3.0/24 cuando el link deja de funcionar. Algunos routers pueden terminar procesando más de una consulta (el Router Uno en este ejemplo). De hecho, si las consultas alcanzaran los routers en un orden distinto, algunos terminarían procesando tres o cuatro consultas. Este es un buen ejemplo de una solicitud sin límites en una red EIGRP.

Cómo Afectan los Puntos de Resumen al Rango de la Consulta

Ahora miremos las trayectorias a 10.1.1.0/24 en la misma red:

  • El Router Dos tiene una entrada en la tabla de topología para la red 10.1.1.0/24 con un costo de 46251885 a través del Router Uno.

  • El Router Tres tiene una entrada en la tabla de topología para la red 10.1.1.0/24 con un costo de 20281600 a través del Router Uno.

  • El Router Cuatro posee una entrada en la tabla de topología para la red 10.0.0.0/8 (porque los Routers Dos y Tres realizan resúmenes automáticos en el límite de red principal) a través del Router Tres con una métrica de 20307200 (la distancia informada a través del Router Dos es mayor que la métrica total a través del Router Tres; por lo tanto, la trayectoria a través del Router Dos no es un sucesor factible).

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17.gif

Si 10.1.1.0/24 deja de funcionar, el Router Uno la marca como inalcanzable y luego realiza una consulta a cada uno de sus vecinos (Routers Dos y Tres) en busca de una nueva trayectoria a esa red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17a.gif

El Router Dos, al recibir la consulta del Router Uno, marca la ruta como inalcanzable (porque la consulta es de su sucesor) y luego realiza una consulta a los Routers Tres y Cuatro:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17b.gif

Cuando el Router Tres recibe la consulta del Router Uno, marca el destino como inalcanzable y consulta a los Routers Dos y Cuatro:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17c.gif

Cuando el Router Cuatro recibe las consultas de los Routers Dos y Tres, responde que 10.1.1.0/24 es inalcanzable (tenga en cuenta que el Router Cuatro no tiene conocimiento de la subred en cuestión, ya que solo tiene la ruta 10.0.0.0/8):

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17d.gif

Los Routers Dos y Tres se responden mutuamente que 10.1.1.0/24 es inalcanzable:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17e.gif

Dado que los Routers Dos y Tres ya no tienen consultas pendientes, ambos responden al Router Uno que 10.1.1.0/24 es inalcanzable:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17f.gif

La consulta, en este caso, está delimitada por el resumen automático en los Routers Dos y Tres. El Router cinco no participa en el proceso de consulta, ni tampoco está involucrado en la reconvergencia de la red. Las consultas también pueden estar delimitadas por resumen manual, límites del sistema autónomo y listas de distribución.

Cómo Afectan los Límites del Sistema Autónomo el Rango de la Consulta

Si un router redistribuye rutas entre dos sistemas autónomos EIGRP, responde a la consulta según las reglas normales de procesamiento e inicia una nueva consulta en el otro sistema autónomo. Por ejemplo, si el link a la red conectada al Router Tres deja de funcionar, el Router Tres marca la ruta como inalcanzable y consulta al Router Dos para obtener una nueva trayectoria:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18.gif

El Router Dos responde que esta red es inalcanzable y envía una consulta por el sistema autónomo 200 hacia el Router Uno. Una vez que el Router Tres obtiene la respuesta a su consulta original, elimina la ruta de su tabla. El Router Tres se encuentra ahora en estado pasivo para esta red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18a.gif

El Router Uno responde al Router Dos, y la ruta entra en estado pasivo:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18b.gif

Si bien la consulta original no se distribuyó a través de la red (estaba limitada por el margen del sistema autónomo), la consulta original se filtra al segundo sistema autónomo como una consulta nueva. Esta técnica podría ayudar a evitar los problemas relacionados con el estado "stuck in active" (SIA) en una red al limitar la cantidad de routers por los que debe pasar una consulta antes de ser respondida, aunque no resuelve el problema general de que cada router debe procesar la consulta. De hecho, este método de delimitar una consulta puede agravar el problema al impedir el resumen automático de rutas que, de otra manera, se resumirían (las rutas externas no se resumen, a menos que haya un componente externo en la red principal).

Cómo Afectan las Listas de Distribución el Rango de la Consulta

En lugar de bloquear la propagación de una consulta, las listas de distribución en EIGRP marcan toda respuesta de una consulta como inalcanzable. Utilicemos la Figura 19 como ejemplo.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19.gif

En la figura anterior:

  • El Router Tres tiene una lista de distribución aplicada en sus interfaces seriales que solo le permite publicar la Red B.

  • Los Routers Uno y Dos no saben que la Red A se puede alcanzar a través del Router Tres (el Router Tres no se utiliza como punto intermedio entre los Routers Uno y Dos).

  • El Router Tres utiliza el Router Uno como su trayectoria preferida a la Red A y no utiliza el Router Dos como sucesor factible.

Cuando el Router Uno pierde su conexión a la Red A, marca la ruta como inalcanzable y envía una consulta al Router Tres. El Router Tres no publica ninguna trayectoria a la Red A debido a la lista de distribución aplicada en sus puertos seriales.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19a.gif

El Router Tres marca la ruta como inalcanzable y luego envía una consulta al Router Dos:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19b.gif

El Router Dos examina su tabla de topología y encuentra que tiene una conexión válida a la Red A. Observe que la lista de distribución no afectó la consulta en el Router tres:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19c.gif

El Router Dos responde que la Red A se puede alcanzar; Ahora el Router Tres tiene una ruta válida:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19d.gif

El Router Tres construye la respuesta a la consulta del Router Uno, pero la lista de distribución hace que el Router Tres envíe una respuesta de que la Red A es inalcanzable, aunque el Router Tres tenga una ruta válida a la Red A:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19e.gif

Regulación de la Velocidad de la Transmisión de Paquetes

Algunos protocolos de ruteo consumen todo el ancho de banda disponible en un link de ancho de banda bajo cuando convergen (adaptándose al cambio en la red). EIGRP evita esta congestión mediante la regulación de la velocidad de transmisión de los paquetes en una red; de esta manera, se utiliza solo una parte del ancho de banda disponible. De manera predeterminada, EIGRP utiliza hasta el 50 por ciento del ancho de banda disponible, pero esta configuración puede modificarse con el siguiente comando:

router(config-if)# 
ip bandwidth-percent eigrp 2 ? 
  <1-999999>  Maximum bandwidth percentage that EIGRP may use

Básicamente, cada vez que el EIGRP pone un paquete en cola para su transmisión en una interfaz, utiliza la siguiente fórmula a fin de determinar cuánto tiempo debe esperar para enviar el paquete:

  • (8 * 100 * tamaño del paquete en bytes) / (ancho de banda en kbps * porcentaje de ancho de banda)

Por ejemplo, si EIGRP pone un paquete en cola para su envío por una interfaz serial con un ancho de banda de 56K y el paquete es de 512 bytes, EIGRP espera:

  • (8 * 100 * 512 bytes) / (56000 bits por segundo * 50 % del ancho de banda) (8 * 100 * 512) / (56000 * 50) 409600 / 2800000 0,1463 segundos

Esto permite que un paquete (o grupos de paquetes) de 512 bytes como mínimo sea transmitido en este link antes de que EIGRP envíe su paquete. El temporizador de regulación de la velocidad determina cuándo se envía el paquete y normalmente se expresa en milisegundos. El tiempo de regulación de la velocidad para el paquete en el ejemplo anterior es de 0,1463 segundos. Hay un campo en la interfaz show ip eigrp que muestra el temporizador regulador de tráfico, tal como se observa a continuación:

router# show ip eigrp interface
IP-EIGRP interfaces for process 2	

                    Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0            1        0/0        28       0/15         127           0
Se1            1        0/0        44       0/15         211           0
router#

El tiempo que se muestra es el intervalo de regulación para la unidad de transmisión máxima (MTU), el paquete más grande que puede enviarse a través de la interfaz.

Ruteo Predeterminado

Hay dos maneras de ingresar una ruta predeterminada en EIGRP: redistribuir una ruta estática o enviar resúmenes a 0.0.0.0/0. Cuando desee arrastrar todo el tráfico hacia destinos desconocidos en una ruta predeterminada en el núcleo de la red, utilice el primer método Este método es eficaz para publicar conexiones a Internet. Por ejemplo:

ip route 0.0.0.0 0.0.0.0 x.x.x.x (next hop to the internet) 
! 
router eigrp 100 
 redistribute static 
 default-metric 10000 1 255 1 1500

La ruta estática que se redistribuye en EIGRP no debe ser para la red 0.0.0.0. Si utiliza otra red, debe ejecutar el comando ip default-network para marcar la red como red predeterminada. Consulte Configuración de un Gateway de Último Recurso para obtener más información.

El resumen a una ruta predeterminada es eficaz solo cuando se desea introducir una ruta predeterminada en sitios remotos. Puesto que los resúmenes se configuran por interfaz, usted no debe preocuparse por usar listas de distribución u otros mecanismos para evitar que la ruta predeterminada se propague hacia el núcleo de su red. Observe que un resumen a 0.0.0.0/0 invalida la ruta predeterminada que se aprendió de cualquier otro protocolo de ruteo. La única manera de configurar una ruta predeterminada en un router con este método es configurando una ruta estática a 0.0.0.0/0. (Principio en Cisco IOS Software 12.0(4)T, usted puede también configurar una distancia administrativa en el extremo del comando ip summary-address eigrp, así que el resumen local no reemplaza las 0.0.0.0/0 rutas).

router eigrp 100 
 network 10.0.0.0 
! 
interface serial 0 
 encapsulation frame-relay 
 no ip address 
! 
interface serial 0.1 point-to-point 
 ip address 10.1.1.1 
 frame-relay interface-dlci 10 
 ip summary-address eigrp 100 0.0.0.0 0.0.0.0

Balance de carga

EIGRP coloca hasta cuatro rutas de igual costo en la tabla de ruteo, y luego el router aplica balanceo de carga. El tipo de balanceo de carga (por paquete o por destino) depende del tipo de switching que se esté llevando a cabo en el router. EIGRP, sin embargo, también puede aplicar balanceo de carga en links de costos desiguales.

Nota: Puede utilizar el comando max-paths para configurar EIGRP para que use hasta seis rutas del mismo costo.

Supongamos que hay cuatro trayectorias a un destino determinado y que las métricas para estas trayectorias son las siguientes:

  • trayectoria 1: 1100

  • trayectoria 2: 1100

  • trayectoria 3: 2000

  • trayectoria 4: 4000

De manera predeterminada, el router coloca el tráfico en las trayectorias 1 y 2. Con EIGRP, usted puede utilizar el comando variance para indicar al router que también coloque el tráfico en las trayectorias 3 y 4. La varianza es un multiplicador: el tráfico se colocará en cualquier link que posea una métrica menor a la mejor trayectoria multiplicada por la varianza. Para aplicar balanceo de carga en las trayectorias 1, 2 y 3, se debe utilizar la varianza 2 porque 1100 x 2 = 2200, que es mayor que la métrica por la trayectoria 3. De manera similar, para agregar también el trayecto 4, ejecute la varianza 4 bajo el comando router eigrp. ConsulteCómo Funciona el Balanceo de Carga de Trayectorias de Costos Desiguales (Varianza) en IGRP y en EIGRP para más información.

¿Cómo el router divide el tráfico entre estas trayectorias? Divide la métrica a través de cada trayectoria en la métrica más grande, redondea al número entero más cercano y utiliza este número como la cuenta del tráfico compartido.

router# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "igrp 100", distance 100, metric 12001 
  Redistributing via igrp 100, eigrp 100 
  Advertised by igrp 100 (self originated) 
                eigrp 100 
  Last update from 10.1.2.2 on Serial1, 00:00:42 ago 
  Routing Descriptor Blocks: 
  * 10.1.2.2, from 10.1.2.2, 00:00:42 ago, via Serial1 
      Route metric is 12001, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 0

En este ejemplo, las cuentas de tráfico compartido son las siguientes:

  • para las trayectorias 1 y 2: 4000/1100 = 3

  • para la trayectoria 3: 4000/2000 = 2

  • para la trayectoria 4: 4000/4000 = 1

El router envía los primeros tres paquetes por la trayectoria 1, los tres paquetes siguientes por la trayectoria 2, los dos paquetes siguientes por la trayectoria 3 y el paquete siguiente por la trayectoria 4. Luego, el router vuelve a empezar y envía los tres paquetes siguientes por la trayectoria 1, y así sucesivamente.

Nota: Aún con la varianza configurada, EIGRP no enviará tráfico por la trayectoria de costo desigual si la distancia informada es superior a la distancia factible para esa ruta determinada. Para obtener más información, consulte la sección Distancia Factible, Distancia Informada y Sucesores Factibles.

Uso de las Métricas

Al configurar EIGRP inicialmente, recuerde estas dos reglas básicas si intenta influir en las métricas de EIGRP:

  • El ancho de banda siempre se debe configurar en el ancho de banda real de la interfaz; los links seriales multipunto y otras situaciones de velocidad desigual de los medios son las excepciones a esta regla.

  • La demora debería utilizarse siempre para influenciar las decisiones de ruteo de EIGRP.

Dado que EIGRP utiliza el ancho de banda de la interfaz para determinar la velocidad a la cual enviar los paquetes, es importante que la configuración sea correcta. Si es necesario influenciar la trayectoria que EIGRP elige, siempre utilice demora para hacerlo.

Cuando los anchos de banda son menores, el ancho de banda tiene más influencia sobre el total de la métrica; cuando los anchos de banda son mayores, la demora tiene más influencia sobre el total de la métrica.

Uso de Etiquetas Administrativas en Redistribución

Las etiquetas administrativas externas son útiles para dividir los loops de ruteo de redistribución entre EIGRP y otros protocolos. Puede bloquear la redistribución del EIGRP al protocolo externo etiquetando la ruta cuando se la distribuye al EIGRP. No es posible modificar la distancia administrativa para un gateway predeterminado que se aprendió de una ruta externa porque, en EIGRP, la modificación de la distancia administrativa solo de aplica a rutas internas. Para aumentar la métrica, se debe utilizar route-map con prefix-list; no se debe cambiar la distancia administrativa. A continuación se proporciona un ejemplo básico de cómo configurar estas etiquetas, pero no se incluye la configuración completa usada para dividir loops de redistribución.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp20.gif

El router Tres, que está redistribuyendo rutas conectadas en EIGRP, muestra lo siguiente:

three# show run 

.... 

interface Loopback0 
 ip address 172.19.1.1 255.255.255.0 
! 
interface Ethernet0 
 ip address 172.16.1.1 255.255.255.0 
 loopback 
 no keepalive 
! 
interface Serial0 
 ip address 172.17.1.1 255.255.255.0 

.... 

router eigrp 444 
 redistribute connected route-map foo  
 network 172.17.0.0 
 default-metric 10000 1 255 1 1500 

.... 

access-list 10 permit 172.19.0.0 0.0.255.255 
route-map foo permit 10 
 match ip address 10 
 set tag 1 

.... 

three# show ip eigrp topo 
IP-EIGRP Topology Table for process 444 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 172.17.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
         via Redistributed (2169856/0) 
P 172.16.1.0/24, 1 successors, FD is 281600 
         via Redistributed (281600/0) 
P 172.19.1.0/24, 1 successors, FD is 128256, tag is 1 
         via Redistributed (128256/0)

El Router Dos, que distribuye las rutas de EIGRP a RIP, muestra lo siguiente:

two# show run 

.... 

interface Serial0 
 ip address 172.17.1.2 255.255.255.0 
! 
interface Serial1 
 ip address 172.18.1.3 255.255.255.0 

.... 

router eigrp 444 
 network 172.17.0.0 
! 
router rip 
 redistribute eigrp 444 route-map foo 
 network 10.0.0.0 
 network 172.18.0.0 
 default-metric 1 
! 
no ip classless 
ip route 1.1.1.1 255.255.255.255 Serial0 
route-map foo deny 10 
 match tag 1 
! 
route-map foo permit 20 

.... 

two# show ip eigrp topo 
IP-EIGRP Topology Table for process 444 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 172.17.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 172.16.1.0/24, 1 successors, FD is 2195456 
         via 172.17.1.1 (2195456/281600), Serial0 
P 172.19.1.0/24, 1 successors, FD is 2297856, tag is 1 
         via 172.17.1.1 (2297856/128256), Serial0

Observe la etiqueta 1 en 172.19.1.0/24.

El Router Uno, que recibe las rutas RIP redistribuidas por el Router Dos, indica lo siguiente:

one# show run

.... 

interface Serial0 
 ip address 172.18.1.2 255.255.255.0 
 no fair-queue 
 clockrate 1000000 

router rip 
 network 172.18.0.0 

.... 

one# show ip route 

Gateway of last resort is not set 

R    172.16.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0 
R    172.17.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0 
     172.18.0.0/24 is subnetted, 1 subnets 
C       172.18.1.0 is directly connected, Serial0

Observe que falta 172.19.1.0/24.

Información sobre el Resultado del Comando EIGRP

show ip eigrp traffic

Este comando se utiliza para visualizar información sobre las configuraciones con nombre de EIGRP y las configuraciones del sistema autónomo de EIGRP. El resultado de este comando muestra la información que se ha intercambiado con el router EIGRP vecino. Abajo de la tabla, se incluye una explicación de cada campo de resultado.

show ip eigrp traffic

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp20a.gif

Explicaciones de la configuración

  • Hellos sent/received muestra la cantidad de paquetes hello enviados y recibidos (sent -1927/received - 1930).

  • Updates sent/received muestra la cantidad de paquetes de actualización enviados y recibidos (sent-20/received-39).

  • Queries sent/received representa la cantidad de paquetes de consulta enviados y recibidos (sent-10/received-18).

  • Replies sent/received muestra la cantidad de paquetes de respuesta enviados y recibidos (enviados: 18/recibidos: 16).

  • Acks sent/received representa la cantidad de paquetes de conocimiento enviados y recibidos (sent-66/received-41).

  • SIA-Queries sent/received representa la cantidad de paquetes de consulta en estado "stuck in active" enviados y recibidos (sent-0/received-0).

  • SIA-Replies sent/received muestra la cantidad de paquetes de respuesta en estado "stuck in active" enviados y recibidos (sent-0/received-0).

  • Hello Process ID es el identificador del proceso hello(270).

  • PDM Process ID significa identificador de proceso de IOS de módulos dependientes de protocolos(251).

  • Socket Queue muestra los contadores de colas de socket de IP a Proceso Hello de EIGRP (current-0/max-2000/highest-1/drops-0).

  • Input Queue muestra los contadores de colas de socket de Proceso Hello de EIGRP a PDM de EIGRP (current-0/max-2000/highest-1/drops-0).

show ip eigrp topology

Este comando solo muestra sucesores factibles. Use el comando show ip eigrp topology all-links para visualizar todas las entradas en la tabla de topología. Abajo de la tabla, se incluye una explicación de cada campo de resultado.

show ip eigrp topology

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp22.gif

Explicaciones de la configuración

  • A significa activo. También se podría mostrar una P, que significa pasivo.

  • 10.2.4.0/24 es el destino o máscara.

  • 0 successors muestra cuántos sucesores (o trayectorias) están disponible para este destino; si successors aparece en mayúscula, la ruta se encuentra en transición.

  • FD is 512640000 muestra la distancia factible, que es la mejor métrica para alcanzar este destino o la mejor métrica conocida en el momento en que se activó la ruta.

  • tag is 0x0 se puede configurar y filtrar mediante el uso de mapas de ruteo y de los comandos set tag y match tag.

  • Q significa que hay una consulta pendiente. Este campo puede también estar indicado de la siguiente manera: U significa que hay una actualización pendiente; y R significa que hay una respuesta pendiente.

  • 1 replies muestra la cantidad de respuestas pendientes.

  • active 00:00:01 muestra el tiempo que esta ruta ha estado activa.

  • query origin: Local origin indica que esta ruta originó la consulta. Este campo puede también estar indicado de la siguiente manera: Multiple origins indica que múltiples vecinos han enviado consultas en este destino, pero no el sucesor. Successor origin significa que el sucesor originó la consulta.

  • via 10.1.2.2 muestra que aprendimos acerca de esta ruta a partir de un vecino cuya dirección IP es 10.1.2.2. Este campo puede también estar indicado de la siguiente manera: Connected si la red está conectada directamente con este router. Redistributed si esta ruta se está redistribuyendo en el EIGRP en este router. o Resumen, si se trata de una ruta de resumen generada en este router.

  • ((Infinity/Infinity) muestra la métrica para alcanzar esta trayectoria a través de este vecino en el primer campo y la distancia informada a través de este vecino en el segundo campo.

  • r muestra que hemos consultado a este vecino y esperamos una respuesta.

  • Q es el indicador de envío para esta ruta, lo que significa que hay un pedido pendiente. Este campo puede también estar indicado de la siguiente manera: U, que significa que hay una actualización pendiente; o R, que significa que hay una respuesta pendiente.

  • Serial1es la interfaz a través de la cual se puede alcanzar a este vecino.

  • Via 10.1.1.2muestra el vecino del cual esperamos una respuesta.

  • rmuestra que hemos hecho una consulta a este vecino acerca de la ruta y que aún no hemos recibido una respuesta.

  • Serial0 es la interfaz a través de la cual se puede alcanzar a este vecino.

  • Via 10.1.2.2 (512640000/128256), Serial1 muestra que estamos utilizando esta ruta (indica qué trayectoria tomará el próximo destino/trayectoria cuando existen múltiples rutas de igual costo).

show ip eigrp topology <network>

Este comando muestra todas las entradas en la tabla de topología para este destino, no solo a los sucesores factibles. Abajo de la tabla, se incluye una explicación de cada campo de resultado.

show ip eigrp topology network

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp23.gif

Explicaciones de la configuración

  • State is Passivesignifica que la red está en estado pasivo, es decir, que no estamos buscando una trayectoria a esta red. La mayoría de las veces, las rutas están en estado pasivo en las redes estables.

  • Query origin flag is 1 Si la ruta está activa, este campo proporciona información sobre quién inició la consulta.

    • 0: Esta ruta está activa pero no se originó ninguna consulta para ella (estamos buscando un sucesor factible localmente).

    • 1: Este router originó la consulta para esta ruta (o la ruta es pasiva).

    • 2: Múltiples cómputos difusos para esta consulta. Este router ha recibido más de una consulta para esta ruta de más de una fuente.

    • 3: El router del cual aprendimos la trayectoria a esta red está consultando por otra ruta.

    • 4: Múltiples orígenes de consulta para esta ruta, incluido el router a través del que aprendimos esta ruta. Similar a 2, pero además implica que hay una cadena de origen de consultas que describe las consultas pendientes para la trayectoria.

  • 2 Successor significa que hay dos trayectorias factibles a esta red.

  • FD is 307200 muestra la mejor métrica actual para esta red. Si la ruta está activa, esto indica la métrica de la trayectoria que se estaba usando anteriormente para rutear paquetes a esta red.

  • Routing Descriptor Blocks cada una de las siguientes entradas siguientes describe una trayectoria a la red.

    • 10.1.1.2 (Ethernet) es el próximo salto a la red y a la interfaz a través de la cual se alcanza el próximo salto.

    • from 10.1.2.2 es la fuente de la información de esta trayectoria.

    • El indicador de envío es:

      • 0x0: Si hay paquetes que deben ser enviados en relación con esta entrada, esto indica el tipo de paquete.

      • 0x1: Este router ha recibido una consulta para esta red y necesita enviar una respuesta de unidifusión.

      • 0x2: Esta ruta está activa y debe enviarse una consulta de multidifusión.

      • 0x3: Esta ruta ha cambiado y debe enviarse una actualización de multidifusión.

  • Composite metric is (307200/281600) muestra los costos totales calculados para la red. El primer número que está entre paréntesis es el costo total a la red a través de esta trayectoria, incluido el costo al salto siguiente. El segundo número que está entre paréntesis es la distancia informada o, en otras palabras, el costo utilizado por el router de salto siguiente.

  • Route is Internal significa que esta ruta se originó dentro de este sistema autónomo (AS) EIGRP. Si la ruta fue redistribuida en este AS EIGRP, este campo indicará que la ruta es externa.

  • Vector metric muestra las métricas individuales usadas por el EIGRP para calcular el costo a una red. El EIGRP no propaga la información sobre el costo total por la red; se propagan la métricas del vector y cada router computa individualmente el costo y la distancia informada.

    • Minimum bandwidth is 10000 Kbit muestra el ancho de banda más bajo en la trayectoria hacia esta red.

    • Total delay is 2000 microseconds muestra la suma de las demoras en la trayectoria a esta red.

    • Reliability is 0/255 muestra el factor de confiabilidad. Este número se calcula dinámicamente, pero no se utiliza de manera predeterminada en los cálculos de métricas.

    • Load is 1/255 indica la cantidad de carga que el link transporta. Este número se calcula dinámicamente y no se utiliza de forma predeterminada cuando EIGRP calcula el costo generado al utilizar esta trayectoria.

    • Minimum MTU is 1500 Este campo no se usa en los cálculos de métricas.

    • Hop count is 2esto no se utiliza en los cálculos de métricas, pero limita el tamaño máximo de un AS EIGRP. De manera predeterminada, el número máximo de saltos que EIGRP aceptará es 100, aunque el máximo puede estar configurado en 220 con saltos máximos métricos.

Si la ruta es externa, se incluye la siguiente información. Abajo de la tabla, se incluye una explicación de cada campo de resultado.

Ruta externa

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp24.gif

Explicaciones de la configuración

  • Originating Router muestra que este es el router que ingresó la ruta en AS EIGRP.

  • External AS muestra el Sistema Autónomo del que provino esta ruta (si la hubiera).

  • External Protocol muestra el protocolo de donde provino esta ruta (si existe alguna).

  • external metric muestra la métrica interna en el protocolo externo.

  • Administrator Tag puede configurarse o filtrarse utilizando mapas de ruta con los comandos set tag y match tag.

show ip eigrp topology [active | pendiente | cero-sucesores]

El mismo formato de salida que la topología EIGRP del IP de la demostración, pero él también muestra una cierta porción de la tabla de topología.

show ip eigrp topology all-links

El mismo formato de salida que la topología EIGRP del IP de la demostración, pero ella también muestra todos los links en la tabla de topología, bastante que apenas los sucesores factibles.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 16406