Marcado y acceso remotos : "Red digital de servicios integrados (ISDN), Señalización por canal asociado (CAS)"

Autenticación ISDN y devolución de llamada con ID de abonado

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

La autenticación basada en el Identificador de llamada proporciona la mayor Seguridad por los clientes remotos de autenticidad basados no sólo en la identificación del usuario y la contraseña, pero también en la ubicación de marca.

prerrequisitos

Requisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

Este documento primero explica los diversos significados para el comando dialer caller (independientemente de su uso para el servicio repetido) cuando está utilizado en una interfaz del perfil del discador bastante que una interfaz del grupo rotativo de dialers.

En este último caso, es un comando de la investigación análogo al llamador isdn en una interfaz de ISDN. En el caso anterior, es un comando que proporciona un mecanismo para atar las llamadas entrantes al perfil del discador correcto basado en el número de la parte llamadora que se presenta en el mensaje setup entrante del q.931. El error hacer juego el número presentado de la persona que llama con un número de parte llamadora del dialer en un perfil del discador no hace necesariamente la llamada ser rechazado como unbindable si la interfaz física se configura para la autenticación PPP. Usted puede también hacer juego el actual nombre del host con el valor configurado del nombre remoto del marcador para atar sobre esta base. Esto es porque el atar en base del número presentado de la persona que llama no es el único criterio posible para un lazo acertado. Refiera a configurar y localización de averías de los Perfiles de marcado para más información sobre atar y los Perfiles de marcado.

Del Software Release 12.0(7)T y Posterior de Cisco IOS�, quite la autenticación PPP de la interfaz física para poder defender las llamadas basadas solamente en el número de la parte llamadora. En estos casos, las llamadas para las cuales el router no pueden encontrar un valor del llamador del marcador que corresponde con se rechazan como unbindable. Usted puede utilizar el PAP o la GRIETA para configurar la autenticación PPP en la interfaz del dialer si usted quiere autenticar correctamente estas llamadas.

La llamada inicial se rechaza (no contestado) con la opción de devolución de llamada agregada a la autenticación de ID de la parte llamadora. Sin embargo, el servicio repetido se inicia al número que llama para hacer la conexión. Usted puede utilizar el servicio repetido para:

  • Consolidación y centralización de la facturación telefónica

  • Ahorro de costos en las llamadas de larga distancia

  • Control de acceso

Esta configuración de muestra ilustra el uso del comando dialer caller number[callback] de configurar la investigación del Identificador de llamada y de habilitar opcionalmente el ISDN Caller ID Callback para el perfil del discador DDR. Usted puede también utilizar este comando para el DDR heredado. Este comando configura el Cisco IOS Software para validar o para rechazar la llamada ISDN basada en el número PSTN de la parte llamadora. Por ejemplo, el comando dialer caller 1234 permite que el router valide la llamada ISDN con el número que llama 1234.

Nota: Esta configuración requiere que la información de Id. de la parte llamadora del paso de la compañía telefónica al router o al Access Server. No se valida si usted habilita la investigación del Identificador de llamada pero no tienen ningunas llamadas información de Id. de la parte llamadora que es pasada al router.

Refiera a configurar el ISDN Caller ID Callback para más información sobre los requisitos previos y otras características opcionales disponibles con la autenticación de ID y el servicio repetido del abonado ISDN que llama.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Nota: Estas configuraciones se truncan para visualizar solamente la información pertinente.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/15925/ISDN_3Rt.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

En este escenario, el Routers 2 y 3 ambos inicia las llamadas de DDR al router 1. que el router1 autentica a ambo Routers 2 y 3 basados solamente en el router1 identificación de llamador se configura al router de devolución de llamadas 2, pero no al router de devolución de llamadas 3.

Consejo: Elija las secciones apropiadas de la configuración para configurar la investigación del Identificador de llamada o la característica de la devolución de llamada de Id. de la parte llamadora, pero no ambas. Por ejemplo, el diagrama muestra que el servicio repetido necesita la configuración del router 2 y el router1. Sin embargo, elija solamente la configuración de la interfaz del dialer asociada al router2 (se marca claramente en el marcador de la interfaz 1) puesto que el router1 realiza ambas tareas.

Router 1
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
isdn switch-type basic-net3
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface BRI0
no ip address
dialer pool-member 1

!--- BRI 0 is a member of dialer pool 1 which is defined 
!--- under interface Dialer 1.

isdn switch-type basic-net3
!
interface Dialer1

!---  DDR dialer interface to call Router 2.

description for Router2
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1

!--- Interface BRI 0 is a member of dialer pool 1.

dialer enable-timeout 2

!--- The time (in seconds) to wait before initiating callback.

dialer string 6121  

!--- This number is used to call back Router 2.

dialer caller 6121 callback

!--- Permits calls from 6121 and initiates callback 
!--- to the same number.
 
dialer-group 1

!--- Use dialer-list 1 to define interesting traffic.

!
interface Dialer2

!--- This interface is used to authenticate calls from Router 3.
!--- (Callback is NOT initiated to Router 3.)

description for Router3
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1

!--- Interface BRI 0 is a member of dialer pool 1.

dialer caller 6101

!--- Permit calls from number 6101.

dialer-group 1

!--- Use dialer-list 1 to define interesting traffic.

!
dialer-list 1 protocol ip permit

!--- Define IP as interesting traffic.

Router 2
version 12.1
service timestamps debug datetime msec
service timestamps log datetime ms
!
hostname Router2
!
isdn switch-type basic-net3
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer1
ip address 10.0.0.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 6122

!--- The number to dial for Router 1 
!--- (which initiates a callback).

dialer caller 6122

!--- Accept calls from 6122 (Router 1).

dialer-group 1
no cdp enable
!
dialer-list 1 protocol ip permit

Router 3
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router3
!
isdn switch-type basic-net3
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer1
ip address 10.0.0.3 255.255.255.0
dialer pool 1
encapsulation ppp
dialer string 6122

!--- The number to dial for Router 1.

dialer-group 1
no cdp enable
!
dialer-list 1 protocol ip permit

Nota: El router de cliente marca el servidor de devolución de llamada en la mayoría de los escenarios de devolución de llamada. El dos Routers entonces negocia los parámetros de devolución de llamada. El servidor desconecta la llamada e inicia el servicio repetido. La parte que llama pudo poner pocas llamadas salientes consecutivas al servidor mientras que esperaba el servidor a la devolución de llamada durante el intervalo entre la desconexión de llamada inicial y el servicio repetido. Éste es comportamiento normal de DDR porque el cliente detecta que la llamada inicial falló y no sabe que un servicio repetido está en curso.

Publique el comando dialer redial en la parte que llama para evitar que el cliente marque constantemente el servidor de devolución de llamada. Esto suprime las llamadas salientes adicionales al servidor mientras que espera el servicio repetido. Se eliminan las llamadas hasta que expire el temporizador predefinido. Por ejemplo, el cliente espera 15 segundos antes de iniciar un volver a marcar si el tiempo del intervalo de remarcación del dialer es 15 segundos. Se completa el servicio repetido y el cliente no tiene que marcar otra vez dentro de ese tiempo.

Refiera a configurar los temporizadores de remarcado después de que los intentos fallides de discado de devolución para más información sobre implementar el marcador vuelvan a marcar.

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Comandos show

Los ciertos comandos show son soportados por el OIT, que permite que usted vea una análisis de la salida del comando show.

  • muestre el active isdn — Visualiza la información sobre las llamadas actuales y proporciona la información sobre ambo llamadas ISDN entrantes y salientes actuales.

  • show users - Muestra información acerca de las líneas activas en el router. Usted puede también utilizar el comando show caller si su versión del Cisco IOS la soporta.

  • show dialer—Muestra información general de diagnóstico para interfaces configuradas para DDR.

Ejemplo de resultado del comando show

Router1#show isdn active

---------------------------------------------------------------------------
ISDN ACTIVE CALLS
---------------------------------------------------------------------------
Call  Calling   Called    Remote  Seconds Seconds Seconds Charges
Type  Number    Number    Name    Used    Left    Idle    Units/Currency
---------------------------------------------------------------------------
Out              6121     6121       24      96      23      0
In       6101             6101        7     113       6
---------------------------------------------------------------------------

Note que se está produciendo una llamada entrante y una saliente. La llamada saliente es numerar 6121, que corresponde al router2. La llamada entrante es a partir del 6101, que corresponde al router3. También observe que un número identifica los routeres remotos en el campo de nombre remoto bastante que un nombre puesto que la autenticación PPP no se configura.

Router1#show user

Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
BR0:1                   Sync PPP             00:00:33   PPP: 10.0.0.2
BR0:2                   Sync PPP             00:00:15   PPP: 10.0.0.3
Interface  User      Mode                     Idle Peer Address

Note que un Canal B está utilizado para conectar con el router2 mientras que el otro Canal B conecta con el router 3. verifica que la coincidencia de los IP Addresses ésos configurados en el Routers 2 y 3.

Troubleshooting

Use esta sección para resolver problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • debug dialer [eventos | paquetes]

  • debug isdn event

  • debug isdn q931

  • negociación ppp del debug — Visualiza la información sobre el tráfico y los intercambios PPP mientras que negocia los componentes PPP incluyendo el (LCP), la autenticación, y el protocolo network control del Link Control Protocol (NCP). Una negociación PPP exitosa abre primero el estado LCP, luego realiza la autenticación y por último negocia el NCP.

Refiérase usando el comando show isdn status para el Troubleshooting de BRI si usted encuentra los problemas de capa inferiores de ISDN.

Ejemplo de resultado del comando debug

Router1#show debug
     Dial on demand: Dial on demand events debugging is on 
     PPP: PPP protocol negotiation debugging is on 
     ISDN: ISDN Q931 packets debugging is on

Esta sección visualiza la salida de los debugs del router1 y muestra que router1 del router de llamada 1. del router2 después inicia un servicio repetido al router2 y establece una conexión.

Nota: Algunas de estas líneas de salida de los debugs están rotas en las líneas múltiples para los propósitos de la impresión.

*Mar  1 04:50:34.782: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0B
*Mar  1 04:50:34.790:         Bearer Capability i = 0x8890
*Mar  1 04:50:34.798:         Channel ID i = 0x89
*Mar  1 04:50:34.802:         Calling Party Number i = 0xA1, '6121
',Plan:ISDN, Type:National

!--- Calling party information is provided by the switch.

*Mar  1 04:50:34.818:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)

!--- Called party information is provided by the switch.

*Mar  1 04:50:34.838: ISDN BR0: Event: Received a DATA call from 6121 on
   B1at 64 Kb/s
*Mar  1 04:50:34.842: BR0:1 DDR: Caller id 6121 matched to profile  

!--- The ISDN call (from Router 2) is authenticated.

*Mar  1 04:50:34.842: Di1 DDR: Caller id Callback server starting to  6121

!--- Initiates callback to 6121.
 
*Mar  1 04:50:34.866: ISDN BR0: TX ->  RELEASE_COMP pd = 8  callref = 0x8B
*Mar  1 04:50:34.870:         Cause i = 0x8095 - Call rejected
*Mar  1 04:50:36.778: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0C
*Mar  1 04:50:36.786:         Bearer Capability i = 0x8890
*Mar  1 04:50:36.794:         Channel ID i = 0x89
*Mar  1 04:50:36.798:         Calling Party Number i = 0xA1, '6121',Plan:ISDN,
   Type:National
*Mar  1 04:50:36.814:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)
*Mar  1 04:50:36.834: ISDN BR0: Event: Received a DATA call from 6121 on B1at
   64 Kb/s
*Mar  1 04:50:36.838: BR0:1 DDR: Caller id 6121 matched to profile
*Mar  1 04:50:36.838: Di1 DDR: callback to 6121 already started
*Mar  1 04:50:36.862: ISDN BR0: TX ->  RELEASE_COMP pd = 8  callref = 0x8C
*Mar  1 04:50:36.866:         Cause i = 0x8095 - Call rejected

!--- Reject call (then initiate callback).

*Mar  1 04:50:36.878: DDR: Callback timer expired

!--- The timer is configured with the dialer enable-timeout command.

*Mar  1 04:50:36.878: Di1 DDR: beginning callback to  6121
*Mar  1 04:50:36.882: BR0 DDR: rotor dialout [priority]
*Mar  1 04:50:36.882: BR0 DDR: Dialing cause Callback return call

!--- The dialing cause is callback.

*Mar  1 04:50:36.886: BR0 DDR: Attempting to dial 6121

!--- Dialing 6121 (Router 2).

*Mar  1 04:50:36.902: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x0E
*Mar  1 04:50:36.906:         Bearer Capability i = 0x8890
*Mar  1 04:50:36.914:         Channel ID i = 0x83
*Mar  1 04:50:36.922:         Called Party Number i = 0x80, '6121',Plan:Unknown,
   Type:Unknown
*Mar  1 04:50:36.998: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x8E
*Mar  1 04:50:37.002:         Channel ID i = 0x89
*Mar  1 04:50:37.402: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x8E
*Mar  1 04:50:37.418: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x0E
*Mar  1 04:50:37.426: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

!--- The interface is up.

*Mar  1 04:50:37.446: DDR: Freeing callback to  6121
*Mar  1 04:50:37.446: BRI0:1: interface must be fifo queue, force FIFO
*Mar  1 04:50:37.450: BR0:1 PPP: Phase is DOWN, Setup
*Mar  1 04:50:37.454: BR0:1 PPP: Treating connection as a callout
*Mar  1 04:50:37.454: BR0:1 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 04:50:37.462: BR0:1 LCP: O CONFREQ [Closed] id 1 len 10
*Mar  1 04:50:37.462: BR0:1 LCP:    MagicNumber 0xE1288054 (0x0506E1288054)
*Mar  1 04:50:37.466: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar  1 04:50:37.478: BR0:1 PPP: Treating connection as a callout
*Mar  1 04:50:37.486: BR0:1 LCP: I CONFREQ [REQsent] id 2 Len 10
*Mar  1 04:50:37.490: BR0:1 LCP:    MagicNumber 0x000F4499 (0x0506000F4499)
*Mar  1 04:50:37.494: BR0:1 LCP: O CONFACK [REQsent] id 2 Len 10
*Mar  1 04:50:37.498: BR0:1 LCP:    MagicNumber 0x000F4499 (0x0506000F4499)
*Mar  1 04:50:37.502: BR0:1 LCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:37.506: BR0:1 LCP:    MagicNumber 0xE1288054 (0x0506E1288054)
*Mar  1 04:50:37.506: BR0:1 LCP: State is Open

!--- The LCP negotiation is complete.

*Mar  1 04:50:37.510: BR0:1 PPP: Phase is UP
*Mar  1 04:50:37.514: BR0:1 IPCP: O CONFREQ [Closed] id 1 Len 10
*Mar  1 04:50:37.518: BR0:1 IPCP:    Address 10.0.0.1 (0x03060A000001)
*Mar  1 04:50:37.522: BR0:1 IPCP: I CONFREQ [REQsent] id 2 Len 10
*Mar  1 04:50:37.526: BR0:1 IPCP:    Address 10.0.0.2 (0x03060A000002)
*Mar  1 04:50:37.530: BR0:1 IPCP: O CONFACK [REQsent] id 2 Len 10
*Mar  1 04:50:37.534: BR0:1 IPCP:    Address 10.0.0.2 (0x03060A000002)
*Mar  1 04:50:37.550: BR0:1 IPCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:37.550: BR0:1 IPCP:    Address 10.0.0.1 (0x03060A000001)

!--- IPCP address negotiation.

*Mar  1 04:50:37.554: BR0:1 IPCP: State is Open
*Mar  1 04:50:37.562: BR0:1 DDR: dialer protocol up
*Mar  1 04:50:37.570: Di1 IPCP: Install route to 10.0.0.2

!--- Route to Router 2 is installed.

*Mar  1 04:50:38.510: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceBRI0:1,
   changed state to up

En esta sección, el router3 del router de llamada 1. del router3 de las visualizaciones de la salida del debug después se autentica sobre la base de la información de Id. de la parte llamadora y está conectado con el router1 sin un servicio repetido.

*Mar  1 04:50:54.230: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0D

!--- Receive a call setup.

*Mar  1 04:50:54.238:         Bearer Capability i = 0x8890
*Mar  1 04:50:54.242:         Channel ID i = 0x8A
*Mar  1 04:50:54.250:         Calling Party Number i = 0xA1, '6101',Plan:ISDN,
   Type:National

!--- Calling party (Router 3) information is provided by the switch.

*Mar  1 04:50:54.266:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)

!--- Called party (Router 1) information is provided by the switch.

*Mar  1 04:50:54.286: ISDN BR0: Event: Received a DATA call from 6101 on B2at
   64 Kb/s
*Mar  1 04:50:54.290: BR0:2 DDR: Caller id 6101 matched to profile 

!--- The ISDN call (from Router 3) is authenticated.

*Mar  1 04:50:54.290: BRI0:2: interface must be FIFO queue, force FIFO
*Mar  1 04:50:54.294: BR0:2 PPP: Phase is DOWN, Setup
*Mar  1 04:50:54.298: %DIALER-6-BIND: Interface BR0:2 bound to profile Di2

!--- The interface is bound to interface Dialer 2.

*Mar  1 04:50:54.314: ISDN BR0: TX ->  CALL_PROC pd = 8  callref = 0x8D
*Mar  1 04:50:54.318:         Channel ID i = 0x8A
*Mar  1 04:50:54.326: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
*Mar  1 04:50:54.350: BR0:2 PPP: Treating connection as a callin
*Mar  1 04:50:54.354: BR0:2 PPP: Phase is ESTABLISHING, Passive Open
*Mar  1 04:50:54.354: BR0:2 LCP: State is Listen
*Mar  1 04:50:54.630: ISDN BR0: TX ->  CONNECT pd = 8  callref = 0x8D
*Mar  1 04:50:54.698: ISDN BR0: RX <-  CONNECT_ACK pd = 8  callref = 0x0D
*Mar  1 04:50:54.706:         Channel ID i = 0x8A
*Mar  1 04:50:54.766: BR0:2 LCP: I CONFREQ [Listen] id 31 Len 10
*Mar  1 04:50:54.770: BR0:2 LCP:    MagicNumber 0x099285FD (0x0506099285FD)
*Mar  1 04:50:54.774: BR0:2 LCP: O CONFREQ [Listen] id 1 Len 10
*Mar  1 04:50:54.778: BR0:2 LCP:    MagicNumber 0xE128C3F7 (0x0506E128C3F7)
*Mar  1 04:50:54.782: BR0:2 LCP: O CONFACK [Listen] id 31 Len 10
*Mar  1 04:50:54.786: BR0:2 LCP:    MagicNumber 0x099285FD (0x0506099285FD)
*Mar  1 04:50:54.790: BR0:2 LCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:54.794: BR0:2 LCP:    MagicNumber 0xE128C3F7 (0x0506E128C3F7)
*Mar  1 04:50:54.798: BR0:2 LCP: State is Open

!---  LCP negotiation is complete.

*Mar  1 04:50:54.802: BR0:2 PPP: Phase is UP
*Mar  1 04:50:54.806: BR0:2 IPCP: O CONFREQ [Closed] id 1 Len 10
*Mar  1 04:50:54.810: BR0:2 IPCP:    Address 10.0.0.1 (0x03060A000001)
*Mar  1 04:50:54.814: BR0:2 IPCP: I CONFREQ [REQsent] id 17 Len 10
*Mar  1 04:50:54.818: BR0:2 IPCP:    Address 10.0.0.3 (0x03060A000003)
*Mar  1 04:50:54.822: BR0:2 IPCP: O CONFACK [REQsent] id 17 Len 10
*Mar  1 04:50:54.826: BR0:2 IPCP:    Address 10.0.0.3 (0x03060A000003)
*Mar  1 04:50:54.830: BR0:2 IPCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:54.834: BR0:2 IPCP:    Address 10.0.0.1 (0x03060A000001)

!--- IPCP address negotiation is complete.

*Mar  1 04:50:54.834: BR0:2 IPCP: State is Open
*Mar  1 04:50:54.842: BR0:2 DDR: dialer protocol up
*Mar  1 04:50:54.850: Di2 IPCP: Install route to 10.0.0.3

!--- Route to Router 3 is installed.

*Mar  1 04:50:55.802: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceBRI0:2,
   changed state to up

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 15925