Voz : H.323

Configurar el Hookflash Relay en los puertos de voz FXS/FXO

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (19 Mayo 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Al integrar tecnologías de telefonía en paquetes como Voz por IP (VoIP) a la central telefónica privada (PBX) y a las redes de telefonía pública conmutada (PSTN), a veces es necesario transmitir un tipo de señal llamada “hookflash”. Un hookflash es una interrupción de la corriente del bucle en troncos de inicio de bucle que el sistema adjunto no interpreta como desconexión de llamada.

Una vez que el PBX o el PSTN detecta el hookflash, pone generalmente la corriente invita al control y proporciona un tono de marcación secundario o un acceso a las otras funciones tales como transferencia o acceso de la llamada en espera.

Un hookflash es hecho momentáneamente apretando la cuna en un teléfono. Algunos microteléfonos de teléfono hacen que un botón llamado 'destello' o “recuerde” que envía un “Timed Loop Break”, o el “Flash calibrado” que es un hookflash que tiene una temporización precisa.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 1750 Router

  • Software Release 12.2.5a de Cisco IOS�

  • El software support de la versión 2 de H.323 es un requisito previó. Esto ha estado disponible desde el Cisco IOS Software Release 12.05T y Posterior. La detección de gancho switch/la generación se soporta en los puertos de voz analogicos de la Estación de intercambio remota (FXS) y del Oficina de intercambio remoto (FXO). Éstos están disponibles en estas plataformas del hardware de Cisco:

    • 1750/51/60

    • 2600

    • 3600

    • 3700

    • MC3810

    • Catalyst 4000 con el módulo de gateway de acceso (AGM)

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Antecedentes

Muchos clientes utilizan una combinación de puertos FXS y FXO para ampliar los microteléfonos de teléfono a través de las redes IP. Quieren preservar las características del PBX existente, tales como llamada adelante, ninguna respuesta al correo de voz, y transferencia/control de las extensiones remotas. VoIP de Cisco el software anterior no proporcionó el control total para permitir la integración transparente. Sin embargo, con la versión del Soporte H.323 versión 2 en el Cisco IOS Software Release 12.0.5T y Posterior, es posible ahora detectar y pasar la señalización de gancho switch a través de las redes IP.

Cuando el puerto FXS se configura para un “hookflash largo en” el valor del temporizador (mayor de 500 milisegundos), los usuarios pueden quejarse de que cuando cuelgan para arriba y cogen inmediatamente el microteléfono, la llamada no ha borrado. Si el valor se fija demasiado bajo, el hookflash se puede interpretar como parada, pero un valor más alto significa que el microteléfono tiene que ser dejado colgado-para arriba por un período más largo para borrar la llamada. En algunos casos, la despedida de la cuna puede causar los problemas también. Mientras que se cuelga-para arriba el microteléfono, la tensión del resorte en el botón Hook Button causa las interrupciones breves múltiples en la línea conocida como despedida de la cuna. El ajustar cuidadoso del hookflash en el valor que mide el tiempo puede ser necesario para los mejores resultados. Una posibilidad en estos casos es utilizar los microteléfonos con un botón de destello que envíe un hookflash de un período específico. Puerto FXO puede ser fijado para hacer juego este valor y puerto FXO entonces genera la función hookflash saliente. Mucho PBXes tiene una opción del Clase de Servicio (CoS) llamada el “Flash calibrado” o “Timed Loop Break” que permite que reconozcan los hookflashes de la duración específica y que ignoren otras roturas más cortas o más largas del loop. Tales configuraciones son útiles en la eliminación de las desconexiones y de la generación falsas de señales de gancho switch inválidas al PBX.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Configure PLAR OPX y Hookflash Relay

Utilice este procedimiento para configurar el Off-Premises eXtension de la línea privada, generación de llamada automática (PLAR) (OPX), y el Hookflash Relay.

  1. Configure puerto FXO encendido el router de sitio principal como conexión PLAR-OPX.

    El modo OPX permite que los usuarios remotos en los puertos FXS aparezcan a un PBX central como extensión directamente conectada. Cuando puerto FXO detecta una señal del timbre del PBX, el router envía una configuración de llamada VoIP al puerto del telecontrol FXS pero no toma puerto FXO el descolgado. Como consecuencia, el PBX ve solamente la señal de respuesta de la llamada cuando el puerto del router FXS de RemoteSide se coge. Después de que el PBX alcance el tiempo de espera sin respuesta (timbres de la llamada hacia fuera), después puede terminar la llamada, transferencia la llamada al correo de voz, o llame otra extensión/grupo en anillo. Sin el modo OPX, puerto FXO va inmediatamente descolgado después de que detecte el sonido y el PBX no puede entonces realizar una llamada adelante, ninguna respuesta, o rueda encima al correo de voz.

  2. El router de Remote Site se debe configurar para detectar y después para pasar la señal de gancho switch en el puerto FXS.

    Puesto que el hookflash es ingreso no autorizado momentáneo el Loop Current en el puerto FXS y no se puede enviar como señal de audio, el router pasa la señal de gancho switch vía la retransmisión de múltiples frecuencias del tono dual (DTMF) como “!” carácter. El router con puerto FXO entonces envía una rotura del Loop corto que el dispositivo externo vea como hookflash. Para pasar correctamente la señal de gancho switch, los voip dial peer necesitan ser configurados para la DTMF-retransmisión h245-signal.

  3. Los temporizadores del puerto físico tienen que ser ajustados para adaptarse a las características del microteléfono en el puerto FXS y la duración del loop del hookflash explota del puerto FXO como se muestra aquí:

    • El puerto de voz FXS (router de Remote Site) utiliza el comando timing hookflash-in msec donde está el valor máximo el milisegundo de una rotura del loop (en los milisegundos) del microteléfono de teléfono que se interpreta como hookflash. Una rotura del loop mayor que el valor configurado se mira mientras que se cae una desconexión y la llamada. Cualquier intervalo bajo este valor hace al router enviar “!” carácter vía el relé dtmf H.245-signal.

    • El puerto de voz FXO (router de sitio principal) utiliza el comando timing hookflash-out msec donde está la duración el milisegundo de la rotura saliente del loop en los milisegundos. Cuando el router recibe una señal del relé dtmf H.245-signal, puerto FXO genera una rotura del loop para el intervalo configurado.

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

/image/gif/paws/15405/pbx_across_ip.gif

Configuraciones

Este documento usa las configuraciones detalladas aquí.

MainSite
MainSite#show run 
Building configuration...

Current configuration : 1121 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MainSite
!
memory-size iomem 20
ip subnet-zero
!
call rsvp-sync
voice rtp send-recv
!
interface Loopback1
 ip address 205.1.1.1 255.255.255.0
!
interface Serial0
 bandwidth 1500
 ip address 192.168.1.1 255.255.255.252
 no fair-queue
 clockrate 1300000
 ip rtp priority 16384 16383 100
!
router eigrp 1
 network 192.168.1.0
 network 205.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
voice-port 1/0
 timing hookflash-out 500
 
!--- Outgoing hookflash is 500 msec. 

 connection plar opx 200
 
!--- Use PLAR OPX option on the FXO port. 

!
voice-port 1/1
 timing hookflash-out 500
 
!--- Outgoing hookflash is 500 msec.

 connection plar opx 201
 
!--- Use PLAR OPX option on the FXO port.

!
dial-peer voice 100 pots
 destination-pattern 100
 port 1/0
!
dial-peer voice 101 pots
 destination-pattern 101
 port 1/1
!
dial-peer voice 200 voip
 incoming called-number .
 destination-pattern 20.
 session target ipv4:200.1.1.1
 dtmf-relay h245-signal
 
!--- H.245-signal to pass hookflash.

 ip precedence 5
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Sitio remoto
RemoteSite#show run 
Building configuration...

Current configuration : 1096 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RemoteSite
!
memory-size iomem 25
ip subnet-zero
!
call rsvp-sync
voice rtp send-recv
!
interface Loopback0
 ip address 200.1.1.1 255.255.255.0
!
interface Serial0
 bandwidth 1500
 ip address 192.168.1.2 255.255.255.252
 no fair-queue
 ip rtp priority 16384 16383 100
!
router eigrp 1
 network 192.168.1.0
 network 200.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
!
voice-port 1/0 
 timing hookflash-in 1000
 
!--- Interpret loop breaks of up to 1 second.   
  
 connection plar 100
 
!--- PLAR provides dial tone from remote PBX. 

!
voice-port 1/1
 timing hookflash-in 1000
 
!--- Interpret loop breaks of up to 1 second.    
 
 connection plar 101
 
!--- PLAR provides dial tone from the remote PBX.

!
dial-peer voice 100 voip
 incoming called-number .
 destination-pattern 10.
 session target ipv4:205.1.1.1
 dtmf-relay h245-signal
 
!--- Use H.245-signal to pass hookflash.

 ip precedence 5
!
dial-peer voice 200 pots
 destination-pattern 200
 port 1/0
!
dial-peer voice 201 pots
 destination-pattern 201
 port 1/1
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Verificación y resolución de problemas

Esta sección proporciona la información que usted puede utilizar para verificar y para resolver problemas su configuración.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

  • haga el debug del h225 {asn1 | eventos} - información adicional de las visualizaciones sobre el contenido real de los mensajes del registro H.225, de la admisión, y del estatus (RAS).

    asn1 Indica que solamente el contenido ASN.1 de cualquier mensaje H.225 enviado o recibido está visualizado.
    eventos Indica que los eventos del q.931 de la clave que ocurren al poner una llamada de H.323 a partir de un gateway a otro se visualizan.

Se pasa el hookflash pues un mensaje H.245 vía el TCP así que él es posible monitorear la señalización usando el asn1 del debug h245 para visualizar los paquetes H.245.

Éstas son dos trazas del debug. El primer muestra el recibo del '5' del dígito (la señalización de llamada H.245 pasa el dígito y la duración). ¡La segunda traza muestra un hookflash (mostrado como “! "). No hay duración para un hookflash. La señal es enviado puerto FXO basado en el valor configurado milisegundo del hookflash-hacia fuera que mide el tiempo.

MainSite#
MainSite#debug h245 asn1 
H.245 ASN1 Messages debugging is on
MainSite#
00:52:17: H245 MSC INCOMING ENCODE BUFFER::= 6D 810B66A0 0F9F58AD AF684A00 00
00:52:17: 
00:52:17: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signal : 
    {
      signalType "5"
      
!--- Digit relayed is 5. 

      duration 4000
      rtp 
      {
        timestamp 2913953866
        logicalChannelNumber 1
      }
    }

00:52:18: H245 MSC INCOMING ENCODE BUFFER::= 6D 82064001 26000000 
00:52:18: 
00:52:18: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signalUpdate :
 
    {
      duration 295
      
!--- Digit duration was 295 msec. 

      rtp 
      {
        logicalChannelNumber 1
      }
    }

MainSite#


!--- This trace from the destination router shows 
!--- the hookflash passed as the character '!'. 

MainSite#
00:52:36: H245 MSC INCOMING ENCODE BUFFER::= 6D 81020420 
00:52:36: 
00:52:36: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signal : 
    {
      signalType "!"
     
 !--- Hookflash is passed as '!'. 

    }

MainSite#

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 15405