Servicios de redes de aplicaciones : Cisco LocalDirector de la serie 400

Configuración de fallas estándar y statefull en LocalDirector.

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Cisco ha anunciado la fin-de-venta para el Cisco LocalDirector. Para más información, refiera al fin de vida de las 400 Series de LocalDirector y los avisos y los boletines de productos del Fin de la Venta.


Contenido


Introducción

La información en esta nota técnica se aplica a todas las versiones de software y hardware del Cisco LocalDirector en una configuración de failover.

Dos tipos de Conmutación por falla pueden ser implementados en LocalDirector: falla estándar y falla total En la Conmutación por falla estándar (NON-statefull), toda la información de la conexión existente se pierde sobre la Conmutación por falla; no obstante, la conmutación por error de estado completo mantiene la información de la sesión, así como la información de la sesión fija.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento se aplica a todas las versiones de software y hardware del Cisco LocalDirector en una configuración de failover.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Comandos failover

  • failover ip address ip_address - Configura la dirección IP de conmutación por error. El argumento de los ip_address indica la dirección IP usada por la unidad en espera para comunicar con la unidad activa. Utilice esta dirección de IP con el comando ping para verificar el estado de la unidad en espera. Esta dirección debe estar en la misma red que la dirección IP del sistema. Por ejemplo, si la dirección IP del sistema es 192.168.1.1, configure la dirección de IP de falla en 192.168.1.2.

  • failover [activo] - Habilita acceso a la característica opcional failover (falla). El argumento activo opcional convierte a LocalDirector en la unidad activa.

  • interface_number replegado de la interfaz — Habilita a la Falla Statefull, y especifica una interfaz para enviar los datos de replicación. El argumento interface_number indica el número a través del cual la unidad activa LocalDirector envía datos de replicación de la conexión a la unidad en espera. El valor predeterminado es interfaz 0.

  • failover alias ip address ip_address – Asigna una dirección IP de alias de conmutación por error. La dirección IP es usada por la unidad inactiva para comunicarse con la activa.

  • reinicio de fallas — Toma a un estado fallido de los de la unidad.

  • show failover – Muestra el estado de falla de LocalDirector, el estado del cable, el estado del host primario y secundario y las descripciones de la interfaz.

  • shutdown Ethernetes | interface_number FDDI — Inhabilita una interfaz.

Para más información, refiera a la referencia del comando localdirector.

Configuraciones

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

LocalDirector en failover estándar

Ésta es una configuración básica de LocalDirector en la falla estándar:

LocalDirector en failover estándar
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 auto 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp 
: end 
[OK] 
localdirector(config)#

LocalDirector en Statefull Failover

Abajo está una configuración de muestra de LocalDirector en la Falla Statefull. Las unidades de conmutación por error con estado comparten información de conexión para las conexiones activas y son configurables de manera virtual. Cada vez que el estado de conexión del Protocolo de control de transmisión (TCP) cambia, los datos se envían al LocalDirector en espera a través del protocolo con estado de LocalDirector. Esto permite que dupliquen al estado actual de todas las sesiones TCP al LocalDirector en espera.

El protocolo LocalDirector-statefull utiliza paquetes del Protocolo de datagrama de usuario (UDP) para enviar los cambios de estado al Localdirector de reserva sobre la interfaz Ethernet. Utilice una interfaz de Ethernet separada para enviar los mensajes de la Falla Statefull. Con la Falla Statefull, no hay interrupción del servicio al cliente. Es ideal para las aplicaciones esenciales para la misión y permite una elevada disponibilidad.

Nota: Este ejemplo utiliza interfaz Ethernet 2, que tiene un cruce entre los dos LocalDirector para transferir información de estado. Este ejemplo también utiliza estos comandos replicate:

replicate interface 2 
replicate 10.1.1.5:0:0:tcp

Estos comandos le indican a LocalDirector que replique el estado de conexión de las unidades activas a las que están en espera en Ethernet 2 y también que replique toda la información de estado de unidad 10.1.1.5 virtual a la unidad en espera.

LocalDirector en Statefull Failover
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
no shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 100full 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
replicate interface 2 
replicate 10.1.1.5:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp

Nota: Todas las interfaces están inicialmente en el modo que espera, significando que el Monitoreo de red no ha comenzado. Después de que las interfaces de la red entren el modo normal, el Monitoreo de red comienza. Esto sucede cuando los mensajes de saludo de LocalDirector comienzan a enviarse cada cinco segundos.

Si transcurre un intervalo de 30 segundos sin que se reciba algún mensaje HELLO de LocalDirector, las unidades ingresan en el modo de prueba para determinar qué unidad ha fallado. Si se quita el cable de serie, las unidades mantendrán su función actual. Si la unidad no pasa una prueba, se fallará y la otra unidad llegará a ser activa. ¿Cada vez que? ¿estado? de los cambios de la conexión TCP, los datos se envían al LocalDirector en espera vía protocolo con estado de LocalDirector. El estado de todas las sesiones TCP se duplica en el LocalDirector de reserva. Si un virtual se cambia para apoyar a la Falla Statefull entonces la información del estado para solamente las nuevas conexiones se envía al LocalDirector en espera. El protocolo con estado de LocalDirector no copia el estado de sesiones TCP existentes.

Verificación del estado failover

El comando show failover puede ser utilizado para visualizar el estado de fallla actual de las unidades y de sus interfaces, tal y como se muestra en de este ejemplo:

Failover Off 
Cable status: My side not connected 
        This host: Secondary - Active 
                Active time: 1 weeks, 3 days, 1 hours, 2 minutes, 5 seconds 
                Interface 5 (10.86.16.225): Normal (Waiting) 
                Interface 4 (10.86.16.225): Normal (Waiting) 
                Interface 3 (10.86.16.225): Normal (Administratively down) 
                Interface 2 (10.86.16.225): Normal (Administratively down) 
                Interface 1 (10.86.16.225): Normal (Waiting) 
                Interface 0 (10.86.16.225): Normal (Waiting) 
        Other host: Secondary - Standby 
                Interface 5 (0.0.0.0): Normal (Waiting) 
                Interface 4 (0.0.0.0): Normal (Waiting) 
                Interface 3 (0.0.0.0): Normal (Administratively down) 
                Interface 2 (0.0.0.0): Normal (Administratively down) 
                Interface 1 (0.0.0.0): Normal (Waiting) 
                Interface 0 (0.0.0.0): Normal (Waiting)

Esto muestra que los paquetes de saludo pasan de un lado al otro entre las dos unidades y que dos de las interfaces en los LD se han cerrado.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 15060