Módulos e interfaces de Cisco : Módulo de switching de contenido de Cisco

Configuración del balance de carga del servidor IOS con Sondas HTTP en el modo enviado

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (19 Septiembre 2015) | Comentarios


Contenido


Introducción

La característica del Equilibrio de carga de servidores (SLB) de Cisco IOS� es una solución basada en IOS de Cisco que proporciona el Server Load Balancing. Esta característica permite que usted defina un servidor virtual que represente un cluster de los servidores reales, conocido como bloque de servidores. Cuando un cliente inicia una conexión al servidor virtual, la carga IOS SLB equilibra la conexión a un servidor real elegido, dependiendo del algoritmo de equilibro de carga configurado o del calculador.

El IOS SLB se puede configurar para actuar en los dos modos siguientes.

  • modo enviado — En este modo, el direccionamiento del servidor virtual se sabe a los servidores reales. Usted debe configurar cada uno de los servidores reales con los Loopback Address para su Loopback Interface único. Esto es necesario dar a cada máquina en el bloque de servidores la misma dirección IP que el servidor virtual real. El servidor real de destino entonces será permitido responder directamente a los clientes que usan el Loopback Address, apenas como para su propia dirección IP. El IOS SLB reorienta los paquetes al servidor real en la capa 2 en el capa de control de acceso de medios (MAC). Puesto que la dirección IP del servidor virtual no se modifica en el modo enviado, los servidores reales deben ser la capa 2-adjacent a IOS SLB, o los routeres intermedios no pudieron poder rutear al servidor real elegido.

  • modo dirigido — En este modo, el servidor virtual se puede asignar a una dirección IP que sea desconocida a los servidores reales. El IOS SLB traduce los paquetes intercambiados entre un cliente y un servidor real, traduciendo la dirección IP del servidor virtual a un direccionamiento del servidor real con el Network Address Translation (NAT). Para utilizar al modo dirigido, agregue el comando nat server al bloque de servidores.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Versión 12.1(6)E del Supervisor IOS del Catalyst 6000 Family para el Supervisor Engine 1 con MSFC1 (c6sup11-jsv-mz.121-6.E1)

  • Servidores Web de Microsoft Windows 2000/IIS

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Configurar

Sondeos de HTTP

Sondas del protocolo supports hypertext transfer IOS SLB (HTTP), sondas del ping, y sondas del Wireless Session Protocol (WSP). Usted puede utilizar el método del sondeo HTTP para verificar la Conectividad y para monitorear los servidores reales que son carga equilibrada. Las sondas determinan el estatus de cada servidor real en el bloque de servidores. En este ejemplo, las sondas HTTP se configuran usando el puerto TCP 80. Las sondas HTTP se configuran para conectar cada ocho segundos y para pedir un comando get del método, buscando un código de 200 respuestas del servidor. Estas configuraciones son todos los valores predeterminados.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/15055/ios_slb-01.gif

Configuraciones

Configuración de SLB del OIS usando el Catalyst 6509
Current configuration:

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname cat6

!

boot buffersize 126968

boot system flash slot0:c6sup11-jsv-mz.121-6.E1.bin

!

redundancy

 main-cpu

  auto-sync standard

ip subnet-zero

!

no ip finger

no ip domain-lookup

!

ip slb probe KEEPALIVE http

!

ip slb serverfarm SERVERS

 probe KEEPALIVE

 !

 real 10.1.1.3

  inservice

 !

 real 10.1.1.5

  inservice

!

ip slb vserver WEBSITE

 virtual 172.17.63.215 tcp www

 serverfarm SERVERS

 inservice

!

cns event-service server

!

interface GigabitEthernet1/1

 no ip address

 shutdown

!

interface GigabitEthernet1/2

 no ip address

 shutdown

!

interface FastEthernet2/1

 no ip address

 switchport

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet2/2

 no ip address

 shutdown

!

interface FastEthernet2/3

 no ip address

 switchport

 switchport access vlan 200

 switchport mode access

!

interface FastEthernet2/4

 no ip address

 switchport

 switchport access vlan 200

 switchport mode access

!

interface FastEthernet2/5

 no ip address

 shutdown

!

interface FastEthernet2/48

 no ip address

 shutdown

!         

interface Vlan1

 no ip address

 shutdown

!

interface Vlan100

 ip address 172.17.63.211 255.255.255.192

!

interface Vlan200

 ip address 10.1.1.250 255.255.255.0

!

ip default-gateway 172.17.63.193

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.63.193

no ip http server

!

line con 0

 transport input none

line vty 0 4

 password cisco

 login

!

end

Comandos show y resumen de comandos

Comando show ip slb mode

El comando show ip slb mode visualiza el estatus del slb mode.

cat6#show ip slb mode 
     SLB forwarding mode = rp (default) 
     SLB configured mode = rp (default) 

Para funcionar con el Cisco IOS software SLB, usted debe configurar el modo usando el slb mode del IP de la demostración [csm | comando rp] antes de cualquier configuración. En el comando show ip slb mode, el argumento rp es predeterminado. Usted puede configurar solamente argumento cms si usted tiene el módulo content switching (CS). El CS proporciona las conexiones de alto rendimiento entre los bloques de servidores de los dispositivos de red basados en los paquetes de información de la capa 4 a 7. Usted puede representar un grupo de servidores reales (bloque de servidores) como caso del servidor único (servidor virtual), equilibrar el tráfico al bloque de servidores seleccionando uno de los servidores reales (Server Load Balancing), y el tráfico del límite a los servidores individuales (conexiones persistentes) y a los bloques de servidores (directivas). Para más información, vea configurar el modo seguro (del router) en el módulo content switching.

Comando show ip slb vserver

El comando show ip slb serverfarms muestra información sobre el servidor virtual. A continuación puede ver el estado del servidor virtual y cuántas conexiones hay:

cat6#show ip slb vserver 

slb vserver      protocol      virtual              state      conns 
------------------------------------------------------------------------ 
WEBSITE         TCP       172.16.63.215/32:80      OPERATIONAL   0 

Comando show ip slb mode

El comando show ip slb reals muestra información para cada servidor real, ya sea el bloque de servidores en el que reside cada servidor, los estados del servidor, los umbrales y las conexiones.

cat6#show ip slb reals 

real             server farm      weight     state        conns 
------------------------------------------------------------------- 
10.1.1.5         SERVERS           8        OPERATIONAL     0 
10.1.1.3         SERVERS           8        OPERATIONAL     0 

Comando show ip slb vlan

El comando show ip slb serverfarms muestra información sobre la granja de servidores. Este comando muestra el predictor usado para el balance de carga. En este ejemplo se utiliza round robin, que es el valor predeterminado. Usted no verá “ninguno” bajo el NAT porque el dispositivo está en el modo enviado.

cat6#show ip slb serverfarm 

server farm      predictor    nat        reals    redirect    bind id 
-------------------------------------------------------------------------- 
SERVERS       roundrobin     none         2          0             0 

Comando show ip slb mode

El conns del slb del IP de la demostración [virtual_server-name del vserver | dirección IP de cliente | el comando del firewallfarm-nombre del Firewall] [detail] visualiza las conexiones activas.

  • vserver - Visualizaciones solamente que esas conexiones conectaron con un servidor virtual determinado.

  • Virtual Server-nombre - Nombre del servidor virtual.

  • cliente - Visualiza las conexiones con un IP Address de cliente particular.

  • IP address - Dirección IP del cliente.

  • detalle - Información de conexión detallada de las visualizaciones.

Si no se especifica ningunas opciones, el comando show ip slb conns visualiza la salida para todas las conexiones activas SLB del IOS.

cat6#show ip slb conns 

vserver         prot    client             real                state            nat 
----------------------------------------------------------------------- --------------- 
WEBSITE         TCP  10.21.188.123:2187    10.1.1.5            ESTAB            none 
WEBSITE         TCP  10.21.188.123:2190    10.1.1.5            CLOSING       	none 
WEBSITE         TCP  10.21.188.123:2192    10.1.1.3            ESTAB            none 
WEBSITE         TCP  10.21.188.123:2197    10.1.1.3            CLOSING       	none 
WEBSITE         TCP  10.21.188.123:2200    10.1.1.5            SYNCLIENT        none 
WEBSITE         TCP  10.21.188.123:2201    10.1.1.5            SYNCLIENT        none 

cat6#show ip slb conns detail 

WEBSITE, client = 10.21.188.123:2187 state = ESTAB, real = 10.1.1.5, 
nat = none  v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 1, sticky = FALSE, flows attached = 0 
WEBSITE, client = 10.21.188.123:2205 state = CLOSING, real = 10.1.1.5, 
nat = none v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 3, sticky = FALSE, flows attached = 0 
WEBSITE, client = 10.21.188.123:2206 state = ESTAB, real = 10.1.1.5, 
nat = none v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 2, sticky = FALSE, flows attached = 0 

show ip slb probe Command

El comando show ip slb probe visualiza la información sobre un IOS SLB.

Hay tres estado operacional de la sonda:

  • FALLADO - La sonda ha fallado actualmente.

  • OPERATIVO - La sonda está funcionando normalmente.

  • PRUEBA - La sonda nunca tuvo éxito, debido a ninguna respuesta. El IOS SLB no guarda ningunos contadores o temporizador para esto estado.

La otra información visualizada es la siguiente:

  • Caídas del sistema - La cantidad de intervalos entre los sondeos exitosos.

  • Actual - El tiempo puesto que el éxito más reciente de la sonda. Es decir, la duración (hasta ahora) de la interrupción actual.

  • Acumulativo - El tiempo total el servidor real ha estado bajo prueba de la sonda y ha fallado. Este valor es la suma de la hora actual más el tiempo total de todas las interrupciones anteriores.

cat6#show ip slb probe 

Server:Port          	State        Outages  	Current    Cumulative 
----------------------------------------------------------------------- 
10.1.1.3:80             OPERATIONAL    1        never         00:05:22 
10.1.1.5:80             OPERATIONAL    0        never         00:00:00 

Loopback del modo Enviado

Después de que usted haya configurado la característica SLB en el Catalyst 6500, usted debe configurar cada servidor real con un dispositivo del Loopback/una interfaz. Configure la dirección IP del servidor virtual como el Loopback IP Address, con un netmask de 255.0.0.0.

Route Table 
======================================================================= ==== 
Interface List 
0x1 ........................... MS TCP Loopback interface 
0x2 ...00 60 b0 87 dc 1a ...... AMD PCNET Family Ethernet Adapter 
0x1000004 ...02 00 4c 4f 4f 50 ...... MS LoopBack Driver 
======================================================================= ==== 
Active Routes: 
Network	        Destination         Netmask         Gateway     Interface   Metric 
0.0.0.0         0.0.0.0             10.1.1.250      10.1.1.3        1 
10.1.1.0        255.255.255.0       10.1.1.3        10.1.1.3        1 
10.1.1.3        255.255.255.255     127.0.0.1       127.0.0.1       1 
10.255.255.255  255.255.255.255     10.1.1.3        10.1.1.3        1 
127.0.0.0       255.0.0.0           127.0.0.1       127.0.0.1       1 
172.17.63.215   255.255.255.255     127.0.0.1       127.0.0.1       1 
224.0.0.0       224.0.0.0           10.1.1.3        10.1.1.3        1 
224.0.0.0       224.0.0.0           172.17.63.215   172.17.63.215   1 
255.255.255.255 255.255.255.255     10.1.1.3        10.1.1.3        1 
======================================================================= ==== 

Examine a la dirección de red en cada fila de la tabla, donde usted ve que aparece el Loopback Address. Para que los servidores comuniquen correctamente, usted necesita una referencia a una dirección de red de multicast conocida. Esto está en la octava fila del ejemplo, así que usted necesita borrar el Default Route adicional. Éste es el cuya dirección de red comienza con el mismo primer dígito que la dirección del clúster, y es seguido por tres ceros. En el ejemplo anterior, la ruta adicional está en la segunda fila.

Los siguientes son direcciones de red de multicast conocida:

224.0.0.0      224.0.0.0    172.17.63.215      172.17.63.215       1 

Los siguientes son rutas predeterminado automático-instaladas quitadas de la tabla antedicha:

0.0.0.0          0.0.0.0    172.17.63.193   172.17.63.215       1

Usted debe borrar la ruta adicional para permitir la comunicación correcta con el servidor virtual SLB.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 15055