Marcado y acceso remotos : "Red digital de servicios integrados (ISDN), Señalización por canal asociado (CAS)"

Configuración de una interfaz asíncrona como respaldo para una línea serial.

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Es común proporcionar trayectos redundantes para las conexiones WAN, tales como seriales, línea en arriendo o Retransmisión de tramas, con circuitos marcado a pedido (DDR). Los módems asíncronos y las líneas de Servicio telefónico sencillo antiguo (POTS) con conmutador de circuito se utilizan a las interfaces WAN de backup. Es necesario un planeamiento cuidadoso al momento de diseñar escenarios de respaldo para el marcado. Considere los factores tales como tráfico en los link de backup, el número de links susceptibles al error, y hojas de operación (planning) de capacidad del puerto a los circuitos de backup soportado.

prerrequisitos

Requisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Una plataforma del Cisco 2500 Router.

  • Software Release 12.1(2)T del ½ del ¿Â de Cisco IOSï en el router gaugin.

  • Cisco IOS Software Release 12.0(7)T en el router sphinx.

  • Los Módems externos conectaron con el puerto serial en el Routers.

Nota: Este documento se puede modificar para el uso en cualquier router con las interfaces asincrónicas (o los módems incorporados). La configuración de la Interfaz de respaldo (Serial2 de la interfaz, en este ejemplo) sería incluida bajo el “async x de la interfaz”.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Antecedentes

Estos son tres métodos comunes disponibles para brindar respaldo a un link de WAN:

  • Interfaces de respaldo - Sigue habiendo una Interfaz de respaldo en el modo de reserva hasta que vaya el link principal abajo. El link de respaldo se activa luego, reestableciendo la conexión entre los dos sitios.

  • Dispositivos de vigilancia de marcador: Se trata de un dispositivo que proporciona conectividad confiable sin depender exclusivamente de la definición del tráfico interesante para accionar las llamadas salientes en el router central. La vigilancia del marcador monitorea ciertas rutas específicas y, si esas redes son inalcanzables, la vigilancia del marcador activa el link secundario.

  • Rutas estáticas flotantes - Las Rutas estáticas flotantes son las Static rutas que tienen una distancia administrativa mayor que la distancia administrativa de las rutas dinámico. Las distancias administrativas se pueden configurar en una Static ruta de modo que la Static ruta sea menos deseable que una ruta dinámico; por lo tanto, la Static ruta no se utiliza cuando la ruta dinámico está disponible. No obstante, si se pierde la ruta dinámica, la ruta estática puede tomar el control y el tráfico puede enviarse a través de esta ruta alternativa.

Este escenario utiliza la Interfaz de respaldo para realizar el respaldo. Para más información sobre las aplicaciones de la Interfaz de respaldo refiera a las evaluaciones de la interfaz de respaldo, a las Rutas estáticas flotantes, y al Monitoreo de marcado del documento para el backup DDR.

Para más información sobre configurar el respaldo refiera por favor a El documento brinda información para decidir qué método de respaldo es el adecuado y demás información de configuración.

Lea y comprenda los dos documentos anteriores antes de continuar con esta configuración.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/14281/async_backup_14281.gif

Configuraciones

En la configuración, estamos utilizando dos routers Cisco (gaugin y sphinx) que están conectados en una línea arrendada a través de sus interfaces seriales 0. Las interfaces serial 2 están conectadas por módems asíncronos mediante una línea de Red de telefonía pública conmutada (PSTN) y se usan como respaldo para la línea arrendada.

Nota: De manera predeterminada, estas interfaces funcionan en modo sincrónico, debe configurarlas manualmente (utilizando el comando physical-layer async) para que funcionen en el modo asíncrono.

Usando el comando show version, usted puede descubrir si estas interfaces pueden trabajar en el modo asincrónico también. La información relevante mostrada por el comando show version se muestra a continuación:

2 Low-speed serial(sync/async) network interfaces

! --- This means it can work in sync or async mode.

Se recomienda que usted completa la configuración y la verifica que la conexión del módem puede ser hecha. Puede hacer esto mediante una conexión remota (Telnet) inversa a los módems y realizando una llamada al número del módem remoto.

Nota: Es también obligatorio utilizar una capacidad del módem (modemcap) dependiendo del tipo de módem. Para más información sobre este tema, consulte la Guía de conexión módem-router.

gaugin (Cisco 2500) – Router de llamada
gaugin#show running-config
 Building configuration...

 Current configuration:
 hostname gaugin

 username sphinx password 0 cisco

 !---Username and shared secret for CHAP authentication.

 !
 chat-script CALLOUT "" "atdt\T" TIMEOUT 60 CONNECT \c

 !--- Chat script used for dialout.

 modemcap entry usr:MSC=& FS0=1 & C1&D2;&H1;&R2;&B1;&W;

 !--- Modemcap for the external modem.
 !--- Refer to Modem-Router Connection Guide for more information.

 interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 !
 interface Serial0
 
!--- Primary link.

  ip address 3.3.3.1 255.255.255.0

 !--- Remote peer serial interface is in same subnet.

  backup interface serial 2

 !--- Designate interface serial 2 as the backup interface.

 !
 interface Serial2

 !--- Backup interface. This interface will be in "Standby" mode until the
 !--- line protocol on interface Serial 0 (the primary) goes down.

  physical-layer async
 
!--- Permit async mode.

  ip unnumbered Loopback1
  encapsulation ppp
  dialer in-band
  dialer map ip 2.2.2.1 name sphinx modem-script CALLOUT 8029

 !--- Dialer map for the peer. 
!--- Note the ip address, the name (which matches the
!--- authenticated username, the chat script used and the number to dial.

  dialer-group 1

 !--- Interesting traffic definition for dialout.

  async mode dedicated
  no peer default ip address

 !--- Do not provide the peer with an IP address. 
!--- It must have one configured.

  no fair-queue
  ppp authentication chap callin

 !--- Use one-way chap authentication.

 !
 ip route 2.2.2.1 255.255.255.255 Serial0
 ip route 2.2.2.1 255.255.255.255 Serial2

 ! -- Identical routes for the peer. 
!--- Note the IP address matches the dialer map ip.
 !--- When the primary is up, the backup in in Standby hence the route using
 !--- Serial 2 will not be used. When the backup is brought out of standby
 !--- it will get used and the serial 0 route is removed (since the link is down/down)
 !--- To create a route for other networks use 
!--- ip route <network> <mask> 2.2.2.1.



 dialer-list 1 protocol ip permit

 !--- Interesting traffic definition. 
!--- Once the backup link is brought out of standby
!--- dialout is ONLY initiaited after the router receives interesting traffic.


 line 2

 !--- Line configuration for the modem on interface Serial 2. 

 script dialer CALLOUT

 !--- Use script CALLOUT.

 modem InOut
 modem autoconfigure type usr

 !--- Use modemcap named "usr" configured earlier.

 transport input all
 speed 115200

 !--- DTE-DCE speed.

 flowcontrol hardware

esfinge (Cisco2500) - Router llamado
sphinx#show running-config
 Building configuration...

 Current configuration:
 !
 version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname sphinx
 username gaugin password 0 cisco

 !--- Username and shared secret for CHAP authentication.

 modemcap entry usr:MSC=& FS0=1 & C1&D2;&H1;&R2;&B1;&W; !
 interface Loopback1
 ip address 2.2.2.1 255.255.255.255
 no ip directed-broadcast
 !
 interface Serial0

 !--- Primary interface
 !--- Note that this router does not initiate the backup when the primary fails
 !--- it will rely on the peer to initiate the connection.

 ip address 3.3.3.2 255.255.255.0
 !
 interface Serial2

 !--- Interface providing backup.
 !--- There is no dialer map/dialer string since it is only accepting the call.
 !--- This interface will be in Up/Up(Spoofing) mode when the primary interface is up.
 !--- Later, configure a floating static route to prevent packet loss.

 physical-layer async
 ip unnumbered Loopback1
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer-group 1
 async mode dedicated
 no peer default ip address
 no fair-queue
 no cdp enable
 ppp authentication chap

 ip route 1.1.1.1 255.255.255.255 Serial0
 ip route 1.1.1.1 255.255.255.255 Serial2 2 

 !--- The 2 makes the route a floating static route.
 !--- This is important since the async interface will be in spoofing mode 
 !--- (not in standby mode) when the primary interface is up.
 !--- If we do not use the 2 here, we lose half of the packets in the return path
 !--- since the router will attempt to load balance
 !--- across the 2 links (eventhough the backup is down).
 !--- To create a route for other networks use 
!--- ip route <network> <mask> 1.1.1.1.


 line 2
  modem InOut
  modem autoconfigure type usr
  transport input all
  speed 115200
  flowcontrol hardware

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • show interface serial - Muestra información acerca de una interfaz en serie.

  • show ip route – Muestra el estado actual de la tabla de ruteo.

  • show line - Muestra los parámetros de una línea terminal.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Para más información sobre la Interfaz de respaldo del troubleshooting refiera por favor a

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

  • show dialer: muestra información sobre una interfaz de marcado.

  • ping - Comprueba la conectividad.

  • debug modem - Para observar la actividad de línea del módem en un servidor de acceso.

  • negociación ppp del debug - Visualiza la información sobre el tráfico y los intercambios PPP mientras que negocia a los componentes PPP incluyendo el (LCP), la autenticación, y el protocolo network control del Link Control Protocol (NCP). Una negociación PPP exitosa abrirá primero el estado LCP, luego realizará la autenticación y por último negociará el NCP.

  • debug ppp authentication – Muestra los mensajes del protocolo de autenticación PPP, entre ellos intercambio de paquetes de protocolo de autenticación por desafío mutuo (CHAP) e intercambios de protocolo de autenticación de contraseña (PAP). Si usted observa un error, verifique que el nombre de usuario y contraseña de la grieta esté configurado correctamente.

  • debug chat - Muestra la actividad de la secuencia de comandos de conversación.

  • debug dialer - Muestra la información de la depuración DDR acerca de los paquetes recibidos en una interfaz de marcado.

En la salida de muestra abajo, podemos ver que la conexión en serie principal (serial0) en el gaugin (el router de llamada) tiene un problema y cae la conexión. La Interfaz de respaldo (comienzo del serial 2) que hace la conexión de respaldo. Para este ejemplo, hemos desconectado el cable para probar el link de respaldo.

Nota: La publicación del comando shutdown en la interfaz primaria no hará el respaldo marcar. Si ejecuta un comando shutdown para cerrar la conexión primaria, el software de IOS de Cisco no cerrará automáticamente la conexión de respaldo. Debe hacer caer la conexión principal mediante la desconexión de cables o a través de algún método equivalente para que aparezcan de las interfaces de respaldo.

   gaugin#
   *Mar 1 00:57:25.127: %LINK-3-UPDOWN: Interface Serial0, changed state to down
   *Mar 1 00:57:26.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
    changed state to down

    !--- Primary Link is brought down. 
    !--- This will cause the backup link (int Serial 2) to be taken out of standby.

   *Mar 1 00:57:37.143: %LINK-3-UPDOWN: Interface Serial2, changed state to down
   
!--- The Backup link is changes from Standby to Down.

   *Mar 1 00:57:37.147: Se2 LCP: State is Closed..
   *Mar 1 00:57:40.019: TTY2: restoring DTR
   *Mar 1 00:57:41.019: TTY2: autoconfigure probe started
   *Mar 1 00:57:52.147: Se2 DDR: re-enable timeout.
   *Mar 1 00:57:55.067: Se2 DDR: Dialing cause ip (s=1.1.1.1, d=2.2.2.1)
   
!--- Interesting traffic for the peer causes the dialout.

   *Mar 1 00:57:55.071: Se2 DDR: Attempting to dial 8029
   *Mar 1 00:57:55.071: CHAT2: Attempting async line dialer script
   *Mar 1 00:57:55.075: CHAT2: Dialing using Modem script: CALLOUT 
   & System script: none
   
!--- Chat-script named CALLOUT is used.

   *Mar 1 00:57:55.083: CHAT2: process started
   *Mar 1 00:57:55.083: CHAT2: Asserting DTR
   *Mar 1 00:57:55.087: CHAT2: Chat script CALLOUT started
   *Mar 1 00:57:55.087: CHAT2: Sending string: atdt\T<8029>
   *Mar 1 00:57:55.091: CHAT2: Expecting string: CONNECT.........
   *Mar 1 00:58:12.859: CHAT2: Completed match for expect: CONNECT
   *Mar 1 00:58:12.859: CHAT2: Sending string: \c
   *Mar 1 00:58:12.863: CHAT2: Chat script CALLOUT finished, status = Success
   *Mar 1 00:58:12.867: TTY2: no timer type 1 to destroy
   *Mar 1 00:58:12.867: TTY2: no timer type 0 to destroy
   *Mar 1 00:58:12.875: Se2 IPCP: Install route to 2.2.2.1.
   *Mar 1 00:58:14.871: %LINK-3-UPDOWN: Interface Serial2, changed state to up
       Dialer state change to up Serial2 Dialer call has been placed Serial2
   *Mar 1 00:58:14.891: Se2 PPP: Treating connection as a callout

    !--- PPP LCP negotiation begins.

   *Mar 1 00:58:14.891: Se2 PPP: Phase is ESTABLISHING, Active Open
   *Mar 1 00:58:14.895: Se2 PPP: No remote authentication for call-out
   *Mar 1 00:58:14.899: Se2 LCP: O CONFREQ [Closed] id 10 len 20
   *Mar 1 00:58:14.899: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:14.903: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:14.907: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:14.907: Se2 LCP: ACFC (0x0802).
   *Mar 1 00:58:16.895: Se2 LCP: TIMEout: State REQsent
   *Mar 1 00:58:16.899: Se2 LCP: O CONFREQ [REQsent] id 11 len 20
   *Mar 1 00:58:16.899: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:16.903: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:16.907: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:16.907: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.063: Se2 LCP: I CONFACK [REQsent] id 11 len 20
   *Mar 1 00:58:17.067: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.067: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:17.071: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.075: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.083: Se2 LCP: I CONFREQ [ACKrcvd] id 32 len 25
   *Mar 1 00:58:17.083: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.087: Se2 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 00:58:17.091: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   *Mar 1 00:58:17.095: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.095: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.099: Se2 LCP: O CONFACK [ACKrcvd] id 32 len 25
   *Mar 1 00:58:17.103: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.103: Se2 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 00:58:17.107: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   *Mar 1 00:58:17.111: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.111: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.115: Se2 LCP: State is Open
    
!--- LCP negotiation is complete.

   *Mar 1 00:58:17.115: Se2 PPP: Phase is AUTHENTICATING, by the peer
   *Mar 1 00:58:17.263: Se2 CHAP: I CHALLENGE id 4 len 27 from "sphinx"
   *Mar 1 00:58:17.271: Se2 CHAP: O RESPONSE id 4 len 27 from "gaugin"
   *Mar 1 00:58:17.391: Se2 CHAP: I SUCCESS id 4 len 4
   *Mar 1 00:58:17.395: Se2 PPP: Phase is UP
   *Mar 1 00:58:17.399: Se2 IPCP: O CONFREQ [Closed] id 4 len 10
   *Mar 1 00:58:17.399: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 1 00:58:17.407: Se2 CDPCP: O CONFREQ [Closed] id 4 len 4
   *Mar 1 00:58:17.411: Se2 IPCP: I CONFREQ [REQsent] id 5 len 10
   *Mar 1.00:58:17.415: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 1 00:58:17.419: Se2 IPCP: O CONFACK [REQsent] id 5 len 10
   *Mar 1 00:58:17.423: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 1 00:58:17.527: Se2 IPCP: I CONFACK [ACKsent] id 4 len 10
   *Mar 1 00:58:17.531: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 1 00:58:17.535: Se2 IPCP: State is Open
   *Mar 1 00:58:17.543: Se2 LCP: I PROTREJ [Open] id 33 len 10 protocol 
   CDPCP (0x820701040004)
   *Mar 1 00:58:17.547: Se2 CDPCP: State is Closed
   *Mar 1 00:58:17.547: Se2 DDR: dialer protocol up
   *Mar 1 00:58:18.075: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2,
    changed state to up

   !--- Connection is successful. Backup link is now active.


   gaugin#show ip route 2.2.2.1
   Routing entry for 2.2.2.1/32
   Known via "connected", distance 0, metric 0 (connected, via interface)
   Routing Descriptor Blocks:
   * directly connected, via Serial2

   !--- The route for the peer uses the backup link.
   !--- Note the static route for primary link is removed
   !--- (since the link is down/down).

   Route metric is 0, traffic share count is 1

   gaugin#show dialer
   Se2 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Dial reason: ip (s=1.1.1.1, d=2.2.2.1)
   Time until disconnect 108 secs
   Connected to 8029
   
   Dial String Successes Failures Last     DNIS  Last status
   8029        4           0      00:01:00       successful
   
   gaugin#show interface serial 2
   Serial2 is up, line protocol is up 

   !--- Backup link is verified to be up.

   Hardware is CD2430 in async mode
   Interface is unnumbered. Using address of Loopback1 (1.1.1.1)
   MTU 1500 bytes, BW 115 Kbit, DLY 100000 usec,    ...   ...

   gaugin#ping 2.2.2.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 2.2.2.1, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 128/132/136 ms

Aquí está la misma llamada desde la perspectiva de la esfinge que recibió la llamada:

sphinx#
   00:57:29: TTY2: DSR came up

   !--- Modem DSR is first changed to up, indicating an incoming call.

   00:57:29: TTY2: destroy timer type 1
   00:57:29: TTY2: destroy timer type 0
   00:57:29: tty2: Modem: IDLE->(unknown)
   00:57:31: Se2 LCP: I CONFREQ [Closed] id 10 len 20
   
!--- Begin LCP negotiation
.
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: Se2 LCP: Lower layer not up, Fast Starting
   00:57:31: Se2 PPP: Treating connection as a callin
   00:57:31: Se2 PPP: Phase is ESTABLISHING, Passive Open
   00:57:31: Se2 LCP: State is Listen
   00:57:31: Se2 LCP: O CONFREQ [Listen] id 31 len 25
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:31: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: Se2 LCP: O CONFACK [Listen] id 10 len 20
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: %LINK-3-UPDOWN: Interface Serial2, 
   changed state to upDialer statechange 
   to up Serial2
   00:57:31: Serial2 DDR: Dialer received incoming call from <unknown>
   00:57:33: Se2 LCP: I CONFREQ [ACKsent] id 11 len 20
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: O CONFACK [ACKsent] id 11 len 20
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: TIMEout: State ACKsent
   00:57:33: Se2 LCP: O CONFREQ [ACKsent] id 32 len 25
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:33: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: I CONFACK [ACKsent] id 32 len 25
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:33: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:33: Se2 LCP: PFC (0x0702)
   0:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: State is Open
   
!--- LCP negotiation is complete.

   00:57:33: Se2 PPP: Phase is AUTHENTICATING, by this end
   00:57:33: Se2 CHAP: O CHALLENGE id 4 len 27 from "sphinx"
   00:57:33: Se2 CHAP: I RESPONSE id 4 len 27 from "gaugin"
   00:57:33: Se2 CHAP: O SUCCESS id 4 len 4

   !--- CHAP authentication is successful.

   00:57:33: Serial2 DDR:
   Authenticated host gaugin with no matching dialer map
   00:57:33: Se2 PPP: Phase is UP
   00:57:33: Se2 IPCP: O CONFREQ [Closed] id 5 len 10
   00:57:33: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   00:57:33: Se2 IPCP: I CONFREQ [REQsent] id 4 len 10
   00:57:33: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   00:57:33: Se2 IPCP: O CONFACK [REQsent] id 4 len 10
   00:57:33: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   00:57:33: Se2 CDPCP: I CONFREQ [Not negotiated] id 4 len 4
   00:57:33: Se2 LCP: O PROTREJ [Open] id 33 len 10 protocol CDPCP
   (0x820701040004)
   00:57:33: Se2 IPCP: I CONFACK [ACKsent] id 5 len 10
   00:57:33: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   00:57:33: Se2 IPCP: State is Open
   00:57:33: Serial2 DDR: dialer protocol up
   00:57:33: Se2 IPCP: Install route to 1.1.1.1

   !--- A route to the peer is installed.

   00:57:34: %LINEPROTO-5-UPDOWN: Line protocol on 
   Interface Serial2, changed state to up
   
!--- Backup link is up.


   sphinx#ping 1.1.1.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 132/142/152 ms

   sphinx#show ip route 1.1.1.1
   Routing entry for 1.1.1.1/32
   Known via "connected", distance 0, metric 0 (connected, via interface)
   Routing Descriptor Blocks:
   * directly connected, via Serial2

   !--- The floating static route is now installed.

   Route metric is 0, traffic share count is 1

   sphinx#show dialer

   Serial2 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Time until disconnect 119 secs (gaugin)

Ahora recomendemos el cable para el link primario. El link principal será movimiento de estado el up/up y el link de backup (el serial 2) será dado vuelta en el estado espera en el gaugin (puesto que tiene el comando backup interface serial 2). Esto hará el link de módem morir y el serial 2 de la interfaz en la esfinge a ir abajo también.

La siguiente depuración en gaugin muestra este proceso:

   gaugin#
   *Mar 1 00:59:38.859: %LINK-3-UPDOWN: Interface Serial0, changed state to up
   *Mar 1 00:59:39.875: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
   changed state to up
   
!--- Primary link is re-established.

   *Mar 1 00:59:59.315: TTY2: Async Int reset: Dropping DTR
   *Mar 1 01:00:00.875: TTY2: DSR was dropped
   *Mar 1 01:00:00.875: tty2: Modem: READY->(unknown)
   *Mar 1 01:00:01.315: %LINK-5-CHANGED: Interface Serial2, 
    changed state to standby mode

   !--- the backup link is returned to standby mode. 
   !--- The modem connection is terminated

   *Mar 1 01:00:01.331: Se2 IPCP: State is Closed
   *Mar 1 01:00:01.335: Se2 PPP: Phase is TERMINATING
   *Mar 1 01:00:01.335: Se2 LCP: State is Closed
   *Mar 1 01:00:01.339: Se2 PPP: Phase is DOWN
   *Mar 1 01:00:01.343: Se2 IPCP: Remove route to 2.2.2.1
   *Mar 1 01:00:01.883: TTY2: dropping DTR, hanging up
   *Mar 1 01:00:01.883: tty2: Modem: HANGUP->(unknown)
   *Mar 1 01:00:02.315: %LINEPROTO-5-UPDOWN: 
   Line protocol on Interface Serial2, changed state to down
   *Mar 1 01:00:02.899: TTY2: cleanup pending. Delaying DTR
   *Mar 1 01:00:03.927: TTY2: cleanup pending. Delaying DTR
   *Mar 1 01:00:04.323: TTY2: no timer type 0 to destroy
   *Mar 1 01:00:04.323: TTY2: no timer type 1 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 3 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 4 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 2 to destroy
   *Mar 1 01:00:04.331: Serial2: allowing modem_process to continue hangup!

La siguiente depuración muestra la misma transacción desde la perspectiva en sphinx.

   sphinx#
   00:58:54: %LINK-3-UPDOWN: Interface Serial0, changed state to up
   00:58:55: %LINEPROTO-5-UPDOWN: Line protocol on 
   Interface Serial0, changed state 
to up
   
!--- Primary link is brought up.

   00:59:16: TTY2: DSR was dropped

   !--- Modem connection is terminated by the peer.

   00:59:16: tty2: Modem: READY->(unknown)
   00:59:17: TTY2: dropping DTR, hanging up
   00:59:17: TTY2: Async Int reset: Dropping DTR
   00:59:17: tty2: Modem: HANGUP->(unknown)
   00:59:18: TTY2: cleanup pending. Delaying DTR
   00:59:19: %LINK-5-CHANGED: Interface Serial2, changed state to reset
   
!--- The Backup Interface (serial 2)is reset.

   00:59:19: Se2 IPCP: State is Closed
   00:59:19: Se2 PPP: Phase is TERMINATING
   00:59:19: Se2 LCP: State is Closed
   00:59:19: Se2 PPP: Phase is DOWN
   00:59:19: TTY2: cleanup pending. Delaying DTR
   00:59:19: Se2 IPCP: Remove route to 1.1.1.1
   
!--- The route to 1.1.1.1 using Serial 2 is removed since 
   !--- it is has a higher administrative distance of 2.

   00:59:20: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2, 
   changed state to down
   00:59:20: TTY2: cleanup pending. Delaying DTR
   00:59:21: TTY2: cleanup pending. Delaying DTR
   00:59:22: TTY2: destroy timer type 0
   00:59:22: TTY2: destroy timer type 1
   00:59:22: TTY2: destroy timer type 3
   00:59:22: TTY2: destroy timer type 4
   00:59:22: TTY2: destroy timer type 2
   00:59:22: Serial2: allowing modem_process to continue hangup
   00:59:22: TTY2: restoring DTR
   00:59:22: TTY2: autoconfigure probe started
   00:59:24: %LINK-3-UPDOWN: Interface Serial2, changed state to down
   00:59:24: Se2 LCP: State is Closed
   sphinx(config-if)#

Información Relacionada


Document ID: 14281