Marcado y acceso remotos : "Red digital de servicios integrados (ISDN), Señalización por canal asociado (CAS)"

Ejemplo de configuración ISDN - IP

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento facilita una configuración de muestra para ISDN con el uso del IP.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/14222/40.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

C2503
C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

!--- See the username explanation in the 
!--- Explanation of the C2503 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 172.16.10.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.1 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155551234
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155556789
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 408555432101 5554321
isdn spid2 408555987601 5559876
ppp authentication chap
!
router igrp 1
network 172.16.0.0
!
ip route 192.168.24.0 255.255.255.0 172.16.20.2
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

C4000
C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

!--- See the username explanation in the 
!--- Explanation of the C4000 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 192.168.24.65 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.2 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 415555123401 5551234
isdn spid2 415555678901 5556789
ppp authentication chap
!
router igrp 1
network 172.16.0.0
network 192.168.24.0
!
ip route 172.16.10.0 255.255.255.0 172.16.20.1
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

Explicación de la configuración C2503

C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

El nombre de usuario C4000 es el nombre del host del router remoto. El comando dialer map, que esta sección explica, utiliza este nombre de usuario. El nombre de usuario no es con diferenciación entre mayúsculas y minúsculas durante la autenticación. Sin embargo, el nombre que usted configura con el comando dialer map es con diferenciación entre mayúsculas y minúsculas. Usted debe hacer juego exactamente el nombre del host del router remoto, que es el "C4000".

Nota: En el router C2503, el nombre que usted configura con el comando username debe hacer juego exactamente el nombre que usted configura con el comando dialer map. Usted publica el comando username en el modo de configuración global.

El proceso de autenticación del Challenge Handshake Authentication Protocol (CHAP) utiliza la contraseña. La contraseña es con diferenciación entre mayúsculas y minúsculas y debe hacer juego la contraseña del router remoto exactamente.

Nota: Para evitar la confusión, este ejemplo de configuración utiliza la forma no encriptada de la palabra clave Cisco. En la configuración real, la contraseña aparece en su forma encriptada: 7 13061E010803. En esta contraseña, 7 denota el tipo de encripción y 13061E010803 es la forma encriptada de la palabra clave Cisco. Cuando usted publica o realiza los cambios al comando username, ingrese la contraseña en su forma no encriptada y no ingrese siempre el tipo de encripción (7). Fijan al tipo de encripción automáticamente.

  • tipo de switch basic-dms100 isdn — El tipo del switch de ISDN debe hacer juego el equipo de su portador. Si usted cambia el tipo de switch, usted debe recargar al router para que el nuevo tipo de switch tome el efecto.

    interface Ethernet0
    ip address 172.16.10.1 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.1 255.255.255.0
  • encapsulación ppp — Utilice la encapsulación PPP en vez del High-Level Data Link Control (HDLC) para permitir el uso de la autenticación CHAP.

  • ancho de banda 56 — La configuración de ancho de banda predeterminado para una interfaz BRI es 64 kbps. Si usted configura sus sentencias de correspondencia de dialer con la opción del speed 56, incluya la sentencia de ancho de banda.

    Nota: Este comando no controla la velocidad de su línea ISDN. Los comandos estableces el punto de referencia correcto para:

    • Las estadísticas de la interfaz de la demostración del puerto BRI

    • El comando dialer load-threshold

    • Métricas de ruteo del (EIGRP) del Interior Gateway Routing Protocol (IGRP) /Enhanced IGRP

  • ocioso-descanso 300 del marcador — Este comandos estableces el número de segundos que la conexión ISDN sigue siendo abierta si no se está ruteando ningún tráfico interesante. El temporizador se reajusta cada vez que un paquete interesante se remite.

  • el speed 56 del nombre C4000 de 172.16.20.2 del IP del mapa de marcador transmite 14155551234

    el speed 56 del nombre C4000 de 172.16.20.2 del IP del mapa de marcador transmite 14155556789

    Utilice el comando dialer map con la autenticación CHAP para poner la llamada inicial al router remoto cuando el tráfico interesante se remite a la interfaz BRI. Cuando la conexión llega a ser activa, el comando dialer idle-timeout determina la longitud del tiempo para que la conexión siga siendo activo. Una sentencia de correspondencia de dialer es necesaria para cada número de teléfono ISDN que sea llamado. Sin embargo, sea consciente que dos sentencias de correspondencia de dialer que la punta a la misma ubicación puede activar ambos canales B cuando usted puede querer solamente utilizar un canal.

    Los parámetros de comando para este ejemplo son:

    • 172.16.20.2 — La dirección IP de la interfaz BRI del router remoto

      Para determinar este direccionamiento, publique el comando show interface bri 0 en el prompt de consola del router remoto.

    • nombre C4000 — El nombre del host del router remoto

      El nombre es con diferenciación entre mayúsculas y minúsculas y debe hacer juego el nombre que usted configura para el comando username.

    • speed 56 — Fija la velocidad del dialer a 56 kbps para los circuitos ISDN que no son 64 End to End del kbps

      Incluya este parámetro en las sentencias de correspondencia de dialer de ambo Routers. La mayoría de las instalaciones en Norteamérica se deben configurar para 56 kbps.

    • broadcast — Permite el reenvío de paquetes de broadcast

      A menos que el comando dialer-list especifique los paquetes de broadcast como paquetes interesantes, los paquetes se remiten solamente cuando el link ISDN es activo.

    • 14155551234 y 14155556789 — Los números de teléfono de ISDN del router remoto

  • control-cola 5 del marcador — Este comando permite que los paquetes interesantes sean hechos cola hasta el establecimiento de la conexión ISDN. En este ejemplo, cinco paquetes interesantes deben ser hechos cola.

  • umbral de carga 100 del marcador — Este comando configura el ancho de banda a pedido. Los comandos estableces la carga máxima antes del marcador ponen otra llamada a través del segundo canal B. La carga es el valor de la carga promedio y ponderada para la interfaz, donde 1 es descargada y 255 es completamente cargada El valor de carga real a configurar depende de las características de su red determinada. En este ejemplo, se activa el segundo canal B cuando la carga alcanza el 39 por ciento del uso máximo, que es 100 divididos por 255.

  • marcador-grupo 1El comando dialer-group 1 habilita la lista del dialer 1 en la interfaz BRI, que determina qué paquetes son interesantes y activarán la conexión ISDN.

  • isdn spid2 408555432101 5554321

    isdn spid2 408555987601 5559876

    Utilice los comandos isdn spid si su portador asigna los identificadores del perfil de servicio (SPID) a sus líneas ISDN.

  • grieta de la autenticación PPP — Este comando habilita la autenticación CHAP.

    router igrp 1 
    network 172.16.0.0
  • ruta de IP 192.168.24.0 255.255.255.0 172.16.20.2 — Este comando ip route crea una Static ruta a la red del router remoto vía la interfaz BRI del router remoto. Esto es un requisito porque se pierden las rutas dinámico cuando el link ISDN está abajo.

    Los parámetros de comando para este ejemplo son:

    • 192.168.24.0 — La red objetivo

    • 255.255.255.0 — La máscara de la red objetivo

      255 en una posición del octeto especifica que un exacto - haga juego para ese octeto es necesario. El A0 en una posición del octeto especifica que cualquier valor hace juego.

    • 172.16.20.2 — El direccionamiento del salto siguiente que se puede utilizar para alcanzar la red objetivo

  • access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    IP 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 del permiso de la lista de acceso 100 — este comando access-list determina que los paquetes IP son interesantes y activarán el link ISDN. La lista de acceso a crear depende de su diseño de red particular.

    la lista de acceso 100 niega el IP 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0 — este comando access-list define todos los paquetes de broadcast como sin interés.

    IP 0.0.0.0 255.255.255.255 0.0.0.0255.255.255.255 del permiso de la lista de acceso 100 — este comando access-list define el resto de los paquetes IP como interesantes.

  • lista 100 del dialer-list 1 — Este comando señala a la lista de acceso 100, que determina que los paquetes IP son interesantes.

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

Explicación de la configuración C4000

C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

El nombre de usuario C2503 es el nombre del host del router remoto. El comando dialer map, que esta sección explica, utiliza este nombre de usuario. El nombre de usuario no es con diferenciación entre mayúsculas y minúsculas durante la autenticación. Sin embargo, el nombre que usted configura con el comando dialer map es con diferenciación entre mayúsculas y minúsculas. Usted debe hacer juego exactamente el nombre del host del router remoto, que es el "C2503".

Nota: En el router C4000, el nombre que usted configura con el nombre de usuario debe hacer juego exactamente el nombre que usted configura con el comando dialer map. Usted publica el comando username en el modo de configuración global.

El proceso de autenticación CHAP utiliza la contraseña. La contraseña es con diferenciación entre mayúsculas y minúsculas y debe hacer juego la contraseña del router remoto exactamente.

Nota: Para evitar la confusión, este ejemplo de configuración utiliza la forma no encriptada de la palabra clave Cisco. En la configuración real, la contraseña aparece en su forma encriptada: 7 13061E010803. En esta contraseña, 7 denota el tipo de encripción y 13061E010803 es la forma encriptada de la palabra clave Cisco. Cuando usted publica o realiza los cambios al comando username, ingrese la contraseña en su forma no encriptada y no ingrese siempre el tipo de encripción (7). Fijan al tipo de encripción automáticamente.

  • tipo de switch basic-dms100 isdn — El tipo del switch de ISDN debe hacer juego el equipo de su portador. Si usted cambia el tipo de switch, usted debe recargar al router para que el nuevo tipo de switch tome el efecto.

    interface Ethernet0
    ip address 192.168.24.65 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.2 255.255.255.0
    
    encapsulation ppp
  • encapsulación ppp — Utilice la encapsulación PPP en vez del HDLC para permitir el uso de la autenticación CHAP.

  • ancho de banda 56 — La configuración de ancho de banda predeterminado para una interfaz BRI es 64 kbps. Si usted configura sus sentencias de correspondencia de dialer con la opción del speed 56, incluya la sentencia de ancho de banda.

    Nota: Este comando no controla la velocidad de su línea ISDN. Los comandos estableces el punto de referencia correcto para:

    • Las estadísticas de la interfaz de la demostración del puerto BRI

    • El comando dialer load-threshold

    • Métricas de ruteo IGRP/EIGRP

  • ocioso-descanso 300 del marcador — Este comandos estableces el número de segundos que la conexión ISDN sigue siendo abierta si no se está ruteando ningún tráfico interesante. El temporizador se reajusta cada vez que un paquete interesante se remite.

    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876 

    Utilice el comando dialer map con la autenticación CHAP para poner la llamada inicial al router remoto cuando el tráfico interesante se remite a la interfaz BRI. Cuando la conexión llega a ser activa, el comando dialer idle-timeout determina la longitud del tiempo para que la conexión siga siendo activo. Una sentencia de correspondencia de dialer es necesaria para cada número de teléfono ISDN que sea llamado. Sin embargo, sea consciente que dos sentencias de correspondencia de dialer que la punta a la misma ubicación puede activar ambos canales B cuando usted puede querer solamente utilizar un canal.

    Los parámetros de comando para este ejemplo son:

    • 172.16.20.1 — La dirección IP de la interfaz BRI del router remoto

      Para determinar este direccionamiento, publique el comando show interface bri 0 en el prompt de consola del router remoto.

    • nombre C2503 — El nombre del host del router remoto

      El nombre es con diferenciación entre mayúsculas y minúsculas y debe hacer juego el nombre que usted configura para el comando username.

    • speed 56 — Fija la velocidad del dialer a 56 kbps para los circuitos ISDN que no son 64 End to End del kbps

      Incluya este parámetro en las sentencias de correspondencia de dialer de ambo Routers. La mayoría de las instalaciones en Norteamérica se deben configurar para 56 kbps.

    • broadcast — Permite el reenvío de paquetes de broadcast

      A menos que el comando dialer-list especifique los paquetes de broadcast como paquetes interesantes, los paquetes se remiten solamente cuando el link ISDN es activo.

    • 14085554321 y 14085559876 — Los números de teléfono de ISDN del router remoto

  • control-cola 5 del marcador — Este comando permite que los paquetes interesantes sean hechos cola hasta el establecimiento de la conexión ISDN. En este ejemplo, cinco paquetes interesantes deben ser hechos cola.

  • umbral de carga 100 del marcador — Este comando configura el ancho de banda a pedido. Los comandos estableces la carga máxima antes del marcador ponen otra llamada a través del segundo canal B. La carga es el valor de la carga promedio y ponderada para la interfaz, donde 1 es descargada y 255 es completamente cargada El valor de carga real a configurar depende de las características de su red determinada. En este ejemplo, se activa el segundo canal B cuando la carga alcanza el 39 por ciento del uso máximo, que es 100 divididos por 255.

  • marcador-grupo 1El comando dialer-group 1 habilita la lista del dialer 1 en la interfaz BRI, que determina qué paquetes son interesantes y activarán la conexión ISDN.

  • isdn spid2 415555123401 5551234

    isdn spid2 415555678901 5556789

    Utilice los comandos isdn spid si su portador asigna los SPID a sus líneas ISDN.

  • grieta de la autenticación PPP — Este comando habilita la autenticación CHAP.

    router igrp 1
    network 172.16.0.0
    network 192.168.24.0
  • ruta de IP 172.16.10.0 255.255.255.0 172.16.20.1 — Este comando ip route crea una Static ruta a la red del router remoto vía la interfaz BRI del router remoto. Esto es un requisito porque se pierden las rutas dinámico cuando el link ISDN está abajo.

    Los parámetros de comando para este ejemplo son:

    • 172.16.0.0 — La red objetivo

    • 255.255.0.0 — La máscara de la red objetivo

      255 en una posición del octeto especifica que un exacto - haga juego para ese octeto es necesario. El A0 en una posición del octeto especifica que cualquier valor hace juego.

    • 172.16.20.1 — El direccionamiento del salto siguiente que se puede utilizar para alcanzar la red objetivo

  • access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    IP 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 del permiso de la lista de acceso 100 — este comando access-list determina que los paquetes IP son interesantes y activarán el link ISDN. La lista de acceso a crear depende de su diseño de red particular.

    la lista de acceso 100 niega el IP 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0 — este comando access-list define todos los paquetes de broadcast como sin interés.

    IP 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 del permiso de la lista de acceso 100 — este comando access-list define el resto de los paquetes IP como interesantes.

  • lista 100 del dialer-list 1 — Este comando señala a la lista de acceso 100, que determina que los paquetes IP son interesantes.

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 14222