WAN : Protocolos X.25

Traducción de X.25 a TCP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El XOT (X.25 sobre el TCP) es diseñado por Cisco Systems, y detallado en la Solicitud de comentarios (RFC) 1613, de transportar el X.25 sobre el internets IP. Esto permite que los paquetes X.25 se envíen sobre una red de Protocolo de control de transmisión /Protocolo de Internet (TCP/IP) en lugar de un link de proceso de acceso a link equilibrado (LAPB). El XOT es un método de enviar los paquetes X.25 sobre el internets IP con la encapsulación del paquete X.25 llano en los paquetes TCP.

Este documento presenta una configuración de muestra que ilustre estas dos traducciones:

  • Transmission Control Protocol (TCP) a la traducción X.25.

  • Traducción de x.25 a TCP.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Esta traducción requiere al conjunto de características para empresas, que se soporta solamente en las plataformas del router de Cisco 26xx y arriba.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/14216/x25_tcptrans1.gif

Como se muestra aquí, los links continuos se utilizan entre el Routers 1 y 2 y entre el Routers 2 y 3.

Configuraciones

En este documento, se utilizan estas configuraciones:

  • Router1

  • Router2

  • Router3

Nota: Hemos truncado las configuraciones siguientes para visualizar la información pertinente.

Router1
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
interface Serial0
 description DCE connection to s1 Router2
 ip address 10.0.0.6 255.255.255.252
 no ip mroute-cache
 clockrate 56000
!
ip route 192.168.7.0 255.255.255.0 10.0.0.5                                             

Router2
version 12.1
service timestamps debug datetime msec                                                  
service timestamps log datetime msec
!
hostname Router2
!
x25 routing
!
interface Loopback0
 ip address 192.168.7.1 255.255.255.0
!
interface Serial0
 description DCE connection to s1 Router3
 encapsulation x25 dce
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 description DTE connection to s0 Router1
 ip address 10.0.0.5 255.255.255.252
!
x25 route 123 interface Serial0
!
translate tcp 192.168.7.2 x25 123
translate x25 345 tcp 10.0.0.6

Router3
Router3#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
hostname Router3
!
ip subnet-zero
!
x25 routing
!
interface Serial1
 description DTE connection to s0 Router2
 encapsulation x25
 x25 address 123
!
x25 route 345 interface Serial1                                                         

Verificación

Utilice los siguientes comandos de probar que su red está actuando correctamente:

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • debug de la demostración — le permite para visualizar una variedad de información del debug, o para realizar las actividades de Troubleshooting específicas.

  • telnet 192.168.7.2 — conecta con los sistemas informáticos en Internet en el modo de prompt.

  • la pista 345 — le registra encendido a una PISTA.

  • muestre el VC X.25 — información de las visualizaciones sobre los Switched Virtual Circuit activos (SVC), y los circuitos virtuales permanentes (PVC) en el modo EXEC privilegiado.

La salida mostrada en las pruebas abajo es un resultado de ingresar estos comandos en los dispositivos mostrados en el diagrama de la red arriba. El resultado muestra que la red está funcionando correctamente.

Prueba 1: Traducción de TCP a X.25

En esta prueba, realizamos a una sesión telnet del router1 a la dirección IP del router2:

  1. Telnet 192.168.7.2 del router1.

    Nota: Este direccionamiento pertenece a la red 192.168.7.0 /24 en el router2. Este direccionamiento no se debe asignar a ningún otro sistema en la red.

  2. El router2 hace una traducción de TCP a X.25 para alcanzar el router3. A continuación se muestran los resultados.

Router2#show debug 
   TCP: 
     TCP special event debugging is on 
   X.29 PAD: 
     X25 PAD debugging is on 
   X.25: 
     X.25 special event debugging is on 
   Protocol translation: 
     Protocol Translation debugging is on 
   Router2#
 
Router1#telnet 192.168.7.2 
   Trying 192.168.7.2 ... Open 
   Trying 123...Open 
    User Access Verification 
    Password: 
   Router3>

Router2# 
   *Mar  1 01:50:28.759: TCP0: state was LISTEN -> SYNRCVD [23 -> 10.0.0.6(11007)]    
   *Mar  1 01:50:28.763: TCB00499CAC setting property TCP_TOS (11) C0094 
   *Mar  1 01:50:28.767: tcppad2: fork started 
   *Mar  1 01:50:28.767: TCP: sending SYN, seq 3338770911, ack 4026886977    
   *Mar  1 01:50:28.771: TCP2: Connection to 10.0.0.6:11007, advertising MSS 1460 
   *Mar  1 01:50:28.775: TCP2: Connection to 10.0.0.6:11007, received MSS 556, MSS is 556 
   *Mar  1 01:50:28.791: TCP2: state was SYNRCVD -> ESTAB [23 -> 10.0.0.6(11007)]    
   *Mar  1 01:50:28.803: pad_open_connection: found a valid route 
   *Mar  1 01:50:28.807: Serial0: X.25 O R1 Call (11) 8 lci 1 
   *Mar  1 01:50:28.811: From (0):  To (3): 123 
   *Mar  1 01:50:28.811: Facilities: (0) 
   *Mar  1 01:50:28.815: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:50:28.827: Serial0: X.25 I R1 Call Confirm (5) 8 lci 1 
   *Mar  1 01:50:28.831: From (0):  To (0): 
   *Mar  1 01:50:28.835: Facilities: (0) 
   *Mar  1 01:50:28.835: PAD2: Call completed 
   *Mar  1 01:50:28.839: PAD2: Control packet received. 
   *Mar  1 01:50:28.851: PAD2: Input X29 packet type 4 (Read X.3 param) len 1 
   *Mar  1 01:50:28.855: PAD2: Output X29 packet type 0 (Parameter indication) len 45 
       1:1, 2:1, 3:2, 4:1, 5:0, 6:0, 7:4, 
       8:0, 9:0, 10:0, 11:14, 12:0, 13:0, 14:0, 15:0, 
       16:127, 17:21, 18:18, 19:0, 20:0, 21:0, 22:0, 
   *Mar  1 01:50:28.879: PAD2: Control packet received. 
   *Mar  1 01:50:28.883: PAD2: Input X29 packet type 6 (Set and Read) len 9 
       2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:50:28.887: tcppad2: Sending WILL ECHO 
   *Mar  1 01:50:28.891: PAD2: Output X29 packet type 0 (Parameter indication) len 9 
       2:0, 4:1, 15:0, 7:21,

Router2#show x25 vc
   SVC 1, State: D1, Interface: Serial0 
     Started 00:00:25, last input 00:00:22, output 00:00:22  
  Line: 2 vty 0 Location: Host: 10.0.0.6    
      connected to 123 PAD <--> X25  
  Window size input: 2, output: 2 
     Packet size input: 128, output: 128 
     PS: 5  PR: 4  ACK: 4  Remote PR: 5 RCNT: 0 RNR: no 
     P/D state timeouts: 0  timer (secs): 0 
     data bytes 57/62 packets 5/4 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
   Router2# 

Prueba 2: Traducción de X.25 a TCP

En esta prueba, comenzamos una sesión del ensamblador/desensamblador de paquetes (PAD) del router3 al direccionamiento X.25 del router2:

  1. Haga una PISTA a 345 del router3.

  2. El router2 hace traducción de x.25 a TCP para alcanzar el router1. A continuación se muestran los resultados.

Router2#show debug 
   TCP: 
     TCP special event debugging is on 
   X.29 PAD: 
     X25 PAD debugging is on 
   X.25: 
     X.25 special event debugging is on 
   Protocol translation: 
     Protocol Translation debugging is on 
   Router2# 

Router3#pad 345 
   Trying 345...Open 
   Trying 10.0.0.6 ... Open 
    User Access Verification 
    Password: CCCC 
   Router1> 
      
Router2# 
   *Mar  1 01:51:31.475: Serial0: X.25 I R1 Call (12) 8 lci 1024 
   *Mar  1 01:51:31.479: From (3): 123 To (3): 345 
   *Mar  1 01:51:31.483: Facilities: (0) 
   *Mar  1 01:51:31.483: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:51:31.487: PAD: translate call to 345 
   *Mar  1 01:51:31.491: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:51:31.495: PAD: Creating proto translation on tty2 for vc 1024    
   *Mar  1 01:51:31.499: Serial0: X.25 O R1 Call Confirm (5) 8 lci 1024 
   *Mar  1 01:51:31.503: From (0):  To (0): 
   *Mar  1 01:51:31.503: Facilities: (0) 
   *Mar  1 01:51:31.507: PAD2: Call completed 
   *Mar  1 01:51:31.511: padtcp2: fork started 
   *Mar  1 01:51:31.515: PAD2: Output X29 packet type 4 (Read X.3 param) len 1 
   *Mar  1 01:51:31.523: TCB0049E7A4 created 
   *Mar  1 01:51:31.523: TCB0049E7A4 setting property TCP_TOS (11) 49C853    
   *Mar  1 01:51:31.527: TCB0049E7A4 bound to UNKNOWN.44034 
   *Mar  1 01:51:31.531: PAD2: Control packet received. 
   *Mar  1 01:51:31.531: TCP: sending SYN, seq 3401534831, ack 0 
   *Mar  1 01:51:31.535: TCP2: Connection to 10.0.0.6:23, advertising MSS 1460 
   *Mar  1 01:51:31.539: TCP2: state was CLOSED -> SYNSENT [44034 -> 10.0.0.6(23)]    
   *Mar  1 01:51:31.559: TCP2: state was SYNSENT -> ESTAB [44034 -> 10.0.0.6(23)]    
   *Mar  1 01:51:31.563: TCP2: Connection to 10.0.0.6:23, received MSS 1460, MSS is 1460 
   *Mar  1 01:51:31.567: TCB0049E7A4 connected to 10.0.0.6.23 
   *Mar  1 01:51:31.571: PAD2: Input X29 packet type 0 (Parameter indication) len 45 
       1:1, 2:1, 3:2, 4:1, 5:0, 6:0, 7:4, 
       8:0, 9:0, 10:0, 11:14, 12:0, 13:0, 14:0, 15:0, 
       16:127, 17:21, 18:18, 19:0, 20:0, 21:0, 22:0, 
   *Mar  1 01:51:31.583: PAD2: Setting ParamsIn, length 44 
   *Mar  1 01:51:31.587: PAD2: Output X29 packet type 6 (Set and Read) len 9 
       2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:51:31.599: PADTCP2: Telnet received WILL ECHO (1) 
   *Mar  1 01:51:31.599: PAD2: Control packet received. 
   *Mar  1 01:51:31.607: PADTCP2: Telnet received DO TTY-TYPE (24) 
   *Mar  1 01:51:31.611: PAD2: Output X29 packet type 6 (Set and Read) len 3 2:0, 
   *Mar  1 01:51:31.619: PAD2: Input 
   *Mar  1 01:51:31.619: PAD2: Control packet received.X29 packet type 0 
       (Parameter indication) len 9 2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:51:31.627: PAD2: Setting ParamsIn, length 8 
   *Mar  1 01:51:31.631: PAD2: Input X29 packet type 0 (Parameter indication) len 3 2:0, 
   *Mar  1 01:51:31.635: PAD2: Setting ParamsIn, length 2 
   *Mar  1 01:51:31.643: PADTCP2: Telnet received DONT TTY-LOCATION (23) 
   *Mar  1 01:51:31.647: PADTCP2: Telnet received DONT TTY-SPEED (32) 
   Router2#  

Router2#show x25 vc 
   SVC 1024,  State: D1,  Interface: Serial0 
     Started 00:00:10, last input 00:00:07, output 00:00:05  
  Line: 2   vty 0    Location:  Host: 123    
     123 connected to 345 PAD <--> X25  
  Window size input: 2, output: 2 
     Packet size input: 128, output: 128 
     PS: 1  PR: 6  ACK: 6  Remote PR: 1  RCNT: 0  RNR: no 
     P/D state timeouts: 0  timer (secs): 0 
     data bytes 3057/60 packets 33/6 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0    
   Router2# 
   Router2# 

Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 14216