WAN : Protocolos X.25

Configurar a un router como PISTA para el XOT a un Host asíncrono

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento presenta una configuración de muestra en la cual un host remoto conecte con el X.25 sobre una red del Transmission Control Protocol (TCP) en una línea de marcado manual del Public Switched Telephone Network (PSTN). El host no envía ni recibe ninguna paquetes X.25. Sin embargo, el router remoto que conecta actúa como un ensamblador/desensamblador de paquetes (PAD) X.25 y encapsula y paquetes de los decapsulates X.25 para el host.

Nota: Esto se refiere como “pista reversa”, mientras que la llamada X.25 se puede establecer solamente del dispositivo X.25 (servidor) al Host asíncrono, no vice versa. La pista delantera requiere una diversa configuración.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Las mejoras a las funciones relacionado a PAD que podemos utilizar en los servicios de la Traducción de protocolo fueron introducidas en el Software Release 11.2 de Cisco IOS�.

Las Plataformas siguientes soportan las mejoras de la PISTA:

  • Cisco 2500 Series Router

  • Cisco 26xx Series Router

  • Cisco 36xx Series Router

  • Cisco 4000 Router

  • Cisco 4500 Router

  • Cisco 4700 Router

  • Series Router del Cisco AS5200

  • Cisco 7000 Series Router

  • Cisco 7200 Series Routers

  • Cisco 7500 Series Router

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Antecedentes

La PISTA sobre el X.25 por TCP (XOT) habilita las llamadas PAD a los destinos que no son accesibles sobre las interfaces físicas X.25, pero sobre los túneles TCP. Esta función habilita las llamadas PAD que originan de un router en un link IP para alcanzar un dispositivo X.25. El PAD over XOT también habilita las conexiones XOT entrantes de un link IP que se validará como conexiones de la PISTA o de la Traducción de protocolo en el router local.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/14188/netdiag1.jpg

Configuraciones

En este documento, se utilizan estas configuraciones:

Router Remoto
Current configuration:
!
version 12.0
 service pad from-xot                   

!---used for allowing incoming xot to pad connection

 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
!OPTIONAL
x29 profile default 2:0, 4:1, 15:0, 7:21 

!---apply customized x29 profile as default to all incoming connections

!
hostname Remote
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
interface Serial0
 ip address 10.10.100.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 ip address 10.10.175.1 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 10.10.10.42 255.255.255.0
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^100 xot 10.10.100.1
 x25 host remote 250                 
!---map the x25 address of 25099 to the router's
hostname
!
line con 0
 no exec
 exec-timeout 0 0
 transport input none
line aux 0                     

!---to async host

 no exec
 modem InOut
 rotary 99                   

!---enable reverse PAD

 transport input pad
 flowcontrol hardware
line vty 0 4
 login local
!

Router Principal
Current configuration:
!
version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
hostname Main
!
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
!
!
interface Serial0
 ip address 10.10.100.1 255.255.255.0
 no ip directed-broadcast
 clockrate 800000
!
interface Serial1
 no ip directed-broadcast
 encapsulation x25 dce
 x25 address 150
 clockrate 56000
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^250 xot 10.10.100.2
 x25 route ^100 interface Serial1
!
line con 0
 transport input none
 line aux 0
 line vty 0 4
 login local
!
no scheduler allocate
end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

  • debug x25 event — Información de las visualizaciones sobre todo el tráfico X.25 o una clase de servicio específica X.25.

  • pista del debug — Mensajes del debug de las visualizaciones para todas las conexiones de la PISTA.

Visualizan a la salida de los debugs siguiente para una llamada acertada X.25 del servidor al host. Ejecutamos estos comandos debug encendido en el router remoto.

Remote#debug x25 events
Remote#debug pad
WORKING CALL
2d01h: pad_ctxt_up: id 808D6F18, reason 80742B9C (event 0, impetus 10)
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT I P/Inactive Call (20) 8
lci 1
2d01h:   From (5): 10006 To (5): 25099
2d01h:   Facilities: (6)
2d01h:     Packet sizes: 128 128
2d01h:     Window sizes: 2 2
2d01h:   Call User Data (4): 0x01000000 (pad)
2d01h: PAD: incoming call to 25099 on line 5 CUD length 4
2d01h: PAD: Creating TTY daemon on tty5 for vc 1
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT O P3 Call Confirm (5) 8
lci 1
2d01h:   From (0):  To (0):
2d01h:   Facilities: (0)
2d01h: PAD5: Call completed
2d01h: PAD5: Output X29 packet type 4 (Read X.3 param) len 1
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 45
1:1, 2:1, 3:2, 4:0, 5:0, 6:5, 7:2,
8:0, 9:0, 10:0, 11:14, 12:1, 13:4, 14:0, 15:1,
16:8, 17:24, 18:18, 19:2, 20:255, 21:7, 22:0,
2d01h: PAD5: Setting ParamsIn, length 44
2d01h: PAD5: Output X29 packet type 6 (Set and Read) len 9 2:0, 4:1,
15:0,7:21,
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 9 2:0,
4:1, 15:0, 7:21,

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 14188