Voz : CCS Digital

VoIP con el Common Channel Signaling (CCS)

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido

CCS
CAS

Introducción

Este documento ilustra las configuraciones necesarias para el dos Routers en este documento comunicar vía la voz sobre IP (VoIP) y el Common Channel Signaling (CCS) sobre un PRI digital.

Es importante observar que en esta configuración, el dos Routers está conectado continuamente sobre segmento de IP. En la mayoría de las topologías sin embargo, el Routers activado mediante la voz puede existir dondequiera. Normalmente, los routers de voz están conectados mediante conectividad LAN a otros routers que se encuentran conectados a la WAN. Esto es importante observar porque si su Routers de la Voz no está conectado sobre una línea arrendada, configuran a todos los comandos configuration de la conectividad WAN en eso Routers que esté conectado con WAN, y no en el Routers de la Voz, pues están en las configuraciones en este documento.

Mientras que utilizan a un Cisco 3640 Router y a un Cisco AS5300 Router en este ejemplo de configuración, estas configuraciones se pueden también utilizar para los Cisco 2600 Series Router.

prerrequisitos

Requisitos

Antes de que usted pueda configurar a su router Cisco para utilizar el VoIP, es el mejor si usted entiende los conceptos de características del Calidad de Servicio (QoS) en el software del ½ del ¿Â de Cisco IOSïÂ. Para aprender más sobre las características de QoS, refiera a los Datos en espera, modelado de tráfico, y filtración y Señalización de QoS de la página de QoS del Cisco IOS en el cisco.com.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 2600 y 3640 Series Router

  • AS5300 de Cisco

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Señalización T1: CAS y CCS

La señalización en el mundo de la telefonía proporciona las funciones tales como supervisión y publicidad de la línea estatus, alertando los dispositivos cuando una llamada está intentando conectar, y el rutear y información de direccionamiento.

Hay dos diversos tipos de información de señalización dentro del mundo T1:

  • CCS

  • Señalización asociada al canal (CAS)

CCS

El CCS es la transmisión de la banda de la información de los de la información de señalización. La forma más notable y más ampliamente utilizada de este tipo de señalización es ISDN. Una desventaja al uso de un ISDN PRI es el retiro de un DS0, o canal de voz. En este caso, para señalar el uso. Por lo tanto, un T1 tendría veintitrés DS0s, o los Canales B para los datos del usuario, y un DS0, o canal D para señalar. Es posible a los PRI múltiples de control con un solo canal D con cada uno usando no la señalización asociada del recurso (NFAS). Por lo tanto, usted puede configurar los otros PRI en el grupo NFAS para utilizar los veinticuatro DS0s como Canales B. El uso de la Señalización de PRI asegura las velocidades de conexión posibles máximas, especialmente con la llegada de los módems 56K. Esto ilustra la capacidad de canal despejado del ISDN.

Otra desventaja de usar el CCS (como se ve en el diagrama de la red) es que el PBX necesita un indicador luminoso LED amarillo de la placa muestra gravedad menor digital del T1 PRI, que es más costoso que un indicador luminoso LED amarillo de la placa muestra gravedad menor de la señalización de E&M. Un indicador luminoso LED amarillo de la placa muestra gravedad menor de la señalización de E&M se utiliza en el mismo diagrama de la red si usted ejecuta CAS entre el AS5300 y el PBX.

CAS

CAS es la transmisión de la información de señalización dentro de la banda de la información, o señalización dentro de la banda. Esto significa que las señales de voz viajan en los mismos circuitos que la línea estatus, direccionamiento, y señales que alertan. Pues hay veinticuatro canales en línea T1 completa, los entrelazados de CAS que señalan los paquetes dentro de los paquetes de voz. Por lo tanto, hay los veinticuatro canales completos a utilizar para la Voz.

Los diversos tipos de señalización de CAS están disponibles en el mundo T1. Las formas mas comunes de señalización de CAS son loopstart, groundstart, y señalización de E&M. La desventaja más grande de la señalización de CAS es que los bits de los usos de la red de los paquetes del IP de la información, tales como paquetes de voz, realizar las funciones de señalización. La señalización de CAS se refiere así a menudo como señalización de bits robada.

CAS no es la opción óptima cuando una intenta alcanzar las velocidades de conexión más altas posible con los módems. La mayoría de los módems pueden ajustar a la calidad de la señal y todavía dar las conexiones confiables de alta velocidad. Sin embargo, el uso de los módems 56K en CAS alinea los descensos las velocidades de la conexión por casi 2 K en la dirección descendente de la comunicación por tronco que utiliza la señalización de CAS.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/14079/voip_pri_cookbook_topo.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

San José del Cisco 3640
sanjose3640A#show run
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3640
!
logging buffered 60000 debugging
enable password cisco
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 3/0/0
 operation 4-wire
!
voice-port 3/0/1
 operation 4-wire
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer voice 1 pots     

!--- More on dial peers.

 destination-pattern 4552468
 port 1/0/1
!
dial-peer voice 2 voip
 destination-pattern 3006
 session target ipv4:10.2.1.2
!
dial-peer voice 3 pots
 destination-pattern 5551234
 port 1/0/0
!
dial-peer voice 4 voip
 destination-pattern 4005
 fax-rate 9600
 session target ipv4:10.2.1.2
!
interface Ethernet0/0
 ip address 10.2.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 64000
!
interface Serial2/1
 no ip address
 no ip directed-broadcast
 shutdown
 clockrate 38000
!
interface Serial2/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial2/3
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

Raleigh del Cisco AS5300
AS5300#show run
Building configuration...
 
Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS5300
!
boot system flash c5300-js-mz_113-6_na2.bin
enable password cisco
!
isdn switch-type primary-dms100
!
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 clock source internal
!
controller T1 2
 clock source internal
!
controller T1 3
 clock source internal
!
!
dial-peer voice 1 voip           

!--- More on dial peers.

 destination-pattern 4552468
 session target ipv4:10.2.1.1
!
dial-peer voice 2 pots
 destination-pattern 3...
 direct-inward-dial
 port 0:D
 prefix 3
!
dial-peer voice 4 pots
 destination-pattern 4...
 direct-inward-dial
 port 0:D
 prefix 4
!
dial-peer voice 3 voip
 destination-pattern 5551234
 fax-rate 9600
 session target ipv4:10.2.1.1
!
!
voice-port 0:D
!
interface Ethernet0
 ip address 10.2.1.2 255.255.255.0
!
interface Serial0:23
 no ip address
 isdn switch-type primary-dms100
 isdn tei-negotiation first-call
 isdn incoming-voice modem
 no cdp enable
!
interface FastEthernet0
 no ip address
 shutdown
!
ip classless
!
logging buffered 60000 debugging
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

  • haga el debug del inout del ccapi del voip — Utilizado para localizar el trayecto de ejecución a través del control de llamada API, que sirve como la interfaz entre la aplicación de la sesión de llamada y el software red-específico subyacente. Usted puede utilizar la salida de este comando de entender cómo las llamadas son manejadas por el router.

  • vpm todo del debug — Utilizado para habilitar todos los comandos debug vpm: haga el debug del spi del vpm, la señal del vpm del debug, y el debug vpm dsp.

    Nota: Este debug genera mucha salida.

  • muestre la voz activa de la llamada — Utilizado para visualizar el contenido de la tabla de llamada activa, que muestra todas las llamadas actualmente conectó a través del router.

  • muestre la Voz del historial de llamadas — Utilizado para visualizar la tabla del historial de llamadas. La tabla del historial de llamadas contiene un anuncio de todas las llamadas conectadas a través de este router en el orden de hora descendente puesto que el VoIP fue habilitado. Usted puede visualizar los subconjuntos de la tabla del historial de llamadas usando las palabras claves específicas.

  • puerto de voz de la demostración — Utilizado para visualizar la información de la configuración sobre un puerto de voz específico.


Información Relacionada


Document ID: 14079