Voz : H.323

Introducción, Configuración y Troubleshooting de la Indicación de Asignación de Recursos

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe abreviadamente la necesidad del monitor de asignación de recurso, cómo trabaja, cómo configurarlo y resolverlo problemas, y algunos defectos del ½ del ¿Â de Cisco IOSï (bug) para mirar para.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Versión 12.2(1) del software del IOS de Cisco

  • Cisco AS5300, 3660, 2611, 3640

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Concepto RAI

Para permitir que los controles de acceso tomen decisiones inteligentes de ruteo de llamadas, el gateway informa el estado de su disponibilidad de recursos a su control de acceso. Los recursos se monitorean que son canales del DS0 y canales del DSP.

El gateway señala su estado del recurso al portero con el uso del Resource Availability Indication RAS (RAI). Cuando un recurso monitoreado cae debajo de un umbral configurable, el gateway envía un RAI al portero que indica que el gateway casi está fuera de los recursos. Cuando los recursos disponibles entonces cruzan sobre otro umbral configurable, el gateway envía un RAI que indique que existe la condición del agotamiento del recurso no más.

Esta característica fue incluida en el Cisco IOS Software Release 12.0(5)T en el gateway del Cisco AS5300, y el Cisco IOS Software Release 12.1(1)T para otros gatewayes en la versión 2 de H.323.

H.225 Definición de RAI

El RAI es una notificación de un gateway a un portero de su capacidad de llamada actual para cada protocolo y velocidad de datos de las H-series para ese protocolo. El portero responde con un Resource Availability Confirmation (RAC) sobre la recepción de un RAI para reconocer a su recepción.

El mensaje RAI incluye:

  • requestSeqNum

  • protocolIdentifier

  • nonStandardData

  • más endpointIdentifier

  • protocolos

  • almostOutOfResources (VERDADERO, FALSO)

  • tokens, cryptoTokens

  • integrityCheckValue

El mensaje RAC incluye:

  • requestSeqNum

  • protocolIdentifier

  • nonStandardData

  • tokens

  • cryptoTokens

  • integrityCheckValue

Nota: Esta definición es del protocolo H.225. En la versión 2 de H.323 y la versión 3 de H.323, el RAI se utiliza para señalar que el gateway tiene o no tiene los recursos para procesar las llamadas VoIP entrantes. La capacidad de llamada viene en la versión 4 de H.323.

Cómo funciona RAI en la gateway y el Gatekeeper de Cisco

  • Los umbrales de información de recursos se configuran con el comando resource threshold bajo la CLI de la gateway. Los umbrales superiores e inferiores se configuran por separado para evitar que el gateway funcione esporádicamente debido a la disponibilidad o a la falta de recursos.

    resource threshold [all] [high percentage-value] [low percentage-value]

    El valor por defecto para “los valores altos” y “bajos” es 90.

    La utilización se calcula según lo considerado aquí:

    • Canales accesibles = en uso + libres

    • Utilización = En uso / Accesible

    Cuando usted calcula la utilización, tenga en cuenta los canales accesibles. Los canales discapacitados no se cuentan. El comando show call resource voice stat muestra la cantidad de “canales a los que se puede direccionar”. Los canales direccionables son los canales que se asocian a los POTS dial peer válidos (por ejemplo, un POTS dial peer que es apaga no se considera válido). Los canales direccionables no igualan necesariamente los canales accesibles, puesto que usted puede haber inhabilitado los canales direccionables (el regulador está abajo, o usted busyout algo del DS0s como un ejemplo).

    Por ejemplo, asuma que usted tiene cuatro T1s: dos T1s para las llamadas entrantes, dos para saliente. Ha ocupado 46 intervalos de tiempo de los intervalos de tiempo de salida y tiene una llamada en uno de ellos. Usted tendrá:

    • Total = 96

    • Direccionables = 48

    • = 46 discapacitados

    • Inuse = 1

    • Libres = 1

    La utilización es igual a 1/(1+1)= 50 %. Tan si el umbral elevado configurado es el 90%, el gateway todavía valida las llamadas.

    Si usted tiene el Inuse del "0" y canales libres del "0", después usted golpea inmediatamente el umbral elevado. Esta es una manera de interrumpir el envío de llamadas a esa gateway, si se desea mantenerla. Las dos maneras de hacer esto son a ocupado hacia fuera todos los intervalos de tiempo en los pasos, o cierre a los POTS dial peer. Hay un riesgo cuando usted utiliza el método de los POTS dial peer. Al cerrar el par de marcado POTS, es probable que el gatekeeper ya haya enrutado algunas llamadas a la gateway. Estas llamadas se desconectan con el código de la causa de desconexión del “no hay circuitos disponibles”. Esto sucede porque cerrar el dial-peer afecta a todos los canales configurados bajo él. La mejor manera es ocupar una determinada cantidad de intervalos de tiempo hasta que encuentre el umbral elevado. Una vez que usted alcanza esa punta, esté seguro que el portero no está enviando ninguna llamadas mientras que usted ocupado hacia fuera los otros intervalos de tiempo.

  • Los cálculos antedichos tomaron solamente los recursos del DS0 en la consideración. Sin embargo, monitorean y se calculan a los recursos DSP de la misma manera. También, dependiendo de las cuales el recurso (DSP o DS0) alcanza el punto bajo o el umbral elevado primero, el gateway envía los mensajes RAI.

  • No se necesita ninguna configuración en el portero para activar el RAI.

  • Un mensaje RAI, como cualquier otro mensaje RAS, es UDP. Una vez que el gateway envía un mensaje RAI al portero, comienza un segundo temporizador tres. Si expira el temporizador antes de que reciba el RAC, el gateway intenta enviar el RAI otra vez nueve más veces. Entonces, abandona hasta la disponibilidad de recursos de los cambios de estado otra vez.

  • El RAI es útil si usted quiere dar la prioridad a cierto gateway. También, una vez que se alcanza el umbral, después usted rutea el tráfico a otros gatewayes.

  • El portero selecciona el gateway basado en la prioridad y el umbral de recursos. Si todos los gatewayes tienen la misma prioridad y recursos, el portero hace el Equilibrio de carga. Una vez que un gateway se marca como “fuera de los recursos”, el portero pone el gateway al fondo de la lista de prioridad (cambia prioridad de la gateway hasta el "1"). Si no hay otro gateway con una prioridad más alta o si todos los gatewayes en esa zona tienen prioridad el "1", después el portero todavía envía las llamadas al gateway que envió un mensaje RAI que declaraba que casi está fuera de los recursos.

  • Con el comando lrq reject-resource-low, el portero rechaza la llamada entre zonas si todos los gatewayes en esa zona se marcan como casi-hacia fuera-de-recursos. Este comando está integrado en la versión 12.1(3a)XI6 del software del IOS de Cisco. Si usted no utiliza este comando, el portero no rechaza ninguna llamadas de otras zonas cuando todos los gatewayes en esa zona se marcan como fuera de recursos.

  • La prioridad del default gateway es 5. Y se puede cambiar el valor predeterminado mediante el comando zone prefix <nombre del gatekeeper> <prefijo de E.164> gw-default-priority <prioridad 0-10>. Este comando es también útil en caso de que usted quiera rutear las llamadas a ciertos gatewayes para ese prefijo. Sin embargo, éste no es el caso para otros. También, usted no quiere configurar cada otro gateway con la prioridad el "0" usando el comando zone prefix <gatekeeper name> <E.164 prefix> gw-priority.

Caso Práctico

/image/gif/paws/14075/ram.gif

Las llamadas originan de PBX A en el T1s conectado con 5300-4. La llamada hace juego a un VoIP dial-peer con el destino de la sesión RAS. En la configuración 2611-gatekeeper, esta llamada es manejada por la zona B. El 2611-gatekeeper envía el LRQ al portero 3660-2 en la zona B y un RIP de nuevo a 5300-4.

Configuran al portero 3660-2 para rutear esa llamada con la prioridad 10 al 5300-3. La siguiente prioridad es el 3640-3 (configurado como prioridad 9). Mientras 5300-3 tenga recursos, todas las llamadas se rutean a él.

El portero 3660-2 envía el LCF con 5300-3 como el gateway de destino. Cuando 5300-3 consigue el mensaje setup, envía el ARQ a su portero. Después del ACF, establece la segunda pierna, que es un tramo de telefonía FGB hacia PBX B.

Una vez que 5300-3 se marca como “fuera de recursos”, el portero 3660-2 en la zona B baja la prioridad de 5300-3 al "1" y comienza a rutear el tráfico al gateway 3640-3 puesto que tiene una prioridad más alta del "9".

En este puesto el 5300-3 tiene 48 DS0 direccionables y se configura con un valor de umbral alto del 70 por ciento.

Las primeras 34 llamadas de PBX A hacen 34 DS0 ser utilizadas en 5300-3. La trigésimo quinta llamada hace el 5300-3 enviar un mensaje RAI al portero que le informa que siente bien a los fuera de recursos. La treinta-sexta llamada y qué sigue se rutea al 3640-3 mientras el 5300-3 siga siendo “fuera de recursos”.

Configuración de 5300-3

!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-fgb dtmf dnis
!
controller T1 2
 framing esf
 clock source line secondary 1
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-fgb dtmf dnis
!
interface Ethernet0
 ip address 172.16.13.45 255.255.255.224
 load-interval 30
 h323-gateway voip interface
 h323-gateway voip id cisco_2 ipaddr 172.16.13.42 1718
 h323-gateway voip h323-id 5300-3
 h323-gateway voip tech-prefix 2#
!
voice-port 0:1
!
voice-port 2:1
!
dial-peer voice 11 pots
 incoming called-number .
 destination-pattern 2#987654
 direct-inward-dial
 port 0:1
 prefix 987654
!
dial-peer voice 12 pots
 destination-pattern 2#987654
 port 2:1
 prefix 987654
!
gateway 
 resource threshold high 70 low 60

!--- The gateway is configured for a high resource threshold 
!--- of 70% and low resource threshold of 60%.

!

Configuración de 3640-3

!
controller T1 2/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-wink-start
!
interface Ethernet0/0
 ip address 172.16.13.40 255.255.255.224
 half-duplex
 h323-gateway voip interface
 h323-gateway voip id cisco ipaddr 172.16.13.50 1718
 h323-gateway voip id cisco_2 ipaddr 172.16.13.42 1718
 h323-gateway voip h323-id 3640-3
 h323-gateway voip tech-prefix 2#
!
voice-port 2/0:0
! 
dial-peer voice 987654 pots
 destination-pattern 2#987654
 port 2/0:0
 prefix 987654
!
gateway 

!--- No resource monitor is configured on this gateway in this lab setup.

!

Configuración de control de acceso 3660-2

!
interface FastEthernet0/0
 ip address 172.16.13.42 255.255.255.224
 duplex auto
 speed auto
!
gatekeeper
 zone local cisco_2 cisco.com 172.16.13.42
 zone remote cisco cisco.com 172.16.13.50 1719
 zone prefix cisco 1*
 zone prefix cisco_2 9* gw-priority 10 5300-3
 
!--- 5300-3 is configured for priority 10 for this prefix.

 zone prefix cisco_2 9* gw-priority 9 3640-3
 gw-type-prefix 2#* default-technology
 no shutdown
!

Configuración de 5300-4

!
controller E1 0
 clock source line primary
 ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled 
 cas-custom 0
!
controller E1 1
 clock source line secondary 1
 ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled 
 cas-custom 1
!
controller E1 2
 clock source line secondary 2
 ds0-group 2 timeslots 1-15,17-31 type r2-digital r2-compelled 
!
controller E1 3
 clock source line secondary 3
 ds0-group 3 timeslots 1-15,17-31 type r2-digital r2-compelled 
!
interface Ethernet0
 ip address 172.16.13.46 255.255.255.224
 no ip mroute-cache
 load-interval 30
 h323-gateway voip interface
 h323-gateway voip id cisco ipaddr 172.16.13.50 1718
 h323-gateway voip h323-id 5300-4
 h323-gateway voip tech-prefix 1#
!
voice-port 0:0
 compand-type a-law
!
voice-port 1:1
 compand-type a-law
!
voice-port 2:2
 compand-type a-law
!
voice-port 3:3
 compand-type a-law
!
dial-peer voice 1234 voip
 incoming called-number .
 destination-pattern 987654
 session target ras
 tech-prefix 2#
!
dial-peer voice 9876 pots
 incoming called-number .
 direct-inward-dial
!
gateway 
!

2611-Configuración de Gatekeeper

!
interface Ethernet0/0
 ip address 172.16.13.50 255.255.255.224
 half-duplex
!
!
gatekeeper
 zone local cisco cisco.com 172.16.13.50
 zone remote cisco_2 cisco.com 172.16.13.42 1719
 zone prefix cisco 1* gw-priority 10 5300-4
 zone prefix cisco_2 9*
 gw-type-prefix 1#* default-technology
 no shutdown
!

Estado de 5300-3 cuando se realizan 34 llamadas en forma simultánea

Utilice el comando show pool del modo “test dsprm” de mostrar cuánto es funcionando DSPs.

dsprm 4> show pool
VFC-voice-pool      Total=120: free=86/86, in_use=34/34, pending=0/0, disabled=0/0

Utilice el comando show call resource voice stat del enable mode de mostrar las estadísticas de todos los recursos (DSPs y DS0s).

En esta salida, la utilización de DSP es 34/120= el 28%, y la utilización del DS0 es 34/48= el 70%. El valor de umbral alto configurado en ambos casos (utitlization del DSP y del DS0) no se excede.

5300-3#show call resource voice stat

Resource Monitor -  Dial-up Resource Statistics Information:

DSP Statistics:

Utilization: 0 percent
Total channels: 120
Inuse channels: 34   

!--- Number of DSP channels used.

Disabled channels: 0
Pending channels: 0
Free channels: 86

DS0 Statistics:

Utilization: 0 percent
Total channels: 96
Addressable channels: 48
Inuse channels: 34 

!--- Number of DS0 channels used.
    
Disabled channels: 24
Free channels: 14

Utilice el comando show call resource voice threshold del enable mode de marcar el estado del umbral en el gateway como se muestra aquí.

5300-3#show call resource voice threshold

Resource Monitor -  Dial-up Resource Threshold Information:

DS0 Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

!--- DS0 threshold is still below the low value.


DSP Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

!--- DSP threshold is still below the low value.

Utilice el comando show gateway de marcar el estatus del umbral de recursos de H.323 si se habilita y active. También le da el punto bajo y los valores de umbral alto configurados.

En esta salida usted puede ver que el umbral de recursos está habilitado y active. “Habilitó” significa que configurado y el “Active” significa que los procesos de H.323 RAS en el IOS están registrados con el monitor de recurso. Como un ejemplo, si el gateway no se registra con el portero, el proceso de H.323 RAS no se inicializa y se habilita el umbral de recursos, pero no activo. La salida del comando se muestra aquí.

5300-3#show gateway
 Gateway  5300-3  is registered to Gatekeeper cisco_2

Alias list (CLI configured) 
 H323-ID 5300-3
Alias list (last RCF) 
 H323-ID 5300-3

 H323 resource thresholding is Enabled and Active
 H323 resource threshold values:
  DSP: Low threshold 60, High threshold 70
  DS0: Low threshold 60, High threshold 70
5300-3#show gateway
 Gateway  5300-3  is not registered to any gatekeeper

Alias list (CLI configured) 
 H323-ID 5300-3
Alias list (last RCF) 
 H323-ID 5300-3

 H323 resource thresholding is Enabled but NOT Active
 H323 resource threshold values:
  DSP: Low threshold 60, High threshold 70
  DS0: Low threshold 60, High threshold 70

Estado de 3660-2 Gatekeeper cuando 34 llamadas están en funcionamiento simultáneamente

Utilice el comando show gatekeeper gw-type-prefix de marcar la prioridad de los gatewayes registradoes con el portero. Vea si ningunos se marcan como “fuera de recursos.”

En esta salida, todos los gatewayes tienen recursos y no hay “(los fuera de recursos)” haber visualizado, que significa que el 5300-3 todavía tiene recursos.

3660-2#show gatekeeper gw-type-prefix 
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 2#*    (Default gateway-technology)
  Zone cisco_2 master gateway list:
    172.16.13.40:1720 6789 
    172.16.13.45:1720 5300-3
  Zone cisco_2 prefix 9* priority gateway list(s):
   Priority 10:
    172.16.13.45:1720 5300-3
   Priority 9:
    172.16.13.40:1720 6789 

También, usted puede utilizar el comando show gatekeeper endpoint de ver si los gatewayes uces de los se señalan por medio de una bandera como fuera de los recursos. Si el campo “F” tiene la carta “O” bajo él para un gateway, después ese portero recibió un “hacia fuera-de-recurso” RAI de ese gateway.

3660-2#show gatekeeper endpoint
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr       Port    RASSignalAddr    Port  Zone Name   Type  F 
-------------------- -----  ----------------  ------ ---------- -------    --
172.16.13.40         1720    172.16.13.40     52975   cisco_2   VOIP-GW  
    E164-ID: 6789
    E164-ID: 11
    E164-ID: 336699
    H323-ID: 3640-3
172.16.13.45         1720   172.16.13.45    58131   cisco_2     VOIP-GW  
    H323-ID: 5300-3
Total number of active registrations = 2

Estado de 5300-3 cuando hay 35 llamadas simultáneas.

En esta salida, la utilización de DSP es 35/120= el 29%, y la utilización del DS0 es 35/48= el 73%. El valor del umbral elevado configurado para los canales del DS0 se excede. También, un mensaje RAI con el campo "fuera de recurso" “VERDAD” se envía al portero. Esto indica que el gateway no puede validar más llamadas.

dsprm 4>show pool
VFC-voice-pool      Total=120: free=85/85, in_use=35/35, pending=0/0, disabled=0/0

5300-3#show call resource voice stat

Resource Monitor -  Dial-up Resource Statistics Information:

DSP Statistics:

Utilization: 0 percent
Total channels: 120
Inuse channels: 35
Disabled channels: 0
Pending channels: 0
Free channels: 85

!--- Number of used DSPs is 35.


DS0 Statistics:

Utilization: 0 percent
Total channels: 96
Addressable channels: 48
Inuse channels: 35
Disabled channels: 24
Free channels: 13

!--- Number of used DS0s is 35.

Como usted puede ver aquí, el gateway golpear el valor de umbral alto para los canales del DS0.

En este hecho salir la carta “O” bajo el campo “F” indica que el gateway 5300-3 es fuera de recursos.

5300-3#show call resource voice threshold

Resource Monitor -  Dial-up Resource Threshold Information:

DS0 Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: high_threshold_hit

!--- The DS0 resources reached the high threshold value.


DSP Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

Y en el portero, usted ve que el gateway 5300-3 está marcado como “fuera de recursos”.

3660-2#show gatekeeper gw-type-prefix 
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 2#*    (Default gateway-technology)
  Zone cisco_2 master gateway list:
    172.16.13.40:1720 6789 
    172.16.13.45:1720 5300-3 (out-of-resources)
  Zone cisco_2 prefix 9* priority gateway list(s):
   Priority 10:
    172.16.13.45:1720 5300-3 (out-of-resources)
   Priority 9:
    172.16.13.40:1720 6789

!--- 5300-3 is out-of-resources.

3660-2#show gatekeeper endpoint
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr     Port  RASSignalAddr  Port   Zone Name  Type    F 
-----------------  ----- -------------- ------ ---------- ------- --
172.16.13.40       1720  172.16.13.40   52975   cisco_2   VOIP-GW  
  E164-ID: 6789
  E164-ID: 11
  E164-ID: 336699
  H323-ID: 3640-3
172.16.13.45       1720  172.16.13.45   58131  cisco_2   VOIP-GW O
  H323-ID: 5300-3
Total number of active registrations = 2

Depuraciones

Encienda la depuración ras y la depuración h225 asn1 si piensa que la gateway no envía el mensaje RAI correcto o que el gatekeeper no envía el mensaje RAC.

Nota:  el asn1 del h225 del debug es prolijo. Usted por lo tanto tiene que tener cuidado cuando usted lo gira, especialmente cuando el portero o el gateway está en la producción y están manejando muchas llamadas. El asn1 del h225 del debug muestra todos los mensajes H.225 (no sólo RAS). Ésta es la salida de estos debugs en el portero 3660-2 después de que treinta y cinco llamadas estén para arriba:

En este hecho salir el campo "almostOutOfresources" es “VERDAD”. Esto significa los informes del gateway al portero que está fuera de los recursos. Cuando el gateway golpea el valor de umbral bajo, envía otro mensaje RAI. Sin embargo, con este campo “FALSO”, dice al portero comenzar a enviar las llamadas otra vez. Todos los mensajes RAS como un número de secuencia y cualquier respuesta a estos mensajes llevan el mismo número de secuencia.

RAW_BUFFER::=
81 340000A1 06000891 
*Mar  5 11:26:02.961: PDU DATA = 60E28808

value RasMessage ::= resourcesAvailableIndicate : 
                     
!--- RAI message.

    {
      requestSeqNum 162
      
!--- Sequence number of the H.225 message.

      protocolIdentifier { 0 0 8 2250 0 2 }
      endpointIdentifier {"6165B9D400000006"}
      protocols 
      {
        voice : 
        {
          supportedPrefixes 
          {

            {
              prefix e164 : "2#"
            }
          }
        }
      }
      almostOutOfResources TRUE
      
!--The value of  almostOutOfResources.

    }
*Mar  5 11:26:02.965: RAI (seq# 162) rcvd

Éste es el mensaje RAC enviado del portero al gateway que reconoce su recepción del mensaje RAI.

PDU DATA = 60E28808

value RasMessage ::= resourcesAvailableConfirm : 
                     
!--- RAC message.

    {
      requestSeqNum 162
      
!--- Sequence number of the H.225 message.

      protocolIdentifier { 0 0 8 2250 0 2 }
    }


RAW_BUFFER::=
82 0A0000A1 06000891 4A0002
*Mar  5 11:26:02.965: 
*Mar  5 11:26:02.965:       RASLib::RASSendRAC: RAC (seq# 162) sent to 172.16.13.45

Algunos errores de funcionamiento para tener en cuenta

Éstos son algo del bug Cisco ID que ha estado en diversas Plataformas. Casi todos ellos están resueltos, pero esto ayudaría en caso de que tenga un problema con RAI, para ver si se ha encontrado con alguno de éstos.

Nota: Usted puede acceder este bug Cisco ID con el Bug Toolkit (clientes registrados solamente).

  • CSCds41207

  • CSCds79319

  • CSCds90317

  • CSCdt00087

  • CSCdt68781

  • CSCdt77870

  • CSCdt93779

  • CSCdu55874

  • CSCdu76312

  • CSCdu79860


Información Relacionada


Document ID: 14075