IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Configuración de IS-IS para IP en los routers de Cisco

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El objetivo de este documento es mostrar una configuración básica de Sistema intermedio a Sistema intermedio (IS-IS) para IP en los routers Cisco. Además de la configuración, cómo monitorear la diversa información IS-IS se demuestra, por ejemplo la información de elección del sistema intermedio designado (DIS) y la información de la base de datos IS-IS.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información en este documento se basa en el Software Release 12.1(5)T9 del ½ del ¿Â del Cisco IOS ïÂ.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configuración de IS-IS de muestra

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Para habilitar el IS-IS para el IP en un router Cisco y hacer que intercambie la información de ruteo por otros routeres habilitados IS-IS, usted debe realizar estas dos tareas:

  • Habilite el proceso IS-IS y asigne un área

  • Habilite IS-IS para el IP Routing en una interfaz

Otras tareas de configuración son optativas, no obstante, las dos tareas anteriores son obligatorias. Para más información sobre las tareas de la configuración optativa, refiera a configurar el IS-IS integrado.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/13795/is-is-ip-config.jpg

Configuraciones

En este documento, se utilizan estas configuraciones:

Las configuraciones de muestra abajo configuran a todo el Routers en la topología antedicha con estos parámetros:

  • Área 49.0001

  • Routers del nivel 1 (L1) y del nivel 2 (L2) (éste es el valor por defecto salvo especificación de lo contrario)

  • Ningún parámetro optativo

  • Ejecución de IS-IS sólo para IP

  • El loopback interconecta (los loopback son hechos publicidad por el IS-IS, no el IS-IS habilitados)

Router 1
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0
ip address 172.16.12.1 255.255.255.0
ip router isis 


!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
router isis
passive-interface Loopback0
net 49.0001.1720.1600.1001.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

Router 2
!
interface Loopback0
ip address 172.16.2.2 255.255.255.255

!--- Creates loopback interface and assigns 
!--- IP address to interface Loopback0.

!
Interface Ethernet0
ip address 172.16.12.2 255.255.255.0
ip router isis

!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
Interface Serial0
ip address 172.16.23.1 255.255.255.252
ip router isis

!--- Assigns IP address to interface Serial0 
!--- and enables IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1720.1600.2002.00
!

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router. 

Router 3
!
interface Loopback0
ip address 172.16.3.3 255.255.255.255 

!--- Creates loopback interface 
!--- and assigns IP address to 
!--- interface Loopback0.

!
Interface Serial0
ip address 172.16.23.2 255.255.255.252
ip router Isis

!--- Assigns IP address to 
!--- interface Serial0 and enables 
!--- IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1234.1600.2231.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

Supervisión IS-IS

Existen varios comandos show disponibles para monitorear el estado de IS-IS en un router Cisco. Este documento muestra algunos de los comandos más básicos, en relación con las configuraciones anteriores del router.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Supervisión de las adyacencias IS-IS

Utilice el comando show clns neighbor para mostrar las adyacencias para un router específico. Ésta es la salida de este comando del router1 (r1) y del router2 (r2):

R1# show clns neighbor
System Id   Interface  SNPA            State  Holdtime  Type Protocol
R2          Et0        0000.0c47.b947  Up     24        L1L2 ISIS
    
R2# show clns neighbor
System Id  Interface  SNPA             State  Holdtime  Type Protocol
R1         Et0        0000.0c09.9fea   Up     24        L1L2 ISIS
R3         Se0        *HDLC*           Up     28        L1L2 ISIS

En el ejemplo anterior, R1 reconoce a R2 en su interfaz E0 con el tipo de adyacencia L1L2. Debido a que R1 y R2 están establecidos con configuraciones predeterminadas, envían y reciben saludos L1 y L2.

El R2 reconoce al R1 en su interfaz E0 y el Router 3 (R3) en su interfaz S0. La misma explicación de arriba vale para el tipo de adyacencia.

Puesto que el r1 y el r2 son en la misma interfaz de Ethernet, han un DIS para el L1 y el L2. Usted puede verificar esto usando el comando show clns interface <int> en el router1, como se muestra abajo:

R1# show clns interface ethernet 0
Ethernet0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  Routing Protocol: ISIS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-1 adjacencies: 1
    Level-2 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-2 adjacencies: 1
    Next ISIS LAN Level-1 Hello in 5 seconds
    Next ISIS LAN Level-2 Hello in 1 seconds

En el resultado anterior, R2 es la DIS. El R2 (DIS) es el que genera el seudo nodo LSP (paquete de estado de link) y se denota con un LSP-ID -R2.01 sin cero

Puesto que el métricos/la prioridad son lo mismo para ambo Routers en el L1/L2, el tiebreaker para el DIS es la dirección de los Puntos de acoplamiento de la subred (SNPA) más alta en el segmento LAN. La dirección de SNPA hace referencia a la dirección de link de datos y en este caso es la dirección de MAC. El otro caso de los direccionamientos del link de datos sería los direccionamientos X.25 y DLCI de Frame Relay.

Tenga en cuenta que DIS se selecciona para ambos niveles y que no existe una copia de respaldo de DIS, al igual que con Abrir primero la ruta más corta (OSPF), que posee un router designado (DS) de respaldo.

Algunos otros puntos de interés de la salida anterior incluyen:

  • Tipo de circuito: L1L2

  • Las métricas de L1 y L2 y las prioridades están en valores predeterminados: 10 y 64

  • Adyacencias L1 y L2: 1 (desde la perspectiva R1 en la interfaz Ethernet es sólo R2)

  • Saludos de LAN IS-IS para L1 y L2

  • Unidad máxima de transmisión (MTU) (MTU): 1497. Esto es porque la encabezado del Open Systems Interconnection (OSI) IS-IS se encapsula dentro 3 de una encabezado del byte 802.2.

Supervisión de la base de datos IS-IS

El comando show isis database (detail) muestra el contenido de la base de datos de IS-IS. Ésta es la salida de este comando cuando está publicada en el r2. Dado que IS-IS es un protocolo de estado del link, la base de datos de estados de link debe ser la misma para cualquier router de la misma área.

R2# show isis database
ISIS Level-1 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x0000008B   0x6843        55              0/0/0
R2.00-00    * 0x00000083   0x276E        77              0/0/0
R2.01-00    * 0x00000004   0x34E1        57              0/0/0
R3.00-00      0x00000086   0xF30E        84              0/0/0
ISIS Level-2 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x00000092   0x34B2        41              0/0/0
R2.00-00    * 0x0000008A   0x7A59        115             0/0/0
R2.01-00    * 0x00000004   0xC3DA        50              0/0/0
R3.00-00      0x0000008F   0x0766        112             0/0/0

Hay algunas cuestiones para considerar en el resultado de arriba. Primero, sobre el LSP-ID:

El LSP-ID, R1.00-00, se puede analizar en tres secciones: R1/00/00

  • R1 = ID del sistema

  • 00 = valor distinto de cero para el seudo nodo. Observe que R2.01-00 es el pseudo nodo LSP.

  • 00 = número del fragmento. En este caso, hay solamente números del fragmento de 00, que indica que todos los datos cabidos en este fragmento LSP, y no había necesidad de crear más fragmentos. Si hubiese habido información que no encajaba en el primer LSP, IS-IS habría creado más fragmentos LSP, tales como 01, 02 y así sucesivamente.

* denota los LSP que fueron generados por este router, el router que publicaron el comando show encendido. Además, dado que este router es un router L1 y L2, posee una base de datos L1 y L2.

Usted puede también mirar un LSP específico y utilizar la palabra clave del detalle para mostrar más información. Un ejemplo de esto se muestra aquí:

R2# show isis database R2.00-00 detail
ISIS Level-1 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x00000093   0x077E        71            0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2 
  Metric: 10         IP 172.16.12.0 255.255.255.0
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
ISIS Level-2 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x0000009A   0x5A69        103           0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IP 172.16.1.1 255.255.255.255
  Metric: 10         IP 172.16.3.3 255.255.255.255
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.12.0 255.255.255.0

La salida anterior muestra que la dirección de loopback de este router se anuncia con un valor de 0. Esto sucede porque al loopback se lo anuncia con un comando passive-interface en el proceso IS-IS del router y la interfaz del loopback en sí no está habilitado para IS-IS. Todos los otros prefijos IP tienen un valor de 10, que es el costo predeterminado en las interfaces que ejecutan IS-IS.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 13795