IP : Protocolo de router de reserva activa (HSRP)

Introducción al comando ip unnumbered y su configuración

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento explica el concepto de un IP sin numerar y presenta varios ejemplos de configuración para referencia. El comando ip unnumbered configuration le permite activar el procesamiento de IP en una interfaz serial sin asignarle una dirección de IP explícita. La interfaz sin numeración IP puede "pedir prestada" la dirección IP de otra interfaz ya configurada en el router, que conserva el espacio de red y dirección.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

¿Qué es una interfaz sin numerar?

Considere la red mostrada abajo. El router A tiene un s0 y una interfaz de Ethernet E0 de la interfaz serial.

/image/gif/paws/13786/20a_new.gif

La interfaz del ethernet0 del router a se puede configurar con una dirección IP como se muestra abajo:

interface Ethernet0
ip address 172.16.10.254 255.255.255.0

Lógicamente, habilitar el IP en el s0 de la interfaz, usted necesitaría configurar un IP Address único en él. Sin embargo, es también posible habilitar el IP en la interfaz serial y traerlo para arriba sin la asignación de un IP Address único a él. Esto es hecha pidiendo prestada una dirección IP configurada ya en una de otras interfaces del router. Para hacer esto, utilizan al comando ip unnumbered interface mode como se muestra abajo.

interface Serial 0
ip unnumbered Ethernet 0

El comando mode innumerable de la interfaz del <number> del IP <type> pide prestada la dirección IP de la interfaz especificada a la interfaz en la cual se ha configurado el comando. El uso del comando ip unnumbered da lugar a la dirección IP que es compartida por dos interfaces. Así, en nuestro ejemplo, la dirección IP que fue configurada en la interfaz de Ethernet también se asigna a la interfaz serial, y a ambas interfaces implicó la función normalmente. Esto se puede verificar usando la salida del comando show ip interface brief, como se muestra abajo:

RouterA# show ip interface brief 

Interface    IP-Address      OK?    Method   Status   Protocol
Ethernet0    172.16.10.254   YES    manual   up       up
Serial0      172.16.10.254   YES    manual   up       up

Como usted puede ver de la salida del comando show ip interface brief arriba, la interfaz serial tiene una dirección IP idéntica a la de la interfaz de Ethernet, y ambas interfaces son completamente - funcionales. La interfaz que pide prestado su direccionamiento a partir de la una de otras interfaces funcionales del router se llama la “interfaz sin numerar”. En nuestro ejemplo, el serial0 es la interfaz sin numerar.

La única desventaja real de la cual la interfaz sin numerar sufre es que es inasequible para la prueba remota y la Administración. Usted debe también recordar que la interfaz sin numerar debe pedir prestado su direccionamiento de una interfaz que sea en servicio. Si la interfaz sin numerar está señalando a una interfaz que no sea funcional (es decir, que no muestra el “estatus de la interfaz PARA ARRIBA”, “protocolo PARA ARRIBA”), la interfaz sin numerar no trabaja. Éste es exacto porqué se recomienda que la punta de la interfaz sin numerar a un Loopback Interface puesto que los loopback no fallan. Finalmente, recuerde que el comando ip unnumbered trabaja en las interfaces Point-to-Point solamente. Cuando usted configura el comando en la interfaz multiaccesa (es decir, Ethernet) o el Loopback Interface, se visualizan los siguientes mensajes:

RouterA(config)# int e0 
RouterA(config-if)# ip unnumbered serial 0 
Point-to-point (non-multi-access) interfaces only 
RouterA(config-if)# ip unnumbered loopback 0 
Point-to-point (non-multi-access) interfaces only  

IP e IP si número

En un router Cisco, cada interfaz conectada a un segmento de red debe pertenecer a una única subred. Los routers conectados directamente tienen interfaces que se conectan al mismo segmento de red y tienen asignadas direcciones IP de la misma subred. Si un router necesita enviar información a una red que no está conectada de forma directa, consulta la tabla de ruteo y envía el paquete al salto siguiente conectado de forma directa al destino. Si no hay una ruta en la tabla de ruteo, el router reenvía el paquete a su gateway de último recurso. Cuando un router que está conectado directamente al destino final recibe el paquete, lo transmite directamente al host extremo.

La tabla de IP Routing contiene las rutas de subred o las rutas de red principal. Cada ruta cuenta con una o más direcciones de salto siguiente directamente adheridas. Las rutas de subred se agregan o se resumen por abandono en los límites de red principal para reducir el tamaño de la tabla de ruteo.

Nota: El esquema de agrupamiento discutido arriba asume un Distance Vector Routing Protocol tradicional tal como Routing Information Protocol (RIP) o Interior Gateway Routing Protocol (IGRP).

Consideremos asignar los IP Addresses a las interfaces de un router que usa una Red clase B de la cual ha sido subnetted usando ocho bits subnetting. Cada interfaz requiere una subred exclusiva. A pesar de que cada conexión en serie punto a punto tiene que manejar solamente dos puntos extremos, si asignamos una subred completa a cada interfaz en serie, podemos utilizar las 254 direcciones disponibles para cada interfaz donde sólo son necesarias dos direcciones. Si utilizamos el IP innumerable en cada interfaz serial, salvamos el espacio de la dirección; el direccionamiento de una interfaz LAN “se pide prestado” y se utiliza como la dirección de origen para las actualizaciones de ruteo y paquetes originados de la interfaz serial. De esta manera, se conserva el espacio de la dirección. IP sin número sólo tiene sentido para links punto a punto.

Cuando un router recibe una actualización de ruteo, instala la dirección de origen de la actualización como el próximo salto en su tabla de ruteo. Normalmente, el próximo salto es un nodo de red conectado directamente. Esto ya no sucede si usamos una IP sin numeración porque cada interfaz serial "pide prestado" su dirección IP a una interfaz LAN diferente, cada una en una subred diferente y posiblemente en una red principal diferente. Cuando se configura un IP sin numerar, las rutas aprendidas a través de la interfaz de IP sin numerar tienen a la interfaz como el salto siguiente, en lugar de la dirección de origen de la actualización de ruteo. De este modo, evitamos un problema de dirección del salto siguiente inválida debido al origen de la actualización del ruteo proveniente de un salto siguiente que no está directamente conectado.

Ejemplos de Configuración

Nota: La información en estos ejemplos de configuración se basa en la versión de software del½ del¿Â del Cisco IOSï 12.2(10b) y fue probada en los Cisco 2500 Series Router.

Miremos cuatro diversas configuraciones de muestra para el IP innumerable.

Nota: Habríamos podido utilizar las interfaces del loopback en vez de las interfaces de Ethernet.

La misma red principal, diferentes subredes

El cuadro 1 muestra que a cada lado del link serial tenemos la misma red principal con diversas subredes.

Cuadro 1 – Diagrama de la red

20a.gif

Router 1.1.1.1 Router 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192 

interface Serial0
 ip unnumbered Ethernet0

router igrp 10
 network 171.68.0.0 

Current configuration:

interface Ethernet 0
 ip address 171.68.179.1 255.255.255.192
 
interface Serial 0
 ip unnumbered Ethernet0 

router igrp 10
 network 171.68.0.0 

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 3 subnets
I       171.68.179.0 [100/8976] via 171.68.179.1, 00:00:02, Serial0
C       171.68.178.192 is directly connected, Ethernet0
I       171.68.0.0 [100/8976] via 171.68.179.1, 00:00:02, Serial0

Router 1.1.1.1# ping 171.68.179.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.179.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms


Router 2.2.2.2# show ip route

     171.68.0.0/26 is subnetted, 3 subnets
C       171.68.179.0 is directly connected, Ethernet0
I       171.68.178.192 [100/8976] via 171.68.178.196, 00:00:02, Serial0
I       171.68.0.0 [100/8976] via 171.68.178.196, 00:00:02, Serial0
     
Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

La información de ruta sobre las subredes se mantiene correctamente en este escenario.

Distintas redes principales, no subredes

El cuadro 2 muestra que a cada lado del link serial tenemos diversas redes principales y ningunas subredes.

Cuadro 2 - Diagrama de la red

/image/gif/paws/13786/20b.gif

Router 1.1.1.1 Router 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.0.0 

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0 
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.0.0 

interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0

Router 1.1.1.1# show ip route

C    171.68.0.0/16 is directly connected, Ethernet0
I    172.68.0.0/16 [100/8976] via 172.68.1.1, 00:01:26, Serial0

Router 1.1.1.1# ping 172.68.1.1

Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms


Router 2.2.2.2# show ip route

I    171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:21, Serial0
C    172.68.0.0/16 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Red principal con subred, red principal sin subred

El cuadro 3 muestra eso en un lado del link serial que tenemos una red principal con una subred, y en la otra red principal sin subred del lado A.

Cuadro 3 – Diagrama de la red

/image/gif/paws/13786/20c.gif

Router 1.1.1.1 Router 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0 
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.0.0

interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 1 subnets
C       171.68.178.192 is directly connected, Ethernet0
I    172.68.0.0/16 [100/8976] via 172.68.1.1, 00:00:03, Serial0

Router 1.1.1.1# ping 172.68.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms


Router 2.2.2.2# show ip route

     171.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       171.68.178.192/32 [100/8976] via 171.68.178.196, 00:00:48, Serial0
I       171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:48, Serial0
C    172.68.0.0/16 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Nota: Antes de la versión del Cisco IOS Software 11.0(2), le requieren poner una Static ruta para el majornet 171.68.0.0/16 en el router 2.2.2.2.

En este escenario, la información de la subred se pierde debido a que se la trata como una ruta host. En la versión del Cisco IOS Software 11.0(2) y más alto, el Interior Gateway Routing Protocol (IGRP) y el Routing Information Protocol (RIP) reparan este problema enviando la ruta de resumen para el majornet a través de los link Point-to-Point sin numerar.

Dos redes principales diferentes y sus respectivas subredes

El cuadro 4 muestra que a ambos lados del link serial tenemos dos diversas redes principales con las subredes correspondientes.

Cuadro 4 – Diagrama de la red

/image/gif/paws/13786/20d.gif

Router 1.1.1.1 Router 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192 

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.255.192 
 
interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0 

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 1 subnets
C       171.68.178.192 is directly connected, Ethernet0
     172.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       172.68.0.0/16 [100/8976] via 172.68.1.1, 00:00:02, Serial0
I       172.68.1.0/32 [100/8976] via 172.68.1.1, 00:00:02, Serial0

Router 1.1.1.1# ping 172.68.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/81/280 ms


Router 2.2.2.2# show ip route

     171.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       171.68.178.192/32 [100/8976] via 171.68.178.196, 00:00:22, Serial0
I       171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:22, Serial0
     172.68.0.0/26 is subnetted, 1 subnets
C       172.68.1.0 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms

Nota: En las versiones anteriores a 11.0(2) del software IOS de Cisco, debe colocar una ruta estática para la red principal 171.68.0.0/16 en el router 2.2.2.2 y 172.68.0.0/16 en el router 1.1.1.1.

En este escenario, la información de la subred se pierde debido a que se la trata como una ruta host. En las versiones 11.0(2) y posteriores del software del IOS de Cisco, los IGRP y RIP solucionan el problema al enviar la ruta de resumen para la red principal a través de los links punto a punto sin numerar.


Información Relacionada


Document ID: 13786