IP : Multidifusión IP

¿Por qué no funciona el modo disperso de PIM con una ruta estática hacia una dirección HSRP?

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento explica por qué los paquetes de multidifusión no se reenvían cuando se configura una ruta estática a la dirección Hot Standby Router Protocol (HSRP) de un vecino de modo disperso de Protocol Independent Multicast (PIM).

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

  • HSRP

  • Modo disperso de PIM

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Diagrama de la red

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-multicast/13783-hsrpmcasta.gif

En la figura arriba, el Routers 2 y 3 está hablando el HSRP en la subred 10.1.3.0, y el router2 es el router activo. El Routers 1, 2, y 3 están hablando el Enhanced Interior Gateway Routing Protocol (EIGRP), y Router4 tiene una Static Default ruta a la dirección virtual del HSRP.

Configuraciones

Router 1 Router 2
Current configuration:

! 
ip multicast-routing 
! 
! 
interface Loopback0 
ip address 10.10.10.10 255.255.255.255 
no ip directed-broadcast 
! 
interface Ethernet0 
no ip address 
no ip directed-broadcast 
shutdown 
! 
interface Ethernet1 
ip address 10.1.1.1 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
! 
interface Serial1 
no ip address 
no ip directed-broadcast 
encapsulation frame-relay 
! 
interface Serial1.1 point-to-point 
ip address 10.1.2.1 255.255.255.252 
no ip directed-broadcast 
ip pim sparse-mode 
frame-relay interface-dlci 612 
! 
! 
interface Serial1.2 point-to-point 
ip address 10.1.2.5 255.255.255.252 
no ip directed-broadcast 
ip pim sparse-mode 
frame-relay interface-dlci 613 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
! 
ip classless 
no ip http server 
ip pim rp-address 10.10.10.10 
! 

end
Current configuration:

! 
ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
interface Ethernet1 
ip address 10.1.3.1 255.255.255.0 
no ip redirects 
ip pim sparse-mode 
standby 1 priority 110 preempt 
standby 1 ip 10.1.3.3 
! 
interface Serial1 
no ip address 
encapsulation frame-relay 
! 
interface Serial1.1 point-to-point 
ip address 10.1.2.2 255.255.255.252 
ip pim sparse-mode 
frame-relay interface-dlci 621 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
! 
ip classless 
ip pim rp-address 10.10.10.10 
!

end
Router 3 Router 4
Current configuration:

! 
ip multicast-routing 
ip dvmrp route-limit 20000 
! 
interface Ethernet1 
ip address 10.1.3.2 255.255.255.0 
no ip redirects 
ip pim sparse-mode 
standby 1 priority 100 preempt 
standby 1 ip 10.1.3.3 
! 
interface Serial1 
no ip address 
encapsulation frame-relay 
! 
interface Serial1.2 point-to-point 
ip address 10.1.2.6 255.255.255.252 
ip pim sparse-mode 
frame-relay interface-dlci 631 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
eigrp log-neighbor-changes 
! 
ip classless 
no ip http server 
ip pim rp-address 10.10.10.10 
!

end
Current configuration:

ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
! 
interface Ethernet0 
ip address 10.1.4.1 255.255.255.0 
no ip directed-broadcast 
ip igmp join-group 239.1.2.3 
! 
interface Ethernet1 
ip address 10.1.3.4 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
! 
no ip http server 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.3.3 
ip pim rp-address 10.10.10.10 
!

end

Para simular un host en el ethernet0, configuraron al comando ip igmp join-group en esta interfaz en el Router4:

router4# ip igmp join-group 

IGMP Connected Group Membership 
Group Address Interface Uptime Expires Last Reporter 
224.0.1.40 Ethernet1 4d23h never 10.1.3.1 
239.1.2.3 Ethernet0 4d23h never 10.1.4.1 

El router 4 también puede hacer ping a la dirección de punto de encuentro (RP):

Type escape sequence to abort. 

Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/68 ms

Mire la tabla de la ruta de Multicast (ruta multicast):

Router4# show ip mroute 239.1.2.3 

IP Multicast Routing Table 

Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned 
R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT 
X - Proxy Join Timer Running 

Timers: Uptime/Expires 
Interface state: Interface, Next-Hop or VCD, State/Mode 
(*, 239.1.2.3), 00:04:28/00:00:00, RP 10.10.10.10, flags: SJCL 
Incoming interface: Ethernet1, RPF nbr 10.1.3.3 
Outgoing interface list: 
Ethernet0, Forward/Sparse, 00:02:12/00:02:53 

Porque hay un receptor para este grupo (debido al comando ip igmp join-group usado en el router 4), construye a (*, G) entrada en la tabla mroute. Tenga en cuenta que el vecino de Reenvío por ruta inversa (RPF) para la entrada (*, G) es 10.1.3.3, que es la dirección de espera de HSRP. Sin embargo, no hay a (S, G) la entrada, que significa el tráfico no se está recibiendo de la fuente.

Dado que el Router 4 posee un receptor interesado para el grupo, ahora debería enviar un mensaje de adhesión/exclusión PIM a sus vecinos PIM. Usar el comando show ip pim neighbor para visualizar los routers 4's PIM vecinos, como se muestra a continuación:

Router4# show ip pim neighbor 

PIM Neighbor Table 
Neighbor Address Interface Uptime Expires Ver Mode 
10.1.3.1 Ethernet1 4d23h 00:01:41 v2 
10.1.3.2 Ethernet1 4d23h 00:01:36 v2

Si el comando debug ip pim 239.1.2.3 está activado, el Router 4 genera este mensaje de adhesión/exclusión PIM, pero en realidad no lo envía:

*Mar 6 18:32:48: PIM: RP alcanzable recibido en Ethernet1 desde 10.10.10.10 *6 de mar 18:32:48: para el grupo 239.1.2.3 * 6 de marzo 18:33:14: PIM: Mensaje de unión/separación constructivo para 239.1.2.3 * 6 de marzo 18:34:13: PIM: Generación de mensajes de adhesión/exclusión para 239.1.2.3

¿Por qué el router no envía el mensaje de incorporación/separación? Los estadosleavingcisco.com del RFC 2362 que “un router envía un mensaje de unión/separación periódico a cada vecino RPF distintivo se asociaron a cada (S, G), (*, G) y (*, *, RP) entrada. Se envían los mensajes de unión/separación solamente si el vecino RPF es un vecino del PIM.”

En el ejemplo, el vecino RPF es 10.1.3.3, dirección HSRP de reserva utilizada por la ruta estática predeterminada. No obstante, esta dirección no está detallada como un vecino PIM. La razón por la cual la dirección HSRP inactiva no está en la lista como un vecino PIM es que los dos routers que ejecutan HSRP (Routers 2 y 3) no cargarán los mensajes PIM vecinos desde la dirección HSRP inactiva.

Para resolver el problema, modifique la configuración del router 4 de manera que el RPF vecino sea también un vecino PIM. Realice esto incluyendo el router 4 en el proceso EIGRP para que ahora éste conozca la dirección RP a través de EIGRP.

Nota: Debido a que Router 4 tiene la capacidad de ejecutar un protocolo de ruteo, no debería tener que depender de una dirección HSRP de reserva para conectividad. El desarrollo de HSRP tenía por objeto ofrecer una manera para que los hosts obtengan una redundancia rápida y eficiente o conmutación por error.

La nueva configuración del Router 4 con EIGRP habilitado aparece a continuación.

ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
! 
interface Ethernet0 
ip address 10.1.4.1 255.255.255.0 
no ip directed-broadcast 
ip igmp join-group 239.1.2.3 
! 
interface Ethernet1 
ip address 10.1.3.4 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
!
router eigrp 1
network 10.0.0.0
no auto-summary
! 
no ip http server 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.3.3 
ip pim rp-address 10.10.10.10 
!
end 

Nota: En lugar de incluir el router 4 en el proceso EIGRP (método preferido), agregue mrutas estáticas al router 4 para hacerlo RPF a las direcciones IP de los routers reales, ya que las mrutas son preferibles en lugar de la tabla de ruteo unidifusión cuando se realizan controles RPF. Por ejemplo, agregue la ruta multicast 0.0.0.0 0.0.0.0 10.1.3.2 del IP.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 13783