IP : Protocolo de router de reserva activa (HSRP)

Distribución de la carga con HSRP

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (19 Mayo 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona un ejemplo de la forma para configurar el Hot Standby Router Protocol (HSRP) a los fines de aprovechar los trayectos múltiples de un destino dado.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Teoría Precedente

Con frecuencia se utiliza HSRP para mejorar la resistencia en redes, pero esto puede causar una disminución en la eficacia de la red. El ejemplo en este documento tiene dos trayectorias de la red del host a la red de servidores. Para la Redundancia, el HSRP se ejecuta entre el r1 y el r2, cualquiera cuyo puede convertirse el router activo y tomar la “propiedad” de la dirección IP virtual del HSRP. El segundo router hace el router en espera, y hace solamente el router activo si va el router activo actual abajo. Para más información sobre el active y los routeres en espera, refiérase a cómo utilizar los comandos standby preempt y standby track.

Asignan la dirección de gateway predeterminado de los hosts como su dirección IP virtual del HSRP. Cuando los host necesitan enviar paquetes a la red del servidor, los dirigen a su puerto de enlace predeterminado o cualquier router que esté activo. Porque solamente un router es activo, los paquetes de los hosts a los servidores atraviesan solamente uno de los dos trayectos disponibles.

Nota: El dependiente sobre en cómo usted configura el R3, los paquetes que vuelven de los servidores a los hosts pudo o no pudo utilizar ambos trayectos de retorno. También, los paquetes que vuelven de los servidores a los hosts no necesitan pasar a través del router activo.

Con el fin de utilizar ambos trayectos desde la red del host a la del servidor, puede configurar Multigroup HSRP (MHSRP) entre R1 y R2. Esencialmente, el r1 se configura con dos grupos del HSRP (por ejemplo, el group1 y agrupa 2) y el r2 también se configura con los mismos grupos del HSRP. Para el grupo 1, R1 es el router activo y R2 es el router en espera. Para el grupo 2, R2 es el router activo y R1 es el router en espera. Entonces usted configura la mitad de los default gatewayes de los hosts con la dirección IP virtual del group1 del HSRP, y la otra mitad de los default gatewayes de los hosts con la dirección IP virtual del group2 del HSRP.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/13781/7a.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Configuración del MHSRP del R1
Current configuration:

interface Ethernet0
        ip address 171.16.6.5 255.255.255.0

        standby 1 preempt
        standby 1 ip 171.16.6.100
        standby 1 track Serial0
        standby 2 preempt
        standby 2 ip 171.16.6.200
        standby 2 track serial 0
        standby 2 priority 95

Configuración del MHSRP del R2
Current configuration:

interface Ethernet0
       ip address 171.16.6.6 255.255.255.0
       standby 1 preempt
       standby 1 ip 171.16.6.100
       standby 1 track Serial0
       standby 1 priority 95
       standby 2 preempt
       standby 2 ip 171.16.6.200
       standby 2 track serial 0

El aviso de las configuraciones que cuando el dos Routers primero comienza a ejecutar el HSRP, el r1 tiene una prioridad predeterminada de 100 para el group1 y una prioridad de 95 para el r2 del grupo 2. tiene una prioridad predeterminada de 100 para el group2 y una prioridad de 95 para el group1. Por lo tanto, el r1 es el router activo para el group1 y el r2 es el router activo para el group2. Este ejemplo muestra que usted puede lograr la carga compartida con el MHSRP. Sin embargo, usted necesita utilizar la prioridad HSRP y apropiarse para lograr esto. HSRP no tiene ningún efecto sobre el tráfico de retorno. La trayectoria tomada por el tráfico de retorno depende del Routing Protocol configurado en el router.

Nota: Cuando configuran el valor y a los comandos standby preempt de prioridad de reserva, es obligatorio mencionar explícitamente el número de grupo. Si no mencionado, entonces el valor es 0 por abandono. El número de grupo predeterminado es 0.

Nota importante

Varios controladores Ethernet (Lance y QUICC) en productos de menor capacidad sólo pueden tener una única dirección de control de acceso a medios (MAC) unidifusión en su filtro de direcciones. Estas Plataformas permiten solamente a un solo grupo del HSRP, y cambian el direccionamiento de la interfaz al HSRP Virtual MAC Address cuando el grupo hace activo. La carga a compartir en las Plataformas con esta limitación no es posible con el HSRP. Presentaron al comando use-bia de trabajar alrededor de los problemas que ocurren cuando usted ejecuta el HSRP en los productos de menor capacidad según lo mencionado. Por ejemplo, si usted ejecuta el HSRP y el DECNet en las mismas interfaces, los problemas ocurren porque el DECNet y el HSRP intentan modificar la dirección MAC. Con el comando use-bia, usted puede configurar el HSRP para utilizar la dirección MAC creada por el proceso del DECNet. Sin embargo, usted debe ser consciente que hay algunas desventajas si usted utiliza el comando use-bia, por ejemplo:

  • Cuando un router se activa, la dirección IP virtual se traslada a una dirección MAC diferente. El nuevo router activo envía una respuesta de protocolo de resolución de dirección (ARP) gratuito, pero no todas las instrumentaciones de host manejan correctamente el ARP gratuito.

  • La configuración uso-BIA rompe el proxy ARP. Un router standby no puede cubrir la base de datos de Proxy ARP del router defectuoso que se perdió.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 13781