IP : Protocolo de router de reserva activa (HSRP)

Cómo utilizar los comandos standby preempt y standby track

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (23 Marzo 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo trabajan juntos los comandos standby preempt y standby track, y cuándo debe utilizar cada uno.

El comando standby preempt habilita el Protocolo de router en reserva activo HSRP con la prioridad más alta para convertirlo inmediatamente en el router activo. La prioridad se determina en primer lugar por el valor de prioridad configurado y luego, por la dirección IP. En cada caso, un valor más alto está de mayor prioridad. Cuando un router más prioritario se apropia de un router de menor prioridad, el router envía un mensaje de golpe. Cuando un router activo de menor prioridad recibe un mensaje de golpe o un mensaje Hello Messages de un activo, un router más prioritario, los cambios del router al estado del discurso y envía un mensaje de la dimisión.

El comando standby track le permite especificar otra interfaz en el router para que el proceso HSRP monitoree y pueda alterar la prioridad HSRP de un grupo determinado. Si va el Line Protocol de la interfaz especificada abajo, se reduce la prioridad HSRP. Esto significa que otros routers del HSRP con la prioridad más alta pueden hacer el router activo si ese router tiene el recurso seguro apropiarse de habilitado.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 12.2(10b) del½ del¿Â del Cisco IOSïÂ

  • Cisco 2503 Routers

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

Este diagrama muestra un ejemplo que utilice el comando standby preempt conjuntamente con el comando standby track.

6a.gif

Ejemplos de Configuración

En el diagrama de la red, el HSRP se configura de este modo:

  • El r1 es el router activo y sigue el estado de la interfaz del serial0 del r1. Cuando el r1 es el router activo, todo el tráfico de los host (el host 1, 2, 3) a los servidores se rutea con el r1.

  • El r2 es el router en espera y sigue el estado de la interfaz del serial 1 del r2.

  • Si va la interfaz del serial0 del r1 abajo, la prioridad HSRP del r1 es disminuida por 10. en este momento que la prioridad HSRP del r2 es más alta que el r1, y el r2 asume el control como el router activo. Cuando siente bien el r2 al router activo, todo el tráfico de los host a los servidores se rutea con el r2.

Nota: El default gateway para los host 1, 2, y 3 se configura con la dirección IP virtual del HSRP (171.16.6.100, en este caso). Un Routing Protocol, por ejemplo, RIP se configura en el Routers para habilitar la Conectividad entre los host y los servidores.

Aquí está la configuración para cada router:

Router1 (Cisco 2503)
interface Ethernet0 
ip address 171.16.6.5 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects 
standby 1 ip 171.16.6.100

!--- Assigns a standby group and standby IP address

standby 1 priority 105

!--- Assign a priority (105 in this case) to the router interface (e0)
!--- for a particular group number (1). The default is 100.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial0

!--- Indicates that HSRP tracks Serial0 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.

interface Serial0 
ip address 171.16.2.5 255.255.255.0

Router2 (Cisco 2503)
interface Ethernet0
ip address 171.16.6.6 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects
standby 1 ip

!--- Indicates the hot standby group. Here the IP address of the virtual router 
!--- is not configured. See the note after this table.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial1

!--- Indicates that HSRP tracks Serial1 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.
!--- The priority is also not configured and hence the default 
!--- priority value of 100 is applied.

interface Serial1
ip address 171.16.7.6 255.255.255.0

Nota: El r2 no tiene un IP Address en Standby configurado. Esto es intencional, tiene como objetivo demostrar que es una configuración válida. Cuando el r1 y el r2 intercambian el hellos del HSRP, el r2 aprende el IP Address en Standby del r1. Para configurar el r2 con un IP Address en Standby (la misma dirección de reserva configurada en el r1) es también una configuración válida.

R1# show standby
Ethernet0 - Group 1
Local state is Active, priority 105, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.458
Virtual IP address is 171.16.6.100 configured
Active router is local
Standby router is 171.16.6.6 expires in 8.428
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 02:09:49
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface    Decrement  State
Serial0         10      Up
 
R2# show standby
Ethernet0 - Group 1
Local state is Standby, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.814
Virtual IP address is 171.16.6.100
Active router is 171.16.6.5, priority 105 expires in 9.896
Standby router is local
3 state changes, last state change 00:10:21
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Aunque el r2 no tenga una prioridad HSRP configurada, la salida muestra la prioridad del r2 como el valor predeterminado del HSRP, 100. La salida de ambo Routers indica que el Routers sigue el estado del serial0. El estado del R1 es activo y el del R2 es inactivo. Pasado, configuran a ambo Routers con el comando standby preempt.

¿Qué ocurre si la interfaz serial 0 de R1 se desactiva? La salida del comando show standby es similar a esto:

R1# show standby
Ethernet0 - Group 1
Local state is Standby, priority 95 (confgd 105), may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.670
Virtual IP address is 171.16.6.100 configured
Active router is 171.16.6.6, priority 100 expires in 8.596
Standby router is local
4 state changes, last state change 00:01:45
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 0 up:
Interface    Decrement  State
Serial0         10      Down
   
R2# show standby
Ethernet0 - Group 1
Local state is Active, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.810
Virtual IP address is 171.16.6.100
Active router is local
Standby router is 171.16.6.5 expires in 9.028
Virtual mac address is 0000.0c07.ac01
4 state changes, last state change 00:01:38
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Aviso en la salida que la prioridad HSRP del r1 es reducida por 10 — a 95. Este cambio hace la prioridad del r2 de 100 más alta. Pues el r2 fue configurado para el recurso seguro apropíese en ese entonces que se convirtió la prioridad del r2 más arriba, r2 hace el router activo y el r1 se convierte en el recurso seguro. Ahora, si viene la interfaz del serial0 del r1 salvaguardia, la prioridad del r1 es 105, otra vez. En una situación semejante, el r1 se apropia y siente bien de nuevo al router activo del HSRP.

Nota: Si el recurso seguro se apropia no se configura en el r2, r2 no habría enviado un mensaje de golpe al r1, que hace el r2 llegar a ser activo. En lugar el r1 habría seguido siendo el router activo.

Por ejemplo, considere esta configuración:

standby priority 120
standby track serial 0
standby track serial 1

Una prioridad HSRP de 120 se configura con el comando standby priority y el HSRP se configura para seguir el estado de dos interfaces, serial0 y Serial1. Porque no se especifica ningún valor de disminución en el comando standby track, la prioridad HSRP decremented por el valor predeterminado de 10 cuando va la interfaz seguida abajo. Inicialmente, ambas las interfaces son ascendentes y la prioridad HSRP de la interfaz es 120, según lo en el comando show standby hecho salir:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 120, may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.034
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:04
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 2 up:
    Interface                  Decrement  State
    Serial0                       10      Up
    Serial1                       10      Up
R1#

Ahora, se derriba el interface serial 0.

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial0, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
R1#

Esto reduce la prioridad HSRP por 10 — a partir del 120 a un valor de 110. Usted puede utilizar el comando show standby de verificar esto:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 110 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 2.544
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:48
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 1 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Up
R1#

Después, se derriba el segundo interface serial 1 seguido —:

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial1, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down
R1#

Esto reduce otra vez la prioridad HSRP por 10 — a partir del 110 a un valor de 100. Usted puede utilizar el comando show standby de verificar esto:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 100 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.846
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:01:06
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 0 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Down  (line protocol down)
R1#

Cuando cualquier de las interfaces seriales seguidas (el serial0 o el serial 1) va abajo, la prioridad resultante es 110. Cuando ambo éstos siguieron las interfaces seriales (el serial0 y el serial 1) van abajo, la prioridad resultante es 100.

Nota: En ciertas versiones anteriores del Cisco IOS, el decremento en la prioridad HSRP no es acumulativo si usted no define explícitamente el valor de disminución en el comando standby track. Refiera al ID de bug CSCdp72834 (clientes registrados solamente) para más información.


Información Relacionada


Document ID: 13780