IP : Traducción de direcciones de red (NAT)

Agrupamientos NAT y subred cero

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento analiza cómo los agrupamientos de traducción de direcciones de red (NAT) están sujetos a las reglas de subred cero, de la misma manera que cualquier otra dirección IP.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Teoría Precedente

Al configurar un agrupamiento NAT para que las direcciones del mismo formen parte de la subred cero, la traducción del NAT falla.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para encontrar la información adicional en los comandos usados en este documento, use la Command Lookup Tool (clientes registrados solamente).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/13777/7a.gif

En este ejemplo de configuración, el dispositivo interno tiene una ruta predeterminado del router NAT. El dispositivo externo tiene una Static ruta a un direccionamiento al cual se traduzca el dispositivo interno. El router NAT tiene la siguiente configuración NAT:

ip nat pool test 171.68.1.1 171.68.1.10 netmask  255.255.240.0
ip nat inside source list 7 pool test 

interface s 0
ip address 171.16.4.6 255.255.255.0
ip nat inside

interface s 1
ip address 171.16.6.6 255.255.255.0
ip nat outside

access-list 7 permit host 171.16.4.4

Note que los direccionamientos en la prueba del agrupamiento NAT son direcciones subred cero. El ping desde el dispositivo interno al dispositivo externo falla porque no se produce ninguna traducción. Si usted funciona con el comando debug ip nat en el router NAT, revela estos mensajes:

NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5

Nota: La "(A)" en el resultado de la depuración significa que falló la traducción después del ruteo.

Nota: Para evitar este problema, configure el comando ip subnet-zero en el router NAT. El comando se habilita por abandono en el Software Release 12.0 del � del Cisco IOS. En versiones de Cisco IOS Software anteriores, no se habilita por abandono. Si el NAT no se configura correctamente cuando está utilizado con la PALMADITA, después la traducción de NAT puede fallar. Éstos son los códigos de falla de la traducción de NAT:

 A = Inside to outside fails after routing
 B = Outside to inside fails before routing
 C = Outside to inside fails after routing 
 D = Helpered fails 
 L = Internally generated packet fails 
 E = Inside to outside fails after routing

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 13777