IP : Protocolo de puerta de enlace fronteriza (BGP)

Cómo Utilizar HSRP para Proporcionar Redundancia en una Red de BGP con Varias Conexiones

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (23 Marzo 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo proporcionar redundancia en una red de Protocolo de la gateway marginal (BGP) con varias conexiones donde usted tiene conexiones a dos proveedores de servicio de Internet (ISP) distintos. En caso de falla de conectividad hacia un ISP, el tráfico se rerrutea dinámicamente a través del otro ISP con mediante el comando BGP set as-path {tag | prepend as-path-string} y Hot Standby Router Protocol (HSRP).

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

El objetivo de la configuración en este documento es alcanzar esta política de red:

  • Todo el tráfico saliente originado de los host en la red 192.168.21.0/24 y destinado al Internet se debe rutear con el r1 al ISP-A. Sin embargo, si ese link falla o el r1 falla, todo el tráfico saliente se debe rerrutear con el r2 al ISP-B (y entonces a Internet) sin la intervención manual.

  • Todo el tráfico entrante destinado a un sistema autónomo, AS100, de Internet se debe rutear por el r1. En caso que el link del ISP-A al r1 falle, el tráfico entrante se debe rerrutear automáticamente con el ISP-B al r2.

Estos requisitos se pueden cumplir con dos Tecnologías: BGP y HSRP.

El primer objetivo de un trayecto de salida completamente redundante se puede observar con el HSRP. Comúnmente, las computadoras no tienen la capacidad de recopilar e intercambiar información de ruteo. La dirección IP del default gateway se configura estáticamente en un PC y si va el router de gateway abajo, el PC pierde la Conectividad dispositivo más allá a su segmento de red local. Éste es el caso incluso si existe un gateway alterno. HSRP fue diseñado para cumplir con estos requisitos. Refiera a las características y a las funciones del HSRP para más información.

El segundo objetivo se puede alcanzar con el comando set as-path prepend BGP, que permite que el BGP propague un más largo COMO trayectoria (por prepending sus los propio COMO número más de una vez) con el r2 al link del ISP-B para el prefijo 192.168.21.0/24. Así, todos trafican destinado para 192.168.21.0/24 que venga desde fuera del AS100 lleve el más corto COMO trayectoria con el ISP-Al link del r1. Si el trayecto principal (ISP-A al r1) falla, todo el tráfico toma el más largo COMO trayectoria (ISP-B al r2) para alcanzar la red 192.168.21.0/24. Para aprender más sobre el comando set as-path prepend BGP, refiera al diagrama del atributo AS_PATH en el documento de los casos prácticos de BGP.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

Este documento utiliza la configuración de la red mostrada aquí:

En este diagrama, el Router 1 (R1) y el Router 2 (R2) se encuentran en AS 100, que tiene una conexión entre pares BGP (eBGP) con ISP-A (AS 300) e ISP-B (AS 400) respectivamente. El router 6 (R6) es una parte de AS 600, que cuenta con conexión entre pares eBGP con ISP-A e ISP-B. R1. El r2 tiene iBGP que mira, que es necesario asegurar el ruteo óptimo. Por ejemplo, cuando usted intenta alcanzar las rutas interno AS400, el r1 no emplea el trayecto más largo sobre el AS300. R1 adelante el tráfico al r2 en lugar de otro.

R1 y R2 también se configuran para HSRP sobre un segmento Ethernet común. Los host en el mismo segmento Ethernet tienen una ruta predeterminado esas puntas hacia la dirección IP 192.168.21.10 del HSRP en espera.

hsrp_bgp-01.gif

Configuraciones

R1
Current configuration

hostname R1
!
interface serial 0
ip address 192.168.31.1 255.255.255.0
!
interface Ethernet1
  ip address 192.168.21.1 255.255.255.0
  standby 1 priority 105
  standby 1 preempt delay minimum 60
  standby 1 ip 192.168.21.10
  standby 1 track Serial0

!--- The 
standby track serial command tracks the state of 
!--- the Serial0 interface and brings down the  
!--- priority of standby group 1, if the interface goes down.
!--- The 
standby preempt delay minimum 60 command makes sure that 
!--- R1 preempts and takes over as active router again. This command also ensures that
!--- the router waits 60 seconds before doing so in order to give BGP time enough
!--- to converge and populate the routing table. This avoids
!--- traffic being sent to R1 before it is ready to forward it.

!
!
router bgp 100
  no synchronization
  network 192.168.21.0
  neighbor 192.168.21.2 remote-as 100
  neighbor 192.168.21.2 next-hop-self
  neighbor 192.168.31.3 remote-as 300
  no auto-summary
!

R2
Current configuration:  

hostname  R2 
!
interface serial 0  
ip address 192.168.42.2 255.255.255.0  
!
interface Ethernet1  
 ip address 192.168.21.2 255.255.255.0  
 standby 1 priority 100  
 standby 1 preempt  
 standby 1 ip 192.168.21.10  
! 
!  
router bgp 100  
 no synchronization  
 network 192.168.21.0   
 neighbor 192.168.21.1 remote-as 100  
 neighbor 192.168.21.1 next-hop-self  
 neighbor 192.168.42.4 remote-as 400  
 neighbor 192.168.42.4 route-map foo out 

!--- It appends AS 100 to the BGP updates sent to AS 400 
!--- in order to make it a backup for the ISP-A to R1 path.

 no auto-summary  
!  
access-list 1 permit 192.168.21.0  
route-map foo permit 10  
 match ip address 1  
 set as-path prepend 100  

end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Cuando usted configura la Redundancia en cualquier red, usted debe considerar dos cosas:

  • La creación de un trayecto redundante para los paquetes que van de una red local a una red de destino.

  • La creación de un trayecto redundante para los paquetes que se vuelven de un destino a una red local.

Paquetes que viajan desde la red local hacia el destino

En este ejemplo, la red local es 192.168.21.0/24. El r1 y el r2 del router están ejecutando el HSRP en el segmento Ethernet conectado para interconectar el Ethernet1. El r1 se configura como el router activo del HSRP con una prioridad de reserva de 105, y el r2 se configura con una prioridad de reserva de 100. El comando del serial0 de la pista del recurso seguro 1 (s0) en el r1 permite que el proceso del HSRP monitoree esa interfaz. Si va el estado de la interfaz abajo, se reduce la prioridad HSRP. Cuando el protocolo de línea de la interfaz de s0 se desactiva, la prioridad HSRP se reduce a 95 (el valor predeterminado por el cual la prioridad se reduce es 10). Esto hace a los otros routers del HSRP, r2, tiene una prioridad más alta (una prioridad de 100). El r2 siente bien al router activo del HSRP y atrae el tráfico destinado al direccionamiento 192.169.21.10 del HSRP activo.

Publique el comando show standby para ver al router HSRP activo cuando el s0 de la interfaz en el r1 está para arriba:

R1#show standby 
   Ethernet1 - Group 1 
     Local state is Active, priority 105, may preempt 
     Hellotime 3 sec, holdtime 10 sec 
     Next hello sent in 0.338 
     Virtual IP address is 192.168.21.10 configured 
     Active router is local 
     Standby router is 192.168.21.2 expires in 8.280 
     Virtual mac address is 0000.0c07.ac01 
     13 state changes, last state change 00:46:10 
     IP redundancy name is "hsrp-Et0-1"(default) 
     Priority tracking 1 interface, 1 up: 
     Interface                    Decrement   State 
     Serial0                          10      Up 

R2#show standby 
   Ethernet1 - Group 1
     State is Standby
     56 state changes, last state change 00:05:13
     Virtual IP address is 192.168.21.10
     Active virtual MAC address is 0000.0c07.ac01
     Local virtual MAC address is 0000.0c07.ac01 (default)
     Hello time 3 sec, hold time 10 sec
     Next hello sent in 1.964 secs
     Preemption enabled
     Active router is 192.168.21.1, priority 105 (expires in 9.148 sec)
     Standby router is local
     Priority 100 (default 100)
     IP redundancy name is "hsrp-Et0-1" (default)

R1#show standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et1         1   105  P Active   local           192.168.21.2    192.168.21.10
R1#

R2#show standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et1         1   100  P Standby  192.168.21.1    local           192.168.21.10
R2#

El comando show standby muestra R1 como el router HSRP activo debido a que la prioridad más alta es 105. Puesto que el r1 es el router activo, el r1 posee el IP Address en Standby 192.168.21.10. Todo el tráfico IP del host configurado con el default gateway a las rutas de 192.168.21.10 con el r1.

Si usted derriba la interfaz del s0 en el r1 del router, el router activo del HSRP cambia puesto que el HSRP en el r1 se configura con el comando track serial 0 espera. Cuando va el protocolo de la interfaz del serial0 abajo, el HSRP reduce la prioridad del r1 por 10 (valor por defecto) a 95. El r1 cambia su estado al “recurso seguro”. El r2 asume el control como el router activo, y posee así el IP Address en Standby 192.168.21.10. Por consiguiente, todos trafican destinado de los host en las 192.168.21.0/24 rutas del segmento trafican con el r2. La salida de los comandos debug y show confirma lo mismo.

R1(config)# interface s0 
R1(config-if)# shut 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active         -> Speak 
 %LINK-5-CHANGED: Interface Serial0, changed state to administratively down 
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby 
 %LINK-3-UPDOWN: Interface Serial0, changed state to down: 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active       -> Speak 
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby 

Note que siente bien el r1 a un router en espera.

Si el r2 entra el estado activo, después usted ve la salida similar a esto:

R2# 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Standby        -> Active 

Si ejecuta el comando show standby en el R1 y el R2, observe las prioridades de espera luego de que la interfaz s0 desciende en el R1:

R1#show standby
Ethernet1 - Group 1
  Local state is Standby, priority 95 (confgd 105), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 0.808
  Virtual IP address is 192.168.21.10 configured
  Active router is 192.168.21.2, priority 100 expires in 9.008
  Standby router is local
  15 state changes, last state change 00:00:40
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 1 interface, 0 up:
    Interface               Decrement   State
    Serial0                      10     Down  (administratively down)
R1#
 
R2#show standby
Ethernet1 - Group 1
  State is Active
    57 state changes, last state change 00:00:33
  Virtual IP address is 192.168.21.10
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (bia)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.648 secs
  Preemption enabled
  Active router is local
  Standby router is 192.168.21.1, priority 95 (expires in 7.096 sec)
  Priority 100 (default 100)
  IP redundancy name is "hsrp-Et0-1" (default)
R2#

R2#

R1#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et0         1   95   P Standby  192.168.21.2    local           192.168.21.10
R1# 

R2#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et0         1   100  P Active   local           192.168.21.1    192.168.21.10
R2#

Note que la prioridad de reserva R1 ha reducido a partir del 105 a 95, y r2 ha hecho el router activo.

Resumen

En caso de falla de conectividad entre el ISP-A y el r1, el HSRP reduce la prioridad del grupo en espera en el r1. R1 pasa de estado Activo a En espera. R2 pasa del estado de reserva al estado activo. El IP Address en Standby 192.168.21.10 llega a ser activo en el r2, y los host que envían el tráfico al r2 y al ISP-B del uso de Internet, proporcionando a un trayecto alterno para el tráfico saliente.

Para más información sobre el comando hsrp standby track, refiérase a cómo utilizar los comandos standby preempt y standby track.

Paquetes que vienen del destino hacia la red local

Según la política de red definida en la sección de información previa, puesto que el ISP-A es su trayecto principal y el ISP-B es el trayecto de backup para el tráfico que viene hacia 192.168.21.0/24 (por las razones tales como una conexión de ancho de banda más grande hacia el ISP-A), usted puede añadir sus los propio al final del fichero PUES número en las actualizaciones de BGP anunciadas hacia el ISP-B en el r2 para hacer COMO trayectoria con el ISP-B para aparecer más de largo. Para hacer esto, configure un Route Map para el vecino BGP 192.168.42.4. En ese Route Map, añada sus los propio al final del fichero COMO con el comando set as-path prepend. Aplique esta correspondencia de ruta a las actualizaciones salientes al vecino 192.168.42.4.

Nota: En la producción, usted debe añadir al final del fichero COMO número más de una vez para asegurarse de que la ruta anunciada se prefiere menos.

Ésta es la tabla BGP en el R6 para la red 192.168.21.0 cuando la conectividad BGP entre el r1 al ISP-A y el r2 al ISP-B está para arriba:

R6#
show ip bgp 192.168.21.0
BGP routing table entry for 192.168.21.0/24, version 30 
Paths: (2 available, best #1) 
  Advertised to non peer-group peers: 
    192.168.64.4 
  300 100 
    192.168.63.3 from 192.168.63.3 (10.5.5.5) 
      Origin IGP, localpref 100, valid, external, best, ref 2 
  400 100 100 
    192.168.64.4 from 192.168.64.4 (192.168.64.4) 
      Origin IGP, localpref 100, valid, external

El BGP selecciona el mejor trayecto como COMO {300 100} con el ISP-A porque tiene un más pequeño COMO longitud del trayecto en comparación con COMO trayectoria {400 100 100} del ISP-B. La razón por la que hay un trayecto AS más largo desde ISP-B es por la configuración prefijada del trayecto AS en R2.

Cuando la Conectividad se rompe entre el r1 y el ISP-A, el R6 debe elegir el trayecto alterno con el ISP-B para alcanzar la red 192.168.21.0/24 en el AS100:

R1(config)#interface s0 
R1(config-if)#shut 
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 

Ésta es la tabla BGP en el R6 para la red 192.168.21.0/24:

R6#show ip bgp 192.168.21.0 
BGP routing table entry for 192.168.21.0/24, version 31 
Paths: (1 available, best #1) 
  Advertised to non peer-group peers: 
    192.168.63.3 
  400 100 100 
    192.168.64.4 from 192.168.64.4 (192.168.64.4) 
      Origin IGP, localpref 100, valid, external, best

Refiera a la configuración de muestra para el BGP con dos diversos proveedores de servicio (multihoming) para más información sobre las configuraciones BGP en una red con varias conexiones.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 13768