IP : Protocolo de puerta de enlace fronteriza (BGP)

Configuración de la característica Local-AS BGP

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento explica la función local-AS del Border Gateway Protocol (BGP), que estaba primero disponible en el Software Release 12.0(5)S del � del Cisco IOS.

La función local-AS permite que un router aparezca ser un miembro de un segundo sistema, además de su real COMO. Esta característica sólo puede utilizarse para entidades pares eBGP verdaderas. Usted no puede utilizar esta característica para dos pares que sean miembros de diversa confederación sub-AS.

prerrequisitos

Requisitos

Para entender este documento es necesario entender previamente el protocolo de ruteo BGP y sus operaciones. Refiera a los casos prácticos de BGP.

Componentes Utilizados

La información en este documento se aplica a estas versiones de software y hardware.

  • Cisco IOS Software Release 12.2(28)

  • Cisco 2500 Series Routers

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Sintaxis del comando

Esta lista muestra el sintaxis de los comandos que las configuraciones en este uso del documento.

Local-COMO no puede ser personalizado para los pares individuales en un grupo de peer.

Local-COMO no puede tener el protocolo BGP local COMO número o COMO número del peer remoto.

El comando local-as es válido únicamente si el par es un par eBGP verdadero. No trabaja para dos pares en diversos sub-AS en una confederación.

Refiera a la guía de referencia del comando bgp para más información sobre los comandos bgp.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

La función local-AS es útil si el ISP-A compra el ISP-B, pero los clientes ISP-B no quieren modificar ningunos arreglos de comunicación entre peers o configuraciones. La función local-AS permite que el Routers en el ISP-B haga miembros de las ISP-a COMO. Al mismo tiempo, este Routers aparece a sus clientes conservar su ISP-B COMO número.

En el cuadro 1, el ISP-A todavía no ha comprado el ISP-B. En el cuadro 2, el ISP-A ha comprado el ISP-B, y el ISP-B utiliza la función local-AS.

En el cuadro 2, el ISP-B pertenece al AS100, y al ISP-C al AS300. Al mirar con el ISP-C, el ISP-B utiliza el AS200 como su COMO número con el uso del comando neighbor ISP-C local-as 200. En las actualizaciones enviadas del ISP-B al ISP-C, AS_SEQUENCE adentro el atributo AS_PATH contiene "200 el 100". El "200" prepended por el ISP-B debido al comando local-as 200 configurado para el ISP-C.

Un ISP-A/B combinado renumera normalmente al Routers en el ISP-B para ser AS100 de la parte de. ¿Qué si ISP-C es el cambio incapaz sus configuraciones de eBGP con el ISP-B? Antes de la función local-AS, el ISP-A/B combinado tiene que mantener dos COMO números. El comando local-as permite que el ISP-A/B sea físicamente uno COMO mientras que aparece ser dos AS al ISP-C.

Configurar

En esta sección se presenta información para configurar las características que este documento describe.

Nota: Para encontrar la información adicional en los comandos que este documento utiliza, que utilice la herramienta de búsqueda de comandos (clientes registrados solamente).

Diagramas de la Red

Este documento utiliza estas configuraciones de la red.

Figura 1

/image/gif/paws/13761/39a.gif

Figura 2

/image/gif/paws/13761/39b.gif

Configuraciones

Este documento usa estas configuraciones.

ISP-B (AS100, local-como 200)
hostname ISP-B
! 
interface serial 0 
ip address 192.168.1.1 255.255.255.252 
! 
interface ethernet 0 
ip address 192.168.4.1 255.255.255.0 
! 
router bgp 100 

!--- Note the AS number 100. This is the AS number of ISP-A, which is now
!--- used by all routers in ISP-B after its acquisition by ISP-A.

 neighbor 192.168.1.2 remote-as 300 

!--- Defines the e-BGP connection to ISP-C.

 neighbor 192.168.1.2 local-as 200 

!--- This command makes the remote router in ISP-C to see this
!--- router as belonging to AS 200 instead of AS 100. 
!--- This also make this router to prepend AS 200 in 
!--- all updates to ISP-C.

network 192.168.4.0
! 
!

ISP-C (AS300)
hostname ISP-C
! 
interface serial 1 
ip address 192.168.1.2 255.255.255.252 
! 
interface ethernet 0 
ip address 192.168.9.1 255.255.255.0 
! 
router bgp 300 
 neighbor 192.168.1.1 remote-as 200

!--- Defines the e-BGP connection to ISP-B.


!--- Note AS is 200 and not AS 100.
 
 network 192.168.9.0 
! 
!

Verificación

Esta sección proporciona la información que usted puede utilizar para confirmar su configuración trabaja correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Refiera a la guía de referencia del comando bgp para aprender más sobre los comandos show usados en esta sección.

Vea la tabla de BGP Routing para ver cómo el comando local-as cambió el AS_PATH. Qué usted observa es ese ISP-B prepends el AS200 a las actualizaciones a las cuales se envían y se reciben del ISP-C. Además, observe que el ISP-B está adentro COMO número 100.

ISP-B# 
show ip bgp summary

  BGP router identifier 192.168.4.1, local AS number 100 
  BGP table version is 3, main routing table version 3 
  2 network entries and 2 paths using 266 bytes of memory 
  2 BGP path attribute entries using 104 bytes of memory 
  1 BGP AS-PATH entries using 24 bytes of memory 
  0 BGP route-map cache entries using 0 bytes of memory 
  0 BGP filter-list cache entries using 0 bytes of memory 
  BGP activity 2/6 prefixes, 2/0 paths, scan interval 15  secs 

  Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
  192.168.1.2     4   300      29      29        3    0    0 00:25:19       1

En esta salida, observe que el ISP-C considera el ISP-B como parte del AS200.

ISP-C# show ip bgp summary 
  BGP table version is 3, main routing table version 3 
  2 network entries (2/6 paths) using 480 bytes of memory 
  2 BGP path attribute entries using 192 bytes of memory 
  0 BGP route-map cache entries using 0 bytes of memory 
  0 BGP filter-list cache entries using 0 bytes of memory 

  Neighbor        V    AS MsgRcvd MsgSent  TblVer InQ OutQ   Up/Down  State/PfxRcd 
  192.168.1.1     4   200      34      34       3   0    0  00:30:19   1

Observe en esta salida que el ISP-B prepends el "200" a las rutas aprendidas del ISP-C.

ISP-B# 
show ip bgp

  BGP table version is 3, local router ID is 192.168.4.1 
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
  Origin codes: i - IGP, e - EGP, ? - incomplete 

  Network          Next Hop            Metric LocPrf  Weight   Path 
  *> 192.168.4.0      0.0.0.0               0          32768   i 
  *> 192.168.9.0      192.168.1.2           0              0   200 300 i

Observe que el ISP-C considera las rutas del ISP-B con un AS_PATH de "200 el 100".

ISP-C# show ip bgp 
  BGP table version is 3, local router ID is 192.168.1.2 
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
  Origin codes: i - IGP, e - EGP, ? - incomplete 

  Network          Next Hop          Metric LocPrf  Weight Path 
  *> 192.168.4.0      192.168.1.1         0              0 200 100 i 
  *> 192.168.9.0      0.0.0.0             0          32768 i

Este de los comandos show configurado local-como valora en su salida:

ISP-B# show ip bgp neighbors 192.168.1.2
BGP neighbor is 192.168.1.2,  remote AS 300,  local AS 200, external link
  BGP version 4, remote router ID 192.168.9.1
  BGP state = Established, up for 00:22:42
  Last read 00:00:42, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                2          1
    Keepalives:            25         25
    Route Refresh:          0          1
    Total:                 28         28
  Default minimum time between advertisement runs is 30 seconds

! Output Suppressed

Troubleshooting

El comando debug ip bgp updates visualiza los prefijos recibidos con sus atributos del vecino. Esta salida muestra que el prefijo 192.168.4.0/24 está recibido con AS PATH 200, 100.

ISP-C#
*May 10 12:45:14.947: BGP(0): 192.168.1.1 computing updates, afi 0, neighbor ver
sion 0, table version 5, starting at 0.0.0.0
*May 10 12:45:14.947: BGP(0): 192.168.1.1 send UPDATE (format) 192.168.9.0/24, n
ext 192.168.1.2, metric 0, path
*May 10 12:45:14.947: BGP(0): 192.168.1.1 1 updates enqueued (average=52, maximu
m=52)
*May 10 12:45:14.947: BGP(0): 192.168.1.1 update run completed, afi 0, ran for 0
ms, neighbor version 0, start version 5, throttled to 5
*May 10 12:45:14.947: BGP: 192.168.1.1 initial update completed
*May 10 12:45:15.259: BGP(0): 192.168.1.1 rcvd UPDATE w/ attr: nexthop 192.168.1
.1, origin i, metric 0, path 200 100
ISP-C#
*May 10 12:45:15.259: BGP(0): 192.168.1.1 rcvd 192.168.4.0/24
*May 10 12:45:15.279: BGP(0): Revise route installing 192.168.4.0/24 -> 192.168.
1.1 to main IP table
ISP-C#

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 13761