IP : Protocolo de puerta de enlace fronteriza (BGP)

Características de contabilidad de la interfaz de salida de las estadísticas de la política de BGP y de las estadísticas de la política de BGP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Con la característica de contabilización de políticas (PA) de Border Gateway Protocol (BGP), podrá contabilizar el tráfico IP de forma diferencial mediante la asignación de contadores según la lista de comunidad, número AS y/o AS_PATH por cada interfaz de entrada.

Las estadísticas de la interfaz de salida del BGP PA introducen varias Extensiones para habilitar el BGP PA en una interfaz de salida y para incluir las estadísticas basadas en una dirección de origen para ambos tráfico entrada y salida en una interfaz. Los contadores basados en parámetros tales como lista de comunidad, el número del sistema autónomo o la trayectoria del sistema autónomo se asignan para identificar el tráfico IP.

prerrequisitos

Requisitos

Antes de que usted utilice la característica del BGP PA, habilite el Cisco Express Forwarding (CEF) o el Distributed Cisco Express Forwarding (dCEF) en el router.

Componentes Utilizados

La característica del BGP PA primero es soportada por las Plataformas siguientes que soportan el Cisco IOS Release 12.0(9)S.

  • Cisco 7200, 7500 y 12000 Series Router

El número de Plataformas que soporten esta característica en el Cisco IOS Release 12.2(13)T es mucho más grande. Las Plataformas incluyen:

  • 1400, 1600, 1700, 2600, 3600, 7100, 7200, 7500, AS5300, AS5350, AS5400, AS5800, AS5850, ICS7750, IGX8400 URM, MGX8850, ubr7200.

Las estadísticas de la interfaz de salida del BGP PA fueron agregadas en 12.0(22)S y primero introdujeron como nueva función en 12.3(4)T. Hay muchas Plataformas de Cisco que soportan esta característica.

Nota: Para conseguir la información actualizada con respecto al Soporte de la plataforma para esta característica, Cisco Feature Navigator II (clientes registrados solamente) del acceso.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Teoría Precedente

Esta característica estaba primero disponible en el Software Release 12.0(9)S ED del½ del¿Â del Cisco IOSïÂ. Para que la función de contabilidad de políticas trabaje, usted debe habilitar el BGP y el CEF/dCEF en el router.

Usando las estadísticas de la política de BGP, usted puede explicar el tráfico (y aplicar la factura) según la ruta que atraviesa. Por ejemplo, usted puede explicar el tráfico que es nacional ruteado, internacional, terrestre, o el satélite. De esta manera, usted puede identificar y explicar todo el tráfico en un según el cliente.

Esta característica se aprovecha del comando bgp table-map, que clasifica los prefijos que pone en la tabla de ruteo según la lista de comunidad, COMO número, AS_PATH, y así sucesivamente. De acuerdo con estos criterios de concordancia, la política de contabilidad BGP fija un número del compartimiento (actualmente 1 a 64) de una tabla de contabilidad asociada a cada interfaz. Cada compartimiento representa una Clasificación de tráfico, que permite que el tráfico IP sea explicado diferenciado por la lista de comunidad, COMO número, o el AS_PATH por la interfaz de entrada.

Para más información, refiera a las estadísticas de la política de BGP.

Nota: El BGP PA mide y clasifica el tráfico IP al cual se envía, o se recibe de, diversos pares. El PA estaba previamente disponible en una interfaz de entrada solamente.

La función BGP Policy Accounting Output Interface Accounting inserta varias extensiones para habilitar BGP PA en una interfaz de salida y para incluir contabilización basada en una dirección de origen para el tráfico de entrada y de salida en una interfaz. Los contadores basados en parámetros tales como lista de comunidad, el número del sistema autónomo o la trayectoria del sistema autónomo se asignan para identificar el tráfico IP. Las estadísticas de la interfaz de salida fueron agregadas en el Cisco IOS Release 12.0(22)S.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configuración de la política de contabilidad BGP

  1. Especifique a las comunidades en las listas de comunidad (o defina las listas del AS_PATH) que clasifican el tráfico para considerar.

    ip community-list 30 permit 100:190
      ip community-list 40 permit 100:198
      ip community-list 50 permit 100:197
      ip community-list 60 permit 100:296
      ip community-list 70 permit 100:201
      !
  2. Defina un route-map para hacer juego las listas de comunidad y para fijar los números apropiados del compartimiento.

    route-map set_bucket permit 10
    match community 30
    set traffic-index 2
    !
    route-map set_bucket permit 20
    match community 40
    set traffic-index 3
    !
    route-map set_bucket permit 30
    match community 50
    set traffic-index 4
    !
    route-map set_bucket permit 40
    match community 60
    set traffic-index 5
    !
    route-map set_bucket permit 50
    match community 70
    set traffic-index 6 
  3. Utilice el comando table-map bajo el BGP de modificar el número del compartimiento cuando la tabla de IP Routing se pone al día con las rutas aprendidas del BGP.

    router bgp 110
      table-map set_bucket
      network 15.1.1.0 mask 255.255.255.0
      neighbor 14.1.1.1 remote-as 100
      !
      ip classless
      ip bgp-community new-format 
  4. Habilite la función de contabilidad de políticas en la interfaz de entrada conectada con el cliente.

    interface POS7/0
      ip address 15.1.1.2 255.255.255.0
      no ip directed-broadcast
      bgp-policy accounting
      no keepalive
      crc 32
      clock source internal

Configurar las estadísticas de la interfaz de salida de las estadísticas de la política de BGP

Las estadísticas de la interfaz de salida de la configuración de BGP PA son muy similares al BGP PA. El primer paso tres descrito en la sección anterior es exactamente lo mismo. El único cambio está en el comando bgp-policy accounting que se utiliza para habilitar la característica PA en la interfaz. En el ejemplo debajo del BGP PA se habilita en la interfaz POS 7/0. Los criterios PA se basan en la dirección de origen del tráfico de la salida

interface POS7/0
 ip address 10.15.1.2 255.255.255.0
 bgp-policy accounting output source
 no keepalive
 crc 32
 clock source internal

Comandos show que supervisan la contabilidad de políticas

Para examinar se asigna qué prefijo al cual compartimiento y al cual utiliza la comunidad (o las comunidades), los comandos show ip cef y show ip bgp.

Router# show ip cef 196.240.5.0 detail
196.240.5.0/24, version 21, cached adjacency to POS7/2
0 packets, 0 bytes, traffic_index 4
  via 14.1.1.1, 0 dependencies, recursive
   next hop 14.1.1.1, POS7/2 via 14.1.1.0/30
   valid cached adjacency

Router# show ip bgp 196.240.5.0
BGP routing table entry for 196.240.5.0/24, version 2
Paths: (1 available, best #1)
  Not advertised to any peer
  100
    14.1.1.1 from 14.1.1.1 (32.32.32.32)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Community: 100:197

Para mirar las estadísticas de tráfico del por interface, utilice el comando show cef interface policy-statistics.

LC-Slot7# show cef interface policy-statistics
:
POS7/0 is up (if_number 8)
Bucket    Packets               Bytes

1          0                      0
2          0                      0
3          50                     5000
4          100                    10000
5          100                    10000
6          10                     1000
7          0                      0
8          0                      0

Información Relacionada


Document ID: 13760