IP : Protocolo de puerta de enlace fronteriza (BGP)

Configuración de muestra para eliminar los números AS privados en BGP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento muestra configuraciones de muestra para la remoción de números de Sistema Autónomo (AS) privado de actualizaciones salientes del eBGP. Hay dos categorías de números: privados y públicos. Como ocurre con las direcciones IP privadas y públicas, no se puede filtrar números AS privados a Internet. Los números AS públicos van de 1 a 64511 y los números AS privados de 64512 a 65535. Puede usar números AS privados para dividir AS grandes en varios AS pequeños conectados a través de eBGP. Además, si está conectado a un único ISP, el ISP puede asignar números AS privados para conservar números AS públicos. No obstante, debe eliminar estos números AS privados antes de enviar las actualizaciones a la malla BGP global (Internet).

Nota: La asignación del soldado COMO números no se recomienda si usted conecta con los ISP múltiples. El soldado COMO números puede ser utilizado si la red del cliente conecta con un solo ISP (o escoja dirigido o dual-homed).

Refiera a quitar los números privados del sistema autónomos en el BGP para más información sobre el soldado COMO números.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información en este documento se aplica a estas versiones de software y hardware:

  • Software Release 12.2(27) del½ del¿Â del Cisco IOSïÂ

  • Cisco 2501 y Cisco 2503 Router

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

Este documento utiliza un público de la configuración de la red en la cual el router3 utiliza el soldado COMO número 65000, y del uso del router1 y del router2 COMO números AS1 y COMO 5 respectivamente.

El router2 está en la nube del proveedor de servicio con el router1 (ejecutándose COMO 1) y router3 (que se ejecutan COMO 65000) como sus clientes.

/image/gif/paws/13758/36-1.gif

Envíe y reciba las actualizaciones

Este procedimiento explica la Secuencia de eventos que ocurre cuando el router3 hace publicidad de una red (10.0.0.0/24 en este caso).

  1. El router3 hace publicidad de la red 10.0.0.0/24 con COMO atributo path 65000 al router2.

  2. El router2 recibe la actualización del router3 y hace una entrada para la red 10.0.0.0 /24 en su tabla de ruteo con el salto siguiente como 172.16.0.1 (s0 de la interfaz serial en el router 3).

  3. El router2 (dispositivo del proveedor de servicio), cuando está configurado con el comando remove-private-as vecino de 192.168.0.2, pela el soldado COMO número y construye un nuevo paquete de actualización con sus los propio COMO número como COMO atributo path para la red 10.0.0.0/24 y envía lo mismo al router1 que está en el AS1.

  4. El router1 recibe la actualización del eBGP para la red 10.0.0.0/24 y hace una entrada en su tabla de ruteo con el salto siguiente como 192.168.0.1 (s1 de la interfaz serial en el router 2). COMO atributo path para esta red según lo visto en el router1 está COMO 5 (router 2). Así, el privados COMO números se previenen de ingresar las tablas BGP del Internet.

Configuraciones

En este documento, se utilizan estas configuraciones:

Router 3
Current configuration :
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.1 255.255.255.0
!
router bgp 65000
 network 10.0.0.0 mask 255.255.255.0
 neighbor 172.16.0.2 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5. 

!
end

Router 2
Current configuration :
!
!
interface Ethernet0
 ip address 172.30.1.1 255.255.0.0
!
interface Serial0
 ip address 172.16.0.2 255.255.255.0
!
interface Serial1
 ip address 192.168.0.1 255.255.255.0
!
router bgp 5
 network 172.30.0.0
 network 192.168.0.0
 neighbor 172.16.0.1 remote-as 65000

!--- Configures Router 3 as an eBGP neighbor in private AS 65000.

 neighbor 192.168.0.2 remote-as 1

!--- Configures Router 1 as an eBGP neighbor in public AS 1. 

 neighbor 192.168.0.2 remove-private-AS

!--- Removes the private AS numbers from outgoing eBGP updates.

!
!
end

Router 1
Current configuration :
!
version 12.2
!
!
interface Serial0
 ip address 192.168.0.2 255.255.255.0
 !
router bgp 1
 neighbor 192.168.0.1 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5.

!
end

Formato de PUNTO del sistema autónomo

Este ejemplo explica cómo convertir COMO número mayor de 65535 al sistema autónomo 4-Byte (formato ASDOT).

Antes de la configuración ASDOT

Router#show run | beg router 
router bgp 131280
no synchronization 
bgp log-neighbor-changes 
no auto-summary 

Configuración ASDOT

Router(config-router)#bgp asnotation dot 
Router(config-router)#end 

Después de la configuración

Router#show run | beg router bgp 
router bgp 2.208  <== 
no synchronization 
bgp asnotation dot 
bgp log-neighbor-changes 
no auto-summary ! 

Verificación

Esta sección proporciona la información que usted puede utilizar para confirmar su configuración trabaja correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Los mensajes del debug tomados con el comando debug ip bgp updates en el router1 muestran que la actualización para la red 10.0.0.0/24 recibida del router2 (192.68.0.1) tiene COMO atributo path 5 cuál es COMO número de router2. El comando show ip bgp en el router2 y el router1 también ilustran lo mismo.

Router1#
1w1d: %BGP-5-ADJCHANGE: neighbor 192.168.0.1 Up
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, 
       neighbor version 0, table version 1, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, 
       ran for 0ms, neighbor version 0, start version 1, throttled to 1
1w1d: BGP: 192.168.0.1 initial update completed
1w1d: BGP(0): 192.168.0.1 rcvd UPDATE w/ attr: nexthop 
       192.168.0.1, origin i, path 5
1w1d: BGP(0): 192.168.0.1 rcvd 10.0.0.0/24
1w1d: BGP(0): Revise route installing 10.0.0.0/24 -> 192.168.0.1 
      to main IP table
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, neighbor 
      version 1, table version 2, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, ran for 0ms,
      neighbor version 1, start version 2, throttled to 2

Router2#show ip bgp
BGP table version is 3, local router ID is 192.168.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network         Next Hop      Metric  LocPrf Weight   Path
 *> 10.0.0.0/24     172.16.0.2         0              0   65000 i
 *> 172.30.0.0      0.0.0.0            0         32768    i
 

Router1#show ip bgp
BGP table version is 19, local router ID is 192.168.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network          Next Hop      Metric  LocPrf  Weight  Path
 *> 10.0.0.0/24      192.168.0.1                        0  5 i
 *> 172.30.0.0       192.168.0.1        0               0  5 i

La tabla BGP de router2 muestra que la red 10.0.0.0 origina COMO de 65000. La tabla BGP de router1 muestra que la misma red origina COMO de 5. Esto está debido al comando remove-private-as vecino de 192.168.0.2 en el router2, que pela el soldado COMO número y previene el soldado COMO números de alcanzar Internet. Por esta razón, el AS 1 (Router 1) considera constantemente al AS 5 como creador de la red 10.0.0.0/24.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 13758