IP : Protocolo de puerta de enlace fronteriza (BGP)

Ejemplo de configuración de iBGP y eBGP con o sin dirección de loopback

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (18 Diciembre 2015) | Comentarios


Contenido


Introducción

BGP es un protocolo de gateway exterior (EGP), usado para realizar el ruteo entre dominios en las redes TCP/IP. Un router BGP debe establecer una conexión (en el puerto TCP 179) con cada uno de sus peers BGP para poder intercambiar las actualizaciones de BGP. La sesión de BGP entre dos peers BGP se dice que es una sesión de BGP externo (eBGP) si los peers BGP se encuentran en sistemas autónomos diferentes (AS). Una sesión de BGP entre dos peers BGP se dice que es una sesión de BGP interno (iBGP) si los peers BGP se encuentran en los mismos sistemas autónomos.

Por abandono, la relación de peer se establece usando la dirección IP de la interfaz más cercana al router del par. Sin embargo, usando el comando neighbor update-source, cualquier interfaz operativa, incluyendo el Loopback Interface, se puede especificar para ser utilizado para establecer las conexiones TCP. Este método de peering usando un Loopback Interface es útil puesto que no derribará a la sesión de BGP cuando hay trayectos múltiples entre los peeres BGP, que darían lugar de otra manera a derribar a la sesión de BGP si va la interfaz física usada para establecer la sesión abajo. Además de eso, también permite al Routers que ejecuta el BGP con los links múltiples entre ellos para cargar la balanza sobre los trayectos disponibles.

Los ejemplos de configuraciones presentes en este documento son para iBGP y eBGP, tanto para las que tienen direcciones de loopback como para las que no.

Nota: Puede utilizar estas configuraciones para establecer relaciones entre vecinos. Refiérase usando el protocolo Protocolo de la puerta de enlace marginal (BGP) para la encaminamiento de Interdomain para más Configuraciones complejas.

prerrequisitos

Requisitos

Antes de que usted intente esta configuración, asegúrese de que usted cumpla este requisito:

  • Conocimiento de los protocolos BGP

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware. Tomaron las salidas de comando mostradas en este documento de los 2500 Series Router que funcionaban con la versión 12.2(24a) del IOS.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

Esta sección contiene los ejemplos de configuración siguientes:

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/13751-23a.gif

configuración de iBGP

En esta configuración, ambo Routers está en el AS400.

R1-AGS R6-2500
Current configuration:

!-- Output suppressed.

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 400

!--- Enables BGP for the autonomous
!--- system 400.

 neighbor 10.10.10.2 remote-as 400
 
!--- Specifies a neighbor 10.10.10.2
 !--- in the remote AS 400, making
 !--- this an iBGP connection.  
!-- Output suppressed.

end
Current configuration:

!-- Output suppressed.

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 400

!-- Output suppressed.

end

configuración de eBGP

En esta configuración, el router R1-AGS está en el AS300 y el router R6-2500 está en el AS400.

R1-AGS R6-2500
Current configuration:

!-- Output suppressed

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 300

!--- Enables BGP for the autonomous
!--- system 300.

 neighbor 10.10.10.2 remote-as 400
 
!--- Specifies a neighbor 10.10.10.2
 !--- in the remote AS 400, making
 !--- this an eBGP connection.


!-- Output suppressed.

end
Current configuration:

!-- Output suppressed.

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 300

!-- Output suppressed.

end

Los pares deben estar directamente conectados cuando utilizan eBGP. Si no están conectados directamente, el comando neighbor ebgp-multihop debe ser utilizado y una trayectoria a través de un IGP o de una Static ruta para alcanzar al par debe existir para que el Routers establezca la relación de vecino. En la configuración arriba, el router R1-AGS pertenece al AS300 mientras que el router R6-2500 pertenece al AS400.

configuración de iBGP con un Loopback Address

Usted puede configurar el iBGP usando un Loopback Address (o cualquier otra interfaz operativa) tal y como se muestra en de esta sección.

R1-AGS R6-2500
Current configuration:


!-- Output suppressed.

interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 300
  neighbor 2.2.2.2 update-source Loopback0
  
!--- This command specifies that the TCP
  !--- connection with the specified external
  !--- peer should be established using the
  !--- address on the loopback interface.

 !
 ip route 2.2.2.2 255.255.255.255 10.10.10.2
 
!--- This static route ensures that the 
 !--- remote peer address used for peering
 !--- is reachable.
!-- Output suppressed.

end
Current configuration:


!-- Output suppressed.

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 300
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1

!-- Output suppressed.

end

configuración de eBGP con un Loopback Address

Usted puede también configurar el eBGP usando un Loopback Address (o cualquier otra interfaz operativa) tal y como se muestra en de esta sección. Las interfaces del loopback se utilizan de este modo para garantizar el accesibilidad en las redes con los trayectos múltiples tal y como se muestra en de la carga a compartir usando el Loopback Address como sección del vecino BGP de la carga a compartir con el BGP en el entornos de una sola conexión y de varias conexiones: Configuraciones de muestra.

R1-AGS R6-2500
Current configuration:


!-- Output suppressed.


interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 400
  neighbor 2.2.2.2 ebgp-multihop 2
 
 !--- This command changes the ttl value in 
  !--- order to allow the packet to reach the 
  !--- external BGP peer which is not directly
  !--- connected or is using an interface other
  !--- than the directly connected interface.

  neighbor 2.2.2.2 update-source Loopback0
  
!--- This command specifies that the TCP
  !--- connection with the external BGP
  !--- peer should be established using the
  !--- address on the loopback interface.
 !

 ip route 2.2.2.2 255.255.255.255 10.10.10.2

 !--- This static route ensures that the 
 !--- remote peer address used for peering
 !--- is reachable.


!-- Output suppressed.


end
Current configuration:


!-- Output suppressed.


interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1


!-- Output suppressed.


end

Verificación

En esta sección encontrará información que puede utilizar para comprobar que su configuración esté funcionando correctamente. La herramienta Output Interpreter admite algunos comandos show y le permite ver un análisis de los resultados de este comando.

Verifique la configuración de iBGP

Utilice el comando show ip bgp neighbors al mostrar información sobre las conexiones TCP y del Border Gateway Protocol (BGP) y verifiquelo si establecen al peer BGP. La salida del comando show ip bgp neighbors abajo muestra el estado BGP como “establecido”, que indica que la relación del peer BGP se ha establecido con éxito.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:04:20
  BGP table version 1, neighbor version 1
R1-AGS#

Han utilizado al comando show ip bgp neighbors arriba con el modificante | incluya el BGP. Esto hace la salida más legible filtrando el salida de comando y visualizando a las partes pertinentes solamente.

Además, el comando show ip bgp summary puede también ser utilizado para visualizar el estatus de todas las conexiones BGP, como se muestra abajo.

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 400	
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

Verifique la configuración de eBGP

Utilice el comando show ip bgp neighbors al mostrar información sobre las conexiones TCP y del Border Gateway Protocol (BGP) y verifiquelo si establecen al peer BGP. La salida del comando show ip bgp neighbors abajo muestra el estado BGP como “establecido”, que indica que la relación del peer BGP se ha establecido con éxito.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:17
  BGP table version 1, neighbor version 1

Además, el comando show ip bgp summary puede también ser utilizado para visualizar el estatus de todas las conexiones BGP, como se muestra abajo.

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.10.10.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

Verifique la configuración de iBGP con un Loopback Address

Utilice el comando show ip bgp neighbors al mostrar información sobre las conexiones TCP y del Border Gateway Protocol (BGP) y verifiquelo si establecen al peer BGP. La salida del comando show ip bgp neighbors abajo muestra el estado BGP como “establecido”, que indica que la relación del peer BGP se ha establecido con éxito.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 300, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:28
  BGP table version 1, neighbor version 1
R1-AGS#

Además, el comando show ip bgp summary puede también ser utilizado para visualizar el estatus de todas las conexiones BGP, como se muestra abajo.

R1-AGS(9)# show ip bgp summary
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

Verifique la configuración de eBGP con un Loopback Address

Utilice el comando show ip bgp neighbors al mostrar información sobre las conexiones TCP y del Border Gateway Protocol (BGP) y verifiquelo si establecen al peer BGP. La salida del comando show ip bgp neighbors abajo muestra el estado BGP como “establecido”, que indica que la relación del peer BGP se ha establecido con éxito.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:16
  BGP table version 1, neighbor version 1
  External BGP neighbor may be up to 2 hops away.

Además, el comando show ip bgp summary puede también ser utilizado para visualizar el estatus de todas las conexiones BGP, como se muestra abajo.

R1-AGS(9)# show ip bgp summary
BGP router identifier 1.1.1.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

Troubleshooting

¿Refiérase a por qué haga la palanca de los vecinos BGP entre la marcha lenta, conecte, y los estados activos? y resolviendo problemas el BGP para la información de Troubleshooting.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 13751