Switching por etiquetas multiprotocolo (MPLS) : MPLS

Configurar la ingeniería de tráfico del básico de MPLS básico usando el IS-IS

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Esta configuración de muestra muestra cómo implementar ingeniería de tráfico (TE) sobre una red existente de Multiprotocol Label Switching (MPLS) usando Frame Relay e Intermediate System-to-Intermediate System (IS-IS). Este ejemplo implementa dos túneles dinámicos (configurados automáticamente por los Label Switch Routers [LSR] de ingreso) y dos túneles que utilizan trayectos explícitos.

El TE es un nombre genérico que corresponde al uso de diversas Tecnologías de optimizar la utilización de una capacidad de estructura básica y de una topología dadas.

MPLS TE brinda un modo para integrar las capacidades TE (tales como las utilizadas en protocolos de capa 2 como ATM) en protocolos de capa 3 (IP). El MPLS TE utiliza una extensión a los protocolos existentes (Resource Reservation Protocol [RSVP], IS-IS, [OSPF] abierto del trayecto más corto primer) para calcular y para establecer los túneles unidireccionales que se fijan según la limitación de red. Los flujos de tráfico se asignan en los diferentes túneles, en función del destino.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 12.0(11)S y 12.1(3a)T del ½ del ¿Â de Cisco IOSïÂ

  • Routers 3600 Cisco

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Componentes funcionales

Componente Descripción
Interfaces de túnel IP Capa 2: una interfaz de túnel MPLS es la cabecera de una Trayectoria Conmutada de Etiquetas (LSP). Está configurado con un conjunto de requisitos de recursos, como ancho de banda y prioridad. Capa 3: la interfaz de túnel LSP es el centro distribuidor de un link virtual unidireccional al destino del túnel.
RSVP con extensión TE RSVP se utiliza para establecer y para mantener los túneles LSP basados en el trayecto calculado usando la TRAYECTORIA y los mensajes RESV. La especificación del protocolo RSVP ha sido ampliada de modo que los mensajes RESV también distribuyan información de etiqueta.
Link-state IGP (IS-IS o OSPF con el extensión TE) Usado para inundar la información de recursos y topología desde el módulo de administración de links. El IS-IS utiliza los nuevos anuncios del estado del link del tipo 10 de los Tipo - longitud - valor (TLV) y de las aplicaciones OSPF (también llamados los Opaque LSA).
Módulo de cálculo de trayecto de MPLS TE Sólo funciona en la cabecera LSP y determina un trayecto utilizando la información de la base de datos de estado de link.
Módulo de administración de links TE MPLS En cada salto LSP, este módulo ejecuta una admisión de llamada de link en los mensajes de señalización RSVP, y contabilidad de la información de recursos y topología a ser inundada por OSPF o IS-IS.
Reenvío de conmutación de etiquetas Mecanismo básico de reenvío MPLS basado en etiquetas.

Configurar

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

/image/gif/paws/13737/mplsteisis1.gif

Configuraciones

Guía de configuraciones rápidas

Este procedimiento se puede utilizar para realizar una configuración rápida. Para más información detallada, refiera a la Ingeniería de tráfico MPLS y a las mejoras.

  1. Configure su red con la configuración habitual (en este caso, se utiliza el Frame Relay).

    Nota: Es obligatorio configurar un Loopback Interface con una máscara IP de 32 bits.

    Este direccionamiento es utilizado para la configuración de la red MPLS y del TE por el Routing Protocol. Esta dirección de loopback debe ser accesible desde la tabla de ruteo global.

  2. Configure un protocolo de ruteo para la red MPLS. Debe ser un protocolo de estado de link (IS u OSPF). En el modo de configuración del Routing Protocol, ingrese:

    • Para IS-IS:

      metric-style wide (or metric-style both) 
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
    • Para OSPF (Abrir la ruta más corta en primer lugar)

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. Habilite MPLS TE. Ingrese ip cef (o ip cef distributed si está disponible, para mejorar el rendimiento) en el modo de configuración general. Habilite MPLS (tag-switching ip) en cada interfaz involucrada. Ingrese el túnel de la Ingeniería de tráfico MPLS para habilitar el MPLS TE, así como el RSVP para los túneles del cero-ancho de banda TE.

  4. Habilite el RSVP ingresando el XXX del ancho de banda del rsvp del IP en cada interfaz afectada para los túneles no-cero del ancho de banda.

  5. Configure los túneles que utilizará TE. Hay muchas opciones que se pueden configurar para el túnel del MPLS TE, pero el comando tunnel mode mpls traffic-eng es obligatorio. El comando tunnel mpls traffic-eng autoroute announce anuncia la presencia del túnel a través del protocolo de ruteo.

Nota: No olvide utilizar el loopback N sin numeración IP para la dirección IP de las interfaces del túnel.

Esta configuración de muestra muestra dos túneles dinámicos con diverso ancho de banda (y las prioridades) que va del router Pescara al router Pesaro, y dos túneles que utilizan un trayecto explícito que vaya del Pesaro a Pescara.

Archivo de configuración

Únicamente se incluyen las partes relevantes de los archivos de configuración. Los comandos usados para habilitar el MPLS se ponen en letra itálica, mientras que los comandos específicos al TE (RSVP incluyendo) están en intrépido.

Pesaro
Current configuration:
 !
 version 12.1
 !
 hostname Pesaro
 !
 ip cef
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.6 255.255.255.255
  ip router isis 
 !
 interface Tunnel158
  ip unnumbered Loopback0
  tunnel destination 10.10.10.4
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 2 2
  tunnel mpls traffic-eng bandwidth 158
  tunnel mpls traffic-eng path-option 1 explicit name low
 !
 interface Tunnel159
  ip unnumbered Loopback0
  tunnel destination 10.10.10.4
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 4 4
  tunnel mpls traffic-eng bandwidth 159
  tunnel mpls traffic-eng path-option 1 explicit name straight
 !

 interface Serial0/0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/0.1 point-to-point
  bandwidth 512
  ip address 10.1.1.22 255.255.255.252
  ip router isis 
  tag-switching ip
  mpls traffic-eng tunnels 
  frame-relay interface-dlci 603   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0006.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 !
 ip classless
 !
 ip explicit-path name low enable
  next-address 10.1.1.21 
  next-address 10.1.1.10 
  next-address 10.1.1.1 
  next-address 10.1.1.14 
 !
 ip explicit-path name straight enable
  next-address 10.1.1.21 
  next-address 10.1.1.5 
  next-address 10.1.1.14 
 !
 end

Pescara
Current configuration:
 !
 version 12.0
 !
 hostname Pescara
 !

 ip cef
 !
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.4 255.255.255.255
  ip router isis 
 !
 interface Tunnel1
  ip unnumbered Loopback0

  tunnel destination 10.10.10.6
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 5 5
  tunnel mpls traffic-eng bandwidth 25
  tunnel mpls traffic-eng path-option 2 dynamic
 !
 interface Tunnel3
  ip unnumbered Loopback0

  tunnel destination 10.10.10.6
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 6 6
  tunnel mpls traffic-eng bandwidth  69
  tunnel mpls traffic-eng path-option 1 dynamic
 !

 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.14 255.255.255.252

  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 401   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0004.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 end

Pomerol
Current configuration:

 version 12.0
 !
 hostname Pomerol
 !
 ip cef
 !
 mpls traffic-eng tunnels
!
 interface Loopback0
  ip address 10.10.10.3 255.255.255.255
  ip router isis 
 !
 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.6 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
   frame-relay interface-dlci 301   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.2 point-to-point
  bandwidth 512
  ip address 10.1.1.9 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 302   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.3 point-to-point
  bandwidth 512
  ip address 10.1.1.21 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 306   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0003.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Pulligny
Current configuration:
 !
 version 12.1
 !
 hostname Pulligny
 !
 ip cef
 !
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.2 255.255.255.255
 !
 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.2 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 201   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.2 point-to-point
  bandwidth 512
  ip address 10.1.1.10 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 203   
  ip rsvp bandwidth 512 512
 !
 router isis 
  passive-interface Loopback0
  net 49.0001.0000.0000.0002.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Pauillac
!
 version 12.1
 !
 hostname pauillac
 !
 ip cef
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.1 255.255.255.255
  ip router isis 
 !
 interface Serial0/0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/0.1 point-to-point
  bandwidth 512
  ip address 10.1.1.1 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 102   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/0.2 point-to-point
  bandwidth 512
  ip address 10.1.1.5 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 103   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/0.3 point-to-point
  bandwidth 512
  ip address 10.1.1.13 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 104   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0001.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Verificación

Comandos show

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • show mpls traffic-eng tunnels brief

  • muestre a mpls el nombre tráfico-inglés Pesaro_t158 de los túneles

  • muestre la interfaz del rsvp del IP

  • muestre a mpls el ancho de banda tráfico-inglés 75 de 10.10.10.6 del destino del trayecto de la topología

Otros comandos útiles (no ilustrados aquí) incluyen:

  • muestre a mpls ISIS los anuncios tráfico-ingleses

  • show tag-switching forwarding-table

  • show ip cef

  • muestre a mpls los túneles tráfico-ingleses sumarios

Ejemplo de resultado del comando show

En cualquier LSR, usted puede utilizar los túneles tráfico-ingleses de los mpls de la demostración para marcar la existencia y el estado de los túneles. Por ejemplo, en el Pesaro, usted ve un total de cuatro túneles, dos que lleguen el Pesaro (Pescara_t1 y T3) y dos que empiecen con el Pesaro (t158 y t159):

Pesaro#show mpls traffic-eng tunnels brief 
Signaling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 606 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Pesaro_t158                      10.10.10.4       -         Se0/0.1   up/up
Pesaro_t159                      10.10.10.4       -         Se0/0.1   up/up     
Pescara_t1                       10.10.10.6       Se0/0.1   -         up/up     
Pescara_t3                       10.10.10.6       Se0/0.1   -         up/up     
Displayed 2 (of 2) heads, 0 (of 0) midpoints,2 (of 2) tails

Esto es se ve qué mientras que en un router intermedio:

Pulligny#show mpls traffic-eng tunnels brief 
Signaling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 406 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Pescara_t3                       10.10.10.6       Se0/1.1   Se0/1.2   up/up
Pesaro_t158                      10.10.10.4       Se0/1.2   Se0/1.1   up/up
Displayed 0 (of 0) heads, 2 (of 2) midpoints, 0 (of 0) tails

La configuración detallada de cualquier túnel se puede considerar usando esto:

Pesaro#show mpls traffic-eng tunnels name Pesaro_t158

Name: Pesaro_t158                         (Tunnel158) Destination: 10.10.10.4
  Status:
    Admin: up         Oper: up     Path: valid       Signaling: connected

    path option 1, type explicit low (Basis for Setup, path weight 40)

  Config Parameters:
    Bandwidth:  158      kbps  Priority: 2  2   Affinity: 0x0/0xFFFF
    AutoRoute:  enabled   LockDown: disabled    

  InLabel  :  - 
  OutLabel : Serial0/0.1, 17
  RSVP Signaling Info:
       Src 10.10.10.6, Dst 10.10.10.4, Tun_Id 158, Tun_Instance 1601
    RSVP Path Info:
      My Address: 10.10.10.6   
      Explicit Route: 10.1.1.21 10.1.1.10 10.1.1.1 10.1.1.14 
 10.10.10.4 
      Record   Route:  NONE
      Tspec: ave rate=158 kbits, burst=8000 bytes, peak rate=158 kbits
    RSVP Resv Info:
      Record   Route:  NONE
      Fspec: ave rate=158 kbits, burst=8000 bytes, peak rate=4294967 kbits
  History:
    Current LSP:
      Uptime: 3 hours, 33 minutes
      Selection: reoptimation
    Prior LSP:
      ID: path option 1 [1600]
      Removal Trigger: configuration changed

En este caso, la trayectoria es explícita y especificada en el mensaje RSVP (el campo que lleva la trayectoria también se conoce como el [ERO] del Explicit Route Object). Si esta trayectoria no puede ser seguida, el motor MPLS TE utiliza la opción de trayecto siguiente, que puede ser otra ruta explícita o una ruta dinámico.

La información específica de RSVP está disponible con los comandos rsvp estándar. En esta salida, hay dos reservas hechas en el Pulligny, uno por Pesaro_t158 (158K) y el otro por el Pescara_t3 (69k).

Pulligny#show ip rsvp interface
interface    allocated  i/f max  flow max pct UDP  IP   UDP_IP   UDP M/C 
Se0/1        0M         0M       0M       0   0    0    0        0       
Se0/1.1      158K       512K     512K     30  0    1    0        0 
Se0/1.2      69K        512K     512K     13  0    1    0        0

Si usted quiere saber qué trayecto TE se utiliza para un destino determinado (y un ancho de banda en particular) sin crear un túnel, usted puede utilizar este comando:

Nota: Observe por favor que este comando está envuelto a una segunda línea por las razones espaciales.

Pescara#show mpls traffic-eng topology path destination 
                          10.10.10.6 bandwidth 75
Query Parameters:
  Destination: 10.10.10.6
    Bandwidth: 75
   Priorities: 0 (setup), 0 (hold)
     Affinity: 0x0 (value), 0xFFFFFFFF (mask)
Query Results:
  Min Bandwidth Along Path: 385 (kbps)
  Max Bandwidth Along Path: 512 (kbps)
  Hop  0: 10.1.1.14      : affinity 00000000, bandwidth 512 (kbps)
  Hop  1: 10.1.1.5       : affinity 00000000, bandwidth 385 (kbps)
  Hop  2: 10.1.1.21      : affinity 00000000, bandwidth 512 (kbps)
  Hop  3: 10.10.10.6

Si la red hace la propagación de TTL IP (refiera a la propagación del IP TTL de los mpls), publique un comando traceroute y vea que la trayectoria seguida es el túnel y que las rutas del túnel según se configura qué:

Pescara#traceroute 10.10.10.6

Type escape sequence to abort.
Tracing the route to 10.10.10.6

  1 10.1.1.13 [MPLS: Label 29 Exp 0] 540 msec 312 msec 448 msec
  2 10.1.1.2 [MPLS: Label 27 Exp 0] 260 msec 276 msec 556 msec
  3 10.1.1.9 [MPLS: Label 29 Exp 0] 228 msec 244 msec 228 msec
  4 10.1.1.22 112 msec *  104 msec

Información Relacionada


Document ID: 13737