Switching por etiquetas multiprotocolo (MPLS) : MPLS

Configuración básica de MPLS usando OSPF

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento muestra cómo configurar una red básica MPLS (Multiprotocol Label Switching). Refiera a los ejemplos de configuración y lista de notas técnicas en las páginas de soporte MPLS para más información sobre cómo configurar los temas más complejos tales como VPN o ingeniería de tráfico (TE).

prerrequisitos

Requisitos

Cisco recomienda que usted es familiar con la operación básica del MPLS. Refiera a la descripción del Multiprotocol Label Switching para una descripción del MPLS.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 12.2(28) de Cisco IOS�

  • Routers 3600 Cisco

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Mecanismo

Una red MPLS es comúnmente una red de estructura básica compuesta de routers activados por MPLS, llamados Label Switch Routers (LSR). Generalmente, la red consiste en una base LSR con un borde LSR que aplique las escrituras de la etiqueta a los paquetes.

Éste es el mecanismo de la configuración de una red MPLS:

  1. Las tablas de ruteo de los diversos LSR se computan con un Interior Gateway Protocol (IGP). Un Link-State Protocol, tal como Open Shortest Path First (OSPF) o Intermediate System-to-Intermediate System (IS-IS), se requiere si usted planea desplegar el MPLS TE.

  2. Un protocolo de distribución de etiquetas (LDP) anuncia las vinculaciones entre rutas y etiquetas. Estas vinculaciones se controlan contra la tabla de ruteo. Si la ruta (prefijo/máscara y salto siguiente) aprendida del LDP hace juego la ruta aprendida del IGP en la tabla de ruteo, una entrada se crea en la escritura de la etiqueta las bases de esa información de los forwards (LFIB) en el LSR.

El LSR utiliza este mecanismo de reenvío:

  1. Una vez que un borde LSR recibe un paquete no etiquetado, se marca la tabla del Cisco Express Forwarding y una escritura de la etiqueta se impone ante el paquete si es necesario. Este LSR se denomina LSR de ingreso.

  2. Sobre la llegada de un paquete etiquetado en la interfaz de entrada de una base LSR, el LFIB proporciona la interfaz de salida y la nueva escritura de la etiqueta que se asocia al paquete saliente.

  3. El router antes del último LSR (el penúltimo salto) elimina la etiqueta y transmite el paquete sin la etiqueta. El último salto se denomina el LSR de salida

Este diagrama ilustra esta configuración de la red:

/image/gif/paws/13736/1b.gif

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: En la información adicional del hallazgo FO de la orden en los comandos usados en este documento, utilice la herramienta de búsqueda de comandos (clientes registrados solamente).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/13736/1a.gif

Guía de configuración rápida

Utilice este procedimiento como guía de configuración rápida.

  1. Configure su red como de costumbre. El MPLS necesita una conexión IP estándar para establecer las bases de reenvío.

  2. Asegúrese de que el Routing Protocol (OSPF o IS-IS) trabaje correctamente. Estos comandos se ponen en letra itálica en las configuraciones en la siguiente sección.

  3. Habilite el cef del IP, porque los mejores rendimientos utilizan el cef del IP distribuido cuando están disponibles, en el modo de configuración general. Esto se muestra en intrépido en las configuraciones en la siguiente sección.

  4. Habilite el IP de los mpls, o el IP del Tag Switching en más viejas versiones de Cisco IOS Software, en el modo de configuración general y en cada interfaz, tal y como se muestra en de intrépido en las configuraciones en la siguiente sección. Incluso cuando utilizan al comando mpls ip, la salida corriente de la demostración puede todavía mostrar el comando como IP del Tag Switching en algunas versiones de Cisco IOS Software, tal y como se muestra en de las configuraciones en la siguiente sección.

    Nota: Los LSR deben tener (para arriba) interfaces del loopback con una máscara de dirección de 32 bits y estas interfaces deben ser accesibles con la tabla de ruteo del IP global.

Configuraciones

En este documento, se utilizan estas configuraciones:

Pomerol

!
version 12.2

!
hostname Pomerol
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.21 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.6 255.255.255.252
 tag-switching ip
!
interface Serial4/0
 ip address 10.1.1.9 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
! 
ip classless
!
end

Pulligny

!
version 12.2
!
hostname Pulligny
!
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.2 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.10 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pauillac
!
version 12.2
!
hostname Pauillac
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.13 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.17 255.255.255.252
 tag-switching ip
!
interface Serial4/0
 ip address 10.1.1.1 255.255.255.252
 tag-switching ip
!
interface Serial5/0
 ip address 10.1.1.5 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pescara
!
version 12.2
!
hostname Pescara
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.14 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pesaro
!
version 12.2
!
hostname Pesaro
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.22 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Perugia
!
version 12.2
!
hostname Perugia
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.5 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.18 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Verificación

En esta sección encontrará información que puede utilizar para comprobar que su configuración funcione correctamente.

Los comandos usados en el MPLS básico que configura usando configuración ejemplo de IS-IS son también aplicables.

Para ilustrar esta configuración de muestra, mire un destino determinado, por ejemplo 10.10.10.4, en el Pomerol LSR.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • ruta de IP de la demostración — Utilizado para marcar la ruta de IP para este destino en la tabla de IP Routing:

    Pomerol#show ip route 10.10.10.4
    Routing entry for 10.10.10.4/32
      Known via "ospf 10", distance 110, metric 129, type intra area
      Last update from 10.1.1.5 on Serial3/0, 17:29:23 ago
      Routing Descriptor Blocks:
      * 10.1.1.5, from 10.10.10.4, 17:29:23 ago, via Serial3/0
          Route metric is 129, traffic share count is 1
    
  • muestre la tabla de reenvío de los mpls — Utilizado para marcar la tabla de reenvío MPLS, que es la equivalente de Label Switching de la tabla de IP Routing para el Routing IP estándar. Contiene las escrituras de la etiqueta entrantes y salientes y las descripciones de los paquetes.

    Pomerol#show mpls forwarding-table 
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    16     Pop tag     10.1.1.12/30      636        Se3/0      point2point
    17     Pop tag     10.10.10.1/32     0          Se3/0      point2point
    18     21          10.10.10.4/32     0          Se3/0      point2point
    19     Pop tag     10.1.1.0/30       0          Se4/0      point2point
           Pop tag     10.1.1.0/30       0          Se3/0      point2point
    20     Pop tag     10.10.10.6/32     612        Se2/0      point2point
    21     Pop tag     10.1.1.16/30      0          Se3/0      point2point
    22     16          10.10.10.5/32     0          Se3/0      point2point
    23     Pop tag     10.10.10.2/32     0          Se4/0      point2point
  • detalles de la tabla de reenvíos de MPLS de la demostración — Utilizado para ver los detalles de la tabla de reenvíos de MPLS:

    Pomerol#show mpls forwarding-table 10.10.10.4 32 detail
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    18     21          10.10.10.4/32     0          Se3/0      point2point
            MAC/Encaps=4/8, MRU=1500, Tag Stack{21}
            0F008847 00015000
            No output feature configured
        Per-packet load-sharing
  • muestre los atascamientos del ldp de los mpls o muestre los atascamientos del tdp del Tag Switching (basados en qué versión de Cisco IOS Software le uso) — usado para ver las vinculaciones de etiquetas asociadas a un destino determinado. El local así como los atascamientos remotos pueden ser vistos.

    Pomerol#show tag-switching tdp bindings 10.10.10.4 32
      tib entry: 10.10.10.4/32, rev 14
            local binding:  tag: 18
            remote binding: tsr: 10.10.10.1:0, tag: 21
            remote binding: tsr: 10.10.10.2:0, tag: 23
            remote binding: tsr: 10.10.10.6:612, tag: 20 
    
    

    Observe que las escrituras de la etiqueta para cada clase de reenvío están establecidas en cada LSR, incluso si no están en la trayectoria (más corta) preferida. En este caso, un paquete destinado a 10.10.10.4/32 puede ir por 10.10.10.1 (con la escritura de la etiqueta 21) o por 10.10.10.2 (con la escritura de la etiqueta 23). El LSR elige la primera solución porque es la más corta. Esta decisión se toma con la tabla de IP Routing estándar, que en este caso, se construye con el OSPF.

  • muestre el detalle del cef del IP — Utilizado para marcar que el Cisco Express Forwarding trabaja correctamente y que las etiquetas están intercambiadas correctamente:

    Pomerol#show ip cef 10.10.10.4 detail
    10.10.10.4/32, version 37, cached adjacency to Serial3/0
    0 packets, 0 bytes
      tag information set
        local tag: 18
        fast tag rewrite with Se3/0, point2point, tags imposed: {21}
      via 10.1.1.5, Serial3/0, 0 dependencies
        next hop 10.1.1.5, Serial3/0
        valid cached adjacency
        tag rewrite with Se3/0, point2point, tags imposed: {21}
    

Troubleshooting

Refiera al Troubleshooting de MPLS para la información sobre cómo resolver problemas el MPLS.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 13736