Switching por etiquetas multiprotocolo (MPLS) : MPLS

Configuración de MPLS Básico mediante IS-IS

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este ejemplo de configuración muestra cómo configurar una red Multiprotocol Label Switching (MPLS) para otras tareas tales como Red Privada Virtual (VPN) o ingeniería de tráfico (puede ver más Ejemplos de Configuración en la Página de Soporte de MPLS).

prerrequisitos

Requisitos

Antes de utilizar esta configuración, asegúrese de que cumple con los siguientes requisitos previos:

  • Para implementar el MPLS, usted necesita a un Cisco 2600 Router o más adelante.

  • Elija el Cisco IOS requerido con el MPLS usando el Software Advisor (clientes registrados solamente).

  • Marque para saber si hay el RAM y la memoria flash adicionales requeridos para ejecutar el MPLS en el Routers. Los WAN Interface Cards (WIC), el WIC-1T y el WIC-2T, pueden ser utilizados.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Cisco 3640, Cisco 3660, Cisco4500, y Cisco 2610 Router

  • El Software Release 12.2(6h) de Cisco IOS� se está ejecutando en todo el Routers

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Teoría Precedente

Una red MPLS es comúnmente una red de estructura básica compuesta de routers activados por MPLS, llamados Label Switch Routers (LSR). Generalmente, la red consiste de un router LSR central con un LSR de borde responsable de aplicar etiquetas a los paquetes.

El mecanismo de configuración de una red MPLS es el que se describe a continuación.

  • El ruteo de tablas de los diferentes LSR se computa por medio un protocolo interno de puerta de enlace (IGP). Si va a implementar ingeniería de tráfico MPLS, se necesita un protocolo de estado de link como Primero la ruta más corta (OSPF) o Sistema intermedio a sistema intermedio (IS-IS).

  • Un protocolo de distribución de etiquetas (LDP) anuncia las vinculaciones entre rutas y etiquetas. Estas vinculaciones se controlan contra la tabla de ruteo. Si la ruta (prefix/mask y next hop) que se aprendió a través de LDP es igual a la ruta que se aprendió a través de IGP en la tabla de ruteo, se crea una entrada en las bases de información de reenvío de etiqueta (LFIB) en LSR.

El LSR utiliza el mecanismo de reenvío siguiente.

  • Una vez que un LSR de borde recibe un paquete sin etiqueta, se comprueba la tabla de reenvío rápido de Cisco y se impone una etiqueta en el paquete, si es necesario. Este LSR se denomina LSR de ingreso.

  • Cuando llega un paquete etiquetado a la interfaz de entrante de un LSR núcleo, LFIB proporciona la interfaz saliente y la nueva etiqueta que estará asociada con el paquete de salida.

  • El router antes del último LSR (el penúltimo salto) elimina la etiqueta y transmite el paquete sin la etiqueta. El último salto se denomina el LSR de salida

El diagrama que se muestra a continuación ilustra la configuración de la red.

/image/gif/paws/13735/1b.gif

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/13735/1a.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Guía de configuración rápida

Complete estos pasos para configurar el MPLS:

  1. Configure su red de manera usual (MPLS requiere una conexión IP estándar para establecer las bases de renevíos).

  2. Asegúrese de que el protocolo de ruteo (OSPF o IS-IS) funciona correctamente. Estos comandos se muestran en los itálicos en las configuraciones en esta sección.

  3. Para habilitar, utilice el comando ip cef (para obtener un mejor rendimiento utilice el comando ip cef distributed, cuando esté disponible) en el modo de configuración general (que se muestra en negrita en las configuraciones de esta sección).

  4. Utilice el comando mpls ip (o el comando tag-switching ip en más viejas versiones de Cisco IOS Software) en el modo de configuración general y en cada interfaz (mostrada en intrépido en las configuraciones en esta sección) de habilitar.

    Nota:  Los LSR deben tener (activadas) interfaces de loopback con una máscara de dirección de 32 bits.

Pomerol
Current configuration:
!
version 12.2
!
hostname Pomerol
!
ip cef

!--- Enables Cisco Express Forwarding globally.

!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis 

!--- Assigns an IP address to interface loopback0 
!--- and enables IS-IS for IP on the interface.

!
interface Serial0/0
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.6 255.255.255.252
 ip router isis   
 tag-switching ip

!--- Enables dynamic Label Switching of 
!--- IPv4 packets on an interface.

 frame-relay interface-dlci 301   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.9 255.255.255.252
 ip router isis  
 tag-switching ip
 frame-relay interface-dlci 303   
!
interface Serial0/0.3 point-to-point
 ip address 10.1.1.21 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 306   
!
router isis  
 net 49.0001.0000.0000.0003.00
 is-type level-1
!
ip classless
!
end

Pulligny
Current configuration:
!
version 12.1
!
hostname Pulligny
!
ip cef
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.2 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 201   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.10 255.255.255.252
 ip router isis 
tag-switching ip
 frame-relay interface-dlci 203   
!
router isis
 redistribute static ip
 passive-interface Loopback0
 net 49.0001.0000.0000.0002.00
 is-type level-1

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

!
ip classless
!
end

Pauillac
Current configuration : 2366 bytes
!
version 12.1
!
hostname pauillac
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.1 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 102   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.5 255.255.255.252
 ip access-group 150 out
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 103   
!
interface Serial0/0.3 point-to-point
 bandwidth 512
 ip address 10.1.1.13 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 104   
!
interface Serial0/0.4 point-to-point
 ip address 10.1.1.17 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 105
!
!
router isis
 net 49.0001.0000.0000.0001.00
 is-type level-1
!
ip classless
!
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • show tag-switching tdp neighbor

  • show tag-switching tdp bindings

  • show tag-switching forwarding-table

  • detalle show tag-switching forwarding-table a b c d

  • traceroute a.b.c.d

Una lista exhaustiva de comandos se incluye en la referencia del comando mpls. Otros ejemplos del comando show se describen en configurar el MPLS básico usando el OSPF.

Ejemplo de Salida

Esta salida se centra en el LDP. El LDP implementado actualmente en el IOS es el TDP (Tag Distribution Protocol), que contiene algunas Extensiones del patentado Cisco, pero se utilice con el LDP, el protocolo oficial de IETF para la distribución de etiqueta. El TDP será substituido por el LDP en el futuro.

Usted puede utilizar el comando show tag-switching tdp * para verificar el estado del TDP. Usted puede ver a los vecinos con el comando show tag-switching tdp neighbor.

Pulligny# show tag-switching tdp discovery
Local TDP Identifier:    
	10.10.10.2:0
TDP Discovery Sources:    
  Interfaces:
 Serial0/0.1: xmit/recv            
   TDP Id: 10.10.10.1:0
 Serial0/0.2: xmit/recv
   TDP Id: 10.10.10.3:0

!--- Ensure you are able to ping this IP address
!--- If not, check whether a route exists in the routing table

Pulligny# show tag-switching tdp neighbor 
Peer TDP Ident: 10.10.10.1:0; Local TDP Ident 10.10.10.2:0
        TCP connection: 10.10.10.1.711 - 10.10.10.2.11001
        State: Oper; PIEs sent/rcvd: 27907/27925; ; Downstream
        Up time: 2w2d
        TDP discovery sources:
          Serial0/0.1
        Addresses bound to peer TDP Ident:
          10.1.1.1        10.1.1.13       10.1.1.17       10.10.10.1      
          10.1.1.5        10.200.28.89    
Peer TDP Ident: 10.10.10.3:0; Local TDP Ident 10.10.10.2:0
        TCP connection: 10.10.10.3.11001 - 10.10.10.2.711
        State: Oper; PIEs sent/rcvd: 22893/22874; ; Downstream
        Up time: 1w6d
        TDP discovery sources:
          Serial0/0.2
        Addresses bound to peer TDP Ident:
          10.200.28.91    10.1.1.6        10.1.1.9        10.1.1.21       
          10.10.10.3

Usted puede utilizar el comando show tag-switching tdp bindings para ver los atascamientos establecidos entre las escrituras de la etiqueta y las rutas.

Pulligny# show tag-switching tdp bindings 
(...)
  tib entry: 10.10.10.4/32, rev 22
        local binding:  tag: 21
        remote binding: tsr: 10.10.10.1:0, tag: 22
        remote binding: tsr: 10.10.10.3:0, tag: 25
  tib entry: 10.10.10.6/32, rev 51
        local binding:  tag: 23
        remote binding: tsr: 10.10.10.3:0, tag: 18
        remote binding: tsr: 10.10.10.1:0, tag: 20
(...)

Usted puede utilizar el comando show tag-switching forwarding-table para ver qué atascamientos se utilizan para construir el LFIB.

Pulligny# show tag-switching forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface 
16     Pop tag     10.1.1.4/30       0          Se0/0.2    point2point       
       Pop tag     10.1.1.4/30       0          Se0/0.1    point2point
17     Pop tag     10.1.1.20/30      0          Se0/0.2    point2point
18     Pop tag     10.10.10.3/32     0          Se0/0.2    point2point
19     Pop tag     10.10.10.1/32     0          Se0/0.1    point2point
20     Pop tag     10.1.1.12/30      0          Se0/0.1    point2point
21     Pop tag     10.1.1.16/30      0          Se0/0.1    point2point
22     20          10.10.10.5/32     0          Se0/0.1    point2point
23     22          10.10.10.6/32     0          Se0/0.2    point2point
24     22          10.10.10.4/32     0          Se0/0.1    point2point

Usted puede utilizar el comando detail de 10.10.10.4 de la tabla de reenvío del Tag Switching de la demostración de ver los detalles de un destino determinado.

Pulligny# show tag-switching forwarding-table 10.10.10.4 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
21     22          10.10.10.4/32     12103      Se0/0.1    point2point  
        MAC/Encaps=4/8, MTU=1500, Tag Stack{22}
        30918847 00016000
    Per-packet load-sharing

Usted puede también utilizar el comando traceroute, si la red hace la propagación de TTL IP, de ver los saltos. Refiera al Multiprotocol Label Switching en los routeres Cisco para más información sobre el comando mpls ip ttl propagate.

Pesaro# traceroute 10.10.10.4

Type escape sequence to abort.
Tracing the route to 10.10.10.4

  1 10.1.1.21 [MPLS: Label 25 Exp 0] 296 msec 256 msec 244 msec
  2 10.1.1.5 [MPLS: Label 22 Exp 0] 212 msec 392 msec 352 msec
  3 10.1.1.14 436 msec *  268 msec

Nota: Exp 0 aparece en la salida si el campo experimental se utiliza la Calidad de servicio (QoS).

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 13735