Switching por etiquetas multiprotocolo (MPLS) : MPLS

Configuración de una VPN MPLS básica

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (19 Mayo 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra de un Multiprotocol Label Switching (MPLS) VPN cuando el Border Gateway Protocol (BGP) o el Routing Information Protocol (RIP) está presente en el sitio de cliente.

Cuando se utiliza con MPLS, la función VPN permite que varios sitios se interconecten de modo transparente a través de una red de proveedor de servicio. Una red proveedora de servicios puede ofrecer soporte a varias VPN IP diferentes Cada una de éstas le aparece a sus usuarios como una red privada, separada de todas las otras redes. Dentro de una VPN, cada sitio puede enviar paquetes IP a cualquier otro sitio dentro de la misma VPN

Cada VPN está asociada con uno o más casos de reenvío o ruteo VPN (VRF). Un VRF consiste de una tabla de IP Routing, una tabla Cisco Express Forwarding (CEF) derivada y un conjunto de interfaces que usen estas tablas de reenvío.

El router mantiene un ruteo separado y una tabla CEF para cada VRF. Esto impide que la información se envíe fuera de la VPN y permite que pueda usarse la misma subred en varias VPN sin causar problemas de dirección IP duplicada

El router que utiliza BGP multiprotocolo (MP-BGP) distribuye la información de ruteo VPN utilizando las comunidades ampliadas MP-BGP.

Para más información sobre la difusión de actualizaciones con un VPN, refiera a estos documentos:

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

P y routers PE

  • El Software Release 12.2(6h) del ½ del ¿Â de Cisco IOSï incluye la característica del MPLS VPN.

  • Cualquier router Cisco de las 7200 Series o de las funciones más altas de los soportes P. El Cisco 2691, así como cualquier funciones del 3640 Series o más altas de los soportes para router PE.

Routers C y CE

  • Usted puede utilizar a cualquier router que pueda intercambiar la información de ruteo por su router PE.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Productos Relacionados

Para implementar la característica MPLS, usted debe tener un router del rango del Cisco 2600 o más arriba. Para seleccionar el Cisco IOS requerido con el MPLS ofrezca, utilice el Software Advisor (clientes registrados solamente). También marque para saber si hay el RAM y memoria flash adicionales requeridos para funcionar con la característica MPLS en el Routers. El WIC-1T, el WIC-2T, y las interfaces seriales pueden ser utilizados.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Las letras que aparecen a continuación representan los distintos tipos de routers y switches usados.

  • P — El router del núcleo del proveedor.

  • PE — El router de borde del proveedor.

  • CE — El router de borde del cliente.

  • C - Router del cliente

Este diagrama muestra una configuración típica que ilustra las convenciones arriba descritas.

/image/gif/paws/13733/mplsvpn.gif

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/13733/new_mpls_vpn_basic1.gif

Procedimientos de configuración

Refiera a las Redes privadas virtuales MPLS para más información.

Habilitación de ip cef

Utilice este procedimiento para habilitar el cef del IP. Para el rendimiento mejorado, utilice el cef del IP distribuido (cuando sea disponible). Complete estos pasos en los PE después de que se haya configurado el MPLS (configurando el IP del Tag Switching en las interfaces).

  1. Cree un VRF para cada VPN conectado usando el comando ip vrf < VPN routing/forwarding instance name>.

    Al hacerlo:

    • Especifique el discriminador de rutas adecuado usado para esa VPN. Esto se usa para extender la dirección IP de modo que pueda identificar a qué VPN corresponde.

      
      rd <VPN route distinguisher>
      
      
    • Configure las propiedades de la importación y de la exportación para las comunidades ampliadas MP-BGP. Éstas se usan para filtrar el proceso de importación y exportación.

      
      route-target [export|import|both] <target VPN extended community>
      
      
  2. Configure a los detalles de reenvío para las interfaces respectivas usando el comando ip vrf forwarding <VPN routing/forwarding instance name> y recuerde configurar la dirección IP después de hacer esto.

  3. Según el protocolo de ruteo PE-CE que esté utilizando, puede configurar rutas estáticas o protocolos de ruteo (RIP, Abrir la ruta más corta en primer lugar [OSPF], o BGP) entre PE y CE. Las configuraciones detalladas están disponibles en el MPLS sobre la página de soporte atmósfera.

Configuración de MP-BGP

Configure el MP-BGP entre los routers PE. Existen diversas maneras de configurar BGP, por ejemplo, usando el reflector de ruta o los métodos de confederación. El método usado aquí — configuración de vecino directo — es el más simple y el lo más menos posible scalable.

  1. Declare los diferentes vecinos.

  2. Ingrese el comando address-family ipv4 vrf <VPN routing/forwarding instance name> para cada VPN presente en este router PE.

    Realice uno o más de los siguientes pasos, según sea necesario:

    • Vuelva a distribuir la información de ruteo estático, RIP u OSPF.

    • Vuelva a distribuir la información de ruteo conectada.

    • Active BGP de vecindad con los routers CE.

  3. Ingrese en el modo address-family vpnv4 y siga los siguientes pasos:

    • Activar los vecinos.

    • Especifique que debe usarse la comunidad extendida. Esto es obligatorio.

Configuraciones

En este documento, se utilizan estas configuraciones:

Pescara
Current configuration:
!
version 12.2
!
hostname Pescara
!
ip cef
!


!--- Customer A commands.

ip vrf Customer_A

!--- Enables the VPN routing and forwarding (VRF) routing table.
!--- This command can be used in global or 
!--- router configuration mode. 

 rd 100:110

!--- Route distinguisher creates routing and forwarding 
!--- tables for a VRF.

 route-target export 100:1000

!--- Creates lists of import and export route-target extended 
!--- communities for the specified VRF.

 route-target import 100:1000
!


!--- Customer B commands.

ip vrf Customer_B
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
 ip router isis


!--- Customer A commands.

interface Loopback101
ip vrf forwarding Customer_A

!--- Associates a VRF instance with an interface or subinterface.

 ip address 200.0.4.1 255.255.255.0

!--- Loopback101 and 102 use the same IP address, 200.0.4.1. 
!--- This is allowed because they belong to two 
!--- different customers' VRFs. 

 no ip directed-broadcast
!


!--- Customer B commands.

interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.4.1 255.255.255.0

!--- Loopback101 and 102 use the same IP address, 200.0.4.1. 
!--- This is allowed because they belong to two 
!--- different customers' VRFs.
 
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no fair-queue
!
interface Serial2/0.1 point-to-point
 description link to Pauillac
 bandwidth 512
 ip address 10.1.1.14 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 401   
!
router isis 
 net 49.0001.0000.0000.0004.00
 is-type level-1
!         
router bgp 100
 bgp log-neighbor-changes

!--- Enables logging of BGP neighbor resets.

 neighbor 10.10.10.6 remote-as 100

!--- Adds an entry to the BGP or multiprotocol BGP neighbor table.

 neighbor 10.10.10.6 update-source Loopback0

!--- Enables BGP sessions to use a specific operational 
!--- interface for TCP connections.

!
 

!--- Customer A and B commands.

 address-family vpnv4

!--- To enter address family configuration mode 
!--- for configuring routing sessions, such as BGP, 
!--- that use standard VPN version 4 address prefixes.

 neighbor 10.10.10.6 activate
 neighbor 10.10.10.6 send-community both
 
!--- Sends the community attribute to a BGP neighbor.

 exit-address-family
 !


!--- Customer B commands.

 address-family ipv4 vrf Customer_B

!--- To enter address family configuration mode 
!--- for configuring routing sessions, such as BGP, 
!--- that use standard VPN version 4 address prefixes.

 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 

!--- Customer A commands.

 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
!
ip classless
!
end

Pesaro
Current configuration:
!
version 12.1
!
hostname Pesaro
!


!--- Customer A commands.

ip vrf Customer_A
 rd 100:110
 route-target export 100:1000
 route-target import 100:1000
!


!--- Customer B commands.

ip vrf Customer_B
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
ip cef

!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
 ip router isis 


!--- Customer A commands.

interface Loopback101
 ip vrf forwarding Customer_A
 ip address 200.0.6.1 255.255.255.0
!


!--- Customer B commands.

interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.6.1 255.255.255.0
!


!--- Customer A commands.

interface Loopback111
 ip vrf forwarding Customer_A
 ip address 200.1.6.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 random-detect
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwidth 512
 ip address 10.1.1.22 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 603   
!
router isis 
 net 49.0001.0000.0000.0006.00
 is-type level-1
!
router bgp 100
 neighbor 10.10.10.4 remote-as 100
 neighbor 10.10.10.4 update-source Loopback0
 !


!--- Customer B commands.

 address-family ipv4 vrf Customer_B
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


!--- Customer A commands.

 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


!--- Customer A and B commands.

 address-family vpnv4
 neighbor 10.10.10.4 activate
 neighbor 10.10.10.4 send-community both
 exit-address-family
!
ip classless
!         
end

Pomerol
Current configuration:
!
version 12.0
!
hostname Pomerol
!
ip cef

!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis 

!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.6 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching mtu 1520
 tag-switching ip 
 frame-relay interface-dlci 301   
!
interface Serial0/1.2 point-to-point
 description link to Pulligny
 ip address 10.1.1.9 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 303   
!
interface Serial0/1.3 point-to-point
 description link to Pesaro
 ip address 10.1.1.21 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip

 frame-relay interface-dlci 306   
!
router isis 
 net 49.0001.0000.0000.0003.00
 is-type level-1
!
ip classless
!
end

Pulligny
Current configuration:
!
version 12.1
!
hostname Pulligny
!
!
ip cef

!
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.2 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 201   
!
interface Serial0/1.2 point-to-point
 description link to Pomerol
 ip address 10.1.1.10 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 203   
!
router isis 
 passive-interface Loopback0
 net 49.0001.0000.0000.0002.00
 is-type level-1
!
ip classless
!
end

Pauillac
!
version 12.1
!
hostname pauillac
!
ip cef

!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis  
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 tag-switching ip
 no fair-queue
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwith 512
 ip address 10.1.1.1 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 102   
!
interface Serial0/0.2 point-to-point
 description link to Pulligny ip address 10.1.1.5 255.255.255.252

 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 103   
!
interface Serial0/0.3 point-to-point
 description link to Pescara
 bandwidth 512
 ip address 10.1.1.13 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 104   
!
router isis 
 net 49.0001.0000.0000.0001.00
 is-type level-1
!
ip classless
!
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • demostración IP VRF — Verifica que exista el VRF correcto.

  • show ip vrf interfaces — Verifica las interfaces activadas.

  • muestre el Customer_A del vrf de la ruta de IP — Verifica la información de ruteo en el Routers PE.

  • Customer_A 200.0.6.1 del vrf del traceroute — Verifica la información de ruteo en el Routers PE.

  • show ip bgp vpnv4 tag — Verifica el BGP.

  • muestre el detalle de 200.0.6.1 del Customer_A del vrf del cef del IP — verifica la información de ruteo en el Routers PE.

En la Guía de solución de problemas de la solución MPLS VPN, se detallan más comandos.

Lo que sigue es salida del comando de ejemplo del comando show ip vrf.

Pescara#show ip vrf 
  Name                             Default RD          Interfaces
  Customer_A                       100:110             Loopback101
  Customer_B                       100:120             Loopback102

Lo que sigue es salida del comando de ejemplo del comando show ip vrf interfaces.

Pesaro#show ip vrf interfaces 
Interface              IP-Address      VRF                              Protocol
Loopback101            200.0.6.1       Customer_A                       up      
Loopback111            200.1.6.1       Customer_A                       up      
Loopback102            200.0.6.1       Customer_B                       up      

Los comandos show ip route vrf siguientes muestran el mismo prefijo 200.0.6.0/24 en ambas las salidas. Esto es porque el telecontrol PE tiene la misma red para dos clientes, Customer_A y Customer_B, que se permite en una solución típica del MPLS VPN.

Pescara#show ip route vrf Customer_A
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR

Gateway of last resort is not set

C    200.0.4.0/24 is directly connected, Loopback101
B    200.0.6.0/24 [200/0] via 10.10.10.6, 05:10:11
B    200.1.6.0/24 [200/0] via 10.10.10.6, 04:48:11
 
Pescara#show ip route vrf Customer_B
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
	   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
	   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
	   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
	   * - candidate default, U - per-user static route, o - ODR       
	   P - periodic downloaded static route
	    
Gateway of last resort is not set
C 200.0.4.0/24 is directly connected, Loopback102
 
B 200.0.6.0/24 [200/0] via 10.10.10.6, 00:03:24

Ejecutando un traceroute entre dos sitios del Customer_A, es posible ver la pila de etiquetas usada por la red MPLS (si es configurada para hacer tan por el mpls IP ttl).

Pescara#traceroute vrf Customer_A 200.0.6.1

Type escape sequence to abort.
Tracing the route to 200.0.6.1

  1 10.1.1.13 [MPLS: Labels 20/26 Exp 0] 400 msec 276 msec 264 msec
  2 10.1.1.6 [MPLS: Labels 18/26 Exp 0] 224 msec 460 msec 344 msec
  3 200.0.6.1 108 msec *  100 msec

Nota:  Exp 0 es un campo experimental utilizado para Calidad de servicio (QoS).

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 13733