Switching por etiquetas multiprotocolo (MPLS) : MPLS

Ingeniería básica de tráfico MPLS utilizando el ejemplo de configuración OSPF

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para la implementación de Traffic Engineering (TE) sobre una red existente de Multiprotocol Label Switching (MPLS) con Frame Relay y Open Shortest Path First (OSPF). Nuestro ejemplo implementa dos túneles dinámicos (configurados automáticamente por los Label Switch Routers [LSR] de ingreso) y dos túneles que utilizan trayectos explícitos.

TE es un nombre genérico que corresponde al uso de distintas tecnologías para optimizar la utilización de una capacidad de estructura básica y topología determinada.

MPLS TE brinda un modo para integrar las capacidades TE (tales como las utilizadas en protocolos de capa 2 como ATM) en protocolos de capa 3 (IP). MPLS TE usa una extensión para los protocolos existente (Intermediate System-to-Intermediate System (IS-IS), Resource Reservation Protocol (RSVP), OSPF) para calcular y establecer túneles unidireccionales que se configuran según la restricción de la red. Los flujos de tráfico se asignan en los diferentes túneles, en función del destino.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware.

  • Software Release 12.0(11)S y 12.1(3a)T del½ del¿Â del Cisco IOSïÂ

  • Routers 3600 Cisco

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Componentes funcionales

La tabla siguiente describe a los componentes funcionales de este ejemplo de configuración:

Componente Descripción
Interfaces de túnel IP Capa 2: una interfaz de túnel MPLS es la cabecera de una Trayectoria Conmutada de Etiquetas (LSP). Está configurado con un conjunto de requisitos de recursos, como ancho de banda y prioridad. Capa 3: la interfaz de túnel LSP es el centro distribuidor de un link virtual unidireccional al destino del túnel.
RSVP con extensión TE RSVP se utiliza para establecer y mantener los túneles de LSP basándose en el trayecto calculado mediante el uso de los mensajes de Reserva de PATH y RSVP (RESV). La especificación del protocolo RSVP ha sido ampliada de modo que los mensajes RESV también distribuyan información de etiqueta.
Protocolo de gateway interior de estado de link (IGP) [IS-IS o OSPF con extensión TE] Usado para inundar la información de recursos y topología desde el módulo de administración de links. El IS-IS utiliza los nuevos Tipo - longitud - valor (TLV); El OSPF utiliza los anuncios del estado del vínculo del tipo 10 (también llamados los Opaque LSA).
Módulo de cálculo de trayecto de MPLS TE Sólo funciona en la cabecera LSP y determina un trayecto utilizando la información de la base de datos de estado de link.
Módulo de administración de links TE MPLS En cada salto LSP, este módulo ejecuta una admisión de llamada de link en los mensajes de señalización RSVP, y contabilidad de la información de recursos y topología a ser inundada por OSPF o IS-IS.
Reenvío de conmutación de etiquetas Mecanismo básico de reenvío MPLS basado en etiquetas.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/13731/mplsteisis1.gif

Guía de configuración rápida

Usted puede utilizar los pasos siguientes para realizar una configuración rápida. Refiera a la Ingeniería de tráfico MPLS y a las mejoras para más información detallada.

  1. Configure la red con la configuración habitual. (En este caso, utilizamos Frame Relay.)

    Nota: Es obligatorio configurar un Loopback Interface con una máscara IP de 32 bits. Esta dirección se usará para la configuración de la red MPLS y TE por medio del protocolo de ruteo. Esta dirección de loopback debe ser accesible desde la tabla de ruteo global.

  2. Configure un protocolo de ruteo para la red MPLS. Debe ser un protocolo de estado de link (IS u OSPF). En el modo de configuración de protocolo de ruteo, ingrese los siguientes comandos:

    • Para IS-IS:

      metric-style [wide | both]
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
      
    • Para OSPF (Abrir la ruta más corta en primer lugar)

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. Habilite MPLS TE. Ingrese ip cef (o ip cef distributed si está disponible, para mejorar el rendimiento) en el modo de configuración general. Habilite MPLS (tag-switching ip) en cada interfaz involucrada. Ingrese el túnel de la Ingeniería de tráfico MPLS para habilitar el MPLS TE, así como el RSVP para los túneles del cero-ancho de banda TE.

  4. Habilite el RSVP ingresando el XXX del ancho de banda del rsvp del IP en cada interfaz afectada para los túneles no-cero del ancho de banda.

  5. Configure los túneles que utilizará TE. Existen muchas opciones de configuración para el túnel MPLS TE, pero el comando tunnel mode mpls traffic-eng es obligatorio. El comando tunnel mpls traffic-eng autoroute announce anuncia la presencia del túnel a través del protocolo de ruteo.

    Nota: No olvide utilizar el loopback N sin numeración IP para la dirección IP de las interfaces del túnel.

    Esta configuración muestra dos túneles dinámicos (Pescara_t1 y Pescara_t3) con diferentes anchos de banda (y prioridades) que van desde el router Pescara hasta el router Pesaro, y dos túneles (Pesaro t158 y Pesaro_t159) usando un trayecto explícito que va desde Pesaro hasta Pescara.

Archivos de configuración

Este documento usa las configuraciones detalladas a continuación. Únicamente se incluyen las partes relevantes de los archivos de configuración. Los comandos usados para habilitar el MPLS están en el texto en azul; los comandos específicos al TE (RSVP incluyendo) están en el texto en negrita.

Pesaro
Current configuration:

!

version 12.1

!

hostname Pesaro

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.6 255.255.255.255

!

interface Tunnel158

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 2 2

 tunnel mpls traffic-eng bandwidth 158

 tunnel mpls traffic-eng path-option 1 explicit name low

!

interface Tunnel159

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 4 4

 tunnel mpls traffic-eng bandwidth 159

 tunnel mpls traffic-eng path-option 1 explicit name straight

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.22 255.255.255.252

 
tag-switching ip


 mpls traffic-eng tunnels 

 frame-relay interface-dlci 603   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

ip explicit-path name low enable

 next-address 10.1.1.21 

 next-address 10.1.1.10 

 next-address 10.1.1.1 

 next-address 10.1.1.14 

!

ip explicit-path name straight enable

 next-address 10.1.1.21 

 next-address 10.1.1.5 

 next-address 10.1.1.14 

!

end

Pescara
Current configuration:

!

version 12.0

!

hostname Pescara

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.4 255.255.255.255

!

interface Tunnel1

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 5 5

 tunnel mpls traffic-eng bandwidth 25

 tunnel mpls traffic-eng path-option 2 dynamic

!

interface Tunnel3

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 6 6

 tunnel mpls traffic-eng bandwidth  69

 tunnel mpls traffic-eng path-option 1 dynamic

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.14 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 401   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

end

Pomerol
Current configuration:



version 12.0

!

hostname Pomerol

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.3 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.6 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 301   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.9 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 302   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.3 point-to-point

 bandwidth 512

 ip address 10.1.1.21 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 306   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pulligny
Current configuration:

!

version 12.1

!

hostname Pulligny

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.2 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.2 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 201   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.10 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 203   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pauillac
!

version 12.1

!

hostname pauillac

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.1 255.255.255.255

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.1 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 102   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.2 point-to-point

 bandwidth 512

 ip address 10.1.1.5 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 103   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.3 point-to-point

 bandwidth 512

 ip address 10.1.1.13 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 104   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

Ilustran a los comandos show generales en configurar la ingeniería de tráfico del básico de MPLS básico usando el IS-IS. Los siguientes comandos son específicos de MPLS TE con OSPF y se encuentran ilustrados debajo:

  • muestre a mpls OSPF del IP el link tráfico-inglés

  • muestre el opaco-área de la base de datos OSPF del IP

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Ejemplo de Resultado del Comando show

Usted puede utilizar el comando show ip ospf mpls traffic-eng link de ver qué será hecha publicidad por el OSPF en un router dado. A continuación, se muestran, en negrita, las características de RSVP y se indica el ancho de banda que puede reservarse, el cual se está anunciando y es usado. Puede ver el ancho de banda usado por Pesacara_t1 (en prioridad 5) y por Pescara_t3 (en prioridad 6).

Pesaro# show ip ospf mpls traffic-eng link 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Area 9 has 1 MPLS TE links. Area instance is 3.

  Links in hash bucket 48.
    Link is associated with fragment 0. Link instance is 3 
      Link connected to Point-to-Point network
      Link ID : 10.10.10.3 Pomerol
      Interface Address : 10.1.1.22
      Neighbor Address : 10.1.1.21
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 32000     
      Priority 6 : 24000       Priority 7 : 24000   
      Affinity Bit : 0x0

El comando show ip ospf database puede ser refrenado al tipo 10 LSA y muestra la base de datos que es utilizada por el proceso del MPLS TE para calcular la mejor ruta (para el TE) para los túneles dinámicos (Pescara_t1 y Pescara_t3 en este ejemplo). Esto puede verse en el siguiente resultado parcial:

Pesaro# show ip ospf database opaque-area 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Type-10 Opaque Link Area Link States (Area 9)

  LS age: 397
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.1
  LS Seq Number: 80000003
  Checksum: 0x12C9
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.1 Pauillac

    Link connected to Point-to-Point network
      Link ID : 10.10.10.3
      Interface Address : 10.1.1.5
      Neighbor Address : 10.1.1.6
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 48125
      Number of Priority : 8
      Priority 0 : 48125       Priority 1 : 48125     
      Priority 2 : 48125       Priority 3 : 48125     
      Priority 4 : 48125       Priority 5 : 16125     
      Priority 6 : 8125        Priority 7 : 8125      
      Affinity Bit : 0x0

    Number of Links : 1
  LS age: 339
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.2
  LS Seq Number: 80000001
  Checksum: 0x80A7
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.2 Pulligny

    Link connected to Point-to-Point network
      Link ID : 10.10.10.1
      Interface Address : 10.1.1.2
      Neighbor Address : 10.1.1.1
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 64000     
      Priority 6 : 64000       Priority 7 : 64000     
      Affinity Bit : 0x0

    Number of Links : 1

 LS age: 249
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.3
  LS Seq Number: 80000004
  Checksum: 0x3DDC
  Length: 132
  Fragment number : 0

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 13731