IP : Protocolo de información de routing (RIP)

Ejemplo de configuración de la extensiones activadas para RIP.

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento muestra las configuraciones de muestra usando el comando ip rip triggered interface configuration.

Las extensiones accionadas del Protocolo de información de ruteo (RIP) aumentan la eficacia en links seriales punto a punto. Esta característica se soporta en todas las Plataformas que funcionan con el Software Release 12.0(1)T y Posterior del ½ del ¿Â de Cisco IOSïÂ. Las extensiones accionadas ayudan a evitar dos problemas comunes con el uso de RIP para conectar con una red WAN:

  • La transmisión periódica mediante RIP puede impedir el cierre de los circuitos WAN.

  • Incluso en links fijos de punto a punto, la sobrecarga de transmisiones RIP periódicas puede interrumpir seriamente la transferencia normal de datos.

Para habilitar esta característica, utilice el comando ip rip triggered interface configuration en ambos los lados del link. A modo de ejemplo, vea las siguientes configuraciones.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/13720/51a.gif

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

S3-3640
interface Serial1/0 
  ip address 172.16.1.1 255.255.255.0
  ip rip triggered
 ! 
 router rip
  network 172.16.0.0 

S3-3620
interface Loopback8
 ip address 172.19.1.1 255.255.255.0
!
interface Ethernet0/3
 ip address 172.18.1.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.0
 ip rip triggered
!
router rip
 network 172.16.0.0
 network 172.18.0.0
 network 172.19.0.0

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

Rutea docto por una interfaz que se configure con el ip rip triggered se muestre como Entrada permanente en la base de datos de RIP y la tabla de ruteo.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • show ip route – Muestra el estado actual de la tabla de ruteo.

  • muestre la base de datos de RIP del IP - Visualiza las entradas de la dirección de resumen en las entradas de la base de datos de ruteo del RIP si las rutas relevantes se están resumiendo basadas sobre una dirección de resumen.

S3-3640#show ip route
C       172.16.1.0/24 is directly connected, Serial1/0
R    172.19.0.0/16 [120/1] via 172.16.1.2, Serial1/0
R    172.18.0.0/16 [120/1] via 172.16.1.2, Serial1/0

S3-3640#show ip rip database
172.18.0.0/16    auto-summary
172.18.0.0/16
    [1] via 172.16.1.2, 00:02:44 (permanent), Serial1/0
	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0
172.19.0.0/16    auto-summary
172.19.0.0/16
    [1] via 172.16.1.2, 00:02:45 (permanent),Serial1/0
  	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

  • haga el debug de los eventos del RIP del IP - Visualiza la información sobre las transacciones de ruteo del RIP.

S3-3640#debug ip rip events
RIP: received v1 triggered request from 172.16.1.2 on Serial1/0
RIP: start retransmit timer of 172.16.1.2
RIP: received v1 triggered ack from 172.16.1.2 on Serial1/0
RIP: Stopped retrans timer for 172.16.1.2
RIP: sending v1 ack to 172.16.1.2 via Serial1/0 (172.16.1.1),

Conclusión

Cuando habilita extensiones activadas al RIP, se transmiten las actualizaciones de ruta en la WAN solamente si ocurren uno de los siguientes eventos:

  • El router recibe una solicitud específica de una actualización de ruteo, lo que ocasiona que se envíe la totalidad de la base de datos.

  • La información de otra interfaz modifica la base de datos de ruteo, que hace solamente los últimos cambios ser enviada.

  • La interfaz sube o va abajo, que hace una base de datos parcial ser enviada.

  • El router se enciende por primera vez para asegurar que se envíe al menos una actualización, lo que ocasiona que se envíe la base de datos completa.


Información Relacionada


Document ID: 13720