IP : Open Shortest Path First (OSPF)

Problemas con funcionar con el OSPF en el NBMA y al modo de broadcast sobre el Frame Relay

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Esta nota técnica explica un problema por el que aparecen rutas OSPF base de datos de Estado de Link pero no en la tabla de ruteo de un entorno de Frame Relay completamente mallado. Para más escenarios, consulte ?Por qué algunas rutas OSPF están en la base de datos pero no en la tabla de ruteo.

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

  • OSPF

  • Frame Relay

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware. Sin embargo, la configuración ilustrada en este documento está probada y actualizada por el uso de las siguientes versiones de software y hardware:

  • Router serie 2500 de Cisco

  • Versión 12.2(24a) del½ del¿Â del Cisco IOSïÂ

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Teoría Precedente

El ejemplo abajo utiliza un entorno de Frame Relay completamente mallado. A continuación, se muestran las configuraciones y el diagrama de la red:

/image/gif/paws/13696/24a.gif

Doc
interface Ethernet0 
 ip address 50.50.50.50 255.255.255.0 

interface Serial0 
 encapsulation frame-relay 

!--- Enables Frame Relay encapsulation on the interface.

interface Serial0.1 multipoint 

!--- The subinterface is configured as a multipoint link.

 ip address 10.10.10.5 255.255.255.0 
 ip ospf network broadcast 

!--- This command is used to define the network type as broadcast.


!--- The network type is defined on nonbroadcast networks to
 

!--- avoid configuring the neighbors explicitly.

 frame-relay map ip 10.10.10.6 101 broadcast 
 frame-relay map ip 10.10.10.10 100 broadcast 

!--- To define the mapping between a destination protocol address


!--- and the data-link connection identifier (DLCI) used to
 

!--- connect to the destination address.
  

!--- The broadcast keyword is used to forward broadcasts to
 

!--- this address when broadcast/multicast is
 

!--- disabled because of non-broadcast medium.

router ospf 1 
 network 0.0.0.0 255.255.255.255 area 0

Soñoliento
interface Ethernet0 
  ip address 70.70.70.70 255.255.255.0 

 interface Serial0 
  encapsulation frame-relay

!--- Enables Frame Relay encapsulation on the interface. 

interface Serial0.1 multipoint 

!--- The subinterface is configured as a multipoint link.

  ip address 10.10.10.6 255.255.255.0 
  ip ospf network broadcast

!--- This command is used to define the network type as broadcast.

!--- The network type is defined on nonbroadcast networks to 

!--- avoid configuring the neighbors explicitly. 

  frame-relay map ip 10.10.10.5 101 broadcast 
  frame-relay map ip 10.10.10.10 102 broadcast 

!--- To define the mapping between a destination protocol address
!--- and the DLCI used to connect to the destination address.   
!--- The broadcast keyword is used to forward broadcasts to 
!--- this address when broadcast/multicast is 
!--- disabled because of non-broadcast medium.

 router ospf 1 
  network 0.0.0.0 255.255.255.255 area 0

Sneezy
interface Ethernet0 
  ip address 60.60.60.60 255.255.255.0 

 interface Serial0 
  encapsulation frame-relay 

!--- Enables Frame Relay encapsulation on the interface.

 interface Serial0.1 multipoint

!--- The subinterface is configured as a multipoint link. 

  ip address 10.10.10.10 255.255.255.0 
  ip ospf network broadcast

!--- This command is used to define the network type as broadcast.
!--- The network type is defined on nonbroadcast networks to 
!--- avoid configuring the neighbors explicitly.
 


  frame-relay map ip 10.10.10.5 100 broadcast 
  frame-relay  map ip 10.10.10.6 102 broadcast 

!--- To define the mapping between a destination protocol address
!--- and the DLCI used to connect to the destination address.   
!--- The broadcast keyword is used to forward broadcasts to 
!--- this address when broadcast/multicast is 
!--- disabled because of non-broadcast medium.

 router ospf 1 
  network 0.0.0.0 255.255.255.255 area 0

Problema

Inicialmente, todos los routers tienen todas las rutas en sus tablas de vecino. Un evento ocurre que las causas doc. y soñoliento para caerse de sus tablas del respectivo vecino. De las tablas vecinas proporcionadas en esta sección, podemos ver que la tabla del vecino Doc no posee la entrada 70.70.70.70 y que la tabla del vecino Sleepy no posee la entrada 50.50.50.50.

Tabla de vecino Doc
doc# 
show ip ospf neighbor

  
 Neighbor ID Pri State        Dead Time Address     Interface
 60.60.60.60 1   FULL/DR      00:00:33 10.10.10.10  Serial0.1
Tabla de vecino Sleepy
sleepy# show ip ospf neighbor

 Neighbor ID Pri State        Dead Time Address     Interface
 60.60.60.60 1   FULL/BDR     00:00:32 10.10.10.10  Serial0.1
Tabla de vecino Sneezy
sneezy# show ip ospf neighbor

 Neighbor ID Pri State        Dead Time Address     Interface
 50.50.50.50 1   FULL/DROTHER 00:00:36  10.10.10.5  Serial0.1
 70.70.70.70 1   FULL/DR      00:00:31  10.10.10.6  Serial0.1

Además, el doc. pierde todas las OSPF rutas de su tabla de ruteo, y Sleepy y Sneezy tiene no más 50.50.50.0 (la subred LAN doc.) en sus tablas de ruteo.

Tabla de ruteo Doc
doc# 
show ip route

 Gateway of last resort is not set
      10.0.0.0 255.255.255.0 is subnetted, 1 subnets
 C       10.10.10.0 is directly connected, Serial0.1
      50.0.0.0 255.255.255.0 is subnetted, 1 subnets
 C       50.50.50.0 is directly connected, Ethernet0
Tabla de ruteo soñolienta
sleepy# show ip route
 Gateway of last resort is not set
      10.0.0.0/ 24 is subnetted, 1 subnets
 C       10.10.10.0 is directly connected, Serial0.1
      60.0.0.0/ 24 is subnetted, 1 subnets
 O       60.60.60.0 [110/ 11175] via 10.10.10.10, 00: 07: 25, Serial0.1
      70.0.0.0/ 24 is subnetted, 1 subnets
 C    70.70.70.0 is directly connected, Ethernet0
Tabla de ruteo de Sneezy
sneezy# show ip route
 Gateway of last resort is not set
      10.0.0.0/ 24 is subnetted, 1 subnets
 C       10.10.10.0 is directly connected, Serial0.1
      60.0.0.0/ 24 is subnetted, 1 subnets
 C       60.60.60.0 is directly connected, Ethernet0
      70.0.0.0/ 24 is subnetted, 1 subnets
 O       70.70.70.0 [110/ 11175] via 10.10.10.6, 00: 07: 53, Serial0.1

Si bien Doc no tiene ninguna ruta OSPF en su tabla de ruteo, se puede observar de la salida que se muestra a continuación que sí cuenta con una base de datos OSPF completa.

Base de datos Doc
doc# 
show ip ospf database


                               OSPF Router with ID (50.50.50.50) (Process ID 1)

                                          Router Link States (Area 0)

 Link ID       ADV Router    Age    Seq#        Checksum Link count
 50.50.50.50   50.50.50.50   169    0x80000030  0x3599   2
 60.60.60.60   60.60.60.60   1754   0x8000002F  0xD26D   2
 70.70.70.70   70.70.70.70   1681   0x8000002D  0xFDD9   2

                                           Net Link States (Area 0)

 Link ID       ADV Router    Age    Seq#        Checksum
 10.10.10.6    70.70.70.70   569    0x8000002B  0x8246

El estado del link de red es un estado de link generado por el router designado (DR) que describe todos los routers conectados a la red. En la salida abajo, vemos que el DR no enumera el Router ID doc. (50.50.50.50) como router conectado, que rompe el modelo de broadcast. Por lo tanto, Doc no instala ninguna de las rutas OSPF aprendidas a través de la red de Frame Relay.

Link-state de la red
doc# 
show ip ospf database network 10.10.10.6


                                           Net Link States (Area 0)

 LS Type: Network Links
 Link State ID: 10.10.10.6 (address of Designated Router)
 Advertising Router: 70.70.70.70

 Network Mask: 255.255.255.0
       Attached Router: 70.70.70.70
       Attached Router: 60.60.60.60

Otra manera de ver esto es que Doc declara a Sneezy como un DR y espera que Sneezy genere un estado de link de red. Sin embargo, como Sneezy no es un DR, no genera un estado del link de red, lo que a su vez no le permite a Doc instalar ninguna ruta en su tabla de ruteo.

Tabla de vecino Doc
doc# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
60.60.60.60       1   FULL/DR         00:00:29    10.10.10.10     Serial0.1

Causas

Según la base de datos, el DR para la nube de Frame Relay es Sleepy. Sin embargo, Sleepy no considera a Doc como un vecino OSPF. Como se observa en este ejemplo, el ping de Sleepy a Doc falla:

sleepy# ping 10.10.10.5

Type escape sequence to abort.
Sending 5, 100- byte ICMP Echos to 10.10.10.5, timeout is 2 seconds:
.....
Success rate is 0 percent (0/ 5)

En el resultado del comando show frame-relay map en Sleepy, podemos observar que la DLCI que va a Doc se encuentra inactiva. Esto explica por qué Sleepy no puede hacer un ping a Doc y por qué estos no pueden verse como vecinos. Éste es el evento que originó el problema:

sleepy# show frame-relay map
Serial0.1 (up): ip 10.10.10.5 dlci 101( 0x65,0x1850), static,
              broadcast,
              CISCO, status defined, inactive

Serial0.1 (up): ip 10.10.10.10 dlci 102( 0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

Como el PVC entre Doc y Sleepy está interrumpido y el link de Doc al router designado (DR) está roto, Doc declara todos los LSA de Sneezy (que no es un DR) como inalcanzables. El modelo transmitido por Frame Relay funciona bien si la nube Frame Relay se encuentra totalmente interconectada. Si se rompe cualquier circuito virtual permanente (PVC), puede causar problemas en la base de datos de OSPF, lo que es evidente desde el resultado del comando show ip ospf database router que se incluye a continuación de—que muestra que el mensaje de que el router Adv no es alcanzable.

Tabla de vecino Doc
doc# 
show ip ospf database router

             OSPF Router with ID (50.50.50.50) (Process ID 1)

                Router Link States (Area 0)

  LS age: 57
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 50.50.50.50
  Advertising Router: 50.50.50.50
  LS Seq Number: 800000D4
  Checksum: 0x355D
  Length: 48
  Number of Links: 2

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.10.10.10
     (Link Data) Router Interface address: 10.10.10.5
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 50.50.50.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10


  Adv Router is not-reachable
  LS age: 367
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 60.60.60.60
  Advertising Router: 60.60.60.60
  LS Seq Number: 800000C9
  Checksum: 0xC865
  Length: 48
  Number of Links: 2

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.10.10.6
     (Link Data) Router Interface address: 10.10.10.10
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 60.60.60.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10


  Adv Router is not-reachable
  LS age: 53
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 70.70.70.70
  Advertising Router: 70.70.70.70
  LS Seq Number: 800000CA
  Checksum: 0xEDD4
  Length: 48
  Number of Links: 2

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.10.10.6
     (Link Data) Router Interface address: 10.10.10.6
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 70.70.70.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10

Solución

Al configurar OSPF para que se ejecute en una red de acceso múltiple, con o sin capacidad de transmisión, todos los dispositivos deben poder comunicarse directamente (como mínimo) con el router designado. El modelo de difusión y NBMA depende de que la nube de Frame Relay esté totalmente mallada. Si se desconecta un Circuito virtual permanente (PVC), la nube ya no está completamente mallada y el OSPF no funciona correctamente.

En un entorno de Frame Relay, si la capa 2 es inestable, como en nuestro ejemplo, no recomendamos un tipo de red de difusión OSPF. Utilice OSPF punto a multipunto en su lugar.


Información Relacionada


Document ID: 13696