IP : Open Shortest Path First (OSPF)

Estrategia de respaldo ISDN con posibilidades de ampliación para redes OSPF extensas

21 Noviembre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Esta nota técnica describe una estrategia de backup de ISDN con posibilidades de ampliación para las redes OSPF grandes. Previamente, era necesario dedicar una interfaz de ISDN en un Router del borde de la área OSPF (ABR) para la cada área que requirió el respaldo. Esto significada si usted tuviera 50 áreas OSPF que el respaldo necesario, usted requeriría 50 interfaces de ISDN que podrían atravesar a través de los backup ABR múltiple. Con el fin de nuestra discusión, el backup ABR es el ABR que termina los links ISDN se establecen que cuando el link principal falla. Miremos porqué es necesario que la cada área tenga una interfaz ISDN dedicada en el backup ABR.

Esta restricción fue traída encendido por el hecho de que una interfaz puede pertenecer solamente a un en un momento del área. Puesto que el ISDN utiliza tradicionalmente el Dial-On Demand Routing de la herencia (DDR) el código, y todos los Canales B en un circuito ISDN físico se atan a una entidad de la punta a de múltiples puntos de la capa de red única llamada una interfaz del dialer. Así, aunque una interfaz de la velocidad primaria (PRI) tiene 23 Canales B, todos los canales en este circuito ISDN físico pertenecen a la misma interfaz de capa de red, SerialX:23, y esta interfaz puede pertenecer solamente a una área OSPF. Se pierde el hecho que podemos físicamente terminar las llamadas a partir de 23 sitios distintos en este PRI puesto que todos los canales deben compartir la misma configuración de capa de red. Así, tenemos la restricción que la cada área que requiere el respaldo tiene que tener una interfaz ISDN dedicada en el backup ABR.

prerrequisitos

Requisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Antecedentes

La versión 11.2 del � del Cisco IOS introdujo una característica llamada los Perfiles de marcado. Una de las diferencias fundamentales entre el DDR heredado y los Perfiles de marcado es el hecho de que los circuitos ISDN físicos están combinados no más a la misma interfaz de capa de red. En lugar, tenemos la capacidad para definir los perfiles del discador múltiples que son entidades de capa de red con algunos parámetros de DDR asociados también. Cuando una llamada entrante llega en un circuito ISDN, ataremos dinámicamente la llamada al perfil del discador apropiado basado en el nombre de usuario autenticado o el identificador de llamada. Usted puede definir muchos más Perfiles de marcado que usted tiene circuitos ISDN físicos, de tal modo permitiendo que usted sobre-inscriba y, esencialmente, que confíe en la multiplexión estadística de sus llamadas ISDN.

Éste parece ser un descubrimiento para nuestra estrategia de backup OSPF. Puesto que cada perfil del discador tiene su propia dirección IP asociada (y por lo tanto área OSPF), si teníamos 50 áreas OSPF del respaldo, podemos configurar 50 diversos Perfiles de marcado en el backup ABR. No necesitamos 50 diversas interfaces de ISDN más, nosotros podemos utilizar lejos menos, dependiendo del nivel de suscripción excesiva que podemos manejar en nuestra red de backup. Cuando una llamada entrante llega en el backup ABR, atamos la llamada del área que fue abajo al perfil del discador apropiado en la misma área.

Desafortunadamente, hay algunos problemas con los Perfiles de marcado. la PRE-configuración de los Perfiles de marcado pone cada perfil del discador dentro de la área correspondiente que el área con copia de seguridad pertenece a. Esto causa:

  • LSA adicionales que se generarán, uno para cada Perfiles de marcado.

  • Las áreas llegan a ser automáticamente discontiguous, puesto que el perfil del discador se convierte en un link del stub en un área. (Las interfaces del dialer nunca van abajo de así que el OSPF establece las relaciones del stub para cada interfaz del dialer configurada en un router).

  • Cada perfil del discador introduce una ruta adicional en el área, que puede ser indeseable al hacer el resumen.

  • Cualquier cambio en las bases de datos LSA (flap del link dondequiera en la red) hace una llamada ISDN ser generado.

  • Puesto que los LSA de áreas se inundan cada 30 minutos para asegurar la sincronización de las bases de datos LSA a través del sistema autónomo, una llamada ISDN se genera a la cada área cuando ocurre la inundación.

Nota: Es posible evitar el escenario más reciente si usted utiliza la característica a pedido OSPF en IOS 11.2. Sin embargo, cada router de backup en cada área tiene que ser actualizado a 11.2 para entender la opción del Demand Circuit (DC) durante la formación de adyacencia.

La característica de los Perfiles virtuales en Cisco 11.3 soluciona todos los problemas antedichos. Los Perfiles virtuales se basan en los Perfiles de marcado, tan otra vez, nosotros tienen la separación de la interfaz de capa de red del circuito ISDN físico. Sin embargo, los Perfiles virtuales amplían los Perfiles de marcado permitiendo la configuración de la interfaz dinámica cuando se hace una llamada entrante. La configuración de la interfaz se salva en un servidor central (en nuestro escenario, un servidor de AAA que soporta el TACACS+ o el protocolo RADIUS) y se descarga al router a pedido. Cuando el área marca nuevamente dentro del ABR, el circuito ISDN físico está limitado a una interfaz dinámica llamada una interfaz de acceso virtual. La configuración de la interfaz de acceso virtual es originada de una virtual-plantilla y, más importante, del servidor de AAA. Salvamos la dirección IP del perfil virtual en el servidor de AAA, y se ha aplicado a la interfaz de acceso virtual que el circuito ISDN físico ha estado limitado a. Cuando el link ISDN es disconnected, se destruye el perfil virtual (o la interfaz de acceso virtual que el área fue conectada con), el link ISDN está lista para la llamada ISDN siguiente.

Con un PRI, tenemos la capacidad de soportar hasta 23 llamadas inmediatamente del mismo o de los diversos sitios. Con el multilink PPP habilitado en el backup ABR, cuando llega una nueva llamada, comparamos el nombre de usuario autenticado con el de los Perfiles virtuales existentes. Si se encuentra una coincidencia (la llamada originada de la misma área), liamos los links juntos en un agrupamiento de links múltiples que permita los circuitos ISDN físicos que originan del mismo lugar para compartir la misma interfaz de capa de red (perfil virtual). Los circuitos ISDN físicos que originan de diversas áreas (cuyo nombre de usuario autenticado diferencie de los Perfiles virtuales creados ya) están limitados a los nuevos Perfiles virtuales y a las nuevas interfaces de acceso virtual se crean con sus configuraciones descargadas del servidor de AAA.

Puesto que estamos preconfigurando no más los Perfiles de marcado en el backup ABR, no encontramos los problemas del perfil del marcador enumerados arriba. La ausencia de PRE-configuración también permite que los backup ABR escalen sin esfuerzo a través de los chasis múltiples, y elimina la tara de administración redundante.

En el backup ABR, usted, sin embargo, necesita preconfigurar las declaraciones de la red OSPF que asocian una subred a una área determinada.

Diagrama de la red

En el ejemplo mostrado abajo, tenemos dos Routers en el área 0, isdn2-1 y isdn2-2. isdn2-1 tiene el link principal a isdn1-7, que está en el área 100. isdn1-5 está el ABR para el área 100 y marca en isdn2-2, que es el router total de backup. isdn1-4 está otro router en el área 100 de la cual podemos ejecutar los traceroutes para monitorear la trayectoria del tráfico IP. isdn1-5 tiene OSPF a pedido que se ejecuta; sincroniza inicialmente hasta isdn2-2 y tiene así conocimientos totales de las rutas interzonales, incluyendo la ruta de resumen. Sin embargo, el coste es más alto en la Interfaz de respaldo, así el trayecto preferido todavía está a través isdn1-7.

/image/gif/paws/13695/23a.gif

Configuraciones

Miremos las configuraciones actuales del Routers en el ejemplo anterior.

isdn2-1
interface Loopback0
  ip address 10.0.1.1 255.255.255.0
 !
 interface Loopback1
  ip address 10.0.2.2 255.255.255.0
 !
 interface Loopback2
  ip address 10.0.3.3 255.255.255.0
 !
 interface Tunnel0
  ip address 10.100.100.2 255.255.255.0
  ip ospf cost 100
  tunnel source Ethernet2/0
  tunnel destination 172.16.25.9
  tunnel key 1234
 !
 interface Ethernet2/0
  ip address 172.16.25.51 255.255.255.240
 !
 router ospf 10
  redistribute static subnets route-map cisco_summary
  network 10.0.0.0 0.0.255.255 area 0
  network 172.16.25.48 0.0.0.15 area 0
  network 10.100.100.0 0.0.0.255 area 100
  default-metric 100
 !
 ip default-gateway 172.16.25.49
 ip classless
 ip route 171.68.0.0 255.254.0.0 172.16.25.49
 ip route 172.16.25.9 255.255.255.255 172.16.25.49
 no logging buffered
 access-list 101 permit ip 171.68.0.0 0.0.255.255 255.254.0.0 0.0.255.255
 route-map cisco_summary permit 10
  match ip address 101
  set metric 200

isdn2-2
aaa new-model
aaa authentication login default none
aaa authentication ppp default if-needed tacacs+
aaa authorization network tacacs+
aaa accounting network start-stop tacacs
!
interface Ethernet0
ip address 172.16.25.52 255.255.255.240
!
interface Virtual-Template1
no ip address
ppp authentication chap
!
interface Serial0:23
no ip address
encapsulation ppp
dialer-group 1
isdn incoming-voice modem
no peer default ip address
ppp authentication chap
!
interface Group-Async1
ip unnumbered Ethernet0
ip tcp header-compression passive
encapsulation ppp
async mode interactive
peer default ip address pool default
ppp authentication chap
group-range 1 24
!
router ospf 10
network 10.0.0.0 0.0.255.255 area 0
network 10.200.0.0 0.0.255.255 area 200
network 172.16.25.48 0.0.0.15 area 0
network 10.100.200.0 0.0.0.255 area 100
!
ip local pool default 172.16.25.59 172.16.25.62
virtual-profile virtual-template 1
virtual-profile aaa
dialer-list 1 protocol ip permit
tacacs-server host 171.68.207.32
tacacs-server key cisco

isdn1-5
interface Ethernet0
  ip address 172.16.25.5 255.255.255.240
 !
 interface BRI0
  ip address 10.100.200.1 255.255.255.0
  encapsulation ppp
  ip ospf cost 1500
  ip ospf demand-circuit
  no peer default ip address
  dialer map ip 10.100.200.2 name isdn2-2 broadcast 4327528
  dialer-group 1
  ppp authentication chap
  ppp chap hostname ospf_backup1
 !
 router ospf 10
  network 0.0.0.0 255.255.255.255 area 100
 !
 dialer-list 1 protocol ip permit

isdn1-7
interface Tunnel0
ip address 10.100.100.1 255.255.255.0
ip ospf cost 100
tunnel source Ethernet0
tunnel destination 172.16.25.51
tunnel key 1234
!
interface Ethernet0
ip address 172.16.25.9 255.255.255.240
media-type 10BaseT
!
router ospf 10
redistribute static
network 0.0.0.0 255.255.255.255 area 100
!
ip classless
ip route 172.16.25.51 255.255.255.255 172.16.25.1

isdn1-4
interface Ethernet0
  ip address 172.16.25.4 255.255.255.240
 !
 router ospf 10
  network 0.0.0.0 255.255.255.255 area 100

Comandos show

Lo que sigue es la salida del comando show para el Routers arriba.

Comandos isdn2-1 show

isdn2-1#show ip ospf
 Routing Process "ospf 10" with ID 10.0.2.2
 Supports only single TOS(TOS0) routes
 It is an area border and autonomous system boundary router
 Summary Link update interval is 00:30:00 and the update due in 00:00:06
 External Link update interval is 00:30:00 and the update due in 00:27:25
 Redistributing External Routes from,
    static with metric mapped to 100, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
    Area BACKBONE(0)
        Number of interfaces in this area is 4
        Area has no authentication
        SPF algorithm executed 38 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:29:21
        Link State Age Interval is 00:20:00 and due in 00:06:06
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
    Area 100
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 35 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:00:37
        Link State Age Interval is 00:20:00 and due in 00:00:05
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 6

isdn2-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 172.16.25.49 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 4 subnets
C       10.0.2.0 is directly connected, Loopback1
C       10.0.3.0 is directly connected, Loopback2
C       10.100.100.0 is directly connected, Tunnel0
C       10.0.1.0 is directly connected, Loopback0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.25.48/28 is directly connected, Ethernet2/0
S       172.16.25.9/32 [1/0] via 172.16.25.49
S    171.68.0.0/15 [1/0] via 172.16.25.49

Comandos show isdn2-2

isdn2-2#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.52
 Supports only single TOS(TOS0) routes
 It is an area border router
 Summary Link update interval is 00:30:00 and the update due in 00:03:21
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 3. 3 normal 0 stub 0 nssa
    Area BACKBONE(0)
        Number of interfaces in this area is 26
        Area has no authentication
        SPF algorithm executed 9 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:03:20
        Link State Age Interval is 00:20:00 and due in 00:03:19
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
    Area 100
        Number of interfaces in this area is 0
        Area has no authentication
        SPF algorithm executed 34 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:00:00
        Link State Age Interval is 00:20:00 and due in 00:03:19
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 10
    Area 200
        Number of interfaces in this area is 0
        Area has no authentication
        SPF algorithm executed 1 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:00:00
        Link State Age Interval is 00:20:00 and due in 00:03:19
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0

isdn2-2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 172.16.25.49 to network 0.0.0.0

     172.16.0.0/28 is subnetted, 1 subnets
C       172.16.25.48 is directly connected, Ethernet0
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O IA    10.100.100.0/24 [110/110] via 172.16.25.51, 00:07:07, Ethernet0
O       10.0.3.3/32 [110/11] via 172.16.25.51, 00:09:40, Ethernet0
O       10.0.2.2/32 [110/11] via 172.16.25.51, 00:09:40, Ethernet0
O       10.0.1.1/32 [110/11] via 172.16.25.51, 00:09:40, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.49, 00:07:07, Ethernet0

isdn2-2#show ip ospf interface virtual-template 1
Virtual-Template1 is down, line protocol is down
   OSPF not enabled on this interface

Comandos isdn1-7 show

isdn1-7#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.9
 Supports only single TOS(TOS0) routes
 It is an autonomous system boundary router
 External Link update interval is 00:30:00 and the update due in 00:03:54
 Redistributing External Routes from,
    static
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 100
        Number of interfaces in this area is 3
        Area has no authentication
        SPF algorithm executed 32 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:10:38
        Link State Age Interval is 00:20:00 and due in 00:10:38
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 6

isdn1-7#show ip ospf neighbor details
 Neighbor 172.16.25.5, interface address 172.16.25.5
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    DR is 172.16.25.5 BDR is 172.16.25.4
    Options 2
    Dead timer due in 00:00:32
 Neighbor 172.16.25.4, interface address 172.16.25.4
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    DR is 172.16.25.5 BDR is 172.16.25.4
    Options 2
    Dead timer due in 00:00:39
 Neighbor 10.0.2.2, interface address 10.100.100.2
    In the area 100 via interface Tunnel0
    Neighbor priority is 1, State is FULL
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options 2
    Dead timer due in 00:00:37

isdn1-7#show ip ospf interface tunnel0
Tunnel0 is up, line protocol is up
  Internet Address 10.100.100.1/24, Area 100
  Process ID 10, Router ID 172.16.25.9, Network Type POINT_TO_POINT, Cost: 100
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

isdn1-7#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 172.16.25.1 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O IA    172.16.25.48/28 [110/1520] via 172.16.25.5, 00:10:33, Ethernet0
S       172.16.25.51/32 [1/0] via 172.16.25.1
C       172.16.25.0/28 is directly connected, Ethernet0
C       172.16.25.3/32 is directly connected, Virtual-Access1
     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O IA    10.0.3.3/32 [110/1521] via 172.16.25.5, 00:10:33, Ethernet0
O IA    10.0.2.2/32 [110/1521] via 172.16.25.5, 00:10:33, Ethernet0
O IA    10.0.1.1/32 [110/1521] via 172.16.25.5, 00:10:33, Ethernet0
C       10.100.100.0/24 is directly connected, Tunnel0
O       10.100.65.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.60.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.55.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.50.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.200.0/24 [110/1510] via 172.16.25.5, 00:10:33, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.5, 00:10:33, Ethernet0

Comandos isdn1-5 show

isdn1-5#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.5
 Supports only single TOS(TOS0) routes
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 3
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 100
        Number of interfaces in this area is 6
        Area has no authentication
        SPF algorithm executed 45 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:05:12
        Link State Age Interval is 00:20:00 and due in 00:05:11
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 7

isdn1-5#show ip ospf neighbor details
 Neighbor 172.16.25.52, interface address 10.100.200.2
    In the area 100 via interface BRI0
    Neighbor priority is 1, State is FULL
    Options 34
    Dead timer due in 00:00:34
 Neighbor 172.16.25.9, interface address 172.16.25.9
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:36
 Neighbor 172.16.25.4, interface address 172.16.25.4
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:36

isdn1-5#show ip ospf interface bri0
BRI0 is up, line protocol is up (spoofing)
  Internet Address 10.100.200.1/24, Area 100
  Process ID 10, Router ID 172.16.25.5, Network Type POINT_TO_POINT, Cost: 1500
  Configured as demand circuit.
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 172.16.25.52  (Hello suppressed)
  Suppress hello for 1 neighbor(s)

isdn1-5#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O IA    10.0.3.3/32 [110/111] via 172.16.25.9, 00:00:56, Ethernet0
O IA    10.0.2.2/32 [110/111] via 172.16.25.9, 00:00:56, Ethernet0
O IA    10.0.1.1/32 [110/111] via 172.16.25.9, 00:00:56, Ethernet0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:00:56, Ethernet0
C       10.100.65.0/24 is directly connected, Loopback3
C       10.100.60.0/24 is directly connected, Loopback2
C       10.100.55.0/24 is directly connected, Loopback1
C       10.100.50.0/24 is directly connected, Loopback0
C       10.100.200.2/32 is directly connected, BRI0
C       10.100.200.0/24 is directly connected, BRI0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/120] via 172.16.25.9, 00:00:57, Ethernet0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.9, 00:00:58, Ethernet0

Comandos isdn1-4 show

isdn1-4#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.4
 Supports only single TOS(TOS0) routes
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 3
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 100
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 27 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:20:41
        Link State Age Interval is 00:20:00 and due in 00:00:40
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 6

isdn1-4#show ip ospf neighbor details
 Neighbor 172.16.25.9, interface address 172.16.25.9
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:35
 Neighbor 172.16.25.5, interface address 172.16.25.5
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:30

isdn1-4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O IA    10.0.3.3/32 [110/111] via 172.16.25.9, 00:02:00, Ethernet0
O IA    10.0.2.2/32 [110/111] via 172.16.25.9, 00:02:01, Ethernet0
O IA    10.0.1.1/32 [110/111] via 172.16.25.9, 00:02:01, Ethernet0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:02:11, Ethernet0
O       10.100.65.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.60.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.55.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.50.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.200.0/24 [110/1510] via 172.16.25.5, 00:02:11, Ethernet0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/120] via 172.16.25.9, 00:02:01, Ethernet0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.9, 00:02:01, Ethernet0

Depuración y verificación

La ruta actual de isdn1-4 a 171.68.191.1 está a través isdn1-7, sobre la interfaz del túnel a isdn2-1, y encendido con 172.16.25.49.

isdn1-4#show ip route 171.68.0.0
Routing entry for 171.68.0.0/15, supernet
  Known via "ospf 10", distance 110, metric 200, type extern 2, forward metric 120
  Redistributing via ospf 10
  Last update from 172.16.25.9 on Ethernet0, 00:00:04 ago
  Routing Descriptor Blocks:
  * 172.16.25.9, from 10.0.2.2, 00:00:04 ago, via Ethernet0
      Route metric is 200, traffic share count is 1

Podemos ver esta ruta usando el comando traceroute en un host en la red interna de Cisco. Cómo el paquete nos vuelve es inútil en este escenario.

isdn1-4#traceroute 171.68.191.1

Type escape sequence to abort.
Tracing the route to dpeng-sun.cisco.com (171.68.200.127)

  1 172.16.25.9 4 msec 4 msec 4 msec      (isdn1-7)
  2 10.100.100.2 4 msec 8 msec 8 msec     (isdn2-1)
  3 172.16.25.49 4 msec 4 msec 4 msec
  4 171.68.191.1 8 msec 8 msec 4 msec

Cambiemos la clave del túnel encendido isdn1-7 para hacer la interfaz del túnel ir abajo. Si esperamos un Intervalo muerto completo (40 segundos son el intervalo muerto predeterminado), detectan al par mientras que abajo y nuestro respaldo comienza.

isdn1-7#
*Mar  1 02:31:17.916: OSPF: 10.0.2.2 address 10.100.100.2 on Tunnel0 is dead

El router de backup del área está isdn1-5. Está ejecutando el OSPF a pedido, así que tiene conocimientos totales de las rutas dentro de una zona a través del router total de backup. Sin embargo, el costo de OSPF a través del link de backup es más alto, así cuando el link principal entre el área 100 y la estructura básica está para arriba, los paquetes todavía atraviesan isdn1-7. Puesto que hemos roto el link principal encendido isdn1-7, la ruta isdn1-5 es mejor ahora, y el cambio en las bases de datos OSPF acciona una llamada al router total de backup.

isdn1-5#
*Mar  7 04:58:09.955: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x05
*Mar  7 04:58:09.959:         Bearer Capability i = 0x8890
*Mar  7 04:58:09.959:         Channel ID i = 0x83
*Mar  7 04:58:09.963:         Keypad Facility i = '4327528'
*Mar  7 04:58:10.103: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x85
*Mar  7 04:58:10.107:         Channel ID i = 0x89
*Mar  7 04:58:10.963: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x85
*Mar  7 04:58:10.975: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  7 04:58:11.007: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x05
*Mar  7 04:58:12.019: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface BRI0:1, changed state to up
*Mar  7 04:58:17.131: %ISDN-6-CONNECT: 
Interface BRI0:1 is now connected to 4327528 isdn2-2
*Mar  7 04:58:24.159: OSPF: 
Cannot see ourself in hello from 172.16.25.52 on BRI0, state INIT
*Mar  7 04:58:27.867: OSPF: Rcv DBD from 172.16.25.52 on BRI0 seq 0x6FE 
opt 0x22 flag 0x7 len 32 state INIT
*Mar  7 04:58:27.871: OSPF: 2 Way Communication to 172.16.25.52 
on BRI0, state 2WAY
*Mar  7 04:58:27.875: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0xEBC opt 0x22 flag 0x7 len 32
*Mar  7 04:58:27.879: OSPF: NBR Negotiation Done. We are the SLAVE
*Mar  7 04:58:27.879: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0x6FE opt 0x22 flag 0x2 len 432
*Mar  7 04:58:28.031: OSPF: Rcv DBD from 172.16.25.52 on BRI0 seq 
0x6FF opt 0x22 flag 0x3 len 432 state EXCHANGE
*Mar  7 04:58:28.035: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0x6FF opt 0x22 flag 0x0 len 32
*Mar  7 04:58:28.043: OSPF: Database request to 172.16.25.52
*Mar  7 04:58:28.043: OSPF: sent LS REQ packet to 10.100.200.2, 
length 24
*Mar  7 04:58:28.079: OSPF: Rcv DBD from 172.16.25.52 on BRI0 seq 
0x700 opt 0x22 flag 0x1 len 32 state EXCHANGE
*Mar  7 04:58:28.079: OSPF: Exchange Done with 172.16.25.52 on BRI0
*Mar  7 04:58:28.083: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0x700 opt 0x22 flag 0x0 len 32
*Mar  7 04:58:28.099: OSPF: Synchronized with 172.16.25.52 on BRI0, 
state FULL
*Mar  7 04:58:28.099: OSPF: Tried to build Router LSA within 
MinLSInterval

El procedimiento para backup encendido isdn1-5 es completo, y la interfaz de ISDN ahora es el link entre el área 100 y la área de estructura básica.

isdn1-5#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O IA    10.0.3.3/32 [110/1511] via 10.100.200.2, 00:00:35, BRI0
O IA    10.0.2.2/32 [110/1511] via 10.100.200.2, 00:00:35, BRI0
O IA    10.0.1.1/32 [110/1511] via 10.100.200.2, 00:00:35, BRI0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:00:35, Ethernet0
C       10.100.65.0/24 is directly connected, Loopback3
C       10.100.60.0/24 is directly connected, Loopback2
C       10.100.55.0/24 is directly connected, Loopback1
C       10.100.50.0/24 is directly connected, Loopback0
C       10.100.200.2/32 is directly connected, BRI0
C       10.100.200.0/24 is directly connected, BRI0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/1510] via 10.100.200.2, 00:00:36, BRI0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 10.100.200.2, 00:00:37, BRI0

isdn1-5#show ip route 171.68.0.0
Routing entry for 171.68.0.0/15, supernet
  Known via "ospf 10", distance 110, metric 200, type extern 2, forward metric 1510
  Redistributing via ospf 10
  Last update from 10.100.200.2 on BRI0, 00:09:33 ago
  Routing Descriptor Blocks:
  * 10.100.200.2, from 10.0.2.2, 00:09:33 ago, via BRI0
      Route metric is 200, traffic share count is 1

Mirando encendido isdn1-4 ahora, vemos que la ruta de resumen para la red interna de Cisco ahora tiene un salto siguiente de isdn1-5.

isdn1-4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O IA    10.0.3.3/32 [110/1521] via 172.16.25.5, 00:01:49, Ethernet0
O IA    10.0.2.2/32 [110/1521] via 172.16.25.5, 00:01:49, Ethernet0
O IA    10.0.1.1/32 [110/1521] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:01:49, Ethernet0
O       10.100.65.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.60.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.55.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.50.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.200.0/24 [110/1510] via 172.16.25.5, 00:01:49, Ethernet0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/1520] via 172.16.25.5, 00:01:49, Ethernet0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.5, 00:01:49, Ethernet0

isdn1-4#show ip route 171.68.0.0
Routing entry for 171.68.0.0/15, supernet
  Known via "ospf 10", distance 110, metric 200, type extern 2, 
  forward metric 1520
  Redistributing via ospf 10
  Last update from 172.16.25.5 on Ethernet0, 00:02:04 ago
  Routing Descriptor Blocks:
  * 172.16.25.5, from 10.0.2.2, 00:02:04 ago, via Ethernet0
      Route metric is 200, traffic share count is 1

El comando traceroute demuestra la trayectoria ha cambiado.

isdn1-4#traceroute 171.68.191.1

     Type escape sequence to abort.
     Tracing the route to dpeng-sun.cisco.com (171.68.200.127)

       1 172.16.25.5 4 msec 4 msec 4 msec         (isdn1-5)
       2 10.100.200.2 16 msec 16 msec 16 msec     (isdn2-2)
       3 172.16.25.49 28 msec 16 msec 72 msec
       4 171.68.191.1 16 msec 16 msec 16 msec

Miremos qué sucede en el router total de backup cuando el link principal (la interfaz del túnel) está abajo y los diales del router de backup del área adentro. Primero, el router total de backup recibe la llamada del router de backup del área:

*Mar  1 01:12:20.587: ISDN Se0:23: RX <-  SETUP pd = 8  callref = 0x1B
*Mar  1 01:12:20.591:         Bearer Capability i = 0x8890
*Mar  1 01:12:20.595:         Channel ID i = 0xA98393
*Mar  1 01:12:20.599:         Calling Party Number i = '!', 0x83, '4082322044'
*Mar  1 01:12:20.603:         Called Party Number i = 0xC1, '4084327528'
*Mar  1 01:12:20.691: %LINK-3-UPDOWN: Interface Serial0:18, changed state to up
*Mar  1 01:12:20.727: Se0:18 PPP: Treating connection as a callin
*Mar  1 01:12:20.731: Se0:18 PPP: Phase is ESTABLISHING, Passive Open
*Mar  1 01:12:20.735: Se0:18 LCP: State is Listen
*Mar  1 01:12:20.755: ISDN Se0:23: TX ->  CALL_PROC pd = 8  callref = 0x801B
*Mar  1 01:12:20.759:         Channel ID i = 0xA98393
*Mar  1 01:12:20.791: ISDN Se0:23: TX ->  CONNECT pd = 8  callref = 0x801B
*Mar  1 01:12:20.791:         Channel ID i = 0xA98393
*Mar  1 01:12:20.863: ISDN Se0:23: RX <-  CONNECT_ACK pd = 8  callref = 0x1B

La negociación PPP comienza:

*Mar  1 01:12:20.995: Se0:18 LCP: I CONFREQ [Listen] id 166 len 34
*Mar  1 01:12:20.999: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.003: Se0:18 LCP:    MagicNumber 0x20039D53 
(0x050620039D53)
*Mar  1 01:12:21.003: Se0:18 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:12:21.007: Se0:18 LCP:    EndpointDisc 1 Local 
(0x130F016F7370665F6261636B757031)
*Mar  1 01:12:21.015: Se0:18 LCP: O CONFREQ [Listen] id 9 len 15
*Mar  1 01:12:21.015: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.019: Se0:18 LCP:    MagicNumber 0x60812EEF 
(0x050660812EEF)
*Mar  1 01:12:21.023: Se0:18 LCP: O CONFREJ [Listen] id 166 len 23
*Mar  1 01:12:21.027: Se0:18 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:12:21.027: Se0:18 LCP:    EndpointDisc 1 Local 
(0x130F016F7370665F6261636B757031)
*Mar  1 01:12:21.043: Se0:18 LCP: I CONFACK [REQsent] id 9 len 15
*Mar  1 01:12:21.047: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.051: Se0:18 LCP:    MagicNumber 0x60812EEF 
(0x050660812EEF)
*Mar  1 01:12:21.055: Se0:18 LCP: I CONFREQ [ACKrcvd] id 167 len 15
*Mar  1 01:12:21.055: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.059: Se0:18 LCP:    MagicNumber 0x20039D53 
(0x050620039D53)
*Mar  1 01:12:21.063: Se0:18 LCP: O CONFACK [ACKrcvd] id 167 len 15
*Mar  1 01:12:21.063: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.067: Se0:18 LCP:    MagicNumber 0x20039D53 
(0x050620039D53)
*Mar  1 01:12:21.071: Se0:18 LCP: State is Open

Una vez que el LCP acaba de negociar, procedemos a la autenticación:

*Mar  1 01:12:21.071: Se0:18 PPP: Phase is AUTHENTICATING, 
by both
*Mar  1 01:12:21.075: Se0:18 CHAP: O CHALLENGE id 9 len 28 
from "isdn2-2"
*Mar  1 01:12:21.155: Se0:18 CHAP: I CHALLENGE id 61 len 33 
from "ospf_backup1"
*Mar  1 01:12:21.159: Se0:18 CHAP: I RESPONSE id 9 len 33 
from "ospf_backup1"

Enviamos nuestro desafío del Challenge Handshake Authentication Protocol (CHAP) y recibimos una respuesta del par. Observe que el router de área de backup demanda ser el "ospf_backup1", en vez del nombre del host real del router el "isdn1-5". Esto sucede porque utilizamos el comando ppp chap hostname de reemplazar el valor por defecto.

Puesto que autenticamos a este usuario que usaba el TACACS+, siguiente entramos en contacto el servidor TACACS+.

*Mar  1 01:12:21.167: AAA/AUTHEN: create_user (0x35F5BC) 
user='ospf_backup1' ruser='' port='Serial0:18' 
rem_addr='4082322044/4084327528' authen_type=CHAP service=PPP priv=1
*Mar  1 01:12:21.171: AAA/AUTHEN/START (1579536474): 
port='Serial0:18' list='' action=SENDAUTH service=PPP
*Mar  1 01:12:21.175: AAA/AUTHEN/START (1579536474): 
using "default" list
*Mar  1 01:12:21.179: AAA/AUTHEN (1579536474): 
status = UNKNOWN
*Mar  1 01:12:21.179: AAA/AUTHEN/START (1579536474): 
Method=TACACS+
*Mar  1 01:12:21.183: TAC+: send AUTHEN/START packet 
ver=193 id=1579536474
*Mar  1 01:12:21.403: TAC+: ver=193 id=1579536474 
received AUTHEN status = PASS
*Mar  1 01:12:21.403: AAA/AUTHEN (1579536474): 
status = PASS
*Mar  1 01:12:21.411: AAA/AUTHEN: free_user (0x35F5BC) 
user='ospf_backup1' ruser='' port='Serial0:18' 
rem_addr='4082322044/4084327528' authen_type=CHAP service=PPP priv=1
*Mar  1 01:12:21.415: Se0:18 CHAP: Waiting for peer 
to authenticate first
*Mar  1 01:12:21.419: AAA/AUTHEN: create_user (0x35F5BC) 
user='ospf_backup1' ruser='' port='Serial0:18' 
rem_addr='4082322044/4084327528' authen_type=CHAP service=PPP priv=1
*Mar  1 01:12:21.423: AAA/AUTHEN/START (3035786780): 
port='Serial0:18' list='' action=LOGIN service=PPP
*Mar  1 01:12:21.427: AAA/AUTHEN/START (3035786780): 
using "default" list
*Mar  1 01:12:21.427: AAA/AUTHEN (3035786780): 
status = UNKNOWN
*Mar  1 01:12:21.431: AAA/AUTHEN/START (3035786780): 
Method=TACACS+
*Mar  1 01:12:21.431: TAC+: send AUTHEN/START packet 
ver=193 id=3035786780
*Mar  1 01:12:21.655: TAC+: ver=193 id=3035786780 
received AUTHEN status = PASS
*Mar  1 01:12:21.659: AAA/AUTHEN (3035786780): 
status = PASS

Puesto que la contraseña está correcta, y se autentica el router de área de backup, ahora procedemos a la etapa de la autorización.

*Mar  1 01:12:21.663: AAA/AUTHOR/LCP Se0:18: 
Authorize LCP
*Mar  1 01:12:21.667: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): user='ospf_backup1'
*Mar  1 01:12:21.667: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): send AV service=ppp
*Mar  1 01:12:21.671: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): send AV protocol=lcp
*Mar  1 01:12:21.671: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): Method=TACACS+
*Mar  1 01:12:21.675: AAA/AUTHOR/TAC+: (221407121): 
user=ospf_backup1
*Mar  1 01:12:21.679: AAA/AUTHOR/TAC+: (221407121): 
send AV service=ppp
*Mar  1 01:12:21.679: AAA/AUTHOR/TAC+: (221407121): 
send AV protocol=lcp
*Mar  1 01:12:21.903: TAC+: (221407121): received 
author response status = PASS_ADD
*Mar  1 01:12:21.911: AAA/AUTHOR (221407121): 
Post authorization status = PASS_ADD
*Mar  1 01:12:21.911: AAA/AUTHOR/LCP Se0:18: 
Processing AV service=ppp
*Mar  1 01:12:21.915: AAA/AUTHOR/LCP Se0:18: 
Processing AV protocol=lcp
*Mar  1 01:12:21.915: AAA/AUTHOR/LCP Se0:18: 
Processing AV interface-config=ip address 
10.100.200.2 255.255.255.0\nip ospf cost 1500

La autorización es completa. Conseguimos las pares de valor de atributo (AVP) que indican ciertas configuraciones debemos estar en la interfaz que estamos creando.

Ahora que la autenticación y autorización para el LCP es completa, dejamos al par conocerlas nos permitimos adentro.

*Mar  1 01:12:21.927: Se0:18 CHAP: O SUCCESS id 9 len 4
*Mar  1 01:12:21.927: Se0:18 CHAP: O RESPONSE id 61 
len 28 from "isdn2-2"
*Mar  1 01:12:21.951: Se0:18 CHAP: I SUCCESS id 61 len 4

El proceso LCP es completo, y ahora el protocolo network control (NCP) será construido, que nos significa necesita una interfaz. Hemos habilitado la característica de los Perfiles virtuales, así que reproducimos una interfaz de acceso virtual de la interfaz de plantilla virtual, después personalizamos la configuración usando los AVP recibidos del AAA.

Miremos cómo creamos la interfaz de acceso virtual.

*Mar  1 01:12:21.955: Vi1 VTEMPLATE: Reuse Vi1, 
recycle queue size 0
*Mar  1 01:12:21.955: Vi1 VTEMPLATE: Set default 
settings with no ip address
*Mar  1 01:12:22.363: Vi1 VTEMPLATE: Hardware address 
0060.3ef1.6f74
*Mar  1 01:12:22.391: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial0:18, changed state to up
*Mar  1 01:12:22.399: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Virtual-Access1, changed state to up
*Mar  1 01:12:22.451: %LINK-3-UPDOWN: 
Interface Virtual-Access1, changed state to up
*Mar  1 01:12:22.455: Vi1 PPP: Treating connection 
as a dedicated line
*Mar  1 01:12:22.459: Vi1 PPP: Phase is ESTABLISHING, 
Active Open
*Mar  1 01:12:22.463: Vi1 LCP: O CONFREQ [Closed] 
id 33 len 10
*Mar  1 01:12:22.467: Vi1 LCP:    MagicNumber 0x60813499 
(0x050660813499)

La configuración básica de la interfaz de acceso virtual viene de la interfaz de plantilla virtual 1, como se especifica en la configuración.

*Mar  1 01:12:22.483: Vi1 VTEMPLATE: 
Has a new cloneblk vtemplate, now it has vtemplate
*Mar  1 01:12:22.487: Vi1 VTEMPLATE: 
Undo default settings
*Mar  1 01:12:22.899: Vi1 VTEMPLATE: 
************* CLONE VACCESS1 *****************
*Mar  1 01:12:22.899: Vi1 VTEMPLATE: 
Clone from vtemplate1
interface Virtual-Access1
no ip address
encap ppp
no ip address
no ip mroute-cache
ppp authentication chap
ppp multilink
end

La interfaz de acceso virtual está empezando para arriba.

*Mar  1 01:12:23.671: Vi1 PPP: 
Phase is TERMINATING
*Mar  1 01:12:23.671: Vi1 PPP: 
Phase is ESTABLISHING, Active Open
*Mar  1 01:12:23.679: Vi1 LCP: 
O CONFREQ [Closed] id 34 len 15
*Mar  1 01:12:23.679: Vi1 LCP:    
AuthProto CHAP (0x0305C22305)
*Mar  1 01:12:23.683: Vi1 LCP:    
MagicNumber 0x6081395A (0x05066081395A)
*Mar  1 01:12:23.743: Vi1 PPP: 
Phase is TERMINATING
*Mar  1 01:12:23.747: Vi1 PPP: 
Phase is ESTABLISHING, Active Open
*Mar  1 01:12:23.751: Vi1 LCP: 
O CONFREQ [Closed] id 35 len 29
*Mar  1 01:12:23.755: Vi1 LCP:    
AuthProto CHAP (0x0305C22305)
*Mar  1 01:12:23.759: Vi1 LCP:    
MagicNumber 0x608139A3 (0x0506608139A3)
*Mar  1 01:12:23.759: Vi1 LCP:    
MRRU 1524 (0x110405F4)
*Mar  1 01:12:23.763: Vi1 LCP:    
EndpointDisc 1 Local (0x130A016973646E322D32)
*Mar  1 01:12:23.847: Vi1 AAA/AUTHOR: LCP_DOWN
*Mar  1 01:12:23.847: Vi1 AAA/AUTHOR: LCP_DOWN

Ahora descarguemos la configuración AVP que conseguimos del servidor de AAA. Especifica la dirección IP para la interfaz y también modifica el costo de OSPF predeterminado.

*Mar  1 01:12:23.947: Vi1 VTEMPLATE: 
Has a new cloneblk AAA, now it has vtemplate/AAA
*Mar  1 01:12:23.951: Vi1 VTEMPLATE: 
************* CLONE VACCESS1 *****************
*Mar  1 01:12:23.955: Vi1 VTEMPLATE: 
Clone from AAA
interface Virtual-Access1
ip address 10.100.200.2 255.255.255.0
ip ospf cost 1500
end

*Mar  1 01:12:24.123: OSPF: 
Interface Virtual-Access1 going Up
*Mar  1 01:12:24.127: Vi1 PPP: 
Unsupported or un-negotiated protocol. Link ip
*Mar  1 01:12:24.235: 
AAA/AUTHEN: dup_user (0x35DEA0) user='ospf_backup1' 
ruser='' port='Serial0:18' rem_addr='4082322044/4084327528' 
authen_type=CHAP service=PPP priv=1 source='AAA dup vp_create'

Un bit de la trapacería permite que forcemos el estado negociado LCP.

*Mar  1 01:12:24.239: Vi1 LCP: 
I FORCED CONFREQ len 11
*Mar  1 01:12:24.243: Vi1 LCP:    
AuthProto CHAP (0x0305C22305)
*Mar  1 01:12:24.247: Vi1 LCP:    
MagicNumber 0x60812EEF (0x050660812EEF)
*Mar  1 01:12:24.247: Vi1 PPP: 
Phase is UP

Estamos listos ahora para negociar los NCP.

*Mar  1 01:12:24.251: AAA/AUTHOR/FSM Vi1: (0): 
Can we start IPCP?
*Mar  1 01:12:24.263: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): user='ospf_backup1'
*Mar  1 01:12:24.263: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): send AV service=ppp
*Mar  1 01:12:24.267: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): send AV protocol=ip
*Mar  1 01:12:24.271: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): Method=TACACS+
*Mar  1 01:12:24.275: AAA/AUTHOR/TAC+: (2432251470): 
user=ospf_backup1
*Mar  1 01:12:24.275: AAA/AUTHOR/TAC+: (2432251470): 
send AV service=ppp
*Mar  1 01:12:24.279: AAA/AUTHOR/TAC+: (2432251470): 
send AV protocol=ip
*Mar  1 01:12:24.503: TAC+: (2432251470): received 
author response status = PASS_ADD
*Mar  1 01:12:24.507: AAA/AUTHOR (2432251470): Post 
authorization status = PASS_ADD
*Mar  1 01:12:24.515: AAA/AUTHOR/FSM Vi1: We can 
start IPCP
*Mar  1 01:12:24.519: Vi1 IPCP: O CONFREQ [Closed] 
id 17 len 10
*Mar  1 01:12:24.523: Vi1 IPCP:    
Address 10.100.200.2 (0x03060A64C802)
*Mar  1 01:12:24.523: Se0:18 PPP: Phase is FORWARDED
*Mar  1 01:12:24.527: Se0:18 IPCP: PPP phase is FORWARDED, 
discarding packet
*Mar  1 01:12:24.531: Se0:18 IPCP: PPP phase is FORWARDED, 
discarding packet
*Mar  1 01:12:25.851: Vi1 LCP: TIMEout: Time 0x424F98 
State Open

El par quiere asignar 10.100.200.1 en su interfaz.

*Mar  1 01:12:26.031: Vi1 IPCP: I CONFREQ [REQsent] 
id 56 len 10
*Mar  1 01:12:26.035: Vi1 IPCP:    Address 10.100.200.1 
(0x03060A64C801)
*Mar  1 01:12:26.035: AAA/AUTHOR/IPCP Vi1: Start.  
Her address 10.100.200.1, we want 0.0.0.0

Preguntamos el servidor TACACS+ para autorizar la dirección IP.

*Mar  1 01:12:26.039: AAA/AUTHOR/IPCP Vi1: 
Processing AV service=ppp
*Mar  1 01:12:26.043: AAA/AUTHOR/IPCP Vi1: 
Processing AV protocol=ip
*Mar  1 01:12:26.043: AAA/AUTHOR/IPCP Vi1: 
Processing AV addr=10.100.200.1
*Mar  1 01:12:26.047: AAA/AUTHOR/IPCP Vi1: 
Authorization succeeded

Se concede la autorización.

*Mar  1 01:12:26.047: AAA/AUTHOR/IPCP Vi1: Done.  
Her address 10.100.200.1, we want 10.100.200.1

Reconocemos su IP Address solicitado.

*Mar  1 01:12:26.051: Vi1 IPCP: 
O CONFACK [REQsent] id 56 len 10
*Mar  1 01:12:26.059: Vi1 IPCP:    
Address 10.100.200.1 (0x03060A64C801)
*Mar  1 01:12:26.067: Vi1 LCP: 
O PROTREJ [Open] id 36 len 10 protocol CDPCP (0x820701350004)
*Mar  1 01:12:26.727: %ISDN-6-CONNECT: 
Interface Serial0:18 is now connected to 4082322044 ospf_backup1
*Mar  1 01:12:26.875: Vi1 IPCP: 
TIMEout: Time 0x425294 State ACKsent
*Mar  1 01:12:26.879: Vi1 IPCP: 
O CONFREQ [ACKsent] id 18 len 10
*Mar  1 01:12:26.879: Vi1 IPCP:    
Address 10.100.200.2 (0x03060A64C802)

El par reconoce nuestra dirección IP.

*Mar  1 01:12:26.899: Vi1 IPCP: 
I CONFACK [ACKsent] id 18 len 10
*Mar  1 01:12:26.903: Vi1 IPCP:    
Address 10.100.200.2 (0x03060A64C802)
*Mar  1 01:12:26.903: Vi1 IPCP: 
State is Open
*Mar  1 01:12:26.911: Vi1 AAA/AUTHOR: 
IP_UP
*Mar  1 01:12:26.911: Vi1 AAA/PER-USER: 
processing author params.
*Mar  1 01:12:26.919: Vi1 IPCP: 
Install route to 10.100.200.1

Puesto que el IP está completamente para arriba en esta interfaz, el OSPF sincroniza y establece la adyacencia.

*Mar  1 01:12:29.427: OSPF: Rcv hello from 10.0.2.2 area 0 
from Ethernet0 172.16.25.51
*Mar  1 01:12:29.427: OSPF: End of hello processing
*Mar  1 01:12:35.295: OSPF: service_maxage: Trying to 
delete MAXAGE LSA
*Mar  1 01:12:37.823: OSPF: Rcv hello from 172.16.25.5 
area 100 from Virtual-Access1 10.100.200.1
*Mar  1 01:12:37.823: OSPF: 2 Way Communication to 
172.16.25.5 on Virtual-Access1, state 2WAY
*Mar  1 01:12:37.827: OSPF: Send DBD to 172.16.25.5 on 
Virtual-Access1 seq 0x6FE opt 0x22 flag 0x7 len 32
*Mar  1 01:12:37.831: OSPF: End of hello processing
*Mar  1 01:12:37.871: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0xEBC opt 0x22 flag 0x7 len 32 state EXSTART
*Mar  1 01:12:37.875: OSPF: First DBD and we are not SLAVE
*Mar  1 01:12:37.927: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0x6FE opt 0x22 flag 0x2 len 432 state EXSTART
*Mar  1 01:12:37.931: OSPF: NBR Negotiation Done. 
We are the MASTER
*Mar  1 01:12:37.939: OSPF: Send DBD to 172.16.25.5 on 
Virtual-Access1 seq 0x6FF opt 0x22 flag 0x3 len 432
*Mar  1 01:12:37.943: OSPF: Database request to 172.16.25.5
*Mar  1 01:12:37.947: OSPF: sent LS REQ packet to 10.100.200.1, 
length 96
*Mar  1 01:12:38.031: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0x6FF opt 0x22 flag 0x0 len 32 state EXCHANGE
*Mar  1 01:12:38.035: OSPF: Send DBD to 172.16.25.5 on 
Virtual-Access1 seq 0x700 opt 0x22 flag 0x1 len 32
*Mar  1 01:12:38.115: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0x700 opt 0x22 flag 0x0 len 32 state EXCHANGE
*Mar  1 01:12:38.119: OSPF: Exchange Done with 172.16.25.5 
on Virtual-Access1
*Mar  1 01:12:38.119: OSPF: Synchronized with 172.16.25.5 
on Virtual-Access1, state FULL

La sincronización de OSPF es completa entre el router de backup del área y el router total de backup. El OSPF a pedido se negocia así que el link ISDN está encima de solamente cuando hay el fluir de tráfico de datos.

isdn2-2#show ip ospf interface virtual-access 1
Virtual-Access1 is up, line protocol is up
  Internet Address 10.100.200.2/24, Area 100
  Process ID 10, Router ID 172.16.25.52, 
  Network Type POINT_TO_POINT, Cost: 1500
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, 
  Wait 40, Retransmit 5
    Hello due in 00:00:05
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 172.16.25.5  
	(Hello suppressed)
  Suppress hello for 1 neighbor(s)

isdn2-2#show interface virtual-access 1 config
Virtual-Access1 is a Virtual Profile interface

Building configuration...

interface Virtual-Access1 configuration...
ip address 10.100.200.2 255.255.255.0
ip ospf cost 1500
no ip mroute-cache
ppp authentication chap

Aquí está el perfil TACACS+ de isdn1-5:

user = ospf_backup1 {
        chap = cleartext "cisco"

        service = ppp protocol = lcp {
                interface-config = "ip address 10.100.200.2 255.255.255.0\nip ospf cost 1500"
        }

        service = ppp protocol = ip {
                addr = 10.100.200.1
        }
}

Y el perfil de RADIUS:

ospf_backkup1 Password = "cisco"
        Service-Type = Framed,
        Framed-Protocol = PPP,
        Framed-IP-Address = 10.100.200.1
        cisco-avpair = "interface-config=ip address 10.100.200.2 255.255.255.0\nip ospf cost 1

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 13695