IP : Open Shortest Path First (OSPF)

Configuraciones iniciales para OSPF en links no transmisores

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

En un medio no apto para broadcast como Frame Relay, X.25, ATM y Switched Multimegabit Data Service (SMDS), OSPF puede ejecutarse de dos modos:

  • NBMA: simula un modelo de broadcast eligiendo un router designado (DR) y un router designado de backup (BDR). Hay dos maneras de simular un modelo de broadcast en una red NBMA: defina el tipo de red según lo transmitido con el submandato de la interfaz del ip ospf network broadcast o configure las sentencias de vecino usando el comando router ospf.

  • Punta-a-mutipoint: trata la red sin broadcast como colección de links punto a punto configurando el comando ip ospf network point-to-multipoint.

Usted debe definir el tipo de red en las redes sin broadcast para evitar configurar las sentencias de vecino. Abajo están las configuraciones de muestra para el OSPF sobre non-broadcast link. Utilice el comando show ip ospf interface de marcar el tipo de red de una interfaz que ejecuta el OSPF y utilizan al comando show ip ospf neighbor de conocer el estatus del router vecino.

prerrequisitos

Requisitos

Este documento requiere que usted entienda la configuración básica del Routing Protocol del Open Shortest Path First (OSPF).

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 2500 Router

  • Software Release 12.2(24a) del � del Cisco IOS que se ejecuta en el Routers

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Diagrama de la red

Abajo está el diagrama de la red usado en los ejemplos de configuración en este documento.

/image/gif/paws/13690/18a_01.gif

Configuraciones para NBMA (Uso de difusión del tipo de red)

Router1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf network broadcast
      no keepalive
      frame-relay map ip 1.1.1.1 16 broadcast
     !
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0

Router2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      ip ospf network broadcast
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Consejos de verificación

Abajo está la salida del comando show para el router1.

Router1# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/BDR        00:00:37    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         Hello due in 00:00:00
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 2
       Last flood scan time is 0 msec, maximum is 4 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)

Y la salida para el router2 está como sigue.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/DR         00:00:38     1.1.1.2         Serial1/0
     
Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         Hello due in 00:00:03
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 2
       Last flood scan time is 0 msec, maximum is 4 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Configuraciones para NBMA (usando sentencias de vecino)

Router1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf priority 2
      no keepalive
      frame-relay map ip 1.1.1.1 16
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
      neighbor 1.1.1.1
     !

Router2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
      neighbor 1.1.1.2
     !

Nota:  En las configuraciones mostradas arriba, el comando ip ospf priority 2 en el router1 establece una prioridad de interfaz más alta que el valor de prioridad predeterminado de 1, que le hace un DR y el router2 el BDR para la red NBMA. Si es necesario, usted puede fijar el valor de prioridad a 0 para configurar a un router nunca para hacer un DR/BDR. Esto es necesario en las redes de hub and spoke donde el concentrador se debe configurar para convertirse en el DR, donde como el spokes debe ni estar el DR ni el BDR. Aunque configurar la sentencia de vecino en un extremo es suficiente formar la adyacencia, es una práctica adecuada hacerla configurar en ambos los extremos como se muestra. También, los comandos frame-relay map no necesitan tener el parámetro del broadcast porque los paquetes OSPF unicasted con la sentencia de vecino.

Consejos de verificación

Abajo está la salida del comando show para el router1.

Router1# show ip ospf neighbors
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/BDR        00:01:39    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:19
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 2, maximum is 2
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)

Y la salida para el router2 está como sigue.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/DR         00:01:49     1.1.1.2         Serial1/0
     
Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:01
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 2, maximum is 2
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Configuraciones para conexiones punto a multipunto

Router1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf network point-to-multipoint
      no keepalive
      frame-relay map ip 1.1.1.1 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Router2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      ip ospf network point-to-multipoint
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0

Consejos de verificación

Abajo está la salida del comando show para el router1.

Router1# show ip ospf neighbors
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/  -        00:01:53    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:18
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2
       Suppress hello for 0 neighbor(s)

Y la salida para el router2 está como sigue.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/  -        00:01:58     1.1.1.2         Serial1/0

Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:18
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3
       Suppress hello for 0 neighbor(s)

Nota: No hay DR y BDR eligió cuando la red NBMA se configura como punta a de múltiples puntos tal y como se muestra en de las salidas, puesto que se trata como colección de links punto a punto.

Para más información, vea configurar el OSPF sobre diversas redes físicas.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 13690