IP : Open Shortest Path First (OSPF)

Configuraciones iniciales para OSPF sobre un link punto a punto

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

En los enlaces punto a punto, tales como High-Level Data Link Control (HDLC) y Point-to-Point Protocol (PPP), Open Shortest Path First (OSPF) se ejecuta como un tipo de red punto a punto. Este tipo de red se activa como opción predeterminada. Este documento muestra ejemplos de configuraciones para OSPF en un link punto a punto. Los otros tipos de red que soporta OSPF son punto a multipunto, broadcast y no-broadcast. Para comprobar el tipo de red de una interfaz que ejecute OSPF, publique el comando show ip ospf interface.

Los ejemplos explicados en este documento trabajan con el HDLC y las encapsulaciones PPP.

prerrequisitos

Requisitos

Los Quien lea este documento deben tener ciertos conocimientos básicos del OSPF Routing Protocol. Para más información sobre el OSPF Routing Protocol, refiera a la primera documentación del trayecto más corto abierto.

Componentes Utilizados

La información en este documento se aplica a estas versiones de software y hardware.

  • Cisco 2500 Router

  • Software Release 12.2(27) del � del Cisco IOS que se ejecuta en el Routers

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

OSPF sobre un link punto a punto con los IP Addresses en las interfaces seriales

Esta sección le presenta con la información que usted puede utilizar para configurar al Routers que ejecuta el OSPF y está conectado a través de un link serial Point-to-Point con el uso del encapsulado HDCL con los IP Addresses configurados en las interfaces seriales.

Nota: Para encontrar la información adicional en los comandos que este documento utiliza, que utilice la herramienta de búsqueda de comandos (clientes registrados solamente).

Diagrama de la red

/image/gif/paws/13687/15a.gif

Configuraciones

Esta sección usa estas configuraciones.

Router1
Router1
!
interface Loopback0
� ip address 3.3.3.3 255.255.255.255
!
interface Serial0
�ip address 1.1.1.2 255.255.255.0
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0

!--- Configures the Serial Interface S0 under OSPF area 0.

!

Router2
Router2
!
interface Loopback0
�ip address 2.2.2.2 255.255.255.255
!
interface Serial0
�ip address 1.1.1.1 255.255.255.0
�clockrate 2000000
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0

!--- Configures the Serial Interface S0 under OSPF area 0..

OSPF sobre un link punto a punto con las interfaces sin numerar

Esta sección le presenta con la información que usted puede utilizar para configurar al Routers que ejecuta el OSPF como el Routing Protocol y está conectado a través de un link serial Point-to-Point con la encapsulación PPP y con las interfaces seriales innumerables. Las interfaces seriales innumerables son las interfaces que no tienen su propia dirección IP. Estas interfaces piden prestada la dirección IP de otra interfaz en el router que hace una dirección IP configurar. Para más información sobre las interfaces seriales innumerables, refiera a entender y a configurar el comando ip unnumbered.

Nota: Para encontrar la información adicional en los comandos que este documento utiliza, que utilice la herramienta de búsqueda de comandos (clientes registrados solamente).

Diagrama de la red

/image/gif/paws/13687/15b.gif

Configuraciones

Esta sección usa estas configuraciones.

Router1
!

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0
 ip unnumbered loopback 0

!--- Configures Serial 0 as an unnumbered interface.

 encapsulation ppp

!--- Configures the Encapsulation on the interface as PPP.

!
router ospf 1
  network 3.3.3.0 0.0.0.255 area 0

!--- Configures the Loopback Interface L0 under OSPF area 0.

!

Router2
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip unnumbered loopback 0

!--- Configures Serial 0 as an unnumbered interface.

 encapsulation ppp

!--- Configures the Encapsulation on the interface as PPP.

!
router ospf 1
  network 2.2.2.0 0.0.0.255 area 0

!--- Configures the Loopback Interface L0 under OSPF area 0..

!

Verificación

Esta sección proporciona la información que usted puede utilizar para confirmar su configuración trabaja correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Verifique la configuración del OSPF con los IP Addresses en las interfaces seriales

Ésta es la salida del comando show ip ospf neighbor publicada en el router1.

Router1#show ip ospf neighbor
   Neighbor ID   Pri   State       Dead Time       Address        Interface
     2.2.2.2      1   FULL/ -       00:00:32       1.1.1.1         Serial 0

Esta salida muestra que el router1 tiene un vecino con un Router ID de 2.2.2.2, y ha formado la adyacencia total con este vecino. El direccionamiento 1.1.1.1 es la dirección IP de la interfaz del serial0 en el router2.

¿Para más información sobre el comando show ip ospf neighbor, refiérase a qué hace el comando show ip ospf neighbor revela?

Ésta es la salida del comando show ip ospf interface serial 0 en el router1. Esta salida muestra el tipo de red OSPF para el serial0 de la interfaz como Punto a punto.

Router1# show ip ospf interface serial 0 
   Serial0 is up, line protocol is up 
   Internet Address 1.1.1.2/24, Area 0 
   Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
   Transmit Delay is 1 sec, State POINT_TO_POINT,
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
   Hello due in 00:00:05
   Index 1/1, flood queue length 0
   Next 0x0(0)/0x0(0)
   Last flood scan length is 1, maximum is 1
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1 
   Adjacent with neighbor 2.2.2.2
   Suppress hello for 0 neighbor(s)

Semejantemente, este ejemplo visualiza la salida para el OSPF del IP de la demostración vecino y los comandos show ip ospf interface en el router2.

Router2# show ip ospf neighbor
   Neighbor ID     Pri    State     Dead Time     Address      Interface
    3.3.3.3         1     FULL/ -    00:00:32      1.1.1.2      Serial0

Router2# show ip ospf interface serial 0
   Serial0 is up, line protocol is up 
   Internet Address 1.1.1.1/24, Area 0 
   Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
   Transmit Delay is 1 sec, State POINT_TO_POINT,
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
   Index 1/1, flood queue length 0
   Next 0x0(0)/0x0(0)
   Last flood scan length is 1, maximum is 1
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 3.3.3.3
   Suppress hello for 0 neighbor(s)

Verifique la configuración del OSPF con las interfaces sin numerar

El comando show ip ospf neighbor en Router1 y Router2 confirma la adyacencia total. Esta salida muestra el tipo de red OSPF para el serial0 de la interfaz como Punto a punto. Usted puede también ver que la dirección de Internet es 0.0.0.0 para la interfaz serial en ambo Routers. Esto es porque una dirección IP se pide prestada del Loopback Interface (en este caso) en virtud del comando ip unnumbered.

Router1#show ip ospf neighbor
      Neighbor ID  Pri   State    Dead Time    Address      Interface
      2.2.2.2      1   FULL/ -    00:00:37    2.2.2.2       Serial0

Router1# show ip ospf interface serial 0
Serial0 is up, line protocol is up
  Internet Address 0.0.0.0/24, Area 0
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)

Este ejemplo visualiza la salida de los comandos show ip ospf neighbor y show ip ospf interface serial 0 en el router2.

Router2#show ip ospf neighbor
      Neighbor ID   Pri   State   Dead Time   Address   Interface
      3.3.3.3        1   FULL/ -  00:00:30    3.3.3.3    Serial0

Router2# show ip ospf interface serial 0
Serial0 is up, line protocol is up
  Internet Address 0.0.0.0/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 3.3.3.3
  Suppress hello for 0 neighbor(s)

Este ejemplo muestra la salida del comando show ip route en el router1 con la encapsulación PPP y el uso de las interfaces sin numerar.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0

Este ejemplo visualiza la salida del comando show ip route en el router2 con la encapsulación PPP y el uso de las interfaces sin numerar.

Router2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Serial0

Este ejemplo visualiza la salida del comando show ip route en el router1 con el encapsulation hdlc y del uso de las interfaces sin numerar.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 2.2.2.2, 00:00:08, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0

Este ejemplo visualiza la salida del comando show ip route en el router2 con el encapsulation hdlc y del uso de las interfaces sin numerar.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

        2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 3.3.3.3, 00:01:28, Serial0

Nota: La salida del comando show ip route pudo diferenciar entre el PPP y los encapsulados HDCL cuando la configuración sin numeración IP se utiliza en las interfaces seriales. El PPP instala una ruta del host a la dirección IP que se utiliza en la interfaz serial en el otro extremo como directamente red conectada. Si el mismo prefijo es OSPF directo también docto como en esta configuración, visualiza solamente como Routeconectad (mientras que esta salida de la ruta de IP de la demostración muestra). Éste es porque los Routeconectad tienen una distancia administrativa menor que el OSPF y es preferido. Usted puede cambiar este comportamiento cuando usted publica el comando no peer neighbor-route bajo interfaces seriales que evita que una ruta del host sea instalada y lo trata como OSPF ruta.

Éste no es el caso con el HDLC porque no instala una ruta del host. El HDLC instala una OSPF ruta para el direccionamiento en el otro extremo cuando el IP innumerable se utiliza.

Troubleshooting

Para la información sobre cómo resolver problemas los problemas OSPF, refiera localización de averías del OSPF.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 13687