IP : Open Shortest Path First (OSPF)

Problemas de ruteo comunes en el reenvío de direcciones OSPF

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe los conceptos y el problema asociado a la dirección de reenvío de OSPF (Open Shortest Path First). Consulte ¿Por qué Algunas Rutas OSPF Están en la Base de Datos pero no en la Tabla de Ruteo? para obtener más información sobre la resolución de problemas de OSPF.

El problema explicado en este documento es solamente observable con las versiones de software del ½ del ¿Â de Cisco IOSï anterior de 12.1(3). La conducta de redistribución ha cambiado en el Cisco IOS Software Release 12.1(3) y Posterior. Para más detalles, refiera al CSCdp72526 del Id. de bug Cisco (clientes registrados solamente). Este bug tiene la lista de versiones de Cisco IOS Software afectadas y de las versiones corregidas. También refiera a redistribuir las redes conectadas en el OSPF donde el cambio en el comportamiento del Cisco IOS se explica.

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

  • IP general ruteando.

  • Conceptos y términos del OSPF Routing Protocol.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 2503 Router

  • Software Release 12.2(24a) del ½ del ¿Â de Cisco IOSï que se ejecuta en todo el Routers

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Descripción de dirección de reenvío OSPF

El concepto del OSPF Forwarding Address fue introducido para evitar los saltos extra cuando el tráfico se rutea a un sistema externo, tal y como se muestra en de esta figura.

/image/gif/paws/13682/10a.gif

En la figura, hay dos Routers en el dominio OSPF que conecta con el dominio externo. Sin embargo, solamente el router1 intercambia la información de ruteo por el router 100. El router1 redistribuye la información aprendida del router 100 en el OSPF y hace publicidad de la información al resto del dominio OSPF. Al hacer esto, el Router 1 se convierte en el próximo salto (o dirección de reenvío) para la información que redistribuye al dominio de OSPF. Cuando el router2 recibe un paquete del dominio OSPF destinado para un direccionamiento en el dominio externo, él adelante el paquete al router1 del router 1. entonces adelante él al router 100. El concepto de la dirección de reenvío permite este salto extra sea evitado porque permite que el router1 especifique la dirección IP de otro router como la dirección de reenvío. En la figura, el router1 puede especificar al router 100 como la dirección de reenvío para la información externa que el router1 redistribuye en el dominio OSPF. Cuando el router2 recibe un paquete del dominio OSPF destinado para un direccionamiento en el dominio externo, él adelante el paquete al router 100. El resultado es que el salto extra está evitado con el router1.

El valor de la dirección de reenvío especificada por el Autonomous System Boundary Router (ASBR) (router1 en la figura anterior) puede ser 0.0.0.0 o no-cero. La dirección 0.0.0.0 indica que el router de origen (el ASBR) es el próximo salto. Estas condiciones determina a la dirección de reenvío:

  • Fijan a la dirección de reenvío a 0.0.0.0 si el ASBR redistribuye las rutas y el OSPF no se habilita en la interfaz de salto siguiente para esas rutas. Esto es verdad en la figura si el router1 no tiene OSPF habilitado en la interfaz de Ethernet.

  • Estas condiciones fijaron el campo de dirección de reenvío a una dirección distinta de cero:

    • El OSPF se habilita en la interfaz de salto siguiente ASBR Y

    • La interfaz de salto siguiente ASBR es NON-pasiva bajo el OSPF Y

    • La interfaz de salto siguiente ASBR no es de punto a punto Y

    • La interfaz de salto siguiente ASBR no es punta a de múltiples puntos Y

    • El direccionamiento de la interfaz de salto siguiente ASBR baja bajo rango de red especificado en el comando router ospf.

  • Otras condiciones además de éstas, configuran la dirección de reenvío como 0.0.0.0.

Para la información sobre cómo la dirección de reenvío es determinada y la selección de trayecto de las influencias refiera a los efectos de la dirección de reenvío sobre la selección de trayecto del tipo 5 LSA.

Problema común de ruteo OSPF en el reenvío de direcciones

/image/gif/paws/13682/10b_01.gif

Agregan al router R2513, que ejecuta solamente el RIP (y puede ser conectado con una red del RIP-solamente), a la red Token Ring en la figura. Cuando el ASBR (R2515) redistribuye las rutas aprendidas de R2513 en OSPF, algunas rutas no se instalan en la tabla de ruteo de algunos routers. La información de configuración pertinente de cada uno del Routers se da en estas tablas.

nombre del host R2504
interface Serial0
ip address 1.1.1.2 255.255.255.0
         
interface TokenRing0
ip address 3.3.4.2 255.255.255.0
         
router ospf 1
network 1.1.1.0 0.0.0.255 area 0
network 3.0.0.0 0.255.255.255 area 1
area 1 range 3.0.0.0 255.0.0.0

nombre de host R2507
interface Serial0
ip address 1.1.1.1 255.255.255.0
         
interface Serial1
ip address 7.7.7.1 255.255.255.0
         
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
default- information originate metric 20
         
ip route 0.0.0.0 0.0.0.0 Serial1 

nombre del host R2513
interface TokenRing0
ip address 3.3.4.4 255.255.255.0
       
interface ethernet 0
ip address 200.1.1.4 255.255.255.0
       
router rip
network 3.0.0.0
network 200.1.1.0

nombre del host R2515
interface TokenRing0
ip address 3.3.4.3 255.255.255.0
       
interface ethernet 0
ip address 3.44.66.3 255.255.255.0
       
interface ethernet 1
ip address 3.22.88.3 255.255.255.0
       
router ospf 1
redistribute rip metric 20 subnets
network 0.0.0.0 255.255.255.255 area 1
       
router rip
network 3.0.0.0

passive-interface ethernet 0
passive-interface ethernet 1

Las configuraciones en las tablas muestran que el R2515 redistribuye el RIP en el OSPF y que el R2504 (el [ABR] del router del borde del área) crea una red resumida 3.0.0.0/8.

Éstas son las tablas de ruteo para cada uno de los routeres habilitados OSPF:

R2507# 
show ip route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0
         1.0.0.0/ 24 is subnetted, 1 subnets
C          1.1.1.0 is directly connected, Serial0
         3.0.0.0/ 8 is variably subnetted, 4 subnets, 2 masks
O IA        3.0.0.0/ 8 [110/ 70] via 1.1.1.2, 00: 15: 37, Serial0
O E2        3.3.4.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
O E2        3.22.88.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
O E2        3.44.66.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
          7.0.0.0/ 24 is subnetted, 1 subnets
C           7.7.7.0 is directly connected, Serial1
S*     0.0.0.0/ 0 is directly connected, Serial1


R2504# show ip route
Gateway of last resort is 1.1.1.1 to network 0.0.0.0
            1.0.0.0/ 24 is subnetted, 1 subnets
C             1.1.1.0 is directly connected, Serial0
            3.0.0.0/ 8 is variably subnetted, 4 subnets, 2 masks
S             3.0.0.0/ 8 is directly connected, Null0
C             3.3.4.0/ 24 is directly connected, TokenRing0
O             3.22.88.0/ 24 [110/ 11117] via 3.3.4.3, 00: 15: 16, TokenRing0
O             3.44.66.0/ 24 [110/ 11117] via 3.3.4.3, 00: 15: 16, TokenRing0
O  E2 200.1.1.0/ 24 [110/ 20] via 3.3.4.4, 00: 06: 16, TokenRing0
O* E2 0.0.0.0/ 0 [110/ 20] via 1.1.1.1, 00: 15: 16, Serial0

R2515# show ip route
 Gateway of last resort is 3.3.4.2 to network 0.0.0.0
            1.0.0.0/ 24 is subnetted, 1 subnets
 O IA         1.1.1.0 [110/ 70] via 3.3.4.2, 00: 10: 28, TokenRing0
            3.0.0.0/ 24 is subnetted, 3 subnets
 C            3.3.4.0 is directly connected, TokenRing0
 R          200.1.1.0/ 24 [120/ 1] via 3.3.4.4, 00: 00: 10, TokenRing0
 O* E2 0.0.0.0/ 0 [110/ 20] via 3.3.4.2, 00: 10: 28, TokenRing0

Red faltante de la tabla de ruteo

El R2515 tiene una ruta derivada (r) del RIP para la red 200.1.1.0/24. El R2515 es el ASBR y redistribuye el protocolo del RIP en el OSPF. El R2504 aprende sobre la red 200.1.1.0/24 del R2515 y lo instala en su tabla de ruteo como ruta externa del tipo-2 OSPF (E2). El problema es que R2507 no posee la red 200.1.1.0/24 en su tabla de ruteo.

El R2507 tiene rutas externo para las redes 3.3.4.0/24, 3.22.88.0/24 y 3.44.66.0/24, aunque todas estas redes se deben incluir en el resumen de 3.0.0.0/8.

La razón que estas rutas externo aparecen es que el ASBR, que redistribuye el RIP en el OSPF, tiene RIP que se ejecuta en estas tres subredes. Por lo tanto redistribuye las subredes como rutas externo en el OSPF. Puesto que estas subredes son rutas externo, no son resumidas por el ABR (R2504). Las OSPF rutas externas se pueden resumir solamente por el ASBR. En este caso, R2515. El ABR resume solamente las rutas OSPF internas del área 1 en el área 0.

Nota: Con el arreglo del CSCdp72526 del Id. de bug Cisco (clientes registrados solamente), el OSPF no genera un anuncio del estado del vínculo type-5 (LSA) de una red externa solapada. El R2507 tiene solamente una ruta interzonal sumaria de 3.0.0.0/8. Entonces, el R2507 instala 200.1.1.0/24 pues la dirección de reenvío y él es accesibles vía la ruta interzonal 3.0.0.0/8. Esto está de acuerdo con el RFC 2328leavingcisco.com .

Esta salida muestra el externo LSA para la red 200.1.1.0/24 en la base de datos OSPF del R2507:

R2507# 
show ip ospf data external 200.1.1.0

       OSPF Router with ID (7.7.7.1) (Process ID 1)
       Type- 5 AS External Link States
       LS age: 72
       Options: (No TOS- capability, DC)
       LS Type: AS External Link
       Link State ID: 200.1.1.0 (External Network Number )
       Advertising Router: 3.44.66.3
       LS Seq Number: 80000001
       Checksum: 0xF161
       Length: 36
       Network Mask: /24
                   Metric Type: 2 (Larger than any link state path)
                   TOS: 0
                   Metric: 20
                   Forward Address: 3.3.4.4
                   External Route Tag: 0

El OSPF permite que el ASBR especifique a otro router como la dirección de reenvío a las rutas externo. En este caso, ASRB (R2515) ha especificado 3.3.4.4 como la dirección de reenvío para la red externa 200.1.1.0.

RFC 2328leavingcisco.com , sección 16.4 (que calcula COMO rutas externo), estados:

“Si la dirección de reenvío es no-cero, mire para arriba a la dirección de reenvío en la tabla de ruteo. La entrada de la tabla de ruteo que corresponde con debe especificar un intra-area o una trayectoria del inter-area; si existe ninguna tal trayectoria, no haga nada con el LSA y considere el siguiente en la lista.”

En este ejemplo, la ruta a la dirección de reenvío 3.3.4.4 se muestra aquí:

R2507# 
show ip route 3.3.4.4

       Routing entry for 3.3.4.0/ 24
           Known via "ospf 1", distance 110, metric 20,type extern 2, forward metric 70
           Redistributing via ospf 1
           Last update from 1.1.1.2 on Serial0, 00: 00: 40 ago
           Routing Descriptor Blocks:
           * 1.1.1.2, from 3.44.66.3, 00: 00: 40 ago, via Serial0
              Route metric is 20, traffic share count is 1

La ruta externo 3.3.4.0/24 corresponde con a la dirección de reenvío de 3.3.4.4 en vez de la ruta de resumen 3.0.0.0/8 del inter-area debido a la regla más larga de la coincidencia. Porque el router no tiene una ruta OSPF interna a la dirección de reenvío, no instala la ruta externo 200.1.1.0/24 en la tabla de ruteo. El uso de una ruta externo de alcanzar otra ruta externo puede llevar a los loopes. Por lo tanto el OSPF no lo permite.

No resuma en el ABR

¿Cómo puede usted asegurarse de que la dirección de reenvío no-cero exista en la tabla de ruteo como un intra-area o ruta interzonal?

La primera solución no es resumir en el ABR.

La segunda solución no es configurar ningún tipo 3 LSA que filtra. Si se filtran las rutas del tipo 3, la dirección de reenvío que aparece en la salida del comando show ip ospf database external no es accesible. Esto hace la red externa inalcanzable. En este caso, R2504. Esto hace al Routers en el área 0 tener rutas interzonales (en vez de las rutas externo) para todas las subredes específicas en otras áreas.

Utilice estos comandos de quitar el resumen en el ABR:

R2504(config)# 
router ospf 1

R2504(config- router)# no area 1 range 3.0.0.0 255.0.0.0

Los resultados de este comando en la tabla de ruteo en el R2507 se muestran aquí:

R2507# show ip route
       Gateway of last resort is 0.0.0.0 to network 0.0.0.0
                 1.0.0.0/ 24 is subnetted,        1 subnets
       C            1.1.1.0        is directly connected, Serial0
                 3.0.0.0/ 24 is subnetted,        3 subnets
       O IA      3.3.4.0 [110/ 70] via 1.1.1.2, 00: 00:        48, Serial0
       O IA      3.22.88.0 [110/ 80] via 1.1.1.2, 00:        00: 48, Serial0
       O IA      3.44.66.0 [110/ 80] via 1.1.1.2, 00:        00: 48, Serial0
                 7.0.0.0/ 24 is subnetted,        1 subnets
       C           7.7.7.0 is        directly connected, Serial1
       O E2 200.1.1.0/ 24 [110/ 20] via 1.1.1.2, 00: 00: 48, Serial0
       S*     0.0.0.0/ 0 is directly connected, Serial1
	   
	  R2507# show ip route 3.3.4.4
     Routing entry for 3.3.4.0/24
      Known via "ospf 1", distance 110, metric 70, type inter area
      Last update from 1.1.1.2 on Serial1, 00:03:52 ago
      Routing Descriptor Blocks:
      * 1.1.1.2, from 3.3.4.2, 00:03:52 ago, via Serial1
          Route metric is 74, traffic share count is 1

De la salida, usted puede ver que el direccionamiento 3.3.4.4 es accesible a través de una ruta interzonal a la red 3.3.4.0/24. El router R2507 aprende la ruta a esta red con un LSA tipo 5 y Type-3 LSA, después de que el resumen en el ABR R2504 se quite. Puesto que el OSPF prefiere una ruta interzonal sobre una ruta externo a la misma red, la instala como ruta interzonal. El seno R2507 ahora tiene una ruta interzonal a la dirección de reenvío 3.3.4,4, la red externa 200.1.1.0/24 también está instalado en su tabla de ruteo.

Nota: Si se utiliza el NSSA (Not So Stubby Area) y si la filtración del tipo 3 LSA se hace en NSSA ABR, después la misma dirección de reenvío del problema inalcanzable existirá.

Evita que la subnet se redistribuya en OSPF como ruta externa

Otra solución es evitar que la subred 3.3.4.0 sea redistribuida en el OSPF como ruta externo, puesto que el OSPF se ejecuta en él. Estos comandos configuration en el ASBR (R2515) crean un route-map. Esto es utilizada por el comando redistribute de permitir que solamente la red 200.1.1.0/24 sea redistribuida en el OSPF. El ABR (R2504) todavía resume las rutas OSPF internas del área 1 en el área 0.

R2515# configure terminal
R2515(config)# router ospf 1
R2515(config-router)# redistribute rip metric 20 subnets route-map rip_to_ospf_filter
R2515(config-router)# exit
   
R2515(config)# 
access-list 28 permit 200.1.1.0 0.0.0.255
   
R2515(config)# 
route-map rip_to_ospf_filter permit 10
R2515(config-route-map)# 
match ip address 28

Los resultados de este comando en la tabla de ruteo en el R2507 se muestran aquí:

R2507# show ip route
       Gateway of last resort is 0.0.0.0 to network 0.0.0.0
                 1.0.0.0/ 24 is subnetted,        1 subnets
       C            1.1.1.0        is directly connected, Serial0
       O IA  3.0.0.0/ 8 [110/ 70] via 1.1.1.2, 00: 07: 05, Serial0
                 7.0.0.0/ 24 is subnetted,        1 subnets
       C            7.7.7.0        is directly connected, Ethernet0
       O E2  200.1.1.0/ 24 [110/ 20] via 1.1.1.2, 00: 00: 21, Serial0
       S*      0.0.0.0/ 0 is directly connected, Ethernet0

La única ruta externo en la tabla de ruteo es 200.1.1.0/24. Esta red está en la tabla de ruteo porque la ruta de resumen 3.0.0.0/8 cubre a la dirección de reenvío de esta red externa (3.3.4.1), que es una ruta interzonal.


Información Relacionada


Document ID: 13682