IP : Protocolo mejorado de routing de gateway interior (EIGRP)

¿Qué significan los mensajes "Not On Common Subnet" (No en la subred común) de EIGRP?

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento explica porqué un router del ½ del ¿Â de Cisco IOSï puede experimentar a no en el mensaje de error común de subred cuando configuran al router con el Enhanced Interior Gateway Routing Protocol (EIGRP).

El EIGRP utiliza los paquetes de saludo de multidifusión para comunicar a otros vecinos EIGRP. Si el EIGRP recibe un paquete de saludo que sea originado de un IP Address en una subred que no se configure en el EIGRP que recibe la interfaz, el EIGRP genera este mensaje de error:

timestamp: IP-EIGRP: Neighbor neighbor_IP_address not on common subnet for interface

prerrequisitos

Requisitos

Este documento requiere una comprensión básica de los IP Routing Protocol y del EIGRP Routing Protocol en general. Para aprender más sobre los IP Routing Protocol y el EIGRP, refiera a estos documentos:

Componentes Utilizados

La información en este documento se basa en el Cisco IOS Software Release 12.2(10b) en los Cisco 2500 Series Router.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

Cisco recomienda que usted configura a todo el Routers en un segmento de red con los IP Address principales en la misma subred. Este ejemplo muestra una configuración EIGRP común:

/image/gif/paws/13674/15a1.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

R1
hostname R1
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

R2
hostname R2
!
interface Ethernet0
ip address 10.1.1.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Publique el comando show ip eigrp neighbor para verificar que ambo Routers se ve.

R1#show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

0   10.1.1.2                Et0           12 00:00:16    0  3000  0  23
R2#show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

0   10.1.1.1                Et0           14 00:01:19   12   200  0  11

Troubleshooting

Use esta sección para resolver problemas de configuración.

Ya no son vecinos

Si todo se configura correctamente, usted ve una forma de la relación del vecino EIGRP. Cambie la configuración del r2. Ponga la interfaz del ethernet0 del r2 en una diversa subred.

R2#configure terminal

R2(config)#interface ethernet0

R2(config-if)#ip address 10.1.2.2 255.255.255.0

R2(config-if)#end

Ahora mire la configuración del r2:

hostname R2
!
interface Ethernet0
ip address 10.1.2.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

Ahora usted comienza a recibir los mensajes de error en la recepción de un paquete de saludo EIGRP. En este caso, los mensajes ocurren aproximadamente cada 15 segundos, en el r1 y el r2:

R1

3w0d: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 

01:05:01: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:15: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:30: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:44: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
R2

3w0d: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 

00:48:40: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:48:54: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:49:08: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:49:22: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)

A pesar de los mensajes de error, el EIGRP trabaja correctamente con el resto de los vecinos del r1 o del r2. La salida del comando updated show ip eigrp neighbor muestra que el mensaje de error indica un problema grave entre el r1 y el r2. El Routers es no más vecinos e intercambia no más la información de ruteo.

R1

R1#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
R2

R2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1

Dirección de IP secundaria

Usted puede también ver este problema en las redes que utilizan las driección IP secundarias, si las redes no se configuran correctamente. Agregue una dirección secundaria al R2:

R2

R2#configure terminal

R2(config)#interface ethernet0

R2(config-if)#ip address 10.1.1.2 255.255.255.0 secondary

R2(config-if)#end

La configuración del r2 ahora parece esto:

hostname R2
!
interface Ethernet0
ip address 10.1.2.2 255.255.255.0


ip address 10.1.1.2 255.255.255.0 secondary
!
router eigrp 1
network 10.0.0.0
!
end

Porque el r2 ahora reconoce 10.1.1.0/24 como subred válida para el interface ethernet0, usted ve no más no no encendido el mensaje de error común de subred en el r2. El r2 muestra el r1 como vecino EIGRP, y el r2 recibe y valida los paquetes de saludo del r1.

Router2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type
                                        (sec)         (ms)       Cnt Num
0   10.1.1.1                Et0           12 00:00:35    1  5000  1  0

Sin embargo, el r1 no muestra el r2 como vecino, y el r1 no valida las actualizaciones de ruteo del r2. Esto significa que el r2 reajusta continuamente su adyacencia de vecino con el r1. En R1, sigue viendo el mensaje de error no en subred común y R2 no aparece en la lista de vecinos de EIGRP.

R1#show ip eigrp neighbor

IP-EIGRP neighbors for process

01:20:54: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:08: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:22: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:36: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)

Esto sucede porque EIGRP actualiza siempre utilizando la dirección IP principal de la interfaz saliente como la dirección de origen. Cambie a la dirección primaria en el r1 para hacer juego la subred primaria del r2, que es 10.1.2.1/24 en este ejemplo.

Usted puede configurar algunas redes con dos subredes distintas en el mismo segmento físico. En este caso, los routeres EIGRP en una subred pueden no poder comunicar con los routeres EIGRP en la otra subred. Si usted funciona con el Cisco IOS Software Release 11.3, 12.0, o más adelante, usted puede inhabilitar no no encendido los mensajes de error común de subred con el uso del comando no eigrp log-neighbor-warnings.

Nota: Cisco no recomienda generalmente el uso del comando no eigrp log-neighbor-warnings. El comando inhabilita no no encendido los mensajes de error común de subred en todas las interfaces que el proceso EIGRP utilice. Utilice el comando con la discreción.

Configure el comando no eigrp log-neighbor-warnings en el modo de configuración del router EIGRP.

Router#configure terminal

Router(config)#router eigrp 1

Router(config-router)#no eigrp	log-neighbor-warnings

Causa general para el mensaje de error

El EIGRP utiliza los paquetes de saludo de multidifusión para comunicar a otros vecinos EIGRP. El EIGRP genera no no encendido el mensaje de error común de subred cuando recibe un paquete de saludo EIGRP originado de un IP Address en una subred que no se configure en su interfaz de recepción.

Éstas son la causa general para este mensaje de error:

  • Misconfiguration de las interfaces o los puertos del switch o el problema del cableado.

  • Discordancía de primario/de las driección IP secundarias en la interfaz vecina.

  • Un Switch/un concentrador se está escapando los paquetes de multidifusión a otros puertos.

  • Si usa un switch LAN, el vlans pudo haberse unido a al Routers junto.

  • Otro router utiliza el EIGRP que hace publicidad en la misma subred/vlan como este router y se configura mal con un incorrecto COMO número.

Para resolver problemas este problema, marque estos elementos:

  • Verifique que el cable esté conectado correctamente.

  • Compruebe la configuración de la interfaz con minuciosidad para los IP Addresses mal configurado en el local y los routeres de la vencidad.

  • Verifique que la dirección primaria de la interfaz esté en la misma subred como la dirección primaria del router vecino.

  • Si la conexión del vecino EIGRP se une a vía un concentrador LAN, utilice los ejes de conexión aparte para romper para arriba el dominio de broadcast para cada segmento LAN lógico, o no configure ninguna registro-vecino-advertencia del eigrp de eliminar los errores.

  • Si hay un Switch implicado, marque la configuración del switch para aseegurarse diversos segmentos LAN no se configuran para estar en el mismo VLA N que compartan el mismo dominio de broadcast.


Información Relacionada


Document ID: 13674