IP : Protocolo mejorado de routing de gateway interior (EIGRP)

Configuración de una Ruta Preferida a través de la Influencia en las Métricas EIGRP

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Interactivo: Este documento ofrece un análisis personalizado de su dispositivo Cisco.


Contenido


Introducción

Este documento explica cómo crear una ruta preferida influenciando la métrica de Enhanced Interior Gateway Routing Protocol (EIGRP). Dada la topología mostrada en el diagrama de la red, este documento describe las diferentes maneras de influenciar el tráfico IP de los clientes a los servidores para dar preferencia al trayecto R1>R2>R3. El objetivo es convertir el trayecto R1>R2>R4 en un trayecto de respaldo que solamente se utilice en caso de falla del R3.

prerrequisitos

Requisitos

Este documento requiere una comprensión básica del IP Routing y el EIGRP Routing. Para aprender más acerca del IP Routing y EIGRP, consulte estos documentos:

Componentes Utilizados

La información que contiene este documento se basa en estas versiones de software y hardware.

  • El EIGRP se soporta en el Software Release 9.21 y Posterior de Cisco IOS�. La información en este documento se basa en el Cisco IOS Software Release 12.3(3).

  • El EIGRP se puede configurar en todo el Routers (tal como las Cisco 2500 Series y las Cisco 2600 Series) y en todos los switches de la capa 3.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

Hay varios métodos para fijar una ruta preferida influenciando la Métrica EIGRP. Este documento describe estos métodos y sus ventajas y desventajas. Este documento también analiza el efecto provocado al modificar el ancho de banda aunque hacerlo no es un medio viable para alterar el trayecto en este ejemplo.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/13673-14-a.gif

Haga clic en el diagrama de la red para visualizarlo en una ventana de buscador diferente para el uso como referencia más adelante en este documento.

Dos de los comandos usados en este documento para verificar del comportamiento EIGRP son la topología EIGRP del IP de la demostración y los comandos show ip eigrp topology network-ip subnet-mask.

Nota: Para más información sobre los comandos usados en este documento, refiera a la herramienta de búsqueda de comandos (clientes registrados solamente).

Si usted tiene la salida de un comando show ip eigrp topology o de un comando show ip eigrp topology network-ip subnet-mask de su dispositivo de Cisco, usted puede utilizar el Output Interpreter (clientes registrados solamente) para visualizar los problemas potenciales y los arreglos. Para utilizar el Output Interpreter (clientes registrados solamente), usted debe ser abierto una sesión y tener Javascript habilitado en su buscador Web.

Antecedente – Técnicas básicas de mediciones EIGRP

Las Actualizaciones de EIGRP contienen cinco métricas: ancho de banda mínima, retardo, carga, confiabilidad, y Unidad máxima de transmisión (MTU) (MTU). De estas cinco métricas, por abandono, solamente el ancho de banda mínima y el retardo se utilizan para computar el mejor trayecto. A diferencia de la mayoría de la métrica, el ancho de banda mínima se fija al ancho de banda mínima de la trayectoria entera, y no refleja cuántos saltos o links de ancho de banda bajas están en la trayectoria. El retardo es un valor acumulativo que aumenta en el valor de retraso de cada segmento en la trayectoria. Para más información sobre la Métrica EIGRP refiera al White Paper del protocolo enhanced interior gateway routing.

Configuraciones posibles

Estas configuraciones pueden ser utilizadas para establecer una ruta preferida.

Configuración de la distribución de carga predeterminada

R1

R1# show run

Current configuration: 640 bytes
!
version 12.3
!
hostname R1
!
interface Serial0
 no ip address
 encapsulation frame-relay

!--- Enables Frame Relay encapsulation.

!
interface Serial0.201 point-to-point

!--- Enables a point-to-point link on the sub-interface.

 ip address 10.1.1.1 255.255.255.0
 frame-relay interface-dlci 201

!--- Assigns a data-link connection identifier (DLCI)
!--- to a Frame Relay sub-interface.

!
router eigrp 1
 network 10.0.0.0
!
end

Nota: El switch Frame Relay está oculto en el diagrama de la red.

R1# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.3.0 [90/2221056] via 10.1.1.2, 00:07:08, Serial0.201
D       10.1.2.0 [90/2195456] via 10.1.1.2, 00:07:08, Serial0.201
C       10.1.1.0 is directly connected, Serial0.201

R1# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
  Routing Descriptor Blocks:
  10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
      Composite metric is (2221056/307200), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 22000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 2

R2

R2# show run

Current configuration: 618 bytes
!
version 12.3
!
hostname R2
!
interface Ethernet0
 ip address 10.1.2.2 255.255.255.0
 no ip directed-broadcast
!
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.101 point-to-point
 ip address 10.1.1.2 255.255.255.0
 frame-relay interface-dlci 101
!
router eigrp 1
 network 10.0.0.0
!
end

R2# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.3.0 [90/307200] via 10.1.2.4, 00:03:47, Ethernet0
                 [90/307200] via 10.1.2.3, 00:03:48, Ethernet0
C       10.1.2.0 is directly connected, Ethernet0
C       10.1.1.0 is directly connected, Serial0.101

Nota: El r2 tiene dos links de costo equivalentes a 10.1.3.0/24 con R3 (10.1.2.3) y R4 (10.1.2.4).

R2# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 2 Successor(s), FD is 307200
  Routing Descriptor Blocks:
  10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
  10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

Nota: Ambas trayectorias tienen la misma medición compuesta (distancia/distancia informada). La Distancia factible (FD) hacia R1 es anunciada y luego, se transforma en la Distancia informada para R1.

R3

R3# show run

Current configuration: 556 bytes
!
version 12.3
!
hostname R3
!
interface Ethernet0/0
 ip address 10.1.2.3 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 10.1.3.3 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 10.0.0.0
!
end

R3# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.1.3.0 is directly connected, Ethernet0/1
C       10.1.2.0 is directly connected, Ethernet0/0
D       10.1.1.0 [90/20537600] via 10.1.2.2, 00:16:14, Ethernet0/0

R3# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Routing Descriptor Blocks:
  0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
      Composite metric is (281600/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
  10.1.2.4 (Ethernet0/0), from 10.1.2.4, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

R3# show interface ethernet0/1

Ethernet0/1 is up, line protocol is up
  Hardware is AmdP2, address is 0050.7329.52e1 (bia 0050.7329.52e1)
  Internet address is 10.1.3.3/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:02, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     291 packets input, 28402 bytes, 0 no buffer
     Received 283 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     500 packets output, 50876 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

R4

R4# show run

Current configuration: 549 bytes
!
version 12.3
!
hostname R4
!
interface Ethernet0/0
 ip address 10.1.2.4 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 10.1.3.4 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 10.0.0.0
!
end

R4# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.1.3.0 is directly connected, Ethernet0/1
C       10.1.2.0 is directly connected, Ethernet0/0
D       10.1.1.0 [90/20537600] via 10.1.2.2, 00:17:08, Ethernet0/0

R4# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Routing Descriptor Blocks:
  0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
      Composite metric is (281600/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
  10.1.2.3 (Ethernet0/0), from 10.1.2.3, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

Cambie el parámetro de retraso de interfaz en el R4

Porque los cambios a la métrica con retraso se propagan a todos los routeres en sentido descendente, el cambio del parámetro de retraso de interfaz es el método preferido de influenciar la selección de trayecto para estos dos escenarios:

  • El segmento Ethernet 10.1.3.0/24 contiene sólo los servidores y no existen otras subredes debajo de la subred 10.1.3.0/24. (Esta configuración es ideal para el bloque de servidores).

  • Desea influir en la selección del trayecto para todas las rutas reconocidas a través de los vecinos EIGRP en el segmento 10.1.3.0/24.

  1. Marque el retardo en la interfaz antes de que usted realice cualquier cambio.

    Es actualmente ti fijado lo mismo que el R3, como se muestra aquí.

    R4# show interface ethernet0/1
    
    Ethernet0/1 is up, line protocol is up
      Hardware is AmdP2, address is 0050.7329.5321 (bia 0050.7329.5321)
      Internet address is 10.1.3.4/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:02, output 00:00:02, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         284 packets input, 27914 bytes, 0 no buffer
         Received 276 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 input packets with dribble condition detected
         482 packets output, 49151 bytes, 0 underruns
         0 output errors, 0 collisions, 2 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  2. Cambie el valor de retraso en el segmento 10.1.3.0/24.

    Usted debe tener cuidado cuando usted selecciona el nuevo retardo. No sería bueno que aumente el retraso de tal manera que R2 considere que la ruta ya no es una sucesora factible.

    R4# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R4(config)# interface ethernet0/1
    
    R4(config-if)# delay 120
    
    !--- Delay is entered in tens of microseconds.
    
    R4(config-if)# end
    
    R4#
  3. Confirme que el retardo ha cambiado a 1200 microsegundos para esta interfaz.

    R4# show interface ethernet0/1
    
      Hardware is AmdP2, address is 0050.7329.5321 (bia 0050.7329.5321)
      Internet address is 10.1.3.4/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1200 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:03, output 00:00:00, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         345 packets input, 33508 bytes, 0 no buffer
         Received 333 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 input packets with dribble condition detected
         575 packets output, 57863 bytes, 0 underruns
         0 output errors, 0 collisions, 2 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  4. Confirme que el r2 tiene solamente el "mejor" ruta a 10.1.3.0 vía el R3.

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:02:43, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101
    
    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (312320/286720), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2200 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

    El comando show ip eigrp topology muestra que la métrica de retraso que anuncia R4 ha aumentado en 200 (a 2200 microsegundos), tal como se esperaba. Este incremento hace que las dos rutas posean distintos costos y evita que se equilibre la carga de R2.

    Nota: Porque la distancia de divulgación por R4 (286720) es menos que la distancia de divulgación por el r2 (la distancia factible, 307200), la trayectoria se considera sin loop. Porque la trayectoria de divulgación por el R4 se considera sin loop, es un sucesor factible y está instalado inmediatamente si el R3 para el hacer publicidad de una ruta a 10.1.3.0/24.

    R1# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/2221056] via 10.1.1.2, 00:25:27, Serial0.201
    D       10.1.2.0 [90/2195456] via 10.1.1.2, 00:25:27, Serial0.201
    C       10.1.1.0 is directly connected, Serial0.201
    
    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/307200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

Utilice una lista de desplazamiento en R4 para modificar la métrica compuesta en R2

La medición compuesta en el r2 se puede modificar usando un offset-list en el router R4. Un valor del offset-list de 20 en el R4 aumenta la medición compuesta para la trayectoria R2-R4 en 20 en el r2. Por lo tanto, el trayecto R2-R4 se convierte en un trayecto de respaldo para R2-R3. Un offset-list es el método preferido si:

  • Usted quiere solamente influenciar un trayecto determinado que es hecho publicidad.

  • El Routers adicional está conectado con la subred 10.1.3.0/24 y usted no quiere influenciar las trayectorias originadas por el Routers.

  1. Configure un offset-list en el R4 que aumenta (por 20) el retardo para cualquier ruta que comienza con 10.1.3.x.

    R4# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R4(config)# access-list 99 permit 10.1.3.0 0.0.0.255
    
    R4(config)# router eigrp 1
    
    R4(config-router)# offset-list 99 out 20 e0/0
    
    R4(config-router)# end
    
    R4#
  2. En esta salida puede ver que la lista de desplazamiento no modifica la tabla de topología EIGRP en R4.

    Los cambios métricos solamente cuando se hace publicidad la ruta.

    R4# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
      Routing Descriptor Blocks:
      0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
          Composite metric is (281600/0), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 1000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 0
      10.1.2.3 (Ethernet0/0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
  3. En el r2, confirme que la ruta con R3 (10.1.2.3) es de nuevo el único mejor trayecto.

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:00:20, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101

    La tabla de topología EIGRP refleja el incremento en retardo desde R4 (10.1.2.4.).

    Distancia factible R4 (281600) + offset-list R4 (20) = distancia informada R4 (281620).

    Nota: Un defecto estético en el Cisco IOS Software Release 12.0(7) evita que el retraso mayor sea reflejado exactamente en la sección de retraso total de la salida mostrada aquí.

    DDTS (Servicio telefónico digital directo) Descripción
    CSCdp36097 (clientes registrados solamente) EIGRP: la lista de desplazamiento agrega un valor de retraso incorrecto

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (307220/281620), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

Cambie la distancia administrativa en el r2

Es también posible alterar el proceso de selección de trayecto cambiando la distancia administrativa, en el r2, de la ruta aprendida del R4. Este método es menos ideal que los otros. Puede aumentar el potencial para que rutea los loopes por las razones enumeradas aquí:

  • La distancia administrativa se utiliza generalmente para determinar el método por el cual una ruta era docta. Si está fijado incorrectamente, el router individual no puede elegir una ruta redistribuido en vez del mejor trayecto real.

  • La distancia administrativa no se propaga al otro Routers. Los protocolos de ruteo se basan en el hecho de que todos los routers eligen el mismo trayecto para un mismo conjunto de parámetros. La alteración de los parámetros en un único router puede llevar a rutear los loopes.

  1. Cambie la configuración R2' para cuando una actualización de ruteo de R4 (10.1.2.4) para la subred 10.1.3.0/24 se oye, aumentar la distancia administrativa a 91.

    Se elige 91 porque es superior en 1 a la distancia administrativa predeterminada de EIGRP para los intervalos (que es 90). La distancia administrativa predeterminada para los externos del EIGRP (rutas redistribuidas en el EIGRP) es 170. ¿Refiera a la Tabla del valor de distancia predeterminada en cuál es distancia administrativa? documento para los valores predeterminados de todos los Routing Protocol.

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# access-list 99 permit 10.1.3.0 0.0.0.255
    
    R2(config)# router eigrp 1
    
    R2(config-router)# distance 91 10.1.2.4 0.0.0.0 99
    
    R2(config-router)# end
    
    R2#
  2. En este momento, usted puede necesitar publicar el comando clear ip route para que los cambios tomen el efecto.

    Nota: Ahora existe sólo una ruta hacia 10.1.3.0/24 a través del R3 (10.1.2.3).

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:05:28, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101

    Nota: Nada en la tabla de topología EIGRP ha cambiado.

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

Problemas posibles

Para ilustrar un problema que este método puede causar si no se usa con cuidado, imagine que R1 y R2 ejecutan Abrir la ruta más corta primero (OSPF) con una distancia administrativa de 110 para la red 11.0.0.0/8. Imagínese también que el R4 tiene una Static ruta para 11.1.1.0/24 esas puntas en el r2 (10.1.2.2). R4 redistribuye las rutas estáticas en EIGRP de modo que algunos nuevos routers en 10.1.3.0/24 puedan llegar a 11.1.1.0/24.

Normalmente, el r2 recibe el EIGRP External Route para 11.1.1.0/24 del R4 con una distancia administrativa de 170. Porque esta distancia es mayor que la de la OSPF ruta (110), no está instalada.

Esta salida es un ejemplo del comando distance usado sobre cuando se configura incorrectamente.

R2# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)# access-list 99 permit 11.1.1.0 0.0.0.255

R2(config)# router eigrp 1

R2(config-router)# distance 91 10.1.2.4 0.0.0.0 99

R2(config-router)# end

R2#

Esta configuración crea un Routing Loop entre el r2 y el R4 para la subred 11.1.1.0/24. El r2 ahora prefiere la ruta 11.1.1.0/24 de divulgación por el R4. Esto se debe a que la distancia administrativa (91) es menor que la distancia administrativa de la ruta OSPF (110).

Cambie el ancho de banda en el r2

Usando el ancho de banda para influenciar los trayectos EIGRP no es recomendado por dos razones:

  • El cambio del ancho de banda puede tener impacto más allá de afectar a la Métrica EIGRP. Por ejemplo, el Calidad de Servicio (QoS) también mira el ancho de banda en una interfaz.

  • El EIGRP estrangula para utilizar el 50 por ciento del configuré el ancho de banda. La baja del ancho de banda puede causar los problemas como los vecinos EIGRP staving de conseguir los paquetes de saludo debido a la parte posterior que estrangula.

El cambio del retardo no afecta otros protocolos ni él hace el EIGRP estrangular detrás.

  1. Marque la tabla de topología EIGRP para el r1 antes de que usted realice cualquier cambio.

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/307200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2
  2. Marque los valores de inicio para la interfaz del ethernet0 en el r2.

    R2# show interface ethernet0
    
    Ethernet0 is up, line protocol is up
      Hardware is Lance, address is 0010.7b3c.6786 (bia 0010.7b3c.6786)
      Internet address is 10.1.2.2/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:01, output 00:00:02, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         1938 packets input, 165094 bytes, 0 no buffer
         Received 1919 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 input packets with dribble condition detected
         1482 packets output, 124222 bytes, 0 underruns
         0 output errors, 0 collisions, 18 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  3. Disminuya el ancho de banda para ver el impacto en el r1.

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# interface ethernet0
    
    R2(config-if)# bandwidth 5000
    
    R2(config-if)# end
    
    R2#
  4. Confirme el cambio.

    R2# show interface ethernet0
    
    Ethernet0 is up, line protocol is up
      Hardware is Lance, address is 0010.7b3c.6786 (bia 0010.7b3c.6786)
      Internet address is 10.1.2.2/24
      MTU 1500 bytes, BW 5000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:02, output 00:00:01, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         1995 packets input, 169919 bytes, 0 no buffer
         Received 1969 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 input packets with dribble condition detected
         1525 packets output, 127831 bytes, 0 underruns
         0 output errors, 0 collisions, 18 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  5. Confirme que también cambió en la tabla de topología EIGRP.

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 2 Successor(s), FD is 563200
      Routing Descriptor Blocks:
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (563200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 5000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (563200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 5000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
  6. Marque el impacto en la tabla de topología EIGRP para el r1.

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/563200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

    No hay cambio, pues la conexión de Frame Relay entre el r1 y el r2 sigue siendo el link más de poca velocidad. Sólo verá el cambio si reduce el ancho de banda en la interfaz 0 de Ethernet para R2 a un valor menor que 1544.

  7. Disminuya el ancho de banda en la interfaz del ethernet0 para el r2 a 1000.

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# interface ethernet 0
    
    R2(config-if)# bandwidth 1000
    
    R2(config-if)# end
    
    R2#
  8. Marque el impacto en la tabla de topología EIGRP para el r1.

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): Topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 312320
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (3123200/2611200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1000 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada

Tecleo a abrirse en una nueva ventana.


Document ID: 13673