Ethernet de largo alcance (LRE) y Línea de suscriptor digital (xDSL) : Línea de suscriptor digital asimétrica (ADSL)

Configurando y resolviendo problemas a un Cisco 1700 Router que usa un WIC de Ethernet como cliente PPPoE con NAT

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (12 Noviembre 2015) | Comentarios


Contenido


Introducción

Este documento muestra cómo configurar un Cisco 1700 usando la Tarjeta de Interfaz WAN Ethernet (WIC-1ENET) para que actúe como cliente de Point-to-Point Protocol over Ethernet (PPPoE) con Traducción de Dirección de Red (NAT).

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 12.1(3) soportar XT1 de Cisco IOS� o más adelante el Cisco 1700 WIC-1ENET.

  • Para esta configuración de muestra, el Universal Access Concentrator-Node Route Processor del Cisco 6400 (UAC-NRP) funcionaba con el Cisco IOS Software Release 12.1(3)DC1.

Para soportar el PPPoE, usted debe tener el conjunto de características ADSL+PLUS. El conjunto de funciones sólo ADSL no es compatible con PPPoE en el Cisco 1700.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Teoría Precedente

El WIC-1ENET es un indicador luminoso LED amarillo de la placa muestra gravedad menor 10BaseT desarrollado para los Cisco 1700 Series Router. El WIC-1ENET proporciona una segunda interfaz de Ethernet para el Cisco 1700, que ayuda a utilizar la funcionalidad mejorada del Cisco IOS Software con cualquier Digital Subscriber Line (DSL) o módem de cable.

La función de cliente de PPPoE permite que la funcionalidad de PPPoE sea movida al router. Los PC múltiples se pueden instalar detrás de la interfaz Fast Ethernet del Cisco 1700 y, antes de que su tráfico se envíe a la sesión PPPoE, puede ser cifrado, filtrado, y así sucesivamente, y el NAT puede ejecutarse. El PPPoE que se ejecuta en el router quita la necesidad de usar el software del Cliente de PPPoE en los PC.

Requisitos del procesador

El Revision B5 del microprocesador MPC860 se requiere. Este procesador se utiliza en todos los Cisco 1700 Series Router envió después de noviembre 21, 1999. Los números de serie del Cisco 1700 que comenzaban con el se han fabricado con el microprocesador del Revision B5 del modelo MPC860.

El código de fecha se incorpora al número de serie. El formato es el LLLYYWWSSSS, donde:

  • El LLL es la ubicación en la cual la unidad fue construida.

  • El YY es el año que la unidad fue construida (1997=01, 1998=02, 1999=03, 2000=04).

  • El WW es la semana del trabajo del año que la unidad fue construida.

  • El SSSS es el número de serie.

La información de la versión del procesador se visualiza en el bootup. Usted puede también verificar la revisión del procesador publicando el comando show version en el prompt del Router-.

Requisitos de Memoria

Para funcionar con las imágenes del IOS del Cisco 1700 que soportan Cisco WIC-1ENET, el router debe tener una cantidad mínima de memoria flash y de DRAM. Para los detalles en los requisitos de memoria para cada imagen, refiera a los Release Note para los Cisco 1700 Series Router para el Cisco IOS Release 12.1(3)XT1.

Restricciones de WIC-1ENET y funciones no soportadas

  • El WIC-1ENET no se soporta en las Plataformas con excepción del Cisco 1700.

  • Solamente se soporta una conexión del par trenzado RJ-45; no hay interfaz de unidad de acoplamiento (AUI) o soporte de la interfaz BNC.

  • No hay negociación automática (detección automática) entre semidúplex y los modos dúplex completo.

  • El WIC-1ENET no se puede utilizar para la descarga de archivos TFTP mientras que el host está en el ROMMON.

  • El WIC-1ENET no es reconocido por el Cisco 1700 cuando está en el modo ROMMON.

  • El Cisco IOS Software actual soporta el WIC-1ENET solamente en el slot0 de un Cisco 1700.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Configuran al Cliente de PPPoE en el Cisco 1700 con los comandos del Virtual Private Dialup Network (VPDN). (Los comandos vpdn no son necesarios para el Cisco IOS Software Release 12.2(13)T o Posterior.) Aseegurese que usted configura estos comandos primero.

Nota: Para la información sobre el cambio del tamaño de la Unidad máxima de transmisión (MTU) (MTU), refiera a la talla del MTU del troubleshooting en la conectividad de marcación PPPoE.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/12956/wic_1enet.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Cisco 1700
! 
vpdn enable 
no vpdn logging
! 
vpdn-group pppoe 
�request-dialin�� 

!--- The PPPoE client requests to establish�� 
!--- a session with the aggregation unit (6400 NRP).
!--- These VPDN commands are not needed with 
!--- Cisco IOS Software Release 12.2(13)T or later.

��protocol pppoe 
! 
int Dialer1
 ip address negotiated
 encapsulation ppp
 ip mtu 1492

!--- The Ethernet MTU is 1500 by default 
!--- (1492 + PPPoE headers = 1500).

 ip nat outside
 dialer pool 1

!--- This ties to interface Ethernet0.

 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname <username>
ppp chap password <password>
!

!--- The ISP instructs you regarding 
!--- the type of authentication to use.
!--- To change from PPP Challenge Handshake Authentication 
!--- Protocol(CHAP) to PPP Password Authentication Protocol (PAP),
!--- replace these three lines:
!--- ppp authentication chap callin
!--- ppp chap hostname 
!--- ppp chap password 
!--- with these two lines:
!--- ppp authentication pap callin.

ppp pap sent-username <username> password <password>�

!
dialer-list 1 protocol ip permit
!

!--- This is the internal Ethernet network.

interface FastEthernet0
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
!
interface Ethernet0
 pppoe enable
 pppoe-client dial-pool-number 1

!--- The PPPoE client code ties into a dialer 
!--- interface upon which a virtual-access 
!--- interface is cloned.

!

!--- For NAT, you overload on the 
!--- Dialer1 interface and add a default route
!--- out of the Dialer1 interface because
!--- the IP address can change.


ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
dialer-list 1 protocol ip permit
access-list 1 permit 10.0.0.0 0.0.0.255

!--- This is for NAT.

!

Cisco 6400
*** local ppp user 

!--- Or, you can use AAA.

username <username> password <password>

!--- Begin with the VPDN commands. 
!--- Notice that you are binding the PPPoE here to 
!--- a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE� 
!--- beginning with the VPDN commands.

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
�accept-dialin 

!--- This is PPPoE server mode.

�protocol pppoe 
�virtual-template 1 
! 
! 
interface ATM0/0/0 
�no ip address 
�no atm ilmi-keepalive 
�hold-queue 500 in 

!--- The binding to the virtual-template 
!--- interface is configured in the VPDN group.

! 
interface ATM0/0/0.182 point-to-point 
�pvc 1/82 
��encapsulation aal5snap

!--- You need the command on the server side. 

� protocol pppoe 
�! 
! 

!--- Virtual-template is used instead of dialer interface. 

! 
interface Virtual-Template1 
�ip unnumbered Loopback10 
�ip mtu 1492 
�peer default ip address pool ippool 
�ppp authentication chap 
! 
! 
interface Loopback10 
�ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Depuración del cliente PPPoE

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Para hacer el debug del Cisco 1700 (Cliente de PPPoE), usted debe considerar la pila del protocolo.

  • Capa 4 - Capa PPP

  • Capa 3 - Capa Ethernet

  • Capa 2 - Capa ATM

  • Layer 1 - Capa física DSL

Usted podría resolver problemas el principio en la parte inferior. Puesto que el DSL y las capas ATM están ocurriendo en el DSL Customer Premises Equipment (CPE), usted necesita resolver problemas solamente los Ethernetes y las capas PPP para el Cisco 1700, como se muestra abajo.

Capa Ethernet

Las tramas Ethernet completas están en los paquetes (RÁPIDOS) del Subnetwork Access Protocol del capa 5 de adaptación del ATM (AAL5). No hay comando debug ethernet packet, pero usted debe realizar algunos debugs VPDN (debugs PPPoE para el Cisco IOS Software Release 12.2(13)T o Posterior) para ver las tramas PPPoE.

Para la referencia, una trama Ethernet que es una trama PPPoE contiene uno de dos Ethertypes:

  • 0x8863 Ethertype = paquete de control PPPoE (administra la sesión PPPoE)

  • 0x8864 Ethertype = Paquete de datos PPPoE (contiene paquetes PPP)

Una NOTA IMPORTANTE es que hay dos sesiones en el PPPoE: la sesión PPPoE que es un protocolo layer two tunneling VPDN (sesión L2TP)-type, y la sesión PPP. Así pues, establecer el PPPoE, hay fase de establecimiento de sesión PPPoE y una fase de establecimiento de la sesión PPP.

La terminación involucra una fase de terminación PPP y una fase de terminación PPPoE.

La fase de establecimiento de PPPoE consiste en el identificar de las direcciones MAC del Cliente de PPPoE y del servidor y el asignar de un ID de sesión. Eso es después completo, el establecimiento normal PPP ocurre apenas como cualquier otra conexión PPP.

Para hacer el debug de, usted puede utilizar los debugs del pppoe VPDN (debugs del pppoe para el Cisco IOS Software Release 12.2(13)T o Posterior) para determinar si la fase de conexión del pppoe es acertada.

# debug vpdn pppoe-events (debug pppoe events)

06:17:58: Sending PADI: vc=1/1

!--- A broadcast Ethernet frame (in this case, encapsulated in ATM) 
!--- requests a PPPoE server, "Are there any PPPoE servers out there?" 


06:18:00:  PPPOE: we've got our pado and the pado timer went off 

!--- This is a unicast reply from a PPPoE server (very similar to 
!--- a DHCP offer).


06:18:00: OUT PADR from PPPoE tunnel

!--- This is a unicast reply accepting the offer.


06:18:00: IN PADS from PPPoE tunnel

!--- This is a confirmation that completes the establishment.

El establecimiento PPP ahora comienza, como en cualquier otra iniciación de PPP. Después de que establezcan a la sesión PPPoE, usted puede publicar los comandos show vpdn de conseguir el estatus.

# show vpdn (show pppoe session)
%No active L2TP tunnels 
%No active L2F tunnels 

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC 
1       0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0    1    1

Usted puede conseguir la información de cuenta de paquetes usando el comando show vpdn session all (show pppoe session all).

show vpdn session all (show pppoe session all)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1

session id: 1
local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
    1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

Otros comandos de depuración:

  • debug vpdn pppoe-data (debug pppoe data)

  • debug pppoe-errors (errores PPPoE del debug)

  • debug pppoe-packets (paquetes pppoe del debug)

Capa PPP

Después de que hayan establecido a la sesión PPPoE, los debugs PPP son lo mismo que para cualquier otro establecimiento PPP.

Se utilizan los mismos comandos debug ppp negotiation y debug ppp authentication Aquí está la salida de muestra:

Nota: En esta muestra, el nombre del host es el "client1", y el nombre del Cisco 6400 remoto es “Nrp-b”.

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:��� MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:��� MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:� ��AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:��� MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:��� AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:��� MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:��� Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:��� Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:��� Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:��� Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:� ��Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:��� Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed 
 state to up

Depuración del servidor PPPoE

Para hacer el debug del Cisco 6400 (el servidor PPPoE), usted puede utilizar el mismo procedimiento ascendente usado para el Cisco 1700 (el Cliente de PPPoE).

  • Capa 4 - Capa PPP

  • Capa 3 - Capa Ethernet

  • Capa 2 - Capa ATM

  • Layer 1 - Capa física DSL

La diferencia es que ahora usted resuelve problemas la capa DSL en el multiplicador del Digital Subscriber Line Access (DSLAM) y la capa ATM en el Cisco 6400, como se muestra abajo.

Capa física DSL

Para verificar la capa física de la DSL, debe ver las estadísticas del DSL en el DSLAM. Para Cisco DSLAM, el comando show dsl interface puede ser utilizado.

Capa ATM

En el lado del Cisco 6400, usted puede también utilizar el comando debug atm packet y habilitar el Cisco 6400 para un PVC específico.

debug atm packet interface atm 0/0/0.182 vc 1/82 

Usted debe ver la salida similar al siguiente, con los mismos campos del tipo, de SAP, CTL, y OUI mostrando que el paquete ATM entrante es AAL5SNAP.

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

Nota: Usted no ve los paquetes de salida con este comando debido a la manera que los paquetes se procesan.

Capa Ethernet

Los mismos comandos show and debug VPDN usados en el Cisco 1700 pueden ser utilizados en el Cisco 6400 para mirar al establecimiento de PPPoE.

# debug vpdn pppoe-events (debug pppoe events)

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel


# show vpdn (show pppoe session)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1   82


nrp-b# 
show vpdn session all (show pppoe session all)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

Éstos son otros comandos de debug:

  • debug vpdn pppoe-data (debug pppoe data)

  • debug pppoe-errors (pppoe data del debug)

  • debug pppoe-packets (paquetes pppoe del debug)

Capa PPP

Ésta es una salida de los debugs PPP del Cisco 6400 que corresponde al debug anterior del Cisco 1700:

debug ppp negotiation and debug ppp authentication

4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:��� MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:� ��MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP: ���Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:��� Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:��� Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed 
 state to up

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12956