Ethernet de largo alcance (LRE) y Línea de suscriptor digital (xDSL) : Línea de suscriptor digital asimétrica (ADSL)

Configuración de la Traducción de dirección de red y la Traducción de direcciones de puerto estáticas para la admisión de un servidor Web interno.

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El Network Address Translation (NAT) del ½ del ¿Â de Cisco IOSï se diseña para la simplificación y conservación de IP Address. Permite que se conecten a Internet internetworks IP privadas que utilizan direcciones IP no registradas. NAT funciona en un router Cisco que conecta dos redes, y traduce las direcciones privadas (locales internas) de la red interna en direcciones públicas (locales externas) antes de que los paquetes se remitan a otra red. Como parte de esta funcionalidad, puede configurar NAT de modo que anuncie únicamente una dirección para toda la red al mundo exterior. Esto oculta al mundo la red interna con eficacia. Por lo tanto, proporciona una seguridad complementaria.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

Una de las funciones principales del NAT es la traducción de la dirección de puerto estática (PALMADITA), que también se refiere como “sobrecarga” en una configuración del Cisco IOS. El PAT estático se diseña para permitir el mapeo uno a uno entre las direcciones local y global. Un de uso común para el PAT estático es permitir que los usuarios de Internet de la red pública accedan a un servidor Web situado en la red privada.

Para conseguir más información sobre el NAT, refiera a las páginas de soporte técnico NAT.

Esta tabla muestra los tres bloques del espacio de IP Address disponibles para las redes privadas. Consulte el RFC 1918leavingcisco.com para más detalles sobre estas redes especiales.

Espacio de IP Address Clase
10.0.0.0 - 10.255.255.255 (prefijo 10/8) Clase A
172.16.0.0 - 172.31.255.255 (prefijo 172.16/12) Clase B
192.168.0.0 - 192.168.255.255 (prefijo 192.168/16) C de la clase

Nota: El primer bloque no es nada pero un solo network number de la clase A, mientras que el segundo bloque es un conjunto de 16 números de redes clase B contiguas, y el tercer bloque es un conjunto de los números de redes clase C contiguas 256.

En este ejemplo, el Proveedor de servicios de Internet (ISP) asigna a suscriptor DSL solamente una sola dirección IP, 171.68.1.1/24. El IP Address asignado es un IP Address único registrado y se llama una dirección global interna. Este IP Address registrado es utilizado por la red privada entera para hojear Internet y también por los usuarios de Internet que vienen de la red pública alcanzar al servidor Web en la red privada.

El LAN privado, 192.168.0.0/24, está conectado con la interfaz de Ethernet del router NAT. Este LAN privado contiene varios PC y a un servidor Web. Configuran al router NAT para traducir los IP Address no registrados (direcciones locales internas) que vienen de estos PC a un solo IP Address público (interior global - 171.68.1.1) hojear el Internet.

La dirección IP 192.168.0.5 (servidor Web) es un direccionamiento en el espacio de dirección privada que no se puede rutear a Internet. El único IP Address visible para que los usuarios de Internet públicos alcancen al servidor Web es 171.68.1.1. Por lo tanto, configuran al router NAT para realizar un mapeo uno a uno entre el puerto 80 de la dirección IP 171.68.1.1 (el puerto 80 se utiliza para hojear Internet) y el puerto 80 de 192.168.0.5. Esta asignación permite que los usuarios de Internet en el lado público tengan acceso al servidor de Web interno.

Esta topología de red y configuración de muestra se pueden utilizar para el Cisco 827, 1417, el SOHO77, y 1700/2600/3600 ADSL WIC. Como un ejemplo, el Cisco 827 se utiliza en este documento.

Configurar

En esta sección, le presentan con la información que usted puede utilizar para configurar las características descritas en este documento.

Nota: Para encontrar la información adicional en los comandos usados en este documento, refiera a

Diagrama de la red

Este documento utiliza esta configuración de red:

/image/gif/paws/12905/827spat.gif

Configuración

Cisco 827
Current Configuration:
! 
version 12.1
service timestamps debug uptime
service timestamps log uptime
!
hostname 827
!
ip subnet-zero
no ip domain-lookup
!
bridge irb
!
interface Ethernet0
ip address 192.168.0.254 255.255.255.0
ip nat inside

!--- This is the inside local IP address and it is a private IP address. 

!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/35
encapsulation aal5snap
!
bundle-enable
dsl operating-mode auto 
bridge-group 1
!
interface BVI1
ip address 171.68.1.1 255.255.255.240
ip nat outside

!--- This is the inside global IP address.
!--- This is your public IP address and it is provided to you by your ISP.

!
ip nat inside source list 1 interface BVI1 overload

!--- This statement makes the router perform PAT for all the 
!--- End Stations behind the Ethernet interface that  uses 
!--- private IP addresses defined in access list #1.

ip nat inside source static tcp 192.168.0.5 80 171.68.1.1 80 extendable 

!--- This statement performs the static address translation for the Web server. 
!--- With this statement, users  that try to reach 171.68.1.1 port 80 (www)  are 
!--- automatically redirected to 192.168.0.5 port 80 (www). In this case 
!--- it is the Web server.

ip classless
ip route 0.0.0.0 0.0.0.0 171.68.1.254

!--- IP address 171.68.1.254 is the next hop IP address, also
!--- called the default gateway.
!--- Your ISP can tell you what IP address to configure as the next hop address.

!
access-list 1 permit 192.168.0.0 0.0.0.255

!--- This access list defines the private network 
!--- that  is network address translated. 

bridge 1 protocol ieee 
bridge 1 route ip 
!
end

Verificación

De la salida del comando show ip nat translation, el Inside Local es el IP Address configurado asignado al servidor Web en la red interna. Note que 192.168.0.5 es un direccionamiento en el espacio de dirección privada que no se puede rutear a Internet. El interior global es la dirección IP del host interior, que es el servidor Web, pues aparece a la red externa. Este direccionamiento es el que está conocido a la gente que intenta acceder al servidor Web de Internet.

El local del exterior es la dirección IP del host exterior pues aparece a la red interna. No es necesariamente una dirección legítima. Pero, se afecta un aparato de un espacio de la dirección que se pueda rutear en el interior.

La dirección global externa es la dirección IP asignada a un host en la red externa por el propietario del host. El direccionamiento se afecta un aparato de un direccionamiento o de un espacio de red que puedan global ser ruteados.

Note que el direccionamiento 171.68.1.1 con el número del puerto 80 (HTTP) traduce a 192.168.0.5 el puerto 80, y vice versa. Por lo tanto, los usuarios de Internet pueden hojear al servidor Web aunque el servidor Web está en una red privada con un IP Address privado.

Para conseguir más información sobre cómo resolver problemas el NAT, refiera al Funcionamiento de NAT que verifica y al Troubleshooting de NAT básico.

827#
827#show ip nat translation
Pro Inside global      Inside local      Outside local       Outside global
tcp 171.68.1.1:80      192.168.0.5:80    ---                 ---
tcp 171.68.1.1:80      192.168.0.5:80    198.133.219.1:11000 198.133.219.1:11000
827#

Troubleshooting

Para resolver problemas la traducción de la dirección, usted puede publicar el término lunes y los comandos debug ip nat detailed en el router de ver si el direccionamiento traduce correctamente. El IP Address visible para que los usuarios externos alcancen al servidor Web es 171.68.1.1. Por ejemplo, reorientan a los usuarios del lado público de Internet que intentan alcanzar el puerto 80 (WWW) de 171.68.1.1 automáticamente al puerto 80 (WWW) de 192.168.0.5, que en este caso es el servidor Web.

827#term mon
827#debug ip nat detailed
IP NAT detailed debugging is on
827#
03:29:49: NAT: creating portlist proto 6 globaladdr 171.68.1.1
03:29:49: NAT: Allocated Port for 192.168.0.5 -> 171.68.1.1: wanted 80 got 80 
03:29:49: NAT: o: tcp (198.133.219.1, 11000) -> (171.68.1.1, 80) [0]
<... snipped ...>

Información Relacionada


Document ID: 12905