Routers : Routers Cisco de la serie 800

Configuración de un router Cisco 827 mediante PPPoA con CHAP y PAP

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Noviembre 2015) | Comentarios


Contenido


Introducción

Las configuraciones de muestra de este documento ilustran como se conecta un Cisco 827 Digital Subscriber Line (DSL) Router a Cisco 6130 Digital Subscriber Line Access Multiplexer (DSLAM) y termina en Cisco 6400 Universal Access Concentrator (UAC). Cada configuración utiliza Point-to- Point Protocol over Asynchronous Transfer Mode (PPPoA). La interfaz de Asynchronous Transfer Mode (ATM) se configura para la encapsulación AALMUX PPP.

Una configuración muestra el PPPoA usando el Challenge Handshake Authentication Protocol (CHAP). La segunda configuración muestra el PPP over ATM usando el protocolo password authentication (PAP).

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Software Release 12.1(1)XB del Customer Premises Equipment del Cisco 827-4V (CPE) IOS�

  • Software Release 12.0(7)DC del Cisco 6400 UAC-NRP IOS

  • Software Release 12.0(4)DB del Cisco 6400 UAC-NSP IOS

  • Versión de software IOS 12.1(1)DA del Cisco 6130 DSLAM-NI2

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/12886/827pppoachap.gif

PPPoA con configuraciones CHAP

Al usar la virtual-plantilla de la interfaz, configure solamente el nombre de usuario del nombre de host del PPP chap y ppp chap password password. No soportan al comando ppp authentication chap callin. En esta interfaz del ejemplo se utiliza el marcador, que no es afectado.

Cisco 827
Current configuration: 
! 
version 12.1 
!
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap callin 
 ppp chap hostname username
 
 ppp chap password password

! 
ip classless 
!
ip route 0.0.0.0 0.0.0.0 Dialer0 
! 
dialer-list 1 protocol ip permit 
!
end

Acceso 6400 NRP1 de Cisco
username 
username
 password 
password
 

!--- The username and password values must match 
!--- the username and password values of the remote device. 

!
interface ATM0/0/0.200 point-to-point
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/301 
  encapsulation aal5mux ppp Virtual-Template11
 !
 interface Virtual-Template11 
  ip address 172.18.0.2 255.255.0.0 
  no ip directed-broadcast 
  ppp authentication chap
! 
ip route 10.0.0.1 255.255.255.255 172.18.0.1

PPPoA con configuración PAP

Al usar la virtual-plantilla de la interfaz, configure solamente el nombre de usuario contraseña contraseña del enviar-nombre de usuario ppp pap. No soportan al comando ppp authentication pap callin. En esta interfaz del ejemplo se utiliza el marcador, que no es afectado.

Cisco 827
version 12.1 
!
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication pap callin
ppp pap sent-username username password password

! 
ip classless 
! 
ip route 0.0.0.0 0.0.0.0 Dialer0 
!
no ip http server 
! 
dialer-list 1 protocol ip permit 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 

Acceso 6400 NRP1 de Cisco
username 
username
 password 
password
 

!--- The username and password values must match 
!--- the username and password values of the remote device. 

!
interface ATM0/0/0.200 point-to-point
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/301 
  encapsulation aal5mux ppp Virtual-Template11
 !
 interface Virtual-Template11 
  ip address 172.18.0.2 255.255.0.0 
  no ip directed-broadcast 
  ppp authentication pap
! 
ip route 10.0.0.1 255.255.255.255 172.18.0.1

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12886