Switches : Cisco 6130 IP DSL Switch

Configurar a un Cisco 827 Router con una sola dirección IP, el DHCP, y el PPPoA

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Noviembre 2015) | Comentarios


Contenido


Introducción

Esta configuración de muestra muestra a un router del Digital Subscriber Line (DSL) del Cisco 827 que conecta con el Cisco 6130 un Digital Subscriber Line Access Multiplexer (DSLAM) y que termina en un Concentrador de acceso universal (UAC) del Cisco 6400. Han configurado al Cisco 827 Router como servidor del Protocolo de configuración dinámica de host (DHCP) con el protocolo Point-to-Point sobre la atmósfera (PPPoA).

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Software Release 12.1(1)XB del Customer Premises Equipment del Cisco 827-4V (CPE) IOS�

  • Versión de software IOS 12.0(7)DC del Route Processor del UAC Node del Cisco 6400 (NRP)

  • Versión de software IOS 12.0(4)DB del Procesador del switch del UAC Node del Cisco 6400 (NSP)

  • Versión de software IOS 12.1(1)DA del Cisco 6130 DSLAM-NI2

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Antecedentes

El en este caso, el Proveedor de servicios de Internet (ISP) ha dado a suscriptor una sola dirección IP (172.18.0.1) para la conectividad a Internet, pero el suscriptor tiene una pequeña red de los PC y quiere tener acceso a internet para todos los dispositivos.

La solución mostrada aquí implementa el Network Address Translation (NAT) en el Cisco 827 Router. El NAT se diseña para la simplificación y conservación de IP Address; permite al internetworks del IP privado esos IP Addresses nonregistered del uso para conectar con Internet. El NAT actúa encendido a un router, generalmente conectando dos redes, y traduce (en este caso los direccionamientos privados de la red de 10.0.0.0) en la red interna (en este caso, 172.18.0.1) a los direccionamientos legales antes de que los paquetes se remitan a otra red. Como parte de estas funciones, el NAT se puede configurar para hacer publicidad de solamente un direccionamiento (172.18.0.1) para toda la red. Esto proporciona la seguridad complementaria, ocultando con eficacia la red interna entera detrás de una sola dirección IP.

El NAT responde a los propósitos duales de la Seguridad y de la conservación de dirección, y se implementa típicamente en los entornos de acceso remoto. En este ejemplo, una dirección IP de 10.0.0.1 se configura manualmente en la interfaz de Ethernet del Cisco 827 Router. Configuran para actuar como servidor DHCP, y arrienda al Cisco 827 Router los IP Addresses a los dispositivos de LAN locales asociados a su red Ethernet.

La configuración siguiente muestra el NAT configurado para los Ethernetes y las interfaces ATM. La interfaz de Ethernet (señalada ethernet0 en el diagrama de la red abajo) tiene una dirección IP de 10.0.0.1, con una máscara de subred de 255.0.0.0. El NAT se configura para dentro, así que significa que la interfaz está conectada con la red interna que está conforme a la traducción de NAT. La interfaz ATM (señalada Dialer0 en el diagrama de la red abajo) tiene una dirección IP de 172.18.0.1 y una máscara de subred de 255.255.0.0. El NAT en Dialer0 se configura para afuera, así que significa que la interfaz está conectada con una red externa tal como Internet. Para más información sobre la arquitectura PPPoA de punta a punta del Asynchronous Digital Subscriber Line (ADSL), refiera a la arquitectura de línea de base PPPoA.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/12880/827dhcp_1ip2.gif

Configuración

Este documento usa la configuración que se detalla a continuación.

Cisco 827 Router
! 
version 12.1
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1

!--- The DHCP pool does not lease this address; 
!--- it is used by interface E0.

!
ip dhcp pool <pool name>
network 10.0.0.0 255.0.0.0
 default-router 10.0.0.1

!--- The default gateway is assigned to local devices.

! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
  ip address 172.18.0.1 255.255.0.0    
  ip nat outside     
  no ip directed-broadcast 
  encapsulation ppp 
  dialer pool 1 
  dialer-group 2 
  ppp pap sent-username <username> password <password>
! 
ip nat inside source list 1  interface Dialer0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
dialer-list 2 protocol ip permit
! 
voice-port 1 
 timing hookflash-in 0
!
voice-port 2
 timing hookflash-in 0 
! 
voice-port 3
 timing hookflash-in 0 
!
voice-port 4 
 timing hookflash-in 0 
! 
end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12880