Ethernet de largo alcance (LRE) y Línea de suscriptor digital (xDSL) : Línea de suscriptor digital asimétrica (ADSL)

Configuraciones de muestra para agregado de banda ancha de Cisco 7200

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (9 Noviembre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una descripción general de los componentes de Digital Subscriber Line (DSL) y cómo encajan entre sí en una implementación DSL básica. Las configuraciones de muestra de este documento muestran las redes DSL más comunes que se utilizan actualmente. Puede utilizar estas configuraciones como referencia general para diseñar una implementación de agrupamiento de banda ancha. Sin embargo, no vea estas configuraciones como solución para todo. Cada cliente y cada requisito son diferentes y hay muchas maneras de lograr los mismos objetivos de diseño.

Mientras que las configuraciones en este documento son tan completas como sea posible, el documento da solamente las líneas esenciales. El documento asume que el usuario tiene una comprensión básica de la configuración de dispositivo de Cisco y omite muchas de las líneas de comando básico. Utilice estas configuraciones solamente como una punta del comienzo para diseñar su propia implementación.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Terminación de la sesión PPPoA: xDSL a 7200

Diagrama de la red

Esta sección utiliza esta configuración de red:

7200_bdaggreg1.gif

Configuraciones

Este ejemplo describe cómo conectar el Cisco 677, o el otro DSL Customer Premises Equipment (CPE), con un Cisco 7200 vía el PPP over ATM (PPPoA). La configuración incluye un switch ATM del Cisco lightstream 1010 (LS1010), que es un componente opcional. Los resultados son lo mismo si usted conecta directamente el Multiplicador de acceso DSL (DSLAM) con el Cisco 7200.

En este ejemplo, usted establece a la sesión PPP en el Cisco 677 y termina en el Cisco 7200. Después de la terminación de la sesión, el IP tradicional pasa el tráfico al Network Service Provider (NSP) o a Internet.

El CPE tiene una configuración para realizar la traducción de la dirección del /port del Network Address Translation (NAT) (PALMADITA). El CPE también implementa a un servidor DHCP para asignar los IP Addresses a las estaciones Ethernet.

Esta sección usa estas configuraciones:

Configuración de la PC para el PPPoA
  1. Fije el IP Addressing para obtener automáticamente una dirección IP.
  2. Fije los TRIUNFOS para utilizar el DHCP para la resolución de los TRIUNFOS.
  3. Asegúrese de que no se fije ningún default gateway.

Nota: Si el DHCP no puede pasar esta información, usted necesita fijar un Domain Name.

Configuración del Cisco CPE para el PPPoA
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

Configuración de Cisco DSLAM para el PPPoA
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 atm pvc 1 32 interface atm0/1 1 35

Configuración de Cisco LS1010 para el PPPoA
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuración del Cisco 7200 para el PPPoA
aaa new-model
AAA authentication ppp default local
!
!
username password 
!
!
interface ATM 2/0.1 multipoint
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template 2
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
!
ip local pool <pool name> 172.22.40.10 172.22.40.25

Conexión en puente RFC1483 xDSL a 7200

Diagrama de la red

Esta sección utiliza esta configuración de red:

7200_bdaggreg2.gif

Configuraciones

Este ejemplo describe cómo conectar un Cisco 677, u otro DSL CPE, con un Cisco 7200 vía el Bridged Encapsulation del RFC 1483. Esta configuración incluye un switch ATM de Cisco LS1010, que es un componente opcional. Los resultados son lo mismo si usted conecta directamente el DSLAM con el Cisco 7200.

En este ejemplo, usted establece la sesión interligada sobre el Cisco 677 y termina en el Cisco 7200. Después de que los Bridges de la sesión al Cisco 7200, IP tradicional pasen el tráfico al NSP o a Internet. Un servidor DHCP con la configuración en los 7200 asigna una dirección IP a la estación de trabajo del cliente.

Esta configuración utiliza el Integrated Routing and Bridging (IRB). Para paliar el scalability y los problemas de seguridad con el IRB, considere el (RBE) del Routed Bridged Encapsulation.

Esta sección usa estas configuraciones:

Configuración de la PC para el RFC 1483
  1. Fije el IP Addressing para obtener automáticamente una dirección IP.
  2. Fije los TRIUNFOS para utilizar el DHCP para la resolución de los TRIUNFOS.
  3. Asegúrese de que no se fije ningún default gateway.

Nota: Si el DHCP no puede pasar esta información, usted necesita fijar un Domain Name.

Configuración de CPE del Cisco 677 para el RFC 1483
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Configuración de Cisco DSLAM para el RFC 1483
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuración de Cisco LS1010 para el RFC 1483
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuración del Cisco 7200 para el RFC 1483
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!         
!
bridge irb
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
 bridge-group 1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
 bridge-group 1!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface BVI 1
 ip address 172.22.40.9 255.255.255.0
 no ip directed-broadcast
!
!
bridge 1 protocol ieee
 bridge 1 route ip

RBE: xDSL a 7200

Diagrama de la red

Esta sección utiliza esta configuración de red:

7200_bdaggreg2.gif

Configuraciones

El RBE es actualmente la configuración de elección para la mayoría de las nuevas instalaciones de DSL. El RBE aborda la Seguridad y los problemas de ampliación del bridging en el entorno del suscriptor a banda ancha.

Un servidor DHCP con la configuración en los 7200 asigna una dirección IP a la estación de trabajo del cliente.

Importante: El DHCP no puede ejecutarse en el router con la atmósfera innumerable a menos que cuando usted utiliza el Software Release 12.1(2)T o Posterior de Cisco IOS�.

Esta sección usa estas configuraciones:

Configuración de la PC para el RBE
  1. Fije el IP Addressing para obtener automáticamente una dirección IP.
  2. Fije los TRIUNFOS para utilizar el DHCP para la resolución de los TRIUNFOS.
  3. Asegúrese de que no se fije ningún default gateway.

Nota: Si el DHCP no puede pasar esta información, usted necesita fijar un Domain Name.

Configuración del Cisco CPE para el RBE
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Configuración de Cisco DSLAM para el RBE
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuración de Cisco LS1010 para el RBE
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuración del Cisco 7200 para el RBE
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!
!
interface Loopback0
 ip address 172.22.40.9 255.255.255.0
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/35 
  encapsulation aal5snap
!
!
interface ATM 2/0.2 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/36 
  encapsulation aal5snap
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!

PPPoE: xDSL a 7200

Diagrama de la red

Esta sección utiliza esta configuración de red:

7200_bdaggreg3.gif

Configuraciones

El PPP over Ethernet (PPPoE) extiende a la sesión PPP del cliente del router al final. El PPP y el software de autenticación se ejecutan generalmente en el cliente dentro del sistema operativo o en una aplicación autónoma. El CPE actúa en el Bridging Mode para interligar a la sesión PPP sobre la conexión DSL. Pero el CPE no puede actuar como el servidor DHCP en este escenario.

Las configuraciones para el CPE, el DSLAM, y el switch ATM son lo mismo que las configuraciones para interligar del RFC 1483. Usted puede configurar al router de agrupamiento del Cisco 7200 para la autenticación local, pues este ejemplo muestra. O usted puede configurar los 7200 con la autenticación de RADIUS del Authentication, Authorization, and Accounting (AAA).

Esta sección usa estas configuraciones:

Configuración de la PC para el PPPoE
  1. Fije el IP Addressing para obtener automáticamente una dirección IP.
  2. Fije los TRIUNFOS para utilizar el DHCP para la resolución de los TRIUNFOS.
  3. Asegúrese de que no se fije ningún default gateway.

Nota: Si el DHCP no puede pasar esta información, usted necesita fijar un Domain Name.

Nota: La estación terminal debe poder establecer una conexión PPP al router. El software cliente especial para la autenticación y el acceso puede ser necesario.

Configuración de CPE del Cisco 677 para el PPPoE
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Configuración de Cisco DSLAM para el PPPoE
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuración de Cisco LS1010 para el PPPoE
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuración del Cisco 7200 para el PPPoE
!
username <username> password <password>
!
vpdn enable
!
vpdn-group 1
 accept-dialin
  protocol pppoe
  virtual-template 1
  pppoe limit per-mac 100
  pppoe limit per-vc 100
!
ip cef
!
interface atm2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
  protocol pppoe
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
  protocol pppoe
!
interface Virtual-Template1
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
ip local pool <pool name> 172.22.32.20 172.22.32.100

L2TP: xDSL a 7200 por L2TP

Diagrama de la red

Esta sección utiliza esta configuración de red:

7200_bdaggreg4.gif

Configuraciones

El protocolo layer two tunneling (L2TP) proporciona los medios de terminar la conexión PPP del usuario final en una ubicación y de transportar los paquetes de datos L2 a otra ubicación. El L2TP descarga mucha de la funcionalidad de IP del dispositivo de agrupamiento y permite los diseños de red más centralizados. Un servidor de RADIUS proporciona el AAA.

Las configuraciones para todos los dispositivos excepto el Cisco 7200 son lo mismo que las configuraciones por el ejemplo del RFC 1483.

Esta sección usa estas configuraciones:

Configuración de la PC para el L2TP
  1. Fije el IP Addressing para obtener automáticamente una dirección IP.
  2. Fije los TRIUNFOS para utilizar el DHCP para la resolución de los TRIUNFOS.
  3. Asegúrese de que no se fije ningún default gateway.

Nota: Si el DHCP no puede pasar esta información, usted necesita fijar un Domain Name.

Configuración de CPE del Cisco 677 para el L2TP
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

Configuración de Cisco DSLAM para el L2TP
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuración de Cisco LS1010 para el L2TP
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuración LAC del Cisco 7200 para el L2TP
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!  
vpdn-group 4
 request-dialin
  protocol l2tp
  domain cisco.com
 initiate-to ip 172.22.32.27 priority 1
 local name cisco-tunnel      
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template1
 ip unnumbered FastEthernet4/0
 no ip directed-broadcast
 ppp authentication pap
!
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Configuración LNS del Cisco 7200 para el L2TP
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!
vpdn-group 1
 accept-dialin
  protocol any
  virtual-template 1
 terminate-from hostname cisco-tunnel
 local name tunnel-gate
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12868