Ethernet de largo alcance (LRE) y Línea de suscriptor digital (xDSL) : Línea de suscriptor digital asimétrica (ADSL)

Terminación de la sesión PPPoA usando las Static rutas: xDSL a un Cisco 6400 UAC usando el aal5ciscoppp

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Noviembre 2015) | Comentarios


Contenido


Introducción

Esta configuración de muestra habilita un PC conectado con un router del Asymmetric Digital Subscriber Line (ADSL) del Cisco 677 para conectar vía un Advanced Digital Subscriber Line Access Multiplexer del Cisco 6130 (ADSLAM) con los concentradores de acceso solos o múltiples del Cisco Universal (UAC). El equipo específico que esta configuración utiliza no se requiere. Por ejemplo, usted puede substituir el Cisco 677 por un Cisco 678.

Esta configuración de muestra tiene algunas características habilitadas en el Cisco 677 que sean comunes a un lanzamiento de ADSL. Estas características son Network Address Translation (NAT), Port Address Translation (PAT), y Protocolo de configuración dinámica de host (DHCP). Estas características permiten un desarrollo en masa. Puesto que todos los cuadros tienen la misma configuración, han una reducción para desarrollo y una documentación del costo importante.

Usted puede copiar y pegar el código para el procesador IOS�-basado Cisco de la ruta de nodo (NRP) y el procesador del switch de nodo (NSP) a sus configuraciones. Sin embargo, el Cisco 677 utiliza el Cisco Broadband Operating System (CBOS) y usted no puede copiar y pegar este código. Los comandos que usted utiliza para configurar el Cisco 677 también se incluyen en esta configuración de muestra.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

Hardware

  • PC o puesto de trabajo

  • Customer Premises Equipment de ADSL del Cisco 677 (CPE)

  • Servicio ADSL de su compañía telefónica local

  • Cisco 6130 ADSLAM con el NI-2, ATU-C DMT-II

  • Cisco 6400 UAC con 1 x NRP y 1 x NSP

Software

  • Cisco IOS Software Release 12.0.7-DC para el Cisco 6400 UAC NRP

  • Cisco IOS Software Release 12.0.7-DB para el Cisco 6400 UAC NSP

  • Versión 2.3.0.012 CBOS para el Router Cisco 677 ADSL

  • Cisco IOS Software Release 12.0.8-DA1 para el Cisco 6130 ADSLAM

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección, le presentan con la información que usted puede utilizar para configurar las características descritas en este documento.

Nota: Para encontrar la información adicional en los comandos usados en este documento, refiera a la herramienta de búsqueda de comandos (clientes registrados solamente).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/12851/6400dsl_pppoa_stat.gif

Configuraciones

Notas de configuración

Usted debe configurar una conexión virtual permanente (PVC) en el Cisco 6130 que permita que el suscriptor de prueba conecte. Cuando usted configura el PVP en el NSP y termina a la sesión PPP en el NRP, la configuración del identificador de ruta virtual/identificador de canal virtual (VPI/VCI) se debe registrar en el Cisco 6400.

Esta configuración de muestra muestra un trayecto virtual en el NSP. Esta trayectoria permite que el Cisco 6400 pase a través de las células del ADSLAM al router de terminación, o a otro switch ATM. Aquí usted puede fijar un PVP para conmutar las células ATM a una red corporativa o un ISP sin la terminación de la sesión PPP en el Cisco 6400 situado en la oficina central.

Esta configuración de muestra permite que a usuarios remotos el acceso transparente a sus redes corporativas (si están conectados) para el email, comparta el archivo/la impresión, la intranet corporativa, y a Internet para exploración de la Web, y así sucesivamente. sin el uso de la conexión de Internet corporativa.

Cuando los PVC múltiples se configuran en el Cisco 677, es posible rutear el tráfico vía cada PVC. La configuración del ADSLAM y de las rutas/conmuta UAC-NSP estos PVC al destino correcto, al ISP/ASP o al corporativo, donde el PPP puede terminar. Esta configuración reduce el tráfico, y de tal modo aumenta el ancho de banda disponible en la red corporativa y utiliza una cuenta actual ISP para llevar el tráfico de la Web.

En este documento, se utilizan estas configuraciones:

Configuración de la PC
Fije el IP Addressing de modo que obtenga una dirección IP automáticamente. Fije los TRIUNFOS de modo que utilice el DHCP para la resolución de los TRIUNFOS. Asegúrese de que no se fije ningún default gateway. Puede ser necesario fijar un Domain Name porque el DHCP no puede pasar esta información.

CPE de Cisco 67x (demostración ejecutada)
[[ IP Routing = Section Start ]]
IP NAT = enabled
IP Port Address = 00, 172.22.10.254
IP Default Route for Unnumbered Links = 002, 01, 0
IP Static Route Table Entries for Unnumbered Links = 172.22.32.0, 001, 255.255.2
55.0, 1, 0;
[[ CBOS = Section Start ]]
NSOS Maximum Number of VCs = 2
NSOS Root Password = <
root password
>
NSOS Enable Password = <
enable password
>
[[ PPP Device Driver = Section Start ]]
PPP Port User Name = 00, <
username for wan0-0
>
PPP Port User Password = 00, <
password for wan0-0
>
PPP Port User Name = 01, <
username for wan0-1
>
PPP Port User Password = 01, <
password for wan0-1
>
PPP Port Option = 01, IPCP,IP Address,3,Auto,Negotiation Not Required,Negotiable
,IP,0.0.0.0
[[ DHCP = Section Start ]]
DHCP Server = enabled
DHCP Server Pool IP = 00, 172.22.10.0
DHCP Server Pool Gateway = 00, 172.22.10.254
[[ ATM WAN Device Driver = Section Start ]]
ATM WAN Virtual Connection Parms = 00, 1, 32, 0
ATM WAN Virtual Connection Parms = 01, 2, 63, 0

Comandos de publicar a Cisco 67x el CPE
cbos#set nat enabled
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos#set int wan0 maxvcs 2
You must use "write" and reboot for changes to take effect.

cbos#write
NVRAM written.

cbos#reboot
 Hello! Expanding CBOS image...
CBOS v2.3.5.012 - Release Software
User Access Verification
Password:<
root password
>

cbos>en
Password:<
enable password
>

cbos#set ppp wan0-0 login <username for wan0-0>
User name for wan0-0 has been set to router.

cbos#set ppp wan0-0 password <password for wan0-0>
Password for wan0-0 has been set to <password for wan0-0>

cbos#set ppp wan0-1 login <username for wan0-1>
Password for wan0-1 has been set to <username for wan0-1>

cbos#set ppp wan0-1 password <password for wan0-1>
Password for wan0-1 has been set to <password for wan0-1>

cbos#set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos#set ppp wan0-1 ipcp 0.0.0.0
PPP wan0-1 IPCP Address set to 0.0.0.0

cbos#set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos#set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0
You must use "write" then reboot for changes to take effect

cbos#set dhcp server enable
DHCP Server enabled

cbos#set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos#set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0
Size of pool 0 is automatically changed to max size 252

cbos#set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos#set password exec <root password>
Exec Password Change Successful! 

cbos#set password enable <enable password>
Enable Password Change Successful! 

cbos#set route default wan0-1
Default Route set

cbos#set route add ip 172.22.32.0 mask 255.255.255.0 gw wan0-0
Route added
cbos#set int wan0-0 close
Closing connection wan0-0

cbos#set int wan0-1 close
Closing connection wan0-1

cbos#set int wan0-0 vpi 1
Change completed.

cbos#set int wan0-0 vc1 32
Change completed.

cbos#set int wan0-1 vpi 2
Change completed.

cbos#set int wan0-1 vci 63
Change completed.

cbos#set int wan0-0 open
Opening connection wan0-0

cbos#set int wan0-1 open
Opening connection wan0-1

cbos#write
NVRAM written

cbos#reboot

61xx ADSLAM
interface ATM 1/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 1 32 int atm 0/1 40 40
 pvc 2 63 int atm 0/1 50 51

6400 NSP (slot 8)
interface ATM 8/0/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvp 40 interface ATM 1/0/0 40
 atm pvp 50 interface ATM 2/0/0 50

6400 NRP (slot 1)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-0> password <password for wan0-0>
!
!
interface ATM 0/0/0.200 multipoint
 no ip directed-broadcast
 pvc 40/40 
  encapsulation aal5ciscoppp Virtual-Template 2
!
!
interface FastEthernet 0/0/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name A>
 ppp authentication pap
!
!
ip local pool <pool name A> 172.22.40.25 172.22.40.50

6400 NRP (slot 2)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-1> password <password for wan0-1>
!
!
interface ATM 0/0/0.300 multipoint
 no ip directed-broadcast
 pvc 50/51 
  encapsulation aal5ciscoppp Virtual-Template 21
!
!
interface FastEthernet 0/0/0
 ip address 172.16.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 21
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name B>
 ppp authentication pap
!
!
ip local pool <pool name B> 172.16.100.10 172.16.100.25

Verificación

En esta sección encontrará información que puede utilizar para comprobar que su configuración funcione correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Utilice estos comandos en el CPE del Cisco 675:

  • show interface wan0 — Las demostraciones entrenaron encima de la velocidad para el link ADSL.

  • show interface wan0-0 — Información de sesión PPP de las demostraciones sobre wan0-0.

  • muestre la interfaz wan0-1 — Información de sesión PPP de las demostraciones sobre wan0-1.

  • show dhcp server pool 0 — Información de DHCP de las demostraciones en el sitio del cliente.

Utilice este comando en el Cisco 6400 UAC:

  • muestre el pvc ATM — Muestra si el PVC correcto está establecido.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Utilice estos comandos en el Cisco 6400 UAC:

  • haga el debug de la negociación ppp — Mensajes del debug de la negociación PPP de las demostraciones.

  • autenticación PPP del debug — Muestra si un cliente pasa la autenticación.

  • debug ppp error — Muestra los errores de protocolo y las estadísticas de error relacionadas con la negociación y operación de conexiones PPP.

Antes de que usted intente los comandos debug uces de los, refiera a la información importante en los comandos Debug.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12851